Contents

Part One  Capture basics

Chapter 1  Getting started  3
Starting Capture ........................................... 3
The Capture session frame ................................. 4

Chapter 2  The Capture work environment  5
The project manager ...................................... 6
  Project manager folders .................................. 6
  Project manager tabs—File and Hierarchy ............ 9
  Single view ............................................... 9
  Flat and hierarchical designs ......................... 10
  Project manager pop-up menus ......................... 10
The schematic page editor .............................. 11
The part editor ............................................ 12
The programmer’s editor ................................. 13
The session log ........................................... 14
The toolbar ................................................ 16
  Displaying or hiding the toolbar ................. 18
The tool palettes .......................................... 19
  The schematic page editor tool palette ............ 19
  The part editor tool palette ......................... 22
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displaying or hiding a tool palette</td>
<td>24</td>
</tr>
<tr>
<td>The status bar</td>
<td>25</td>
</tr>
<tr>
<td>Left field</td>
<td>25</td>
</tr>
<tr>
<td>Center field</td>
<td>25</td>
</tr>
<tr>
<td>Right field</td>
<td>25</td>
</tr>
<tr>
<td>Displaying or hiding the status bar</td>
<td>26</td>
</tr>
<tr>
<td>Selecting and deselecting objects</td>
<td>27</td>
</tr>
<tr>
<td>Grouping objects</td>
<td>29</td>
</tr>
<tr>
<td>Editing properties</td>
<td>30</td>
</tr>
<tr>
<td>Instance and occurrence properties</td>
<td>31</td>
</tr>
<tr>
<td>Instance properties</td>
<td>31</td>
</tr>
<tr>
<td>Occurrence properties</td>
<td>31</td>
</tr>
<tr>
<td>The Browse spreadsheet editor</td>
<td>32</td>
</tr>
<tr>
<td>The property editor</td>
<td>35</td>
</tr>
<tr>
<td>The property editor window</td>
<td>36</td>
</tr>
<tr>
<td>The property editor Filter menu</td>
<td>40</td>
</tr>
<tr>
<td>Using the property editor</td>
<td>43</td>
</tr>
<tr>
<td>The Package Properties spreadsheet editor</td>
<td>46</td>
</tr>
<tr>
<td>Moving and resizing graphic objects</td>
<td>48</td>
</tr>
<tr>
<td>Undoing, redoing, and repeating an action</td>
<td>49</td>
</tr>
<tr>
<td>Using the Accessories menu</td>
<td>51</td>
</tr>
<tr>
<td>The Package Properties spreadsheet editor</td>
<td>51</td>
</tr>
<tr>
<td>Chapter 3 Starting a project</td>
<td>51</td>
</tr>
<tr>
<td>Creating new projects, designs, libraries, and VHDL files</td>
<td>52</td>
</tr>
<tr>
<td>Opening existing projects, designs, libraries, and VHDL files</td>
<td>55</td>
</tr>
<tr>
<td>Working with files in a project</td>
<td>57</td>
</tr>
<tr>
<td>Saving projects, designs, and libraries</td>
<td>58</td>
</tr>
<tr>
<td>Closing a project</td>
<td>59</td>
</tr>
<tr>
<td>Archiving a project</td>
<td>61</td>
</tr>
<tr>
<td>Chapter 4 Setting up your project</td>
<td>63</td>
</tr>
<tr>
<td>Defining your preferences</td>
<td>65</td>
</tr>
<tr>
<td>Defining colors/print options</td>
<td>66</td>
</tr>
<tr>
<td>Controlling the grid</td>
<td>68</td>
</tr>
<tr>
<td>Setting pan and zoom</td>
<td>69</td>
</tr>
<tr>
<td>Defining selection options</td>
<td>71</td>
</tr>
<tr>
<td>Setting miscellaneous options</td>
<td>73</td>
</tr>
<tr>
<td>Setting text editor options</td>
<td>76</td>
</tr>
<tr>
<td>Setting up your project template</td>
<td>78</td>
</tr>
<tr>
<td>Setting up fonts for new projects</td>
<td>79</td>
</tr>
<tr>
<td>Defining title block information</td>
<td>80</td>
</tr>
<tr>
<td>Contents</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Placing parts</td>
<td>118</td>
</tr>
<tr>
<td>Place Part dialog box</td>
<td>121</td>
</tr>
<tr>
<td>Most Recently Used (MRU) part list</td>
<td>124</td>
</tr>
<tr>
<td>Searching for parts</td>
<td>125</td>
</tr>
<tr>
<td>Editing parts</td>
<td>125</td>
</tr>
<tr>
<td>Placing and editing power and ground symbols</td>
<td>128</td>
</tr>
<tr>
<td>Placing power and ground symbols</td>
<td>128</td>
</tr>
<tr>
<td>Place Power and Place Ground dialog boxes</td>
<td>130</td>
</tr>
<tr>
<td>Editing power and ground symbols</td>
<td>131</td>
</tr>
<tr>
<td>Placing and editing no-connect symbols</td>
<td>132</td>
</tr>
<tr>
<td>Placing no-connect symbols</td>
<td>132</td>
</tr>
<tr>
<td>Editing no-connect symbols</td>
<td>133</td>
</tr>
<tr>
<td>Placing and editing hierarchical blocks</td>
<td>134</td>
</tr>
<tr>
<td>Placing hierarchical blocks</td>
<td>134</td>
</tr>
<tr>
<td>Place Hierarchical Block dialog box</td>
<td>136</td>
</tr>
<tr>
<td>Editing hierarchical blocks</td>
<td>138</td>
</tr>
<tr>
<td>Placing and editing hierarchical ports and hierarchical pins</td>
<td>139</td>
</tr>
<tr>
<td>Placing hierarchical ports</td>
<td>139</td>
</tr>
<tr>
<td>Place Hierarchical Port dialog box</td>
<td>140</td>
</tr>
<tr>
<td>Placing hierarchical pins</td>
<td>141</td>
</tr>
<tr>
<td>Place Hierarchical Pin dialog box</td>
<td>143</td>
</tr>
<tr>
<td>Editing hierarchical ports and hierarchical pins</td>
<td>143</td>
</tr>
<tr>
<td>Placing and editing off-page connectors</td>
<td>144</td>
</tr>
<tr>
<td>Placing off-page connectors</td>
<td>144</td>
</tr>
<tr>
<td>Place Off-Page Connector dialog box</td>
<td>146</td>
</tr>
<tr>
<td>Editing off-page connectors</td>
<td>147</td>
</tr>
<tr>
<td>Placing and connecting wires and buses</td>
<td>148</td>
</tr>
<tr>
<td>Placing wires</td>
<td>149</td>
</tr>
<tr>
<td>Editing wires</td>
<td>150</td>
</tr>
<tr>
<td>Moving wires</td>
<td>151</td>
</tr>
<tr>
<td>Placing buses</td>
<td>152</td>
</tr>
<tr>
<td>Editing buses</td>
<td>153</td>
</tr>
<tr>
<td>Placing bus entries</td>
<td>153</td>
</tr>
<tr>
<td>Editing bus entries</td>
<td>154</td>
</tr>
<tr>
<td>Ripping a subset of signals off the bus</td>
<td>155</td>
</tr>
</tbody>
</table>

**Chapter 8 Adding and editing graphics and text**  
157

| Drawing tools                                                          | 158  |
| Drawing lines                                                          | 159  |
| Drawing rectangles and squares                                         | 160  |
| Drawing circles and ellipses                                           | 161  |
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawing arcs</td>
<td>162</td>
</tr>
<tr>
<td>Drawing polylines and polygons</td>
<td>163</td>
</tr>
<tr>
<td>Adding fill to an object</td>
<td>164</td>
</tr>
<tr>
<td>Mirroring an object</td>
<td>164</td>
</tr>
<tr>
<td>Rotating an object</td>
<td>165</td>
</tr>
<tr>
<td>Moving an object</td>
<td>165</td>
</tr>
<tr>
<td>Cutting an object</td>
<td>165</td>
</tr>
<tr>
<td>Copying an object</td>
<td>166</td>
</tr>
<tr>
<td>Pasting an object</td>
<td>166</td>
</tr>
<tr>
<td>Deleting a selected object</td>
<td>166</td>
</tr>
<tr>
<td>Placing a bitmap</td>
<td>167</td>
</tr>
<tr>
<td>Placing text</td>
<td>168</td>
</tr>
<tr>
<td>The text bounding box</td>
<td>170</td>
</tr>
<tr>
<td>Deleting text</td>
<td>170</td>
</tr>
<tr>
<td>Modifying text</td>
<td>170</td>
</tr>
<tr>
<td>Finding text</td>
<td>171</td>
</tr>
<tr>
<td>Replacing text</td>
<td>172</td>
</tr>
<tr>
<td>Importing text</td>
<td>172</td>
</tr>
<tr>
<td>Exporting text</td>
<td>173</td>
</tr>
<tr>
<td>Character formatting</td>
<td>173</td>
</tr>
<tr>
<td>About screen fonts</td>
<td>174</td>
</tr>
<tr>
<td>Chapter 9 Using macros</td>
<td>175</td>
</tr>
<tr>
<td>Recording a macro</td>
<td>177</td>
</tr>
<tr>
<td>Playing a macro</td>
<td>178</td>
</tr>
<tr>
<td>Configuring a macro</td>
<td>179</td>
</tr>
<tr>
<td>Configure Macro dialog box</td>
<td>180</td>
</tr>
<tr>
<td>Naming a macro</td>
<td>183</td>
</tr>
<tr>
<td>Assigning a shortcut key to a macro</td>
<td>185</td>
</tr>
<tr>
<td>Sample macros</td>
<td>186</td>
</tr>
<tr>
<td>Chapter 10 Changing your view of a schematic page</td>
<td>187</td>
</tr>
<tr>
<td>Zooming</td>
<td>188</td>
</tr>
<tr>
<td>Zooming to a specified scale</td>
<td>189</td>
</tr>
<tr>
<td>Other viewing options</td>
<td>189</td>
</tr>
<tr>
<td>Moving to a new location</td>
<td>192</td>
</tr>
<tr>
<td>Moving to an X, Y location</td>
<td>192</td>
</tr>
<tr>
<td>Go To dialog box, Location tab</td>
<td>193</td>
</tr>
<tr>
<td>Jumping to a specific grid reference</td>
<td>194</td>
</tr>
<tr>
<td>Go To dialog box, Grid Reference tab</td>
<td>194</td>
</tr>
<tr>
<td>Jumping to a marked location</td>
<td>195</td>
</tr>
</tbody>
</table>
## Contents

Updating instances and occurrences ........................................... 246

### Chapter 14 Preparing to create a netlist  247

Annotating ................................................................. 247
  Annotate dialog box .................................................... 249
Updating properties ......................................................... 251
  Update Properties dialog box ........................................... 253
  Update file format ...................................................... 255
Checking for design rules violations ....................................... 256
  Design Rules Check dialog box, Design Rules Check tab .......... 259
  Design Rules Check dialog box, ERC Matrix tab ................. 262
  Sample Design Rules Check report .................................. 263
Back annotating .................................................................. 266
  Back Annotate dialog box ............................................... 268
  Swap file format ......................................................... 269

### Chapter 15 Creating a netlist  271

Using the Create Netlist tool ................................................. 271
Netlist format files .......................................................... 273
Netname resolution ........................................................... 274

### Chapter 16 Creating reports  275

Creating a bill of materials .................................................. 275
  Bill of Materials dialog box ............................................. 277
  Include file format ....................................................... 279
Creating a cross reference report ........................................... 280
  Cross Reference Parts dialog box ..................................... 281

### Chapter 17 Exporting and importing schematic data  283

Exporting and importing designs ............................................ 283
  Exporting designs ....................................................... 284
  Importing designs ....................................................... 285
Exporting and importing properties ....................................... 286
  Exporting properties .................................................... 286
  Property file format .................................................... 288
  Editing a property file .................................................. 288
  Importing properties .................................................... 290

### Chapter 18 Generating a part  293

Using the Generate Part tool ................................................ 294
Contents

Generate a new part ......................................................... 294
Update the pin numbers of an existing part ...................... 297

Chapter 19  Using Capture with Orcad Layout  299
Preparing your Capture design for use with Layout ............. 301
Creating a netlist for use in Layout ................................. 303
Loading a new netlist into Layout .................................... 304
Back annotating board information from Layout ................ 306
Forward annotating schematic data to Layout ..................... 307
Cross probing between Capture and Layout ......................... 308
   Enabling intertool communication between Capture and Layout 308
   Cross probing from Capture to Layout ............................ 309
   Cross probing from Layout to Capture ............................ 310
General rules .................................................................... 311

Chapter 20  Using Capture with PSpice  313
Overview ........................................................................... 313
Specifying simulation model libraries ............................... 314
Creating a design for PSpice A/D simulation ....................... 315
Editing simulation models from Capture ............................ 316
Adding and defining stimulus ............................................ 317
   Placing stimulus sources .............................................. 317
   Using the Stimulus Editor .............................................. 317
Setting up and running analyses ....................................... 318
Viewing results .............................................................. 319
   Viewing results as you simulate .................................. 319
   Using markers .......................................................... 319
   Configuring the display of simulation results ................. 320
Creating designs for PSpice simulation and board layout ....... 321
   Handling unmodeled pins ............................................. 322
Displaying bias point information ...................................... 323
   Displaying bias point values ........................................ 323

Glossary  325

Index  337
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Figure 1</td>
<td>Capture’s session frame</td>
<td>4</td>
</tr>
<tr>
<td>Figure 2</td>
<td>New project manager window</td>
<td>6</td>
</tr>
<tr>
<td>Figure 3</td>
<td>File tab</td>
<td>9</td>
</tr>
<tr>
<td>Figure 4</td>
<td>Hierarchy tab</td>
<td>9</td>
</tr>
<tr>
<td>Figure 5</td>
<td>Schematic page editor</td>
<td>11</td>
</tr>
<tr>
<td>Figure 6</td>
<td>Part editor</td>
<td>12</td>
</tr>
<tr>
<td>Figure 7</td>
<td>Programmer’s editor</td>
<td>13</td>
</tr>
<tr>
<td>Figure 8</td>
<td>Session log</td>
<td>14</td>
</tr>
<tr>
<td>Figure 9</td>
<td>Capture’s toolbar</td>
<td>16</td>
</tr>
<tr>
<td>Figure 10</td>
<td>Schematic page editor tool palette</td>
<td>19</td>
</tr>
<tr>
<td>Figure 11</td>
<td>Part editor tool palette</td>
<td>22</td>
</tr>
<tr>
<td>Figure 12</td>
<td>The status bar</td>
<td>25</td>
</tr>
<tr>
<td>Figure 13</td>
<td>Browse spreadsheet editor</td>
<td>32</td>
</tr>
<tr>
<td>Figure 14</td>
<td>Property editor</td>
<td>36</td>
</tr>
<tr>
<td>Figure 15</td>
<td>Package Properties spreadsheet editor</td>
<td>46</td>
</tr>
<tr>
<td>Figure 16</td>
<td>Open project, design, and schematic page</td>
<td>55</td>
</tr>
<tr>
<td>Figure 17</td>
<td>Open library</td>
<td>56</td>
</tr>
<tr>
<td>Figure 18</td>
<td>Open VHDL file</td>
<td>56</td>
</tr>
<tr>
<td>Figure 19</td>
<td>Colors/Print tab of the Preferences dialog box</td>
<td>66</td>
</tr>
<tr>
<td>Figure 20</td>
<td>Grid Display tab of the Preferences dialog box</td>
<td>68</td>
</tr>
<tr>
<td>Figure 21</td>
<td>Pan and Zoom tab of the Preferences dialog box</td>
<td>69</td>
</tr>
<tr>
<td>Figure 22</td>
<td>Select tab of the Preferences dialog box</td>
<td>71</td>
</tr>
<tr>
<td>Figure 23</td>
<td>Miscellaneous tab of the Preferences dialog box</td>
<td>73</td>
</tr>
<tr>
<td>Figure 24</td>
<td>Text Editor tab of the Preferences dialog box</td>
<td>76</td>
</tr>
<tr>
<td>Figure 25</td>
<td>Fonts tab of the Design Template dialog box</td>
<td>79</td>
</tr>
<tr>
<td>Figure 26</td>
<td>Title Block tab of the Design Template dialog box</td>
<td>80</td>
</tr>
<tr>
<td>Figure 27</td>
<td>Title block</td>
<td>81</td>
</tr>
<tr>
<td>Figure 28</td>
<td>Page Size tab of the Design Template dialog box</td>
<td>82</td>
</tr>
<tr>
<td>Figure 29</td>
<td>Grid Reference tab of the Design Template dialog box</td>
<td>84</td>
</tr>
<tr>
<td>Figure 30</td>
<td>Hierarchy tab of the Design Template dialog box</td>
<td>86</td>
</tr>
<tr>
<td>Figure 31</td>
<td>SDT Compatibility tab of the Design Template dialog box</td>
<td>87</td>
</tr>
<tr>
<td>Figure 32</td>
<td>Miscellaneous tab of the Design Properties dialog box</td>
<td>90</td>
</tr>
</tbody>
</table>
Figures

Figure 33  Miscellaneous tab of the Schematic Page Properties dialog box  .  .  .  .  .   93
Figure 34  An abstract representation of a simple hierarchy.  .  .  .  .  .  .  .  .  .  .  .  .  .  107
Figure 35  A simple hierarchical design, as seen in the project manager  .  .  .  .  .  .  .  108
Figure 36  An abstract representation of a complex hierarchy  .  .  .  .  .  .  .  .  .  .  .  .  .  109
Figure 37  A complex hierarchical design, as seen in the project manager  .  .  .  .  .  .  109
Figure 38  Schematics before hierarchy  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  113
Figure 39  Schematics with hierarchy  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  113
Figure 40  Schematics carrying a net  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  114
Figure 41  Connectivity across pages in a schematic  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  114
Figure 42  Schematic with power and ground symbols  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  115
Figure 43  Part editor in package view  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  117
Figure 44  Part editor in part view  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  118
Figure 45  Place Part dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  121
Figure 46  Property editor with filter set to Capture  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  126
Figure 47  Power and ground symbols in CAPSYM.OLB  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  128
Figure 48  Place Power dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  130
Figure 49  Hierarchical block  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  134
Figure 50  Place Hierarchical Block dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  136
Figure 51  Hierarchical ports in CAPSYM.OLB  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  139
Figure 52  Place Hierarchical Port dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  140
Figure 53  Place Hierarchical Pin dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  143
Figure 54  Off-page connectors in CAPSYM.OLB  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  144
Figure 55  Place Off-Page Connector dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  146
Figure 56  Connectivity change warning  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  151
Figure 57  Schematic page editor tool palette  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  158
Figure 58  Part editor tool palette  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  158
Figure 59  Configure Macro dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  180
Figure 60  Location tab of the Go To dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  193
Figure 61  Grid Reference tab of the Go To dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  194
Figure 62  Bookmark tab of the Go To dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  196
Figure 63  Replace Cache dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  206
Figure 64  New Part Properties dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  214
Figure 65  Place Pin dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  220
Figure 66  Place Pin Array dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  225
Figure 67  User Properties dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  232
Figure 68  Part editor in Package View  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  234
Figure 69  Edit Part Properties dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  237
Figure 70  Before annotation  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  248
Figure 71  After annotation  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  248
Figure 72  Annotate dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  249
Figure 73  Update Properties dialog box  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  253
Figure 74  Design Rules Check tab of the Design Rules Check dialog box  .  .  .  .  .  .  .  .  259
<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>75</td>
<td>ERC tab of the Design Rules Check dialog box</td>
<td>262</td>
</tr>
<tr>
<td>76</td>
<td>Back Annotate dialog box</td>
<td>268</td>
</tr>
<tr>
<td>77</td>
<td>Create Netlist dialog box</td>
<td>272</td>
</tr>
<tr>
<td>78</td>
<td>Bill of Materials dialog box</td>
<td>277</td>
</tr>
<tr>
<td>79</td>
<td>Cross Reference Parts dialog box</td>
<td>281</td>
</tr>
<tr>
<td>80</td>
<td>Export Design dialog box</td>
<td>284</td>
</tr>
<tr>
<td>81</td>
<td>Import Design dialog box</td>
<td>285</td>
</tr>
<tr>
<td>82</td>
<td>Export Properties dialog box</td>
<td>287</td>
</tr>
<tr>
<td>83</td>
<td>Import Properties dialog box</td>
<td>291</td>
</tr>
<tr>
<td>84</td>
<td>Generate Part dialog box</td>
<td>295</td>
</tr>
<tr>
<td>85</td>
<td>Generate Part dialog box</td>
<td>297</td>
</tr>
</tbody>
</table>
Tables

Table 1  Tools on the Capture toolbar  ........................................ 16
Table 2  Tools on the schematic page editor tool palette  ................. 20
Table 3  Tools on the part editor tool palette  .......................... 22
Table 4  Capture’s macro subroutines  ........................................ 183
Table 5  Valid shortcut keys  ............................................... 186
Table 6  Pin shapes  .................................................. 221
Table 7  Pin types  .................................................. 222
Table 8  Capture tools overview  ........................................... 245
Table 9  Updating instances or occurrences  ................................... 246
Table 10 Netlist format file types  ........................................... 273
Table 11 Action on part or pin properties  .................................... 290
Table 12 Cross probing from Capture to Layout  ......................... 309
Table 13 Cross probing from Layout to Capture  .......................... 310
Before you begin

Welcome

Orcad family products offer a total solution for your core design tasks: schematic- and VHDL-based design entry; FPGA and CPLD design synthesis; digital, analog, and mixed-signal simulation; and printed circuit board layout. What’s more, Orcad family products are a suite of applications built around an engineer’s design flow—not just a collection of independently developed point tools. Orcad Capture is just one element in our total solution design flow.

Capture is a versatile design entry product you can use to create schematics for analog or mixed signal designs, printed circuit board layout designs, and programmable logic designs. First, create your flat or hierarchical design in the schematic page editor, then use Capture’s tools to quickly annotate it and prepare it for the next stage of development.
Before you begin

**How to use this guide**

This guide is designed so you can quickly find the information you need to use Insert Product Name. To help you learn and use Insert Product Name efficiently, this manual is separated into the following sections:

- **Part 1, Capture basics**, includes how to get started with Capture; what you need to know about the Capture windows, editors, session log, the toolbar and tool palettes, and general Capture concepts; how to start and set up a project; and printing and plotting.

- **Part 2, Creating designs**, discusses design structure; placing, editing, and connecting parts and symbols; adding and editing graphics and text; using macros, and changing your schematic page view.

- **Part 3, Libraries and parts**, tells you about libraries and parts, and how to create and edit parts.

- **Part 4, Processing your design**, provides an overview of the processing tools; creating a netlist and reports; exporting and importing schematic data; generating a part; and using Capture with Orcad Layout and PSpice.

**Symbols and conventions**

Our printed documentation uses a few special symbols and conventions.

<table>
<thead>
<tr>
<th>Notation</th>
<th>Examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+R</td>
<td>Press Ctrl+R.</td>
<td>Means to hold down the Ctrl key while pressing R.</td>
</tr>
<tr>
<td>Alt, F, O</td>
<td>From the File menu, choose Open (Alt, F, O).</td>
<td>Means that you have two options. You can use the mouse to choose the Open command from the File menu, or you can press each of the keys in parentheses in order: first Alt, then F, then O.</td>
</tr>
</tbody>
</table>
## How to use this guide

<table>
<thead>
<tr>
<th><strong>Monospace font</strong></th>
<th>In the Part Name text box, type PARAM.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Text that you type is shown in monospace font. In the example, you type the characters \texttt{P}, \texttt{A}, \texttt{R}, \texttt{A}, and \texttt{M}.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>UPPERCASE</strong></th>
<th>In Capture, open CLIPPERA.DSN.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Path and filenames are shown in uppercase. In the example, you open the design file named CLIPPERA.DSN.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Italics</strong></th>
<th>In Capture, save design_name.DSN.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Information that you are to provide is shown in italics. In the example, you save the design with a name of your choice, but it must have an extension of .DSN.</td>
</tr>
</tbody>
</table>

## Related documentation

In addition to this guide, you can find technical product information in the online help, the online interactive tutorial, online books, and our technical web site, as well as in other books. The table below describes the types of technical documentation provided with Insert Product Name.

<table>
<thead>
<tr>
<th><strong>This documentation component . . .</strong></th>
<th><strong>Provides this . . .</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>This guide—</td>
<td>A comprehensive guide for understanding and using the features available in Insert Product Name.</td>
</tr>
<tr>
<td>Orcad Capture User's Guide</td>
<td></td>
</tr>
</tbody>
</table>
### Before you begin

<table>
<thead>
<tr>
<th>This documentation component . . .</th>
<th>Provides this . . .</th>
</tr>
</thead>
</table>
| Online help                        | Comprehensive information for understanding and using the features available in Insert Product Name. You can access help from the Help menu in Insert Product Name by choosing the Help button in a dialog box, or by pressing $\text{F1}$. Topics include:  
  - Explanations and instructions for common tasks.  
  - Descriptions of menu commands, dialog boxes, tools on the toolbar and tool palettes, and the status bar.  
  - Error messages and glossary terms.  
  - Reference information.  
  - Product support information.  
  You can get context-sensitive help for a error message by placing your cursor in the error message line in the session log and pressing $\text{F1}$. |
| Online interactive tutorial        | A series of self-paced interactive lessons. You can practice what you’ve learned by going through the tutorial’s specially designed exercises that interact directly with Insert Product Name. You can start the tutorial by choosing Learning Insert Product Name from the Help menu. |
| Online Orcad Capture User’s Guide  | An online, searchable version of this guide, available when choosing Online Manuals from the Orcad family program group (on the Start menu). |
| Online Insert Product Name quick reference | Concise descriptions of the commands, shortcuts, and tools available in Insert Product Name, available when choosing Online Manuals from the Orcad family program group (on the Start menu). |
How to use this guide

<table>
<thead>
<tr>
<th>This documentation component</th>
<th>Provides this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orcad family customer support at <a href="http://www.orcad.com/technical/technical.asp">www.orcad.com/technical/technical.asp</a></td>
<td>An Internet-based support service available to customers with current support options. A few of the technical solutions within the customer support area are:</td>
</tr>
</tbody>
</table>

- The Knowledge Base, which is a searchable database containing thousands of articles on topics ranging from schematic design entry and VHDL-based PLD design to PCB layout methodologies. It also contains answers to frequently asked questions.

- The Knowledge Exchange, which enables you to share information and ideas with other users and with our technical experts in a real-time online forum. You can submit issues or questions for open discussion, search the Knowledge Exchange for information, or send email to another participant for one-on-one communication. A list of new postings will appear each time you visit the Knowledge Exchange, providing you with a quick update of what's been discussed since your last visit.

- The Technical Library, which contains online customer support information that you can search through by category or product. You can find product manuals, product literature, technical notes, articles, samples, books, and other technical information. Additionally, technical information can be obtained through SourceLink, which is an online customer support information service for users of Cadence software other than Capture, Component Information System (CIS), Express, Layout, or PSpice.

- The Support Connection, which allows you to choose to either view and update existing incidents, or create new incidents. The information is delivered directly to us via our internal database. This service is only available to customers with current maintenance or Extended Support Options (ESOs) in the United States and Canada.

- The Live Connection, which enables you to open access to your computer to a Customer Support person, who can then view your actions on your computer monitor as you demonstrate the problem you're having. Live Connection's two-way transmission can also let you view the actions on the Customer Support person's computer monitor, as he or she demonstrates a method or procedure to help you solve your problem. To participate in Live Connection, you need to contact a Customer Support person, in order to obtain a support number to grant you access to the Live Connection site, and to set up a time to “meet online” using Live Connection.
Part One

Capture basics

Chapter 1, Getting started, describes how to start Capture.

Chapter 2, The Capture work environment, orients you to Capture windows, the toolbar and tool palettes, and general Capture concepts such as selecting and editing objects, and undoing and repeating actions.

Chapter 3, Starting a project, describes the different types of designs that Capture supports: flat, simple hierarchical, and complex hierarchical. It introduces the electrical objects used to create these types of designs, and provides an example of how to create a simple hierarchy.

Chapter 4, Setting up your project, shows how to open a design and navigate the schematics and schematic pages in a design, or a portion of a design, such as an individual schematic page.

Chapter 5, Printing and plotting, explains how to print or plot schematic pages, parts, packages, the session log, or text, and how to scale and preview printer or plotter output.
This chapter describes how to start Orcad Capture and provides an overview of the Capture session frame.

**Starting Capture**

The Orcad Family installation process offers a default location for Capture and adds “Orcad Family Release” to the Programs menu (available from the Start button).

**To start Capture**

1. From the Start menu, point to Programs and choose Orcad Family Release.
2. From the Orcad Family Release menu item, choose Capture.
The Capture session frame

Once you start Capture, you see the Capture session frame. You do all your schematic design and processing within this window.

Figure 1  Capture’s session frame

The minimized Session Log icon in the lower left portion of the Capture session frame is the session log. The session log provides information about everything you have done in the current Capture session. Detailed information about this window—and the other windows in Capture—is given in Chapter 2, The Capture work environment.

In Capture, each design that you open is in a separate project manager window. If you need to work simultaneously with several designs, you can open them all, and each will have its own project manager window.

Depending on which type of window you have active (an active window is one whose title bar is highlighted), certain buttons on the toolbar and certain items on the menus may be unavailable, since you perform tasks and use tools based upon the type of window that is active. Also, the menus and menu choices vary, depending on which type of window is active. The available menus and menu choices also vary depending upon the type of project.
The Capture work environment

This chapter describes the things you need to know to find your way around in Capture. It shows the windows you’ll see in Capture: the project manager, the schematic page editor, the part editor, the text editor, and the session log. It also introduces you to the toolbar, tool palettes, and general Capture concepts such as selecting and editing objects, editing properties, and undoing and repeating actions.
The project manager

You use the project manager to collect and organize all the resources you need for your project. These resources include schematic folders, schematic pages, part libraries, parts, VHDL files, and output reports such as bills of materials and netlists. Figure 2 shows a new project manager window.

A project doesn’t actually contain all the resources. It merely “points to” the various files that the project uses. For this reason, be sure you don’t move or delete any files referenced by a project. If you do, the project won’t be able to find them.

The project file is saved with an .OPJ file extension. It is an ASCII file, and can be viewed in any text editor.

Project manager folders

The project manager provides a graphical display of a project’s resources by grouping them into appropriate folders, as described below.

- Shown underneath the Design Resources folder is the design folder with the design’s schematic folders and schematic pages, and a Design Cache folder that shows all the parts used on the schematic pages. Capture automatically adds any schematic folders or schematic pages that you create to the design folder. (In Figure 2, the design folder is named DESIGN3.DSN.) You can add other files or information using the Project command on the Edit menu. For example, you can add an existing VHDL file to the design folder and later attach the models within that VHDL file to hierarchical blocks on a schematic page.
• The Library folder (in the Design Resources folder) shows the schematic part library files you’ve added to the project using the Project command on the Edit menu.

• The Outputs folder shows the output of Capture’s processing tools. Generally, these files include bill of materials reports and technology-specific netlists. Capture adds files to this folder when each is created.

Each project may have only one design, but may have multiple libraries. The design may consist of any number of schematics or VHDL models, but it must have a single root module. The root module is defined as the top level of the design. That is, all other modules in the design are referenced within the root module.

Within the project manager, you can expand or collapse the structure you see by double-clicking on a folder, or by clicking on the plus sign or minus sign to the left of a folder. A plus sign indicates that the folder has contents that are not currently visible; a minus sign indicates that the folder is open and its contents are visible, listed below the folder. It appears as a schematic folder with a slash on it in a design file, or as a page in a VHDL file.

Each project you open has its own project manager window. You can move or copy folders or files between projects by dragging them from one project manager window to another (as well as to and from Windows Explorer). To copy rather than move items, press and hold the [Ctrl] key while you drag them. If you close a project manager window, you close the project.

In the project manager’s File tab, double-clicking on a schematic folder expands it and displays icons for each schematic page within the schematic folder. Then, if you double-click on a schematic page icon, the schematic page opens in a schematic page editor. Or, if the page is already open, its window becomes active.

Tip: The root module for a design has a backslash in its folder icon, as shown in Figure 2 on page 2-6.

Note: If a schematic page is open, you cannot drag its icon to a different location.
A design can consist of a single schematic page within a single schematic folder, or a number of schematic pages within a number of schematic folders. A schematic folder contains schematic pages in a relationship similar to that of a directory and the files it contains. Files are contained in a directory; schematic pages are contained in a schematic folder.

A schematic page provides a graphical description of the electrical connectivity of a design. It is made up of parts, wires, and other electrical symbols. A schematic page may also contain borders, title blocks, text, and graphics.

Capture acts on any schematic folders or schematic pages you have selected within an active project manager window. For example, the Find and Browse commands on the project manager’s Edit menu, the Print command on the project manager’s File menu, and the various tools on the Tools menu only apply to the selected schematic folder or page.

Note The project manager is also used to manage libraries and the parts they contain. This is covered in detail in Chapter 11, About libraries and parts.
Project manager tabs— File and Hierarchy

The project manager provides two ways to display a project’s resources.

If you choose the File tab (shown in Figure 3), the project manager displays all the project’s folders, schematic folders, and schematic pages. These are displayed in a tree-like fashion. You can expand or collapse the tree by clicking the plus sign in front of the icon. When that branch of the tree is expanded, the plus sign change to a minus sign.

If you choose the Hierarchy tab (shown in Figure 4), the project manager displays the hierarchical relationship among the project’s schematic folders and schematic pages.

For information about simple and complex hierarchical designs, see Chapter 6, Design structure.

Single view

In Capture v7.2 and earlier versions, Capture uses logical view and physical view to separate instance and occurrence information. In Capture Release 9 and later, both instances and occurrences are together in a single view. The project manager shows all occurrences in the Hierarchy tab.

Capture v7.2 and earlier require you to change view before creating a netlist for use with Orcad Layout. In Capture Release 9 and later, the netlist tool provides an option to use either the instance properties or the occurrence properties for creating a netlist.
Flat and hierarchical designs

In Capture, you can organize your schematics into flat or hierarchical structures and interface to downstream EDA products using either flat (popular for PCB layout) or hierarchical (popular for synthesis and simulation) netlists. The schematic system also supports reuse of schematics within a hierarchy so you only need to draw a schematic once, then instance it in multiple places for a variety of applications. This guide uses the following nomenclature to describe the parts and part properties of these reused schematics:

Simple hierarchy. A hierarchical schematic design with no reuse.

Complex hierarchy. A hierarchical schematic design with reuse.

Part instance properties. The properties of any part that has been placed in a schematic.

Part occurrence properties. The properties of a part that make it unique from others in reused schematics. Required to create a flat netlist with Capture.

Project manager pop-up menus

Several pop-up menus are available in the project manager window. Pop-up menus are available by clicking the right mouse button. You can use the commands on these pop-up menus to open a file or schematic page, or edit and view the properties of the currently selected item.
The schematic page editor

In the schematic page editor, you can display and edit schematic pages. You can place parts, wires, buses, and draw graphics. The schematic page editor has a tool palette that you can use to draw and place everything you need to create a schematic page. You can print from within the schematic page editor, or from the project manager window.

Figure 5 Schematic page editor
Chapter 2  The Capture work environment

The part editor

Create and edit parts using the part editor.

From the View menu of the part editor, you can choose Part or Package. In Part view you can:

- Create and edit parts and symbols, then store them in new or existing libraries.
- Create and edit power and ground symbols, off-page connector symbols, and title blocks.
- Use the tool palette’s electrical tools to place pins on parts, and its drawing tools to draw parts and symbols.

Package view shows the entire package. A package is a physical part that contains more than one logical part. You can edit the properties of the entire package, such as part reference, prefix, part alias, and so on. You cannot edit individual parts in this view, but you can select individual parts to edit by double-clicking on them.

The part editor is very similar to the symbol editor. The main difference between the two is the symbol editor’s lack of Pin and Pin Array tool palette buttons.

For more information, see The part editor tool palette on page 2-22.
See Chapter 11, About libraries and parts for complete definitions of parts and packages. See Chapter 12, Creating and editing parts for a complete description of the part editor.
The programmer’s editor

Use the programmer’s editor to create or view VHDL files or other text files within Capture. VHDL keywords and comments are displayed in the colors you specify. (From the Options menu, choose Preferences and select the Text Editor tab.)

Figure 7  Programmer’s editor

To create a new VHDL file in the programmer’s editor
1  From the File menu, point to New, then choose VHDL File. A blank VHDL file appears in the text editor.

To open a VHDL file in the programmer’s editor
1  From the File menu, point to Open, then choose VHDL File. The Open VHDL File dialog box appears.
2  Select a file, then click OK.

Or
1  In the project manager, select a VHDL file.
2  Click the right mouse button, and choose Edit from the pop-up menu.

Note  Designs and parts of designs can be VHDL-based instead of schematic-based.
The session log

The session log lists the events that have occurred during the current Capture session, including messages resulting from using Capture’s tools. To display context-sensitive help for an error message, put the cursor in the error message line in the session log and press [F1].

The ruler along the top appears in either inches or millimeters, depending on which measurement system (U.S. or Metric) you have selected in the Windows Control Panel. You can add tab settings to the ruler by clicking in the ruler bar and dragging the tabs to different positions, or remove them by dragging them down into the session log window. Capture saves your tab settings so that they reappear each time you start Capture.

You can search for information in the session log using the Find command on the Edit menu. You can also save the contents of the session log to a file, which is useful when working with OrCAD’s customer support staff to solve technical problems. The default filename is SESSION.TXT.

Tip You can clear the session log by choosing the Clear Session Log command, or by pressing [Ctrl] + [Del].
To display the session log
1  Click on the session log’s maximize button, or choose Session Log from the Window menu.

To minimize the session log
1  Click the minimize button on the title bar.

To copy session log text to the Clipboard
1  Select the session log window to make it active.
2  Select the text and choose Copy from the Edit menu.

To print the session log
1  Select the session log window to make it active.
2  From the File menu, choose the Print command.

To use Find in the session log
1  Select the session log window to make it active.
2  From the Edit menu, choose the Find command. The Find dialog box appears.
3  Enter the word or words that you want to find.
4  Click Find Next.

To save the session log to a text file
1  Select the session log window to make it active.
2  From the File menu, choose the Save As command. The Save As dialog box appears.
3  Enter a file name in the File name text box. By default, the session log is saved to SESSION.TXT in the current directory. If necessary, specify a new location for the file.
4  Click Save. The session log text is saved to the file.
Chapter 2 The Capture work environment

The toolbar

Capture's toolbar is dockable (that is, you can select an area between buttons and drag the toolbar to a new location) and resizable. By choosing a tool button, you can quickly perform a task. If a tool button is dimmed, you can't perform that task in the current situation.

![Capture's toolbar](image)

Some of the tools operate only on what you have selected, while others give you a choice of either operating on what is selected or expanding the scope to the entire project.

Table 1 summarizes the tools on the toolbar. The tasks that these tools perform are described throughout this manual.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![icon]</td>
<td>New</td>
<td>Create a new document based on the active document. Similar to the New command on the File menu. For more information, see Creating new projects, designs, libraries, and VHDL files on page 3-52.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Open</td>
<td>Open an existing project or library. Similar to the Open command on the File menu. For more information, see Opening existing projects, designs, libraries, and VHDL files on page 3-55.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Save</td>
<td>Save the active document, schematic, or part. Equivalent to the Save command on the File menu. For more information, see Saving projects, designs, and libraries on page 3-58.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Print</td>
<td>Print the selected pages in the schematic folder, or the active schematic page or part. Equivalent to the Print command on the File menu. For more information, see Chapter 5, Printing and plotting.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Cut</td>
<td>Remove the selected object and place it on the Clipboard. Equivalent to the Cut command on the Edit menu.</td>
</tr>
<tr>
<td>![icon]</td>
<td>Copy</td>
<td>Copy the selected object to the Clipboard. Equivalent to the Copy command on the Edit menu.</td>
</tr>
<tr>
<td><strong>Tools on the Capture toolbar (continued)</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td></td>
</tr>
<tr>
<td><strong>Paste</strong></td>
<td>Paste the contents of the Clipboard at the cursor. Equivalent to the Paste command on the Edit menu.</td>
<td></td>
</tr>
<tr>
<td><strong>Undo</strong></td>
<td>Undo the last command performed, if possible. Equivalent to the Undo command on the Edit menu.</td>
<td></td>
</tr>
<tr>
<td><strong>Redo</strong></td>
<td>Redo the last command performed, if possible. Equivalent to the Redo command on the Edit menu.</td>
<td></td>
</tr>
<tr>
<td><strong>MRU</strong></td>
<td>Place a part or symbol from the list of most recently used parts and symbols. For more information, see To place a part using the Most Recently Used (MRU) List on page 7-120.</td>
<td></td>
</tr>
<tr>
<td><strong>Zoom In</strong></td>
<td>Zoom in to see a closer, enlarged view. Equivalent to choosing Zoom and In from the View menu. For more information, see To zoom in on page 10-188.</td>
<td></td>
</tr>
<tr>
<td><strong>Zoom Out</strong></td>
<td>Zoom out to see more of your document. Equivalent to choosing Zoom and Out from the View menu. For more information, see To zoom out on page 10-188.</td>
<td></td>
</tr>
<tr>
<td><strong>Zoom Area</strong></td>
<td>Specify an area of the schematic page or part to enlarge to fill the entire window. Equivalent to choosing Zoom and Area from the View menu. For more information, see To view a selected area on page 10-189.</td>
<td></td>
</tr>
<tr>
<td><strong>Zoom All</strong></td>
<td>View the entire document. Equivalent to choosing Zoom and All from the View menu. For more information, see To view the entire page or part on page 10-191.</td>
<td></td>
</tr>
<tr>
<td><strong>Annotate</strong></td>
<td>Assign part references to parts on the selected schematic pages. Equivalent to the Annotate command on the Tools menu. For more information, see Annotating on page 14-247.</td>
<td></td>
</tr>
<tr>
<td><strong>Back Annotate</strong></td>
<td>Back annotate the selected schematic pages. Equivalent to the Back Annotate command on the Tools menu. For more information, see Back annotating on page 14-266.</td>
<td></td>
</tr>
<tr>
<td><strong>Design Rules Check</strong></td>
<td>Check for design rules violations on the selected schematic pages. Equivalent to the Design Rules Check command on the Tools menu. For more information, see Checking for design rules violations on page 14-256.</td>
<td></td>
</tr>
<tr>
<td><strong>Create Netlist</strong></td>
<td>Create a netlist for the selected schematic pages. Equivalent to the Create Netlist command on the Tools menu. For more information, see Using the Create Netlist tool on page 15-271.</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 2  The Capture work environment

Displaying or hiding the toolbar

You can hide the toolbar, then display it again when you need it.

To display or hide the toolbar

1. From the schematic page editor’s View menu, choose Toolbar.
   or
   From the part editor’s View menu, choose Toolbar.

Table 1  Tools on the Capture toolbar (continued)

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cross Reference</td>
<td>Create a cross reference report for the selected schematic pages. Equivalent to the Cross Reference command on the Tools menu. For more information, see Creating a cross reference report on page 16-280.</td>
</tr>
<tr>
<td>Bill of Materials</td>
<td>Create a bill of materials report for the selected schematic pages. Equivalent to the Bill of Materials command on the Tools menu. For more information, see Creating a bill of materials on page 16-275.</td>
</tr>
<tr>
<td>Snap-to-Grid</td>
<td>Toggle schematic page and part editing to either on or off grid.</td>
</tr>
<tr>
<td>Project Manager</td>
<td>Display the project manager window for the active document, providing an overview of project contents. Equivalent to choosing a project manager window by number from the Window menu.</td>
</tr>
<tr>
<td>Help Topics</td>
<td>Open online help. Equivalent to the Help Topics command on the Help menu.</td>
</tr>
</tbody>
</table>
The tool palettes

Capture has two tool palettes: one for the schematic page editor and one for the part editor. Both tool palettes are dockable (that is, you can click on an area between buttons and drag a tool palette to a new location) and resizable. While the drawing tools on the two tool palettes are identical, each tool palette has different electrical tools. After you choose a tool (and, in the case of some tools, after you respond to the tool’s dialog box), click the right mouse button to display a context-sensitive pop-up menu.

The schematic page editor tool palette

The first group of tools on the tool palette is electrical tools, used to place electrical connectivity objects. The second group is drawing tools, used to create graphical objects without electrical connectivity.

Table 2 describes the tools on the schematic page editor tool palette.

Note: The tool palette is always docked on the right edge of the session frame the first time you open a schematic page or part in a new session of Capture. The position of the tool palette is not saved.

For information on using the electrical tools, see Chapter 7, Placing, editing, and connecting parts and symbols. For information on how to use the drawing tools, see Chapter 8, Adding and editing graphics and.
Table 2  *Tools on the schematic page editor tool palette*

<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Select" /></td>
<td>Select</td>
<td>Select objects. This is the normal mode.</td>
</tr>
<tr>
<td><img src="image" alt="Part" /></td>
<td>Part</td>
<td>Select parts from a library for placement. Equivalent to the Part command on the Place menu. For more information, see <a href="#">Placing parts on page 7-118</a>.</td>
</tr>
<tr>
<td><img src="image" alt="Wire" /></td>
<td>Wire</td>
<td>Draw wires. Press and hold <code>Shift</code> to draw non-orthogonal (not a multiple of 90°) wires. Equivalent to the Wire command on the Place menu. For more information, see <a href="#">Placing wires on page 7-149</a>.</td>
</tr>
<tr>
<td><img src="image" alt="Net Alias" /></td>
<td>Net Alias</td>
<td>Place aliases on wires and buses. Equivalent to the Net Alias command on the Place menu. For more information, see <a href="#">Placing buses on page 7-152</a>.</td>
</tr>
<tr>
<td><img src="image" alt="Bus" /></td>
<td>Bus</td>
<td>Draw buses. Press <code>Shift</code> to draw non-orthogonal segments. Equivalent to the Bus command on the Place menu. For more information, see <a href="#">Placing buses on page 7-152</a>.</td>
</tr>
<tr>
<td><img src="image" alt="Junction" /></td>
<td>Junction</td>
<td>Place junctions. Equivalent to the Junction command on the Place menu.</td>
</tr>
<tr>
<td><img src="image" alt="Bus Entry" /></td>
<td>Bus Entry</td>
<td>Draw bus entries. Equivalent to the Bus Entry command on the Place menu. For more information, see <a href="#">Placing bus entries on page 7-153</a>.</td>
</tr>
<tr>
<td><img src="image" alt="Power" /></td>
<td>Power</td>
<td>Place power symbols. Equivalent to the Power command on the Place menu. For more information, see <a href="#">Placing power and ground symbols on page 7-128</a>.</td>
</tr>
<tr>
<td><img src="image" alt="Ground" /></td>
<td>Ground</td>
<td>Place ground symbols. Equivalent to the Ground command on the Place menu. For more information, see <a href="#">Placing power and ground symbols on page 7-128</a>.</td>
</tr>
</tbody>
</table>
### Tools on the schematic page editor tool palette (continued)

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
<th>Equivalent to</th>
<th>For more information, see</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Hierarchical Block</strong></td>
<td>Place hierarchical blocks. Equivalent to the Hierarchical Block command on the Place menu. For more information, see Placing hierarchical blocks on page 7-134.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Hierarchical Port</strong></td>
<td>Place hierarchical ports on schematic pages. Equivalent to the Hierarchical Port command on the Place menu. For more information, see Placing hierarchical ports on page 7-139.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Hierarchical Pin</strong></td>
<td>Place hierarchical pins in hierarchical blocks. Equivalent to the Hierarchical Pin command on the Place menu. For more information, see Placing hierarchical pins on page 7-141.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Off-Page Connector</strong></td>
<td>Place off-page connectors. Equivalent to the Off-Page Connector command on the Place menu. For more information, see Placing off-page connectors on page 7-144.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>No Connect</strong></td>
<td>Place no-connect symbols on pins. Equivalent to the No Connect command on the Place menu. See Placing and editing no-connect symbols on page 7-132.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Line</strong></td>
<td>Draw lines. Equivalent to the Line command on the Place menu. For more information, see Drawing lines on page 8-159.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Polyline</strong></td>
<td>Draw polylines. Press and hold (\text{Shift}) to draw non-orthogonal polylines. Equivalent to the Polyline command on the Place menu. For more information, see Drawing polylines and polygons on page 8-163.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Rectangle</strong></td>
<td>Draw rectangles. Holding (\text{Shift}) constrains to a square. Equivalent to the Rectangle command on the Place menu. For more information, see Drawing rectangles and squares on page 8-160.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Ellipse</strong></td>
<td>Draw ellipses. Holding (\text{Shift}) constrains shape to a circle. Equivalent to the Ellipse command on the Place menu. For more information, see Drawing circles and ellipses on page 8-161.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The part editor tool palette

The first group of tools on the part editor tool palette are electrical tools, used to place pins and IEEE symbols. The second group of tools are drawing tools, used to create graphical objects without electrical connectivity.

Table 2  Tools on the schematic page editor tool palette (continued)

<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📜</td>
<td>IEEE Symbol</td>
<td>Place IEEE symbols on a part. Equivalent to the IEEE Symbol command on the Place menu. For more information, see Adding graphics, text, and IEEE symbols to a part on page 12-217.</td>
</tr>
</tbody>
</table>

Table 3  Tools on the part editor tool palette

<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📜</td>
<td>IEEE Symbol</td>
<td>Place IEEE symbols on a part. Equivalent to the IEEE Symbol command on the Place menu. For more information, see Adding graphics, text, and IEEE symbols to a part on page 12-217.</td>
</tr>
</tbody>
</table>
Table 3  Tools on the part editor tool palette (continued)

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin</td>
<td>Place pins on a part. Equivalent to the Pin command on the Place menu. For more information, see Placing pins on a part on page 12-218.</td>
</tr>
<tr>
<td>Pin Array</td>
<td>Place multiple pins on a part. Equivalent to the Pin Array command on the Place menu. For more information, see Placing pins on a part on page 12-218.</td>
</tr>
</tbody>
</table>
Displaying or hiding a tool palette

Like the toolbar, you can hide a tool palette, then display it again when you need it.

To display or hide a tool palette

1. From the schematic page editor’s View menu, choose Tool Palette.
   or
2. From the part editor’s View menu, choose Tool Palette.
The status bar

The status bar, located at the bottom of the Capture session frame, reports on current actions, number of items selected, zoom scale, and pointer location.

![Figure 12: The status bar]

**Left field**

The left field displays descriptions of selected tools or menu items, prompts, or the current status.

**Center field**

The center field displays the number of items selected in the schematic page editor or part editor.

**Right field**

The right field displays the current scale and pointer location (such as: Scale=50% X=10.0 Y=5.0). The location in the schematic page editor is measured in either inches or millimeters, depending on the Units settings in the Schematic Page Properties dialog box (Page Size tab). The pointer location in the part editor is measured in grid units.

Note When a session log or a project manager window is active, the center field of the status bar doesn’t display.
Displaying or hiding the status bar

You can hide the status bar, then display it again when you need it.

To display or hide the status bar

1. From the schematic page editor’s View menu, choose Status Bar.
   
or
   From the part editor’s View menu, choose Status Bar.
Selecting and deselecting objects

Once you select an object, you can perform operations on it, including moving, copying, cutting, mirroring, rotating, resizing, or editing. You can also select multiple objects and edit them, or group them into a single object. Grouping objects maintains the relationship among them while you move them to another location.

This section describes different ways to select individual objects and groups of objects in both the schematic page editor and the part editor.

To select an object

1. Position the pointer on the object and click the left mouse button. The object displays in the selection color.

To reset the selection color

1. From the Options menu, choose Preferences, then select the Colors tab.
2. Click the left mouse button on the Selection color.
3. Click to select a color from the Selection Color window, then click OK. Click OK again to dismiss the Preferences dialog box.

To select multiple objects

1. For each object to select, position the pointer on the object and hold [Ctrl] while you click the left mouse button. Every object in the selection set displays in the selection color.

Tip To select a part, click within the part itself. To select a graphical object, zoom in and click on an outside edge of the object.

To deselect objects

1. Click on the schematic page away from any objects. Selected objects become deselected. Keep in mind that a part occupies a rectangular area encompassing all its graphics. This means that a part may occupy a larger area than is initially apparent.

Note You can edit the properties of a group of objects using the property editor. See The property editor on page 34.
To select all objects in an area
1. From the tool palette, choose the selection tool.
2. Click on an area away from any objects or parts to deselect any items that may be selected.
3. Move the pointer to one corner of the area to select. Press and hold the left mouse button while you drag the mouse to the opposite corner, then release the left mouse button. Every object in the selection set appears in the selection color.

To include or exclude objects intersected by your selection rectangle
1. From the Options menu, choose Preferences.
2. On the Select tab, select one of the Area Select options. You can choose Intersecting to include items that are not fully enclosed by your selection rectangle, or choose Fully enclosed to exclude items that were not entirely selected.

To select all objects on a schematic page or part
1. From the Edit menu, choose Select All. All objects appear in the selection color.

To select an object from a set of objects stacked atop one another
1. Position the pointer over the stack of objects.
2. Press [Tab] while you click the left mouse button. This cycles through the objects in the stack.

To remove one object from a selection set
1. Place the pointer over the object, press [Ctrl], and click the left mouse button.

Note: A selection set behaves as if it is one object, so you can move, copy, cut, delete, mirror, or rotate the entire set. Be aware, however, that the Select All command also selects the title block on the schematic page. If you copy or move the selection set, you could create a duplicate title block, or inadvertently move the title block off the schematic page.
Grouping objects

Use the Group command on the Edit menu to group multiple objects into one selectable object. This is a convenient way to maintain the relationship among several objects while moving them to another location. You can nest groups, meaning a group can contain other groups as well as objects.

The Group command is only available when multiple objects are selected. Objects remain grouped until you ungroup them or close the schematic page or part that contains them.

To group multiple selected objects

1. Select the objects you want to group. (See Selecting and deselecting objects on page 2-26 for more information).
2. From the Edit menu, choose Group. You can move the objects as a group.
3. When have finished working with the objects as a group, you can ungroup them. From the Edit menu, choose Ungroup.

Caution The Group command will not be available if your selection includes a net alias (a property). After block selecting the objects you want to group, deselect the included net aliases by holding the [Ctrl] key and clicking on each object.
Editing properties

In a Capture schematic design, each object has properties that define their characteristics. These objects include:

- Parts (including hierarchical blocks)
- Nets (including constituent nets within buses)
- Pins
- Globals
- Aliases
- Hierarchical ports
- Off-page connectors
- DRC markers
- Bookmarks
- Title block

A property consists of a property name (for example, Part Value or Part Reference) and an associated value (for example, TIP31C or Q2). For example, part properties define the name, value, reference designator, and other information for each part in your design.

In Capture you can edit property values, create or delete properties, or cause the properties to be displayed on the schematic page.

Use one of three editors to edit properties:

- The **Browse spreadsheet editor**, as described on page 2-31.
- The **property editor**, as described on page 2-34.
- The **Package Properties spreadsheet editor**, as described on page 45.
Instance and occurrence properties

Since Capture allows for complex hierarchical design structures (as discussed in Chapter 6, Design structure), each of the objects listed above can exist as instances or occurrences.

In complex hierarchical designs, a schematic page can be referenced (or reused) at several points in the design. An instance refers to the object that is placed on the defining schematic. An occurrence represents the use or reuse of that instance within a design. When you edit properties for an object, you can edit the instance, or you can edit a particular occurrence of that instance.

Instance properties

An instance property is a user property applied to the placed instance of a part or symbol in the design. This includes PCB Footprint, Value, and Name properties of each placed part or symbol in a design. The instance property overrides the library definition.

An instance property will “shine through” to all occurrences of that instance unless it is overridden by occurrence properties. A change using any of the tools, like Annotate, also may update the instance property.

Occurrence properties

An occurrence property is a user property applied to multiple occurrences of place instances of parts or symbols in a design. The occurrence property overrides the instance property definition.

The spreadsheet editors expand to display occurrence properties if values are different from the instance value. To quickly hide or display all the occurrence properties, press and hold the [Ctrl] key while clicking on one of the plus (+) symbols in the property editor.

A change using any of the tools, like Annotate, also may update the instance property.
The Browse spreadsheet editor

You display the Browse spreadsheet editor from the project manager’s Edit menu, the schematic page editor, or the part editor. The particular Browse spreadsheet that you display depends on the object you select from the Browse pull-right menu. The options include:

- Hierarchical ports
- Off-page connectors
- DRC markers
- Bookmarks
- Part (including hierarchical block) occurrences
- Net (including constituent nets within a bus) occurrences
- Pin properties
- Title block occurrences
- Flat nets

The Browse spreadsheet editor browses the entire design for the objects you select, then displays their properties. Each property appears as a column heading in the spreadsheet. Each row is an object located by the editor.

It is important to note that, in the Browse spreadsheet editor you can only edit properties for occurrences. The only exception being in the part editor, where you can only edit instances. To edit instance properties, you must use the property editor discussed in The property editor on page 2-34.
To create a new property in the Browse spreadsheet editor

1. In the first column of the Browse spreadsheet, select the object or occurrence for which you want to create the new property.
2. From the Edit menu, choose Properties. Capture displays the object in a new Browse spreadsheet window.
3. Click New. Capture displays the New Property dialog box.
4. Enter a name and value for the new property, then click OK. Capture adds the property to the object or occurrence and displays the new property in the original Browse spreadsheet.

To copy a value from one property to another property in the Browse spreadsheet editor

1. In the first column of the Browse spreadsheet, select the object or occurrence that has the property with the value you want to copy.
2. From the Edit menu, choose Properties. Capture displays the object in a new Browse spreadsheet window.
3. Select the cell that contains the value you want to copy.
4. Click Copy.
5. Select the cell that you want to contain the copied value.
6. Click Paste. Capture pastes the value into the selected cell.
Chapter 2  The Capture work environment

To remove a user-defined property in the Browse spreadsheet editor

1. In the first column of the Browse spreadsheet, select the object or occurrence that has the property you want to remove.
2. Select the column heading for the property you want to remove.
3. Click Remove. Capture removes that property from the object.

To replace property values

1. Select the objects whose properties you want to edit. Note that the objects must be of the same type (for example, all pins or all hierarchical ports); otherwise, the Properties command is grayed out.
2. From the Edit menu, choose Properties. The Browse spreadsheet appears.
3. Double-click on a cell holding the value you wish to replace, then enter the new value.
4. Click the copy button.
5. Select the cells that are to receive the replacement value.
6. Click the Paste button. The replacement value appears in the selected cells.
7. Click the OK button to close the Browse spreadsheet.

Note  Some properties cannot be removed as they are essential for creating a netlist. You can only remove user-defined properties.

Note  If you remove a property from an occurrence for which there is a defined instance property, the occurrence property is not removed, but rather, the instance property value “shines through” to the occurrence. In order to remove an instance property you must use the property editor.

For more information about instance and occurrence properties see The property editor on page 2-34.
The property editor

You display the property editor either by selecting items on a schematic page, then choosing Properties on the Edit or popup menu, or by simply double-clicking on an item in the schematic page editor.

The property editor allows you to edit properties for instances or occurrences of the following objects:

- Parts (including hierarchical blocks)
- Nets (including constituent nets within buses)
- Pins
- Title blocks
- Globals
- Ports
- Aliases

The property editor is constrained such that it can only edit instances or occurrences on the active schematic page. To browse and edit properties for an entire design, see The Browse spreadsheet editor on page 2-31.

Note: Globals are power and ground symbols, or any other objects that behave like power and ground.
The property editor window

The properties that appear in the property editor depend on the items selected in the schematic page. Also, these properties depend on the tab selection at the bottom of the property editor. For example, if the Parts tab is active, the properties for selected parts appear in the property editor.

![Property editor window diagram]

- **Instance name**: schematic name:page:reference
- **Property names**: Filter drop-down list
- **Occurrence**: hierarchical path:reference
- **Property value**: Item selection tabs

**Figure 14  Property editor**

Each column in the property editor is a placeholder that you can use to add properties.

Each row is an instance or occurrence. Occurrence rows appear in yellow below their associated instance row. They only appear if one or more occurrence property values are different from the instance property values and you expand the instance by clicking the plus sign (+) to the left of the instance name.

The cells in the property editor show the property values for each instance or occurrence. If a white cell contains a cross-hatch pattern, the corresponding property does not have an instance value, causing the library definition to “shine through” to the instance. If a yellow cell contains a
cross-hatch pattern, the corresponding property does not have an occurrence value, causing the instance property value to “shine through” to the occurrence.

**New Column or New Row** Displays the Add New Column dialog box or the Add New Row dialog box, depending on the property editor orientation. These dialog boxes add a new property column or row, respectively. To add the property to an object, you must enter a property value for the object.

**Apply** Applies the changes in the property editor to the schematic page. The Apply button does not dismiss the property editor. You can also apply the changes to the schematic page by closing the property editor.

**Display** Opens the Display Properties dialog box to set the display options of the selected property and its value. You cannot display properties of an occurrence property using the Display Properties dialog box.

**Delete Property** Deletes the property, if editable, from the selected object or objects. If you select all of a property’s cells and click the Delete Property button, the property will be removed from the selected objects but will remain in the filter. This is indicated by the cross-hatch pattern that appears in the cell.

**Filter by** Specifies a filter by which you can view objects. Use the filters available in the drop-down list to constrain the available properties. Each filter is a set of properties that are typically useful for particular project types. For example, the Actel Designer Part/Net Properties filter includes properties that are useful for constraining a PLD project for integration with Actel’s Designer software. The Capture filter displays common schematic capture properties available to most parts. The Layout filter displays properties needed to send a design to Orcad Layout. The <Current properties> filter causes

Note: You can pivot the property editor spreadsheet. Instances and occurrences appear in columns across the top and properties appear in rows. This may be advantageous if your selected object or objects have several properties. See To pivot the property editor spreadsheet on page 2-38.

Note: Properties that are not editable appear in italics.
the property editor to display all properties that currently exist for the selected item. For more information, see The property editor Filter menu on page 2-39.

**Parts tab** Displays the parts of the selected objects, including hierarchical blocks.

The Graphic property column provides the option to toggle the display of the part between Normal and Convert view. When you click the Graphic cell, a down arrow indicates a drop-down list where you can select a different view.

**Schematic Nets tab** Displays the schematic nets of the selected objects, including constituent nets within buses.

**Pins tab** Displays the pins of the selected objects, including hierarchical pins in hierarchical blocks.

**Title Blocks tab** Displays the title blocks of the selected objects. With this tab, you can add a property to the Title Block instance on a schematic page that displays the full hierarchical path to the schematic.

**Globals tab** Displays selected globals for simultaneous editing of multiple names.

**Ports tab** Displays the source symbol, source library, and type of port. This tab provides for simultaneous editing of multiple ports.

**Aliases tab** Displays color, font, name, and rotation of net aliases. Use this tab to edit multiple aliases at one time.
**To pivot the property editor spreadsheet**

1. Right-click the empty cell in the top-leftmost position of the spreadsheet.
2. From the pop-up menu, choose Pivot.

**To display or hide all occurrence properties**

1. To display all occurrence properties, press and hold the Ctrl key while clicking on one of the plus (+) symbols in the left-most column.
2. To hide all occurrence properties, press and hold the Ctrl key while clicking on one of the minus (-) symbols in the left-most column.

**To move columns in the property editor**

1. Select the column you want to move by clicking on its title cell.
2. Drag the column to the new location.

**To sort columns in the property editor**

1. Right-click on the column heading. A pop-up menu appears.
2. Choose Sort Ascending or Sort Descending.

*Note*  The Find command searches down columns in the spreadsheet, regardless of the spreadsheet orientation.

*Note*  If the spreadsheet is pivoted, use these steps to move rows.
The property editor Filter menu

The property editor filter is a powerful tool with which you can show or hide properties on selected objects. You can use the pop-up Filters menu on the spreadsheet to view the status of a property or edit columns, tabs, or the entire property editor spreadsheet.

You can add, delete, or change any filter except the <Current properties> filter. The <Current properties> filter displays all properties as undefined until you create or select another filter.

When you create a new filter, all properties appear undefined, just as in the <Current properties> filter. If you right-click a column heading and select Filters from the pop-up menu, you will see that each property is Undefined, and the filter specifies Show Undefined.

Your results will be more reliable if you use the property editor Filters menu to make changes rather than editing the PREFPROP.TXT file manually.

Changes to the filters are saved to PREFPROP.TXT when you close the spreadsheet. If you need to retrieve the original version, you can copy PREFPROP.TXT from the Orcad installation CD in the Capture directory.

The first four choices on the Filter menu apply to the appearance of a particular tab and column.

**Show** The selected column always appears when you use the filter, unless the filter is inverted.

**Hide** The selected column never appears when you use the filter, unless the filter is inverted.

**Optional** The selected column only appears if the property exists on one or more objects when you use this filter.
Undefined  The selected property is not defined. It isn’t included or excluded from the filter.

You can control the display of undefined properties on individual tabs with the next two choices on the Filter menu. Select any combination of the two.

**Show Undefined**  Specifies that any undefined property columns that are selected appear when you use the filter. However, if you also select Invert Filter, these same selections will not appear.

Defined properties appear at the beginning of the spreadsheet (toward the left side) when you select this option.

**Invert Filter**  Shows hidden property columns when you use the filter. Conversely, it will hide any property columns that you have specified to show. For example, if a property is optional and does not exist on any objects, you can use Invert Filter to show the property.

The last two choices on the Filter menu affect all tabs on the property editor.

**Add Filter**  Add a new filter to all tabs. The default of a new filter is to show all properties as undefined.

**Remove Current Filter**  Delete the filter currently displayed in the Filter by list box. You cannot undo this operation.
Chapter 2  The Capture work environment

To create a new filter in the property editor

1  Right-click any column heading in the spreadsheet.
2  Point to Filters in the pop-up menu and choose Add Filter.
3  Type the new filter name in the Add Filter dialog box and click OK. The new filter is saved in PREFPROP.TXT when you close the property editor.

To edit a filter

1  Select a filter from the Filter by drop-down list. The appearance of the properties on the spreadsheet may change when you change the filter.
2  Right-click any column heading and point to Filters in the pop-up menu.
3  Use the Filters menu choices to change the property definitions and appearance of the spreadsheet.
Using the property editor

When editing properties in the property editor, it is important to remember a few key points:

- Property values that are applied to instances will “shine through” to all occurrences of those instances, unless an occurrence has a value (independent of the instance value) for a particular property.
- Occurrence property values override instance property values.
- When you delete an instance property, that property will no longer “shine through” to its occurrences.
- Deleting a property value from an occurrence causes the instance property value to “shine through” to that occurrence.
- Library definitions will “shine through” to the instance and occurrence of the object only if the instance or occurrence value is unedited.

To create a new property in the property editor

1. In the schematic page editor, select the object(s) for which you want to create the property.
2. From the Edit menu, choose Properties. Capture displays the property editor.
3. Click the New Column or the New Row button. Capture displays the Add New Column dialog box or the Add New Row dialog box.
4. Enter a name for the new property and click OK. Capture adds the new property to the property editor and to all instances and occurrences currently displayed therein.
5. Enter values for the property as described in To edit a property value in the property editor.
Chapter 2  The Capture work environment

To edit a property value in the property editor

1. In the property editor, select the cell that contains the value you want to change.
2. Right-click and choose Edit from the pop-up menu. The Edit Property Values dialog box appears.
3. Type in the new value and press Enter. Note that changing an instance property value causes that value to “shine through” to all occurrences of the instance that do not have a value independent of the instance.

To edit the a property value for all instances and occurrences currently displayed in the property editor

1. In the property editor, click the top-leftmost cell to select the entire spreadsheet.
2. Right-click and choose Edit from the popup menu.
3. Select a property cell in the Edit Property Value dialog box spreadsheet.
4. Type the new value for the property and click OK. The new property value appears on the spreadsheet for all selected objects.

To delete a property in the property editor

1. Select the column of the property you want to delete.
2. Click the Delete Property button. The property is removed. (The property column remains in the display. To see that the property is deleted, leave the property editor and then return to it.)

Note Some property values (those that have particular significance to the design database) cannot be edited. Properties that are not editable appear in italics.

Note Some property values (those that have particular significance to the design database) cannot be deleted.
To display a property on the schematic page

1. In the property editor, select the instance property cells you want to display, then click the Display button. Capture displays the Display Properties dialog box.

2. Complete the dialog box as desired, then click OK. Capture displays the property on the schematic page for all instances currently displayed in the property editor.

For information on the Display Properties dialog box, see the Capture online help.

Note: Although you can only set the display for instances, the property value that appears on the schematic page is that of the particular occurrence.
The Package Properties spreadsheet editor

You can edit package properties using the Package Properties spreadsheet editor. The Package Properties spreadsheet editor is available in the part editor while in Package View. Use the Properties command on the Edit menu to display this spreadsheet. The spreadsheet displays all the package information on pins.

![Package Properties spreadsheet editor](image)

Figure 15  Package Properties spreadsheet editor

The Package Properties spreadsheet editor is similar to the Browse spreadsheet editor with the following differences:

- The Package Properties spreadsheet editor doesn’t have New or Remove buttons. You cannot add properties to a package or remove existing properties.
- The Package Properties spreadsheet displays all of the pins in the package, regardless of what is selected in the part editor.
- The Package Properties spreadsheet displays the PinGroup and Ignore properties. These do not show up in the Browse spreadsheet editor.
- The Package Properties spreadsheet has an Update button and a Validate button.
**Update button**  Use this to update the properties of all the pins in the package. This is useful if you change a property on one pin and need to change this property on the same pin in the other parts of the package. For example, say you have a four-part package and each part in the package has a pin named IN. If you change this pin from a passive pin to an input pin the A package part, you could use Update to change the property for the IN pin in the B, C, and D package parts. The Update button updates all pins at once, without requiring that you click OK.

**Validate button**  Use this button to check for duplicate pins. For example, suppose you have a pin 1, and then change another pin to pin 1. Using Validate detects the duplicate. The Validate button checks for duplicate pin numbers without requiring that you click OK.
Moving and resizing graphic objects

For some objects—such as wires, buses, lines, ellipses, rectangles, and so on—you can edit the object’s size and shape by clicking on it and dragging its resize handles.

Before you can move or resize a graphic object, you must first select it. A selected object has resize handles that you use to change the size of the graphical object.

To resize and move objects

1. Select the object to resize or move.
2. To resize the object, press the left mouse button on a resize handle, and drag the handle until the object is the size you would like it. Release the mouse button. 
   *or*
   To move the object, press the left mouse button anywhere on the object—except on a resize handle—and drag the object until it is where you want it. Release the mouse button.
3. To deselect the object, click in an area where there are no parts or objects.

Note: For descriptions of other ways to manipulate objects, see Chapter 8, Adding and editing graphics and text.
Undoing, redoing, and repeating an action

You use the Undo command to undo your action. To repeat an edit action, use the Repeat command. For example, you might move a selected object five grid units, then realize you also need to move a different object the same distance. Select the second object, then from the Edit menu, choose the Repeat command. You can use the Undo, Redo, and Repeat commands with the following actions:

- Placing objects
- Deleting objects (except for the Repeat command)
- Copying objects
- Moving objects
- Resizing objects
- Rotating objects
- Mirroring objects

To undo an action

1. From the Edit menu, choose Undo.

To reverse an undone action

1. From the Edit menu, choose Redo.

To repeat a command

1. Perform the command once.
2. From the Edit menu, choose Repeat.

Tip: You can use the Repeat command to align objects or to quickly create repetitive structures such as buses.
To repeat a copy operation

1. Select an object on a schematic page.
2. Press [Ctrl] and drag the object to a new location. This creates a copy of the object. Leave the object selected.
3. From the Edit menu, choose Repeat. The pointer repeats the relative move in step 2 and an additional object is placed.
Using the Accessories menu

You can use extensions to the Orcad-supplied functionality of Capture if you purchase software developed by associates of Orcad. These associates create .DLL files that address specific Capture functionality, such as customized netlist creation. The associates configure their .DLL files so that they are listed as menu choices on the Accessories menu, available in either the project manager window or the schematic page editor window.
Chapter 2  The Capture work environment
A project file (.OPJ) stores pointers to a single design file (.DSN), and can also contain libraries, VHDL files, and output reports associated with the design file. A design file contains one or more schematic folders, in which there are one or more schematic pages. A design file also contains a design cache, which is like an embedded library—it contains a copy of all the parts and symbols used on the schematic pages. When a design is saved with the project file, information from the various Tools dialog boxes is also saved in the project file.

Note: Parts reside in a library the same way schematic pages reside in schematic folders. Symbols and title blocks also reside in libraries. A project can use any number of libraries, and a library can be included in any number of projects. However, a project may have only one design (.DSN).
Creating new projects, designs, libraries, and VHDL files

Capture includes a project wizard that provides an easy method for creating a project, complete with library and simulation resources.

Creating a project does not create a design within the project. A new design inherits characteristics from the settings in the Design Template dialog box, so you should always check those settings before you create a design.

A newly created project contains a schematic folder that holds one schematic page. After you create a schematic folder, you can move existing pages into it, and you can create new pages in it.

Libraries store parts, symbols, custom title blocks, as well as schematic folders and the schematic pages contained in them. With Capture, you can have as many libraries as you wish to suit any purpose, and you can specify the name and storage location of your library. Each library is available to each project.

To create a new project

1. From the File menu, choose New, then choose Project. The New Project dialog box appears.
2. Type a name for your new project in the Name text box.
3. Use the Browse button to select a new directory.
4. Select a project type in the Create a New Project Using group box, and click OK. Capture provides the following project types:
   - Analog or mixed signal circuit—select this type of project if you intend to use your design with PSpice. Follow the guidance of the Analog Mixed-Mode Project wizard to add the appropriate files to your project.

Note: The project types available to you will depend upon which Orcad programs you have installed. As a minimum, you will have the option to create a PC Board or Schematic project type.
• PC board—select this type of project if you intend to use your design with Orcad Layout. Follow the guidance of the PCB Project Wizard to add the appropriate files to your project.

• Programmable logic—select this type of project if you intend to use your design with an FPGA or CPLD EDA tool. Follow the guidance of the Programmable Logic Project Wizard to add the appropriate files to your project.

• Schematic—select this type of project if none of the other project types apply. Using this option, Capture creates a basic project containing only the design file.

**To create a new design**

1. From the File menu, choose New, then choose Design.
2. The design opens in a new PCB project manager and a new schematic page displays.

The first time you save a new design, the Save As dialog box appears, giving you the opportunity to specify a drive and replace the system-generated name.

**To create a new schematic page**

1. On the File tab of the project manager, select the schematic folder that requires a new schematic page.
2. Click the right mouse button and choose New Page from the pop-up menu. A new schematic page appears within the schematic folder you selected in step 1.

**To create a new library**

1. From the File menu, choose New, then choose Library.
2. The library opens in the project manager and a Library Cache folder is added to the project manager, or the library opens in the existing open project manager and a library cache is added.

**Note** A project cannot have more than one design (.DSN) file. If you try to add a second .DSN file to your project, the Overwrite dialog box appears, asking if you want to replace the existing design.

For information on how to create parts for inclusion in a library, see Chapter 12, Creating and editing parts.
To create a new VHDL file

There are two ways to create a new VHDL file in Capture:

1. From the File menu, choose New, then choose VHDL File.
2. A VHDL file opens in Capture’s VHDL programmer’s editor.

Or

1. With the project manager active, choose New VHDL File from the Design menu. The file opens in the VHDL programmer’s editor and a dialog box appears, asking if you want to add the file to the project.
2. Choose the Yes button to add the file to the project that is currently open. The Save As dialog box appears.
3. Select a directory for the file and supply a filename. By default, the VHDL file’s name is VHDLn.VHD (where n is an integer indicating the number of .VHD files created in the current session).
4. Choose the Save button. Capture saves the file and places it in the Design Resources folder of your project.

Note: If you choose the No button, Capture does not add the VHDL file to your project and you must save it yourself at a later point in time.
Opening existing projects, designs, libraries, and VHDL files

You can open an existing project, design, library or VHDL file. Existing schematic pages can only be opened from within designs and libraries.

To open an existing project

1. From the File menu, point to Open, then choose Project. The Open Project dialog box displays.
2. Select a project (.OPJ) or type the name in the File name text box, then choose the Open button. The project opens in the project manager.

To open an existing design

1. From the File menu, point to Open, then choose Design. The Open Design dialog box displays.
2. Select a design (.DSN) or type the name in the File name text box, then choose the Open button. The design opens in the project manager.

To open an existing schematic page

1. In the project manager, select the File tab and double-click the icon of a schematic folder; this expands the folder and reveals the schematic pages it contains.
2. Double-click on the icon of the schematic page you want to open. The schematic page opens in a schematic page editor window.

Tip: The four files that were last opened are listed at the bottom of the File menu. To open one of these files, select it from the File menu.
Chapter 3  Starting a project

To open an existing library
1  From the File menu, point to Open, then choose Library. The Open Library dialog box displays.
2  Select a library (.OLB) or type the name in the File name text box, then choose the Open button. The library opens in the project manager.

To open an existing VHDL file
1  From the File menu, point to Open, then choose VHDL File. The Open VHDL File dialog box displays.
2  Select a VHDL file (.VHD) or type a name in the File name text box, then choose the Open button. The VHDL file opens in Capture’s text editor.
Working with files in a project

Using the project manager, you can add or delete project files. You can add any file to your project, including libraries and VHDL files. Files not in ASCII format, or a Capture generated format, may not appear as expected when opened in Capture.

To add a file to your project

1. In the project manager, select the folder to which you want to add a file.
2. From the Edit menu, choose Project. The Add File to Project Folder dialog box displays.
3. Select the file you want to add and choose the Open button. The file is added to the project.

Or

1. Drag the file from the Windows Explorer into the folder in the project manager.

Note You can also add files to your project interactively. When you create a design using the New command on the File menu, it is placed in the project manager’s Design Resources folder.

To delete a file from a project

1. In the project manager, select the file you want to delete.
2. Press the Delete key. The file is removed from the project.

Caution You will not be given a chance to cancel this process after you press the Delete key. If you delete a file by mistake, you will have to add it back to the project.
Saving projects, designs, and libraries

When the project manager window is active, you can save a new or existing project, design, or library. The Save command saves all open documents referenced by the project, as well as the project itself.

A Capture design file (.DSN) is associated with a project file (.OPJ). Each time you use the Save As command from the File menu to save a design file to another name or directory, you should also use Save As for the project file.

The Save As command saves files depending on what you have selected in the project manager.

- If one or more designs or libraries are selected, Capture prompts you to save each file in turn.
- If no top-level folders (Design Resources or Outputs) are selected, and items other than designs or libraries are selected, the Save As command is unavailable.
- If no designs or libraries are selected in the project manager, Capture prompts you to save the project.

To save a new design or library

1. With the design or library selected in the project manager, from the File menu, choose Save. The Save As dialog box displays.

2. Enter a name for the design or library in the File name text box, specify a location, then choose the Save button.

The design or library is saved, and the project manager remains open. When you close the project, Capture prompts you to save the project file.
Closing a project

To save an existing project

1. With the Design Resources or Output folder selected, choose Save from the File menu.

   The project is saved, and remains open in the Capture session frame.

Using the Save As command

The following process saves a .DSN file and a .OPJ file into the same directory so you can continue editing the current project without altering the original files.

1. In the project manager, select the design file.
2. From the File menu, choose Save As.
3. Change the drive and directory as appropriate, then select the file name and click Save.
4. Select the Design Resources folder.
5. From the File menu, choose Save As.
6. Change the drive and directory as appropriate, then select the file name and click Save.

Closing a project

When the project manager window is active, you can close a project without quitting Capture, or you can close and save your project as you quit.

To close a project

1. From the project manager’s File menu, choose Close Project.

When you close a project, a dialog box displays, asking if you want to save your changes.

To quit Capture

1. From the project manager’s File menu, choose Exit.
When you choose the Exit command, a dialog box displays, asking if you want to save your changes.

- Choose Yes to save the specific document within the project.
- Choose Yes All to save all documents in the project.
- Choose No to close the document without saving it.
- Choose No All to close all open documents without saving them.
- Choose Cancel to abort closing the project.
Archiving a project

When the project manager window is active, you can archive a project. Archiving saves all files related to your project in the specified directory. Specifically, this command saves your project files (*.OPJ), design files (*.DSN), and library files (*.OLB) in the Design Resources folder. You can include output files and library files, like *.OLB files in the Library folder and *.VHD files.

To archive a project

1. Make sure that the project you want to archive is active.
2. From the project manager’s File menu, choose Archive Project. The Archive Project dialog box appears.
3. Select the types of additional files you want archived with your project. If you don’t select any of the options (Library files, Output files, Referenced projects), Capture automatically arches your project (*.OPJ) and design files (*.DSN).
4. Enter or browse to the directory in which you want to archive your project.
5. Click OK. Capture archives your project with all the selected external files to the specified directory. The working directory does not change to the archive directory.

Note: Archive Project archives the simulation profiles and the local files (*.LIB, *.STL, and *.INC files) along with PSpice projects. The Output files option does not archive simulation output like *.DAT and *.OUT files.
Setting up your project

Capture provides different levels of configuration. Using commands on the Options menu, you can:

- Customize the working environment specific to your system (using Preferences).
- Create default settings for new designs (using Design Template). These settings stay with the design as design properties even if it is moved to another system with different preferences.
- Override settings in individual designs (using Design Properties) or individual schematic pages (using Schematic Page Properties).

Regardless of which Capture window is active, the Options menu has a Preferences command and a Design Template command. In addition, the Options menu contains commands specific to the current active window. For example, the project manager’s Options menu contains the Design Properties command, while the schematic page editor’s Options menu contains the Schematic Page Properties command.
The settings in the Preferences dialog box determine how Capture works on your system, and persist from one Capture session to the next because they are stored in the Capture initialization (.INI) file on your system. If you pass projects to others, they won’t inherit your Preferences settings. This means you can set colors, grid display options, pan and zoom options, and so on to your liking and be assured that your settings will remain, even if you work on a project created on another system.

The Design Template dialog box determines the default characteristics of all the projects created on your system. Because a new project inherits characteristics from the current Design Template settings, it’s a good idea to check the settings before you create a new project.

Once you begin working on a project, you can customize its particular characteristics by choosing Design Properties from the Options menu when you are in the project manager, or Schematic Page Properties when you are in the schematic page editor.
Defining your preferences

The options that you define in the tabs of the Preferences dialog box affect how Capture works with your projects. Choose Preferences from the Options menu to access the Preferences dialog box.

- Colors/Print. Set up colors for objects such as off-page connectors, hierarchical blocks and ports, text, title blocks, and so on, and specify which objects will be printed or plotted. You can also change the background color and the color of the grid.

- Grid Display. Select dots or lines for your grid, and whether to display or print your grid. You can select whether to have your pointer snap to grid as you place objects. You can set these options independently for the schematic page editor and the part editor.

- Pan and Zoom. Define how you want autoscrolling to work, and what the zoom factor should be. You can set these options independently for the schematic page editor and the part editor.

- Select. Define whether you want to select objects enclosed by a selection rectangle or objects inside and intersecting a selection rectangle, the maximum number of objects to display at high resolution while dragging, and whether to show the tool palette. You can set these options independently for the schematic page editor and the part editor.

- Miscellaneous. Define the default fill, line style and width, and color for graphic objects, define the font used in the project manager and session log, render TrueType fonts with strokes (for printing and plotting), and set whether to auto recover your project and how often. In addition, you can enable intertool communication, which is the method that Capture uses to communicate with other Orcad software, such as Orcad Layout.

- Text Editor. Define which (if any) VHDL keywords are highlighted, and the font and tab settings used within the text editor.
Defining colors/ print options

You control the color in which different schematic page objects display by using the Colors/Print tab in the Preferences dialog box.

![Figure 19 Colors/Print tab of the Preferences dialog box](image)

To define if an object is printed or plotted

1. From the Options menu, choose Preferences, then choose the Colors/Print tab.

2. Select the check box by the color for the object to be printed or plotted. Clear the check box for the object not to be printed or plotted. Objects are always displayed on your screen, regardless of the setting of their check boxes.
To define an object’s color

1. From the Options menu, choose Preferences, then choose the Colors/Print tab.

2. Click the left mouse button on the color of an item. The color palette window opens.

3. Select a new color. Click OK to dismiss the color palette.

4. Click OK.

Graphics objects (lines, polylines, and arcs) use the colors specified by Miscellaneous tab. If the color options in the Miscellaneous tab are set to Default color, then Capture uses the color specified for graphics by the Colors/Print tab.

Note: The color that you select for Title Block is also the color used for borders and grid references.
Controlling the grid

You can control whether Capture displays a grid independently in the schematic page editor and the part editor, and whether the grid uses dots or lines. You can also specify whether the pointer snaps to grid in each editor.

To control the grid

1. From the Options menu, choose Preferences, then choose the Grid Display tab.
2. For the schematic page editor and the part editor, specify:
   - Whether to display the grid.
   - Whether the grid uses dots or lines.
   - Whether the pointer snaps to grid as you place objects.
3. Click OK.
Setting pan and zoom

When you have an object attached to the pointer and you move the pointer near the edge of the window while holding the left mouse button down, the display changes to a different region of the document. This change is called *panning*. The display automatically pans only if you hold the left mouse button down whether or not an object is attached to the pointer; otherwise, you must use the window’s scroll buttons to view a different region of the document. You configure the percent by which the display changes using the Auto Scroll Percent setting.

When you zoom in or out, the view changes by the zoom factor. You can define pan and zoom settings for the schematic page editor and the part editor independently.

![Pan and Zoom tab of the Preferences dialog box](image)

*Figure 21  Pan and Zoom tab of the Preferences dialog box*
Chapter 4  Setting up your project

To configure zoom factor and auto scroll percent

1. From the Options menu, choose Preferences, then choose the Pan and Zoom tab.

2. For the schematic page editor and the part editor, set these options:
   - Zoom Factor. Enter an integer to indicate the magnification or reduction of the objects shown in the window when you zoom in or zoom out. This number is a multiplier for each time you zoom in or out.
   - Auto Scroll Percent. Enter the percent of the window’s horizontal or vertical dimension by which the display will scroll when the pointer approaches the edge of the window with an object attached.

3. Click OK.

Tip  You can also auto scroll without an object attached to the pointer by pressing the left mouse button as the pointer approaches the edge of the window.
Defining selection options

You can specify whether objects are selected when the selection border intersects them or if the objects are selected only when they are completely enclosed in the selection area. You can also change the maximum number of objects displayed at high resolution while dragging, and set tool palette visibility in both the schematic page editor, and the part and symbol editor.

![Preferences dialog box]

**Figure 22** Select tab of the Preferences dialog box

To define selection options

1. From the Options menu, choose Preferences, then choose the Select tab.

2. For the schematic page editor and the part editor, set these options:
   - Area Select. Specify whether to select objects that are inside and intersecting the selection border or only objects that are fully enclosed by the selection border.
Chapter 4  Setting up your project

Note  Capture may perform slower if you set the Maximum number of objects to display at high resolution while dragging to a large number.

• Maximum number of objects to display at high resolution while dragging. If you drag more objects than you specify here, you will see rectangular placeholders for the objects as you drag them.

3  Click OK.
Setting miscellaneous options

You can specify the default fill, line style and width, and color for graphics objects, define the font used in the project manager and session log, render TrueType fonts with strokes (for printing and plotting), and set whether to enable auto recovery for your project and how often. In addition, you can enable intertool communication, which is the method that Capture uses to communicate with other Orcad software, such as PSpice.

You can change the fill style, line style and width, and color on graphic objects on an individual basis once they are drawn on a schematic page. Select the object, then from the Edit menu, choose Properties. For specific instructions, see Chapter 8, Adding and editing graphics and text.

For information about intertool communication between Capture and Layout, see Chapter 19, Using Capture with Orcad Layout.

For information about intertool communication between Capture and PSpice, see Chapter 20, Using Capture with PSpice.

Figure 23  Miscellaneous tab of the Preferences dialog box

To set miscellaneous options

1  From the Options menu, choose Preferences, then choose the Miscellaneous tab.

2  For the schematic page editor and the part editor, set these options:
   • Fill Style. Select the fill pattern to be used when drawing rectangles, ellipses, and closed shapes drawn with the polyline tool.
Chapter 4  Setting up your project

3 For the schematic page editor, set this option:

- Color. Select the color used for graphic objects (rectangles, ellipses, and closed polylines).

4 Set the following options:

- Session Log. Select a font for display text in the project manager and session log. If you select this option, a standard Windows dialog box for font selection appears. Select a font, style, and size from the dialog box, then click OK.

- Text Rendering. The text rendering options affect how text on a schematic page appears on your screen, and how it is printed or plotted. The Render TrueType fonts with strokes option displays text as a series of lines, connected to resemble the outlines of the corresponding TrueType letters or numbers they represent. Enabling the Fill text option causes the text outlines to be filled in.

Note The Default color is the color defined in the Graphics box in the Colors/Print tab in the Preferences dialog box.

Graphics objects use the colors specified by the Miscellaneous tab. If the color options in the Miscellaneous tab are set to Default color, then Capture uses the color specified by the Colors/Print tab.

Tip The Render TrueType fonts with strokes option produces text that is printed or plotted quickly, but is not aesthetically pleasing as TrueType text. For this reason, you may want to enable the option when you print or plot drafts of your schematic pages, then disable the option when you print or plot the final versions of your schematic pages.

Note The Default color is the color defined in the Graphics box in the Colors/Print tab in the Preferences dialog box.

Graphics objects use the colors specified by the Miscellaneous tab. If the color options in the Miscellaneous tab are set to Default color, then Capture uses the color specified by the Colors/Print tab.

Tip The Render TrueType fonts with strokes option produces text that is printed or plotted quickly, but is not aesthetically pleasing as TrueType text. For this reason, you may want to enable the option when you print or plot drafts of your schematic pages, then disable the option when you print or plot the final versions of your schematic pages.
Defining your preferences

- Auto Recovery. Select whether to enable auto recovery for your project and, if so, the interval between saves. You can specify any interval between five minutes and 120 minutes. When the time interval is up, any design, library, or VHDL file in your project that hasn’t been saved, or has been modified since the last save, is saved as a temporary file (with an .ASP extension) in the WINDOWS\TEMP\AUTOSAVE directory. When you close your project normally, the \AUTOSAVE directory and temporary files are deleted. In cases of power outages or system crashes, however, the temporary files are saved. When you restart Capture, it loads the auto recovered files, showing “Restored” in their title bars. You must use the Save As command and provide a filename to have an auto recovered file overwrite the original file.

- Auto Reference. Select whether to enable automatic annotating of reference designators when parts are placed.

- Intertool Communication. Select whether to enable intertool communication (also known as ITC), so that you can test and display design information using other Orcad software (such as Orcad Layout and PSpice) in conjunction with Capture. Capture processes its tools faster when intertool communication is not selected.

Click OK.
Setting text editor options

Capture’s text editor options include automatic highlighting of VHDL keywords, comments, or quoted strings. You can also set the font, the tab spacing, and enable or disable the highlighting feature.

![Text Editor tab of the Preferences dialog box](image)

Figure 24  Text Editor tab of the Preferences dialog box

To set text editor options

1. From the Options menu, choose Preferences, then choose the Text Editor tab.
2. Set these options:
   - **Syntax Highlighting.** Select the color to use to highlight VHDL keywords, comments, and quoted strings. You can choose a different color for each.
   - **Current Font Setting.** Click Set to change the font setting for the text editor to values other than those displayed.
   - **Tab Setting.** Set the number of spaces to use for tabs in the text editor.

*Note* The Highlight Keywords, Comments, and Quoted Strings option must be enabled for Capture to use the syntax highlighting options.
Defining your preferences

3 Check the Highlight Keywords, Comments, and Quoted Strings option to have those VHDL items highlighted in the text editor. The colors used to highlight these items are the ones set in the Syntax Highlighting group box.

4 If you want to reset the text editor options to the Capture default values, click the Reset button.

5 Click OK.
Setting up your project template

The options that you define in the Design Template dialog box are the default settings for all new projects, and for schematic pages you add to an existing project. You can override some of these options for individual projects or schematic pages. Some of the things you can define in the Design Template dialog box are:

- **Fonts.** You can define the fonts for schematic page objects that contain text, such as part references and values.
- **Title Block.** You can specify the text to appear in title block fields, as well as the path and filename of the library containing the title block. This affects new projects, as well as new schematic pages in existing projects.
- **Page Size.** You can specify whether inches or millimeters are used as the unit of measure, the width and height of a schematic page, and the spacing between pins.
- **Grid Reference.** For horizontal and vertical border grid references, you can set the number of border grid references to display in either direction, whether the grid references are alphabetic or numeric, whether they increment or decrement across the schematic page, and how wide grid reference cells are. You can also make the border, grid references, and title block visible or invisible. This affects new projects, as well as new schematic pages in existing projects.
- **Hierarchy.** For hierarchical blocks and part instances that have their Primitive property set to Default, you can specify if you want Capture to treat each as primitive (cannot descend into attached schematic folders) or nonprimitive (can descend into attached schematic folders).
- **SDT Compatibility.** You can specify which Capture properties map to which Orcad Schematic Design Tools (SDT) part fields when saving a project in SDT format.
Setting up fonts for new projects

You can define the fonts assigned to the text associated with different schematic page objects in new designs. The fonts specified here do not affect existing designs.

To assign fonts used for new designs

1. From the Options menu, choose Design Template, then choose the Fonts tab.
2. Click the left mouse button on the font of an item. A standard Windows font dialog box appears.
3. Select a font, font style, and size. Click OK to dismiss the font dialog box.
4. Click OK.

To change the fonts for an existing project, use the Fonts tab in the Design Properties dialog box. You can access this dialog box by choosing Design Properties from the project manager’s Options menu.

The default fonts were selected for optimal compatibility with SDT. Changing these fonts may result in less optimal text sizes for translated projects.
Defining title block information

There are two types of title blocks: default and optional.

- You specify the information that goes into the default title block in the Title Block tab of the Design Template dialog box. Capture places a default title block in the lower right corner of each schematic page (if a library and title block name are specified), and places the information you enter in the text fields in the Title Block tab into the title block. This information is also used in reports created by the commands on the Tools menu. This affects new projects, as well as new schematic pages in existing projects. You can set the default title block to be visible or invisible on an existing schematic page by changing the setting in the Grid References tab in the Schematic Page Properties dialog box.

- You can place any number of optional title blocks anywhere on the schematic page using the Title Block command on the Place menu. Optional title blocks display information that you define as property values for the title block symbol.

Figure 26  Title Block tab of the Design Template dialog box
Capture provides default title block symbols in the CAPSYM.OLB library. One such title block is shown below. The text shown in curly braces acts as property text placeholders. You can specify the value by double-clicking on the text and supplying a value. You can control the visibility by selecting or deselecting the Visible check box in the Display Properties dialog box.

![Figure 27 Title block](image)

To choose a title block and define the text it contains

1. From the Options menu, choose Design Template, then choose the Title Block tab.
2. In the Text group box, enter the information you want to appear in the title block.
3. In the Symbol group box, enter the path and filename of the library containing the title block.
   a. The Library Name text box can be left blank if you are using title block from the CAPSYM.OLB library and CAPSYM.OLB has not been moved to a different directory from where it was installed.
   b. If you are using a custom title block, then put the full path and file name for the library in the Library Name text box.
4. Enter the exact name of the title block into the Title Block Name text box. Symbol names are case sensitive and space sensitive.
5. Click OK.

You can access the Display Properties dialog box by following these steps:

1. Double-click on the property.

or

1. Double-click the object containing the property.
2. Select the property in the property editor, and click Display.

You can create custom title blocks and store them in a library using the New Symbol command from the project manager’s Design menu. If you specify the name of the custom library and title block in the Symbol group box of the Design Template’s Title Block tab, the custom title block appears in the lower right corner of each new schematic page. See Capture’s online help for specific instructions.

For Capture to automatically place the information you entered in the text fields into your custom title block, you must give your custom title block the appropriate properties. See the topic Creating a custom title block in Capture’s online help for more information.
Chapter 4  Setting up your project

Setting the schematic page size for new projects

For new projects, you can specify the default unit of measure, the default width and height of schematic pages, and the spacing between pins. The value you enter in the Pin-to-Pin Spacing text box defines how close together pins are placed in the part editor. It also defines the grid spacing (the space between grid dots or grid lines).

You can select a different unit of measure or page size (A, B, C, D, E, and Custom if the unit of measure is Inches; or A4, A3, A2, A1, A0, and Custom if the unit of measure is Millimeters) for individual schematic pages in existing projects. Choose Schematic Page Properties from the schematic page editor’s Options menu, and use the Page Size tab.

Caution  Changing from Inches to Millimeters resets the page sizes to their defaults; therefore, if you make any changes to the standard page size dimensions, then change the units, the page size changes are not translated between the two types of units.

To set up the schematic page size

1. From the Options menu, choose Design Template, then choose the Page Size tab.

2. In the Units area, select the default unit of measure for new projects. This setting only affects the schematic page editor, not the part editor.
3 Select the default schematic page size for new projects. For each schematic page size (A, B, C, D, E, and Custom if the unit of measure is Inches; or A4, A3, A2, A1, A0, and Custom if the unit of measure is Millimeters) you can specify the width and height. The values that you enter in the Width and Height text boxes become the dimensions for each page size. You cannot change these dimensions for individual schematic pages, although you can select a different page size, or choose to define a custom size.

4 In the Pin-to-Pin Spacing text box, specify the default spacing between pins. The value you enter in this text box defines how close together pins are when you place a part on a schematic page. It also defines the grid spacing (the space between grid dots or grid lines). You cannot change this value for existing projects or individual schematic pages. Note Part size will vary when copying and pasting parts between pages with different pin-to-pin spacings.

5 Click OK.
Chapter 4    Setting up your project

Defining the grid reference

You set the border’s grid references to display either horizontally or vertically, alphabetically or numerically, incrementally or decrementally across the schematic page, and the width of their cells. You can also make the border, grid references, and title block visible or invisible on the screen and on schematic pages you print. The settings affect new projects and new schematic pages in existing projects.

You can change these settings for existing schematic pages. Choose Schematic Page Properties from the schematic page editor’s Options menu, then choose the Grid Reference tab in the Schematic Page Properties dialog box.

![Design Template dialog box](grid_reference_tab.png)

**Figure 29  Grid Reference tab of the Design Template dialog box**

**To define the grid reference**

1. From the Options menu, choose Design Template, then choose the Grid Reference tab.

2. Specify the number of border grid references, whether they are alphabetic or numeric, whether the grid references increment (Ascending) or decrement (Descending) across the schematic page, and how wide the grid reference cells are.

**Note** The size of the Grid Reference font is tied to the width.
3 For the border, title block, and grid reference, select Displayed to have the item display on the screen or Printed to have the item appear on schematic pages you print. Select ANSI grid references to display the grid references in accordance with ANSI standards (see the glossary entry ANSI).

4 Click OK.
Chapter 4  Setting up your project

Defining the default hierarchy option for new projects

For hierarchical blocks and part instances that have their Primitive property set to Default, you can specify if you want Capture to treat each as primitive (cannot descend into attached schematic folders) or nonprimitive (can descend into attached schematic folders). The Primitive and Nonprimitive options in the Hierarchy tab of the Design Template dialog box only affect new projects.

Note that this setting affects how the options on the Tools menu process projects.

Note  You can change the hierarchy option for existing projects using the Hierarchy tab in the Design Properties dialog box. Choose Design Properties from the project manager’s Options menu.

For more information, see Primitive and nonprimitive parts on page 11-208.

To define the default hierarchy option

1 From the Options menu, choose Design Template, then choose the Hierarchy tab.

2 For hierarchical blocks and parts, select Primitive or Nonprimitive. All hierarchical blocks and part instances that have their Primitive property set to Default will use the setting selected here.

3 Click OK.
Setting up compatibility with Orcad’s Schematic Design Tools (SDT)

You can specify which properties Capture stores in the eight SDT part fields when saving a project in SDT format. In the dialog box shown below, the part fields listed on the left are SDT’s part fields. The text boxes on the right are used to specify which of Capture’s properties map to the part fields in SDT. The options in the SDT Compatibility tab of the Design Template dialog box only affect new projects.

![SDT Compatibility tab of the Design Template dialog box](image)

Figure 31 SDT Compatibility tab of the Design Template dialog box

To set up compatibility with Orcad’s Schematic Design Tools

1. From the Options menu, choose Design Template, then choose the SDT Compatibility tab.

2. For each Capture property you want mapped to an SDT part field, specify the part field to contain the property value.

3. Click OK.

Orcad’s Schematic Design Tools (SDT 386+) was Orcad’s DOS-based schematic capture program.

Note. You can also use the part fields for mapping netlists that use part field information. For information on creating these types of netlists and the combined property strings they require, see the Capture online help.

Tip. To change the part field to property mapping for existing projects, use the SDT Compatibility tab in the Design Properties dialog box (from the project manager’s Options menu, choose Design Properties).
Changing properties of existing projects

When you create a new project, it uses the options defined in the Design Template dialog box. You can set the options on existing projects using the Design Properties dialog box (from the project manager’s Options menu). The options are:

- Fonts. You can define the fonts for schematic page objects that contain text, such as part references and part values.
- Hierarchy. You can specify hierarchical blocks and part instances whose Primitive property is set to Default be treated as primitive (cannot descend into attached schematic folders) or nonprimitive (can descend into attached schematic folders).
- SDT Compatibility. You can specify which Capture properties map to which SDT part fields when saving the design in SDT format.
- Miscellaneous. You can view the project name, root schematic folder name, creation time, and modification time. Also, if you need to see the power pins on a schematic page for documentation or debugging purposes, you can display them on the screen.
Assigning fonts

Fonts are assigned to new projects using the Fonts tab in the Design Template dialog box. You can change fonts for existing projects using the Fonts tab in the Design Properties dialog box (choose Design Properties from the project manager’s Options menu). When you change the settings for the fonts in Design Properties, all affected text which is set to the default font will be changed. If you have assigned a unique font to any piece of text in the design, these will not be affected by changing the default font. See Setting up fonts for new projects on page 4-79 for more information.

Defining hierarchy

The behavior for hierarchical blocks and part instances whose Primitive property is set to Default (whether to act as primitive or nonprimitive) is defined for new projects using the Hierarchy tab in the Design Template dialog box. You can change this behavior for individual projects using the Hierarchy tab in the Design Properties dialog box (choose Design Properties from the project manager’s Options menu). See Defining the default hierarchy option for new projects on page 4-86 for more information.

Using Capture with SDT

The mapping of Schematic Design Tools to Capture properties for new projects is defined using the SDT Compatibility tab in the Design Template dialog box. You can change this mapping for individual projects using the SDT Compatibility tab in the Design Properties dialog box (choose Design Properties from the project manager’s Options menu). See Setting up compatibility with Orcad’s Schematic Design Tools (SDT) on page 4-87 for more information.
Viewing design information

Capture displays information in the Design Properties dialog box about the .DSN file that’s selected in the project manager. On the Options menu, choose Design Properties and select the Miscellaneous tab to open the Design Properties dialog box and view:

- The path and file name of the design.
- The name of the root schematic in the design.
- The format for the date in the title block. (You can click the down arrow and select a new format.)
- The creation time of your schematic page.
- The last time your schematic page was modified.

![Image of the Miscellaneous tab of the Design Properties dialog box]

**Figure 32** Miscellaneous tab of the Design Properties dialog box

You can also set Capture to display power pins for the purpose of documentation. For more information, see Viewing and connecting to invisible power pins on page 4-91.
Viewing and connecting to invisible power pins

Normally, power pins are invisible and thus global. Selecting the Display Invisible Power Pins (for documentation purposes only) option in the Miscellaneous tab will display the pins on the screen, and they are still considered global. However, you can only view the power pins—you cannot connect to them.

To view invisible power pins without isolating them

1. From the project manager’s Options menu, choose Design Properties, then choose the Miscellaneous tab.
2. Select the Display Invisible Power Pins option.
3. Click OK.

Note: To connect wires and other electrical objects to power pins, you must make them visible on the part or instance. Select the part and then, from the Edit menu, choose Properties. Select the Power Pins Visible option and click OK. If you connect a wire or other electrical object to a power pin made visible by this method, that pin is isolated from the global net.
Changing properties of existing schematic pages

When you add a new schematic page, the options defined in the Design Template dialog box are used. You can override these options on existing schematic pages by using the options in the Schematic Page Properties dialog box. You access this dialog box by choosing Schematic Page Properties from the schematic page editor’s Options menu. The options in the Schematic Page Properties dialog box are:

- **Page Size.** You can specify the unit of measure and the page size.
- **Grid Reference.** You can set the number of horizontal or vertical border grid references to display, whether the grid references are alphabetic or numeric, whether they increment or decrement across the schematic page, and how wide the grid reference cells are. You can also make the border, grid references, and title block visible or invisible.
- **Miscellaneous.** You can view information about the schematic page, such as creation time, modification time, and page number.

Changing page size

For existing schematic pages, you can change the unit of measure from Inches to Millimeters or select a different page size. Since the width and height for each page size (except Custom) and the pin-to-pin spacing are set in the Design Template Page Size tab, you cannot change these particular items in the Schematic Page Properties Page Size tab. You can access the Schematic Page Properties dialog box by choosing Schematic Page Properties from the schematic page editor’s Options menu. See Setting the schematic page size for new projects on page 82 for more information.
Changing properties of existing schematic pages

Setting up new grid references

Horizontal and vertical border grid references for new schematic pages are set up in the Grid Reference tab of the Design Template dialog box. You can change these settings for existing schematic pages using the Grid Reference tab in the Schematic Page Properties dialog box (choose Schematic Page Properties from the schematic page editor’s Options menu). See Defining the grid reference on page 84 for more information.

Viewing miscellaneous schematic page properties

The Miscellaneous tab in the Schematic Page Properties dialog box displays the creation time and the last modification time of the schematic page, as well as the page number.

Figure 33  Miscellaneous tab of the Schematic Page Properties dialog box
To view miscellaneous schematic page properties

1. From the schematic page editor’s Options menu, choose Schematic Page Properties, then choose the Miscellaneous tab.
2. When you are done viewing the information, click OK.
To send output to a printer, a plotter, or an encapsulated PostScript® file, use the standard Windows Print Setup, Print Preview, and Print dialog boxes.

Printing commands can be chosen from the File menu in the project manager, the schematic page editor, or the part editor. You can print schematic pages, parts, or packages.

To configure a printer or plotter

1. From the File menu, choose the Print Setup command. Select an appropriate printer or plotter, or change the printer settings if necessary, and then click OK.

Note: Capture can send output to any print driver that Windows supports. For additional information on print drivers, see the documentation included with Microsoft Windows.

Note: To install and remove printers and plotters, and to set additional printing options, see the documentation included with Microsoft Windows regarding the Windows Control Panel.
Printing or plotting schematic pages

You can print or plot a schematic page, or several schematic pages, from the project manager.

To print or plot a schematic page or pages

1. Activate the schematic page editor window for the page you want to print.
   or
   In the project manager, select the schematic page or pages.
   or
   If you want to print all the pages in the design, select the design name in the project manager.

2. From the File menu, choose Print. The Print dialog box appears.

3. Select the scale, print offsets, print quality, number of copies, and whether to print to file.

4. Click OK to send the image to the output device.
Printing or plotting parts or packages

With the part editor active and open to a specific part or package, you can create a print or a plot of that part or package. You can also print a library part from the project manager.

To print or plot a part or package

1. Select the part or package you want to print in the schematic page editor.
   or
   Select the library part in the project manager.
2. Click the right mouse button in the project manager, and choose Edit Part from the pop-up menu. The part appears in the part editor.
3. From the part editor’s View menu, choose Part to print a part or choose Package to print a package.
4. From the File menu, choose Print. The Print dialog box appears.
5. Select the scale, the print quality, and the number of copies.
6. Click OK to send the image to the output device.
Printing the session log and text editor windows

With the text editor window or session log active, you can print the contents of the window.

**To print a text editor window**

1. Make the text editor the active window.
2. From the File menu, choose Print. The Print Range Selection dialog box appears.
3. Select whether to print highlighted text or the entire file.
4. Click OK to send the text to the output device.

**To print the session log**

1. Make the session log the active window.
2. From the File menu, choose Print. The Print dialog box appears.
3. Click OK to send the text to the output device.
Previewing printer or plotter output

Using the Print Preview command, you can preview your schematic page, part, or package output to check its appearance before you commit it to paper.

To preview a schematic page

1. From the File menu, choose Print Preview. The Print Preview dialog box appears.
2. Specify appropriate values in the dialog box, and then click OK. The Print Preview display window opens with a display of your schematic page, part, or package.
3. Use the Previous page and Next page buttons to view other pages you intend to print.
4. To zoom in, move the magnifier pointer to a specific area and click the left mouse button.
5. Choose the Close button to close the Print Preview window.

Or

1. Choose the Print button to send the page or pages to the output device, using the defaults set in the Print Setup dialog box.
Scaling printer or plotter output

You can manually scale, or have Capture automatically scale, printer output and plots to fit a given paper size.

To scale a print or a plot

1. From the File menu, choose Print. The Print dialog box appears.
2. Select one of the three options in the Scale box.
   - The Scale to paper size option scales each schematic page to fit a single sheet of paper (as configured in the printer driver).
   - The Scale to page size option scales each schematic page to the sheet size you select in the Page size area. The sheet size is configured in the Page Size tab in the Design Template dialog box.
   - The Scaling option scales your schematic page to a factor between 0.100 and 10.000.
3. If you select the Scale to page size option in step 2, the Page size area becomes available. Select a sheet size. This results in multiple sheets of paper if you select a sheet size larger than your printer paper.
4. Click OK to print the image.
Special considerations for plotting

Vector (pen) plotters do not support bitmaps directly. If you are sending Capture output to such a plotter, it will not plot your bitmaps. Most inkjet and thermal plotters will plot bitmaps.

Plotter pen colors

The plotter driver maps your color choice to the closest available pen color as established in your plotter driver configuration. See your plotter’s driver setup and documentation for more details.

Many plotters do not have drivers that ship with Windows. If you do not see the plotter you are looking for in the list of available drivers, contact your plotter manufacturer and ask for a Windows driver. If your plotter emulates HPGL, use the HPGL driver as an alternative solution.

Tip Vector-based plotters tend to produce higher quality output than raster-based printers.

Note The plotter setup dialog boxes are only accessible from the Windows Control Panel. See the documentation included with Microsoft Windows regarding the Windows Control Panel.
Part Two

Creating designs

Chapter 6, Design structure, describes how to customize the working environment specific to your system, how to create default settings for new designs, and how to override default settings in individual designs.

Chapter 7, Placing, editing, and connecting parts and symbols, describes how to place and edit parts and symbols. It also describes how to connect the elements of your design using hierarchical blocks, hierarchical ports, off-page connectors, wires, and buses.

Chapter 8, Adding and editing graphics and text, describes the drawing tools you can use to add text and a variety of graphic shapes to your design.

Chapter 9, Using macros, describes how to create and run macros.

Chapter 10, Changing your view of a schematic page, describes how to view specific areas of a schematic page using the Zoom command. It also describes jumping to different locations within a schematic using the Location, Reference, and Bookmark commands.
Many schematic designs can fit on one schematic page. Some designs, however, are too large for even the biggest page, and even if a complex design could fit on one page, there are good reasons for dividing it:

- To fit at full scale on your printer’s page.
- To partition a design so that several people can work on it at once.
- To develop the design using a top-down approach. That is, you may want to begin with a block diagram in which each block represents a major function and then construct more detailed diagrams for each block.
- To organize your design by functional parts.
- To meet department specifications.

Capture offers two ways of handling multiple-page designs: a flat design structure and a hierarchical design structure.
Flat designs

Flat designs are practical for small designs with few schematic pages. A flat design is a structure in which the output nets of one schematic page connect laterally to the input nets of another schematic page in the same schematic folder through objects called off-page connectors. A flat design has no hierarchy (no hierarchical blocks, hierarchical ports, hierarchical pins, or parts with attached schematic folders). The structure of a flat design is shown to the left.

All schematic pages in a flat design are contained within a single schematic folder, and are on a single level, as shown at left. In the figure, SCHEMATIC1 is a schematic folder. It contains schematic pages named PAGE1 and PAGE2.

Since you must manage all of the interconnections between the pages of a flat design using names assigned to off-page connectors, it is best to keep a flat design relatively small.
Hierarchical designs

You can create symbols on schematic pages that represent other schematic folders. These symbols are called hierarchical blocks. The layered arrangement created by placing schematic folders inside schematic pages is called a hierarchy.

Any schematic page can contain hierarchical blocks (or parts with attached schematic folders) that refer to other schematic folders; a design’s structure can be many levels deep. The schematic folder at the top of a hierarchy, which directly or indirectly refers to all other schematic folders in the project, is called the root module.

In the project manager, the root module has a backslash in its folder icon. The root module, as well as any other schematic folder, can contain as many schematic pages as you need.

Simple hierarchical designs

![Diagram of a simple hierarchy](image)

**Figure 34** An abstract representation of a simple hierarchy.

**Tip** If you intend to take your design into a digital simulator like PSpice, it is best to place only one schematic page in each lower level schematic folder. This may reduce problems you encounter while troubleshooting your designs.
A one-to-one correspondence between hierarchical blocks (or parts with attached schematic folders) and the schematic folders they reference is called a *simple hierarchy* (Figure 35).

In a simple hierarchy, each hierarchical block or part with an attached schematic folder represents a unique schematic folder.

*Figure 35* A simple hierarchical design, as seen in the project manager
Complex hierarchies

A many-to-one correspondence between hierarchical blocks (or parts with attached schematic folders) and the schematic folders they reference is called a complex hierarchy. In Figure 36, schematic A references schematic B three different times. These references can be via hierarchical blocks or parts with attached schematic folders.

Figure 37 shows a complex hierarchical design as seen on the Hierarchy tab of the Capture project manager.
Connecting schematic folders and schematic pages

In Capture, you connect schematic folders and schematic pages by extending nets between them using hierarchical blocks (or parts with attached schematic folders), hierarchical ports, hierarchical pins, and off-page connectors. Hierarchical blocks (or parts with attached schematic folders), hierarchical ports, and hierarchical pins carry signals between schematic folders and schematic pages in a hierarchy, while off-page connectors carry signals between schematic pages within a single schematic folder of a flat design.

Hierarchical blocks

Hierarchical blocks (or parts with attached schematic folders) refer to child schematics in a design, providing vertical (downward-pointing) connection only. Hierarchical pins in a hierarchical block, and hierarchical ports outside a hierarchical block, act as points of attachment for electrical connections between the hierarchical block and other electrical objects in an attached schematic folder. The picture at left shows hierarchical pins (X, Y, SUM, and CARRY) within a hierarchical block, and a hierarchical port (CARRY_IN) outside a hierarchical block.

A part with an attached schematic folder functions like a hierarchical block, and pins on a part with an attached schematic folder function like hierarchical pins within a hierarchical block. You can use either method to define a hierarchy. The only difference between the methods is that a part with an attached schematic folder can be reused.

Note Before you create or resize a hierarchical block, make sure the Snap to grid option is turned on (by choosing Preferences from the Options menu). If the hierarchical block is off grid, then hierarchical pins inside it are also off grid— even if you change the Snap to grid setting before you place them— and it may be difficult to connect to these off-grid hierarchical pins.
You can attach a schematic folder that is external to a project to a hierarchical block, but be aware that you won’t be able to use any of Capture’s tools to make changes to the external design unless you explicitly open that external design.

Caution If you incorporate an external schematic folder into a hierarchical block, include the schematic folder when you give the project to another engineer or to a board fabrication house. Attached schematic folders external to a project do not automatically accompany schematic folders that you copy or move to another project. For this reason, you should copy all attached schematic folders into your project if you want your project to be “portable.”

Hierarchical ports

Hierarchical ports provide vertical (upward-connecting) and lateral connections within a design hierarchy. A hierarchical port connects vertically to a like-named hierarchical pin inside a hierarchical block, and connects laterally to like-named nets in the same schematic page, and hierarchical ports within the same schematic folder.

Hierarchical pins

Hierarchical pins provide vertical (downward-pointing) connections only. You connect them by name to hierarchical ports on schematic pages in an attached schematic folder. Think of hierarchical pins as bringing a net “up” from an attached schematic folder into the hierarchical block, but not out onto the schematic page. In the figure shown, X, Y, SUM and CARRY represent hierarchical pins.
Off-page connectors

Off-page connectors provide connection between schematic pages within the same schematic folder. An off-page connector is connected by name to other off-page connectors within the same schematic folder. Like-named off-page connectors in different schematic folders are not connected.
An example: creating a simple hierarchy

As described earlier in this chapter, you connect schematic folders and schematic pages by extending nets between them using off-page connectors, hierarchical ports, and hierarchical pins in hierarchical blocks. Off-page connectors carry nets between schematic pages within a single schematic folder. Hierarchical blocks, hierarchical ports, and hierarchical pins carry nets between schematic folders, which need not be in the same design.

The rest of this section contains an example of how to use off-page connectors, hierarchical ports, hierarchical pins, and hierarchical blocks to create a simple hierarchy.

Figure 38 shows two schematic folders (Sch. A and Sch. B), each with two schematic pages. The schematic folder marked with a backslash (\) is called the root module.

To establish a hierarchy with schematic folder A positioned “above” schematic folder B

Figure 39 illustrates the schematics with hierarchy established.

1. Place a hierarchical block on schematic page 1.
2. In the Place Hierarchical Block dialog box, set the following options to attach schematic folder B:
   - Type in a reference.
   - Select Schematic View for the Implementation Type.
   - Type in Sch.B as the Implementation Name.

Note: For information about placing hierarchical blocks, hierarchical ports, hierarchical pins, and off-page connectors, see Chapter 7, Placing, editing, and connecting parts and symbols.
To carry a net between schematic folder A and schematic folder B

Figure 40 illustrates the schematics carrying a net between them.

1. Select the hierarchical block on schematic page 1 and place a hierarchical pin named “X” inside it.
   
   The hierarchical pin is a point of attachment for electrical connections between the hierarchical block and other objects on schematic page 1.
   
2. Place a hierarchical port named “X” on schematic page 3.
   
   The hierarchical port is a point of attachment for electrical connections between schematic page 3 and other schematic pages within schematic folder B. It is connected by name to the hierarchical pin inside the hierarchical block on schematic page 1.

Hierarchical ports generally carry a net “up” through a hierarchy. In a root module, they usually represent external signals, such as a hierarchical block in another project.

The two hierarchical ports added to schematic folder A are electrically connected to each other by the name “Y,” so any electrical objects (such as power or ground symbols) on schematic pages 1 and 2 named “Y” are part of the net named “Y.” You could make both of these hierarchical ports off-page connectors without affecting the electrical connections. Figure 41 illustrates this electrical connectivity across pages in a schematic.

To connect the schematic pages in schematic folder B, place a hierarchical port named “X” on schematic page 4. Any like-named electrical objects on schematic pages 3 and 4 are now part of a single net named “X.”

To connect the “X” nets in schematic folder B and the “Y” nets in schematic folder A, you cannot simply rename one set of objects to match the other set of objects. Remember, the hierarchical pin “X” inside the hierarchical block on schematic page 1 does not bring net “X” out onto schematic page 1. You must physically connect hierarchical pin “X” to net “Y” in order to join the two nets.
Placing, editing, and connecting parts and symbols

Capture includes libraries containing parts, power symbols, and ground symbols. You can place instances of these objects on a schematic page. Once you place a part, you can edit its appearance, properties, or location. Once you have placed a power or ground symbol, you can rotate it or edit its name.

This chapter contains information about placing and editing objects from Capture libraries. It also explains how to connect these objects using wires and buses.

Figure 42  Schematic with power and ground symbols
Capture libraries also include symbols used to establish connectivity between schematic pages. You use off-page connectors to connect signals between schematic pages within a schematic folder. You use hierarchical blocks, hierarchical ports, and hierarchical pins to connect signals from one schematic folder to another, or from an attached schematic folder. See An example: creating a simple hierarchy on page 113 for more information on working with connectivity across schematic pages.

Wires and buses are used to conduct signals between parts and electrical objects. Nets are made up of one or more wires; a bus represents multiple signals or nets.
Placing and editing parts

Capture includes libraries with a total of over 30,000 parts that you can use on your schematic pages. You can also create your own parts.

A library part has a *package* view, which corresponds to the actual physical object that can be placed, for example, on a printed circuit board. The package view identifies the physical pin numbers and the number of logical objects (for example, parts or devices) that are contained within the package.

![Part editor in package view](image)

*Figure 43  Part editor in package view*

The different parts that make up a package can be identical in their graphic appearance and electrical connectivity (homogeneous) or they can be dissimilar in their graphic appearance or electrical connectivity (heterogeneous).

In addition to the package view, a library part has a *part* view, which is a graphical representation used to define a single, logical, electrical object whose electrical connectivity is represented by pins.

Note  For information about creating your own parts, see Chapter 12, Creating and editing parts.
Each part has a set of properties that contains information—such as part value and reference designator—used by layout or simulation tools. In addition, you can create your own unique part properties that hold information relevant to your application.

Parts have pins that define the part’s electrical connectivity. Pins carry information in properties that define the characteristics of each pin. This information includes the pin’s name, number, shape (clock, dot, dot-clock, line, short, or zero length), type (3-state, bidirectional, input, open collector, open emitter, output, passive, or power), width (scalar or bus), and visibility. The pin type is used by the Design Rules Check command on the Tools menu to check conformance to basic electrical rules.

A primitive part is a basic part without any underlying hierarchy. A nonprimitive part is a part that has an underlying hierarchy, such as an attached schematic folder, PSpice model, or VHDL code. Placing a nonprimitive part adds all its underlying hierarchy to your project without moving the actual schematic folders, making it easy to add levels of hierarchy to your project.

### Placing parts

You select parts from libraries and place them on schematic pages using the Part command on the Place
Placing and editing parts

menu, or using the part tool on the schematic page editor tool palette.

Alternatively, if you’ve placed the part or symbol recently, place the part using the Most Recently Used (MRU) list on the Capture toolbar. See To place a part using the Most Recently Used (MRU) List on page 7-120.

To place a part

1. From the schematic page editor’s Place menu, choose Part.
   or
   Choose the part tool on the schematic page editor’s tool palette.
   The Place Part dialog box appears.

2. Select a part from the list that appears.
   or
   In the Part text box, type the name of the part. If you aren’t sure of the name of the part, enter wildcard characters to constrain the list of parts, then click OK. Valid wildcard characters are an asterisk (*) to match multiple characters and a question mark (?) to match a single character.

   After you type the name of the part to be placed, click OK. All parts in the libraries (listed in the Libraries list box) that match the part name appear in the box below the Part text box. When you select a part from this box, its graphic image displays in the preview box.

3. When you have located the part you want to place, click OK.

   An image of the selected part is attached to your pointer. You can click the right mouse button to display a pop-up menu with commands that you can use to change the properties of the part before you place it. You can mirror the part horizontally or vertically, rotate the part, or edit the part’s properties.

4. Move the pointer to the location on your schematic page where you want to place the part, then click the left mouse button.

Tip You can add more libraries to the Libraries list box by clicking Add Library.
Tip You can remove a library from the Libraries list box by selecting it and clicking Remove Library.
Tip You can switch to the convert view of a part while placing it using the Graphic option on the Place Part dialog box.
Tip If your part is a multiple-part package, you can select which part in the package to view using the Part drop-down list in the Packaging area of the Place Part dialog box.

Note All schematic page objects have right mouse button pop-up menus. These menus are context sensitive, displaying commands appropriate for the selected object. For information about pop-up menu commands, see the Capture online help.
Chapter 7  Placing, editing, and connecting parts and symbols

This places an instance of the part on your schematic page. (You can place multiple instances of the part by clicking the left mouse button at each location where you want an instance of the part.)

5 When you are done placing instances of the selected part, choose End Mode from the right mouse button pop-up menu, or press [Esc].

To place a part using the Most Recently Used (MRU) List

Note To select a part, point-and-click, type into the list box, or press [Ctrl]+[M]. For information about the MRU list, see Most Recently Used (MRU) part list on page 124.

1 While the schematic page editor is active, select a part or symbol from the MRU list on the Capture toolbar.

An image of the selected part is attached to your pointer. You can click the right mouse button to display a pop-up menu with commands that you can use to change the properties of the part before you place it. You can mirror the part horizontally or vertically, rotate the part, or edit the part’s properties.

Note All schematic page objects have right mouse button pop-up menus. These menus are context sensitive, displaying commands appropriate for the selected object. For information about pop-up menu commands, see the Capture online help.

2 Move the pointer to the location on your schematic page where you want to place the part, then click the left mouse button.

This places an instance of the part on your schematic page. (You can place multiple instances of the part by clicking the left mouse button at each location where you want an instance of the part.)

3 When you are done placing instances of the selected part, choose End Mode from the right mouse button pop-up menu, or press [Esc].
Place Part dialog box

**Part**

Specifies the name of the part. Start typing the part name and if Capture finds the part in the selected libraries, it will automatically complete the part name for you.

If you aren’t sure of the exact name of the part, you can enter wildcard characters to constrain the list of parts, then click OK. Valid wildcard characters are an asterisk (*) to match multiple characters and a question mark (?) to match a single character. The names of all parts in the selected libraries that match the wildcard appear in the Part list box.
Part list  Lists the names of all parts in the selected libraries that match the name entered in the Part text box. If more than one library is selected, the part name is followed by a forward slash (/) and a library name. When you select a part in the list, its name appears in the Part text box, and its graphic displays in the preview box.

The full path of the library appears when you hover your pointer over a part or a library name in the part list.

Libraries  Lists the library names currently available. All parts in the selected libraries that match the Part text box appear in the Part list. To select more than one library, hold [Ctrl] while you click the mouse. To select all the libraries in the list, press [Ctrl]+[A].

The full path of the library appears when you hover your pointer over the library name.

Graphic  You can choose the view of the part: Normal or Convert. Some parts have a Convert view that is used for things such as a DeMorgan equivalent of a part.

Packaging  Parts per package indicates the number of parts in the package you are editing. Part indicates which part of a multiple-part package you are placing.

Preview box  Displays the graphic of the selected part.

Application Indicator  Four possible property values (Layout, Schematic View, VHDL, and PSpice) cause one or more icons to appear at the bottom of the Place Part dialog box while you place a part that has one or more of the properties. A schematic view or VHDL implementation type property causes the Schematic View or VHDL icon to appear, while the PSpice icon indicates that a PSpice Template property exists and the Layout icon shows that a PCB Footprint property is on the part or symbol. The name of the relevant downstream tool appears when you hover your pointer over the icon.
Placing and editing parts

**Add Library**  Displays a standard Open dialog box that you can use to locate a library and add it to the Libraries list.

**Remove Library**  Removes the selected libraries from the Libraries list.

**Part Search**  Opens the Part Search dialog box, so you can search for a part in all the libraries listed in a particular directory.

*Note*  If you select an SDT 386+ or SDT Release IV library from the dialog box that appears when you choose Add Library, Capture automatically translates the file after you specify the name of the new Capture library.
Most Recently Used (MRU) part list

The Most Recently Used list is in the middle of the Capture toolbar. It is enabled only the window of a schematic page is active.

Each time you place a part or symbol using a command from the Place menu, the name of that same part or symbol is added to the top of the MRU list. When you select a part or symbol from the MRU list and use it in your design, the name of that item moves to the top of the list.

The MRU list holds up to 25 placed items for a given project. If you exceed that limit, Capture removes the last part or symbol from the list and places the name of the most recently placed item at the top of the list.

Capture saves the MRU list on a project-by-project basis for each session. If you have more than one project open, the list updates for the active project.

You can select a part from the MRU list using any of these methods:

- **Use the mouse.** Expand the MRU drop-down list by clicking on the arrow at the right of the list, then click on a part or symbol to select it.

- **Type the part or symbol name.** Click in the MRU list box and begin typing the name of the part or symbol. Capture automatically completes the name if the item is in the list. When the name is highlighted in the MRU list box, press Enter.

  If the part or symbol is not in the MRU list, but is a part in the set of configured libraries, an image of the part attaches to your pointer when you press Enter.

- **Use the shortcut.** Press Ctrl+M to highlight a part in the MRU list. Press ↑ and ↓ to select a part or symbol in the list. When the correct part or symbol is highlighted in the list box, press Enter.
Placing and editing parts

Searching for parts

Capture can search for a particular part inside all the libraries it finds in the specified directory.

To find a part

1. In the schematic page editor, choose Part from the Place menu.
2. Click the Part Search button. The Part Search dialog box appears.
3. Enter the part name you want to locate.
4. Click Browse to locate the directory where your libraries are located.
5. Click Begin Search. Capture returns the names of all the libraries in the specified directory, that contain your part.

Editing parts

You can move a part on a schematic page by selecting it and dragging it to a new location. You can use the Rotate or the Mirror command from the Edit menu. You can use the part editor to change the part’s physical appearance, and you can edit the part’s properties. When you edit a part on a schematic page, your edited part differs from the part in the library and exists only in your design; you can place another copy of the part you edited by using the Copy command from the Edit menu, and by dragging the part from the design cache.

Note: Using the Find command on the schematic page editor’s Edit menu, you can specify a search and replace for parts, nets, title blocks, off-page connectors, flat nets, power or ground symbols, bookmarks, hierarchical ports, text, or DRC markers.

Note: For more information about editing parts, see Chapter 12, Creating and editing parts.
To edit the physical appearance of a part, select it, and either choose Part from the Edit menu or choose Edit Part from the right mouse button pop-up menu. This opens the part in a part editor window. After you finish editing the part and choose Save, you’re given a choice of updating the single instance, or updating all instances in the design. If you update only the single instance, Capture creates a new part in the design cache. If you update all instances, Capture replaces the library part in the design cache with your edited part. These new parts are placed in the design cache with “-n” appended to the name, where n is an integer.

To edit the properties of a part, select the part on the schematic page, and either choose Properties from the Edit menu, or choose Edit Properties from the right mouse button pop-up menu. You can also double-click the part. This displays the property editor, shown in Figure 46.

![Property editor with filter set to Capture](image)

Capture displays properties according to the selected filter. All the properties are shown when the filter is set to All. General schematic page properties are shown when the filter is set to Capture. The following are common properties:

**Value** Specifies the part value name. By default, the part value is set to the name of the part if you don’t specify a part value in the library.
**Reference**  Specifies the part reference.

**Primitive**  Default indicates that the part uses the setting in the Hierarchy tab of the Design Properties dialog box. Yes indicates that the part is primitive. No indicates that the part is nonprimitive.

**Designator**  Indicates which part of a multiple-part package you are editing.

**PCB Footprint**  The PCB physical package name to be included for this part in the netlist.

**Power Pins Visible**  Specifies the visibility of the part’s power pins.

**Implementation Type**  Specifies if the part has an attached schematic folder or other implementation, and the type of implementation, if one exists. Implementation types include schematic folders, VHDL entities, netlists, and PSpice models.

**Caution** An attached schematic folder or other file external to the project or library is not stored with the project or library. If you copy or move the project or library to a new location, you must also move or copy the attached object to keep them together. In addition, you may need to edit the path to the attached schematic folder or file if you move the project to a new location with a different directory structure.

**Note** To change the Part Reference property, you will need to edit the Reference property, the Designation property, or both. The Part Reference property is a read-only property that Capture calculates from the Reference and Designator values.

**Note** For information on power pin visibility and how it affects a global net, see the Capture online help.
Placing and editing power and ground symbols

You can place power and ground symbols, and you can edit their names before or after placing them. You can also edit the text associated with the symbols. The name of a power symbol becomes the name of the global net that is created.

Placing power and ground symbols

Power and ground symbols are placed on a schematic page using the Power command or Ground command on the Place menu, or using the power tool or ground tool on the tool palette. Power and ground symbols are selected from libraries the same way parts are selected from libraries. CAPSYM.OLB contains all the power and ground symbols shipped with Capture.

To place a power symbol

1. From the schematic page editor’s Place menu, choose Power.
   or
   Choose the power tool on the schematic page editor’s tool palette.
   The Place Power dialog box appears.

2. In the Symbol text box, type the name of the symbol to place. If you aren’t sure of the exact name of the symbol, you can enter wildcard characters to constrain the list of symbols, then press Enter. Valid wildcard characters are an asterisk (*) to match multiple characters and a question mark (?) to match a single character. All power symbols in the libraries selected in the Libraries list box that match the name of the power symbol are listed in the box below the Power Symbol text box. When you select a symbol from this box, its graphic image appears.
3 After you locate the power symbol you want to place, click OK. An image of the power symbol is attached to your pointer.

You can press the right mouse button to display a pop-up menu with commands to change the attributes of the power symbol before you place it. You can mirror the power symbol horizontally or vertically, or rotate it.

4 Move the pointer to the location on your schematic page where you want the power symbol and click the left mouse button. This places the power symbol on your schematic page.

You can place multiple instances of the power symbol by clicking the left mouse button each place you want an instance of the symbol.

5 When you are done placing power symbols, choose End Mode from the right mouse button pop-up menu, or press [Esc].

**To place a ground symbol**

1 Follow the instructions in the previous section, **To place a power symbol** on page 7-128, but substitute the Ground command or the ground tool in the appropriate places.
Chapter 7 Placing, editing, and connecting parts and symbols

Place Power and Place Ground dialog boxes

The Place Power and Place Ground dialog boxes are identical, except that each displays the last power or ground symbol you placed on this page. This figure shows the Place Power dialog box.

![Place Power dialog box](image)

**Figure 48 Place Power dialog box**

**Symbol** Specifies the name of the power or ground symbol in the library. If you aren’t sure of the exact name of the symbol, you can enter wildcard characters to constrain the list of symbols, then click OK. Valid wildcard characters are an asterisk (*) to match multiple characters and a question mark (?) to match a single character. The names of all symbols in the selected libraries that match the wildcard appear in the Symbol list box.

**Symbol list** Lists the names of all symbols in the selected libraries that match the name entered in the Symbol text box. If more than one library is selected, the symbol name is followed by a slash (/) and a library name. When you select a symbol in this list, its name displays in the Symbol text box, and its graphic displays in the preview box.
**Libraries**  Lists the library names currently available. Select the libraries from which to select power or ground symbols. All symbols in the selected libraries that match the Symbol text box display in the Symbol list. To select more than one library, press [Ctrl] while you click the mouse.

**Preview box**  Displays the graphic of the selected symbol.

**Add Library**  Displays a standard Open dialog box that you can use to locate a library and add it to the Libraries list.

**Remove Library**  Removes the selected libraries from the Libraries list.

**Name**  Assigns a name—such as +5, GND, +5VDC, -12VDC, VSS, or VEE—to the symbol. By default, the name of the symbol is assigned.

---

**Editing power and ground symbols**

You can change the name of a power or ground symbol by selecting the symbol on the schematic page, and either choosing Properties from the Edit menu, or choosing Edit Properties from the right mouse button pop-up menu. You can also double-click the symbol. This displays a dialog box in which you can edit the symbol’s name, then click OK.

You can also edit the display properties of the name of the power or ground symbol. Select only the text of the symbol, then either choose Properties from the Edit menu, or choose Edit Properties from the right mouse button pop-up menu. You can also double-click the text. This displays a Display Properties dialog box. Once you have finished editing the properties, click OK.

*Note*  You cannot assign user properties to power or ground symbols.
Placing and editing no-connect symbols

A no-connect symbol (shown as an “X” attached to a pin) causes unused pins to be ignored by reports (such as Design Rules Check and netlists) that show unconnected pins. If a pin is connected, the no-connect symbol doesn’t affect the pin. They are pin properties.

Placing no-connect symbols

No-connect symbols are placed on pins on a schematic page using the No Connect command on the Place menu, or using the no-connect tool on the schematic page editor’s tool palette.

To place a no-connect symbol

1. From the schematic page editor’s Place menu, choose No Connect.
   or
   Choose the no-connect tool on the schematic page editor’s tool palette.

2. Position the mouse over the pin end and click the left mouse button. The end of the pin changes from a square (unconnected) to an X (not connected). This changes the pin property called “Is No Connect” from False to True and displays an X on the pin end.
Editing no-connect symbols

No-connect symbols cannot be deleted using the Delete key. To remove a no-connect symbol, place another no-connect symbol on top of the existing no-connect symbol. You can temporarily override a no-connect symbol by attaching a wire to the pin, but if you delete the wire, you’ll again be able to see the no-connect symbol.
Placing and editing hierarchical blocks

Hierarchical blocks (or parts with attached schematic folders) refer to child schematic folders in a project, providing vertical (downward-connective) connection only. Hierarchical pins in a hierarchical block, and hierarchical ports outside a hierarchical block, act as points of attachment for any electrical connections between the hierarchical block and other electrical objects in an attached schematic folder.

A part with an attached schematic folder functions like a hierarchical block, and pins on a part with an attached schematic folder function like hierarchical pins within a hierarchical block. You can use either method to define a hierarchy. The only difference between the two methods is that a part with an attached schematic folder can be more easily reused.

Placing hierarchical blocks

You create hierarchical designs using hierarchical blocks to represent child schematic folders. When you create a hierarchical block, you specify the name of the child schematic folder that the hierarchical block represents. Once you’ve created the hierarchical block, you place hierarchical pins inside it to connect it to hierarchical ports on the child schematic folder’s schematic pages.

To place a hierarchical block

1. From the schematic page editor’s Place menu, choose Hierarchical Block.
   or
   Choose the hierarchical block tool on the schematic page editor’s tool palette.

   The Place Hierarchical Block dialog box appears.
2 In the Reference text box, type the name of the hierarchical block.

3 Accept the Primitive setting of Default, or choose Yes or No. (See Place Hierarchical Block dialog box on page 7-136 for more information.)

4 If necessary, click User Properties, add or change property names and their associated values in the dialog box that appears, then click OK.

5 Specify the type of implementation. (See Place Hierarchical Block dialog box on the next page for a description of implementation types.)

6 Specify the name of the attached schematic folder, VHDL entity, netlist, or project.

7 Specify the path and filename of the attached schematic folder, VHDL entity, PSpice entity, netlist, or project.

8 Click OK to close the Place Hierarchical Block dialog box.

9 Draw the hierarchical block. Press the left mouse button, drag the mouse to draw a rectangle, and release the mouse button when the rectangle is the desired size. Click an open space on the page to deselect the block.

Note Once you’ve placed a hierarchical block, you must place hierarchical pins inside it, then name the pins so that they connect to like-named hierarchical ports in the schematic pages in the child schematic folder. See Placing hierarchical pins on page 7-141.

Note If the child schematic folder you specify as the hierarchical block’s attached schematic folder already exists, Capture automatically adds hierarchical pins to the hierarchical block that match the corresponding ports on the schematic pages in the child schematic folder. If the child schematic folder doesn’t yet exist and you place the hierarchical block and choose Descend Hierarchy from the right mouse button pop-up menu, Capture creates a new schematic folder and creates a new schematic page containing hierarchical ports that match the hierarchical pins in the hierarchical block.
Place Hierarchical Block dialog box

Reference   The name of the hierarchical block. If you place a zero as the last character of the Reference, Capture increments this number when the hierarchical block is copied.

Primitive   Default indicates that the part uses the setting in the Hierarchy tab of the Design Template dialog box. Yes indicates that the part is primitive, and contains no underlying hierarchy. No indicates that the part is nonprimitive, and contains underlying hierarchy.

User Properties   Displays a dialog box that you can use to edit the part’s property names and their respective property values.
Implementation Type  Specifies the type of implementation from one of the following:

- Schematic View—Indicates that the attached implementation is a schematic folder. Capture will automatically generate the appropriate hierarchical pins for the block based on the schematic ports.
- VHDL—Indicates that the attached implementation is a VHDL entity. Capture will automatically generate the appropriate hierarchical pins for the block based on the port declarations in the VHDL entity.
- EDIF—Indicates that the attached implementation is an EDIF netlist. If your design includes EDIF implementations for hierarchical blocks, you must specify the hierarchical pins for the block; Capture will not generate them from the EDIF netlist.
- Project—Indicates that the attached implementation is a programmable logic project. You must specify the hierarchical pins for the block; Capture will not generate them.
- PSpice Model—Indicates that the attached implementation is a PSpice model file. You must specify the hierarchical pins for the block; Capture will not generate them.
- PSpice Stimulus—Indicates that the attached implementation is a PSpice stimulus file. You must place the hierarchical pins on the block. Capture will not generate them.

Implementation Name  Specifies the name of the attached schematic folder, VHDL entity, netlist, or project for the hierarchical block. Schematic folder names are case sensitive.

Path and filename  Specifies the path and filename of the attached schematic folder, VHDL entity, netlist, or project for the hierarchical block.

Caution  An attached schematic folder or other file external to the project or library is not stored with the project or library. If you copy or move your project or library to a new location, you must also move or copy the attached file, to keep them together. In addition, you may need to edit the path to the attached schematic folder or file if you move your project to a new location with a different directory structure.
Editing hierarchical blocks

You can edit a hierarchical block after it is placed. Select the hierarchical block and do one of the following:

- Double-click it.
- Choose Properties from the Edit menu.
- Choose Edit Properties from the pop-up menu.

Each of these methods displays the property editor, in which you can change the block’s reference, choose among the options in the Primitive group box, or modify the attached schematic folder’s name or path. You can also add and modify user properties in the property editor.

You can also edit the display properties of the text associated with the hierarchical block. Select the text of the hierarchical block and do one of the following:

- Double-click it.
- Choose Properties from the Edit menu.
- Choose Edit Properties from the pop-up menu.

Each of these methods displays the Display Properties dialog box, in which you can edit the visibility, color, font, or rotation of the text of the hierarchical block.

You can click a hierarchical block and move it to another location, or you can drag its selection handles to resize it. You can also use the Mirror or Rotate commands to change the appearance of the block.
Placing and editing hierarchical ports and hierarchical pins

For information on how hierarchical designs are connected using hierarchical blocks, hierarchical ports, and hierarchical pins, see Connecting schematic folders and schematic pages in Chapter 6, Design structure.

Placing hierarchical ports

You place hierarchical ports on schematic pages in child schematic folders, then name the ports so that they connect to like-named hierarchical pins inside hierarchical blocks on schematic pages in parent schematic folders.

Hierarchical ports also connect to like-named hierarchical ports, and to off-page connectors with the same name, on schematic pages within the same schematic folder. Hierarchical ports are stored in the CAPSYM.OLB library.

To place a hierarchical port

1. From the schematic page editor’s Place menu, choose Hierarchical Port.
   The Place Hierarchical Port dialog box appears.
2. Select CAPSYM.OLB or your own custom library containing hierarchical ports from those listed in the Libraries field, or use the Add Library and Remove Library buttons to change what is listed in the Libraries field and select one or more libraries.
3. In the list below the Symbol text box, select the type of the hierarchical port. The selection’s name appears in the Symbol text box and its graphic displays in the preview box.
4. Type in the name for the hierarchical port. The name is added to the attached net, and is used to determine which like-named hierarchical pins and hierarchical

Note: You can create custom power, ground, and other symbols for hierarchical ports, hierarchical pins, off-page connectors, title blocks, and power objects by using the New Symbol command on the Design menu in the project manager window. For information on how to use this command, see Capture’s online help.

Figure 51 Hierarchical ports in CAPSYM.OLB

Tip: You can place a hierarchical port anywhere on a schematic page. A hierarchical port connects to like-named hierarchical ports and off-page connectors on schematic pages in the same schematic folder, and connects to like-named hierarchical pins inside hierarchical blocks in parent schematic folders.
ports the port connects to. Hierarchical ports attached to buses must have a bus type name, preferably the same name as the bus. For more information, see *Bus naming conventions* in Capture’s online help.

5 When you have specified the characteristics of the hierarchical port, click OK. The Place Hierarchical Port dialog box closes.

6 You can now place the hierarchical port anywhere on the schematic page. If you want to move the port, you can select it and drag it to another location after you place it.

### Place Hierarchical Port dialog box

![Place Hierarchical Port dialog box](image)

**Symbol**  Specifies the hierarchical port symbol to use. If you aren’t sure of the exact name of the symbol, you can enter wildcard characters to constrain the list of symbols, then click OK. Valid wildcard characters are an asterisk (*) to match multiple characters and a question mark (?) to match a single character. The names of all symbols in the selected libraries that match the wildcard appear in the Symbol list box.

**Symbol list**  Lists the names of all symbols in the selected libraries that match the text entered in the Symbol
text box. If more than one library is selected, the symbol name is followed by a slash (/) and a library name. When you select a part in this list, its name displays in the Symbol text box, and its graphic displays in the preview box.

**Libraries**  Lists the library names currently available. Select the libraries from which to select symbols. All symbols in the selected libraries that match the Symbol text box display in the Symbol list. To select more than one library, press **Ctrl** while you click the mouse.

**Preview box**  Displays the graphic of the selected symbol.

**Name**  Specifies the symbol’s name. This name is used to determine which like-named hierarchical ports the port will connect to.

**Add Library**  Displays a standard Open dialog box that you can use to locate a library and add it to the Libraries list.

**Remove Library**  Removes the selected libraries from the Libraries list.

**Placing hierarchical pins**

You place hierarchical pins inside hierarchical blocks on schematic pages in parent schematic folders. You name the hierarchical pins to correspond to hierarchical port names on schematic pages in child schematic folders.

**To place a hierarchical pin**

1. Select a hierarchical block.

**Note**  If you do not select the Pointer snap-to-grid option in the Grid Display tab of the Preferences dialog box, hierarchical pins you place in a hierarchical block may not snap to grid. Delete the pin and place it again with the snap-to-grid option selected.
2 From the schematic page editor’s Place menu, choose Hierarchical Pin. The Place Hierarchical Pin dialog box appears.

3 In the Name text box, type in a name for the hierarchical pin. This name, which is also the net name, is used to determine which like-named hierarchical ports the pin connects to.

4 From the drop-down list box under Type, select a pin type for the hierarchical pin.

5 In the Width group box, select either Scalar or Bus.

6 Choose the User Properties to display a dialog box where you can add or change property names and their associated values. When you’ve finished editing the hierarchical pin’s properties, click OK.

7 Click OK to close the Place Hierarchical Pin dialog box.

8 Position the hierarchical pin on an edge of the hierarchical block and click the left mouse button to place the pin.

**Tip** You can only place a hierarchical pin within the boundaries of a hierarchical block. A hierarchical pin connects to any like-named hierarchical port on the schematic pages in the schematic folder you attached to the hierarchical block.

**Note** Bus width hierarchical pins must be given bus type names. See Bus naming conventions in Capture’s online help for more information.
Placing and editing hierarchical ports and hierarchical pins

Place Hierarchical Pin dialog box

![Place Hierarchical Pin dialog box](image)

**Name**  Specifies the hierarchical pin’s name.

**Type**  Specifies the type of pin.

**Width**  Specifies whether the pin is Scalar or Bus.

**User Properties**  Displays a dialog box that you can use to edit the pin’s property names and their respective property values.

**Editing hierarchical ports and hierarchical pins**

You can edit a hierarchical port or hierarchical pin after it is placed by selecting it and choosing Properties from the Edit menu, choosing Edit Properties from the right mouse button pop-up menu, or double-clicking on it. This opens the property editor, where you can change the information for Name and Type properties.

You can edit the display properties of the text associated with a hierarchical port by selecting the text of the port and choosing Properties from the Edit menu, choosing Edit Properties from the right mouse button pop-up menu, or double-clicking on it. Using the Display Properties dialog box, you can change the text itself, or change the text’s color, font, or rotation. After you have finished editing the text’s properties, click OK.

**Tip**  If you move the text of a hierarchical port, it will snap to the grid. To return it to its correct position with respect to the hierarchical port, use the Mirror command on the Edit menu, or turn snap-to-grid off, and move the text back into place.
Placing and editing off-page connectors

Off-page connectors are used to connect signals to like-named off-page connectors and hierarchical ports on other schematic pages within the same schematic folder. Off-page connectors are stored in the CAPSYM.OLB library.

Placing off-page connectors

To place an off-page connector, you use the Off-Page Connector command on the Place menu or the off-page connector tool on the tool palette.

1. From the schematic page editor’s Place menu, choose Off-Page Connector.

2. In the Symbol text box, type the name of the symbol to place. If you aren’t sure of the exact name of the symbol, you can enter wildcard characters to constrain the list of symbols, then click OK. Valid wildcard characters are an asterisk (*) to match multiple characters and a question mark (?) to match a single character.

After you type the name of the symbol to place, click OK. All symbols in the libraries listed in the Libraries list box that match the symbol name are listed in the box below the Symbol text box. When you select a symbol from this box, its graphic image displays.
3 When you have located the symbol you want to place, click OK.

An image of the symbol is attached to your pointer. You can press the right mouse button to display a pop-up menu with commands that you can use to change the appearance of the symbol before you place it. You can mirror the symbol horizontally or vertically, rotate the symbol, or edit its properties.

4 Move the pointer to the location on your schematic page where you want the symbol and click the left mouse button. This places the symbol on your schematic page.

You can place multiple instances of the symbol by clicking the left mouse button each place you want an instance of the symbol.

5 When you are done placing symbols, choose End Mode from the right mouse button pop-up menu, or press [Esc].

Note All objects that you can place on a schematic page have right mouse button pop-up menus. These menus are context sensitive, meaning the displayed commands are appropriate for the selected object. For information about the commands on a pop-up menu, see Capture's online help.
Chapter 7  Placing, editing, and connecting parts and symbols

Place Off-Page Connector dialog box

![Place Off-Page Connector dialog box](image)

**Figure 55** Place Off-Page Connector dialog box

**Symbol**  Specifies the off-page connector symbol to use. If you aren’t sure of the exact name of the symbol, you can enter wildcard characters to constrain the list of symbols, then click OK. Valid wildcard characters are an asterisk (*) to match multiple characters and a question mark (?) to match a single character. The names of all symbols in the selected libraries that match the wildcard appear in the Symbol list box.

**Symbol list**  Lists the names of all symbols in the selected libraries that match the text entered in the Symbol text box. If more than one library is selected, the symbol name is followed by a slash (/) and a library name. When you select an off-page connector in this list, its name displays in the Symbol text box, and its graphic displays in the preview box.

**Libraries**  Lists the library names currently available. Select the libraries from which to select symbols. All symbols in the selected libraries that match the Symbol text box display in the Symbol list. To select more than one library, press \[Ctrl\] while you click the mouse.
Preview box  Displays the graphic of the selected symbol.

Name  The name of the symbol. Other off-page connectors and hierarchical ports in the same schematic folder that have this name are connected to this off-page connector.

Add Library  Displays a standard Open dialog box that you can use to locate a library and add it to the Libraries list.

Remove Library  Removes the selected libraries from the Libraries list.

Editing off-page connectors

You can edit an off-page connector after it is placed by selecting it and either choosing Properties from the Edit menu, or choosing Edit Properties from the right mouse button pop-up menu. You can also double-click the off-page connector. This displays the Edit Off-Page Connector dialog box, which lets you change the Name. Once you have finished editing the information in the Edit Off-Page Connector dialog box, click OK.

You can also edit the display properties of the text associated with the off-page connector. Select only the text of the off-page connector, then either choose Properties from the Edit menu, or choose Edit Properties from the right mouse button pop-up menu. You can also double-click the off-page connector. This displays the Edit Off-Page Connector dialog box. Once you have finished editing the properties, click OK.

You can click an off-page connector and move it to another location. You can also use both the Mirror and Rotate commands from the Edit menu to change the appearance of the off-page connector.

Tip  If you move the text of a hierarchical port, it will snap to the grid. To return it to its correct position with respect to the off-page connector, select the symbol, use the Mirror command on the Edit menu, or turn snap-to-grid off, and move the text back into place.

Note  You can create custom power, ground, and other symbols for hierarchical ports, off-page connectors, title blocks, and power objects by using the New Symbol command from the Design menu in the project manager window. For information on how to use this command, see the Capture online help.
Placing and connecting wires and buses

Two wires or two buses can be connected physically by the following methods:

- If you begin or end a wire segment on a segment of another wire, as in a T-intersection, Capture adds a junction and the wires are connected.
- If you begin or end a bus segment on a segment of another bus, as in a T-intersection, Capture adds a junction and the buses are connected.
- If you begin or end a wire segment on a segment of another wire, as if to continue the same wire, Capture treats it as one wire. The same is true of two bus segments.

A wire and a bus can be connected in name only by the following methods:

- If you begin or end a wire segment on a segment of a bus, Capture adds a junction (if they T-intersect), and they will be connected.
- If you begin or end a bus segment on a segment of a wire, Capture adds a junction (if they T-intersect), and they will be connected.

Wires and buses, along with other parts and symbols in the project that are logically connected via net names, form a net. When you place a wire, it is assigned a system-generated netname, which you can replace with an alias or a different netname. Once a bus acquires a valid name or alias, that name or alias defines the signals carried by the bus and connects those signals to the corresponding nets. For example, the alias A[0:3] defines a four-signal bus and connects the four signals it carries with nets A0, A1, A2, and A3.

Like wires, buses can acquire names and aliases by two means:

- Direct application of a net alias with valid bus name

Note: For more information about placing and connecting wires and buses, see Capture’s online help.
Placing and connecting wires and buses

- Electrical connection to a hierarchical port, off-page. connector, or global bus pin with a valid bus name.

Placing wires

When you connect a wire to a pin, Capture provides visual confirmation of the connection by removing the unconnected pin box on the pin. If two continuous wires cross at 90°, they are not electrically connected unless you create a junction by clicking the left mouse button as you draw a wire across an existing wire.

You can determine whether wires or buses that cross each other are connected by the presence or absence of a junction. Unless a junction is present, wires or buses that cross each other are not connected. If you drag a net up to another net so that they touch, Capture adds a junction where the nets meet and the two nets are connected.

You can add a junction using the Place junction button on the schematic page editor’s toolbar, or by choosing Junction from the Place menu in the schematic page editor. You can place junctions anywhere on a wire or bus, but they only take effect when another object is connected at the junction’s location. You can remove a junction by selecting the junction and pressing Delete, or by placing another junction on top of the existing one.

To place a wire

1. From the schematic page editor’s Place menu, choose Wire.
   or
   Choose the wire tool on the schematic page editor’s tool palette.
2. Click the left mouse button to start the wire.
3. Move the mouse to draw the wire. Click the left mouse button if you want to place a vertex and change directions.

Tip To find out the name of the net to which a pin is connected, select the pin, then right-click and choose Select Entire Net. Use [Ctrl]+E to open the property editor. Click the Schematic Nets tab to see the Name property.

Note If you place parts so that two pins meet end to end, the pins are connected. When you move the parts away from each other, a wire is automatically placed.

Note Junctions can only be placed on wires and buses. A junction cannot be placed in an open area, or on an object such as a pin or a port.

Note The wire is constrained to multiples of 90° unless you hold down the Shift key while you draw the wire.
4  Double-click to end the wire. The wire displays in the selection color.
   or
   Click on another wire. Clicking on another wire connects the two wires.

5  When you are done placing wires, choose End Mode from the right mouse button pop-up menu, or press [Esc].

Editing wires

Capture makes it easy for you to modify the appearance and properties of a wire. You can implement most changes with two clicks of the mouse or a key combination.

To create a net alias

1  Select a wire or net on the schematic page.
2  From the Place menu, choose Net Alias.
   or
   Click the Net Alias tool on the schematic page editor tool palette.
3  Type a name in the Alias text box and choose a color, rotation, and font for display in the Place Net Alias dialog box.
4  Click OK to finish.

To edit a net alias

1  Double-click the alias name on the wire or net.
   or
   Right-click on the alias name on the wire or net and choose Edit Properties from the pop-up menu.
   or
   Select the alias name, then from the Edit menu, choose Properties.

Note  When you click a wire, all its graphical handles are highlighted. To add another wire to the selection, hold down the [Ctrl] key and click the additional wire. To select the entire net, select the wire, then choose Select Entire Net from the right mouse button pop-up menu. Zoom out to view the entire selected net.

Note  For more information about editing wires and nets, see the Capture online help.
2 Change alias name, color, rotation, or font settings in the Edit Net Alias dialog box.

3 Click OK to finish.

Moving wires

To move a wire, select it and drag it to a new location; the wire stretches to maintain its connectivity. To break the wire’s connectivity, press [Alt] while you move it. To move a vertex, select a wire segment next to the vertex and drag the vertex to the new location.

Capture warns you of connectivity changes as you drag an object by placing markers at the connectivity change points visible on the schematic page. At the same time, the cursor changes to an exclamation point as shown below, and the status line warns of net connectivity changes.

![Figure 56 Connectivity change warning](image)

Because some connectivity changes may not be visible on screen, most connectivity changes for which you see an alert are documented in the session log.

For more information about connectivity and orthogonal drag, see Capture’s online help.

Tip Before you edit a design created in an earlier version of Capture in Capture Release 9.1 or later, run a Design Rules Check to show where Capture will place junctions in your design. If you do not want electrical connections at “T” intersections and on pins where wires cross, you can adjust the design as necessary using Capture Release 9 or earlier.
Placing buses

A bus is a group of scalar signals (wires). Once the bus acquires a valid name or alias, then that name or alias defines the signals carried by the bus and connects those signals to the corresponding nets. For example, the alias A[0:3] defines a four-signal bus that connects the four bus signals to the individual wires named A0, A1, A2, and A3. Net aliases on wires do not use brackets.

To place a bus

1. From the schematic page editor’s Place menu, choose Bus.
   or
   Choose the bus tool on the schematic page editor’s tool palette.

2. Click the left mouse button to start the bus.

3. Move the mouse to draw the bus. Click the left mouse button if you want to place a vertex and change directions, or to connect to another bus as you pass over it. The bus is constrained to multiples of 90° unless you hold down the Shift key while you draw the bus.

4. Double-click to end the bus, then click the Select button on the schematic page editor’s tool palette.

5. Highlight the bus and choose Net Alias from the Place menu. Enter an alias for the bus in the Place Net Alias dialog box that appears, then click OK.

6. When you are done placing buses, choose the selection tool or press Esc to dismiss the bus tool.

Note: Bus names and aliases have the form X[m..n]. X represents the “base name.” The portion m..n represents the range of signals carried by the bus. Note that m may be less than or greater than n. In other words, both A[0..3] and A[3..0] are valid bus aliases. You can use two periods (..), a colon (:), or a dash (-) to separate m and n. Do not use two digits for single-digit signals (for example, use A[0..3], but don’t use A[00..33]). See Bus naming conventions in the Capture online help for more information.
Editing buses

Use the select tool on the schematic page editor’s tool palette to select bus, then use one of the following methods to open the property editor:

- Choose Properties from the Edit menu
- Choose Edit Properties from the right mouse button pop-up menu

Add or change the bus’s properties on the Schematic Nets tab. These changes can be applied to the schematic page by clicking Apply or closing the property editor. To make new properties visible in the schematic page, you must select them in the property editor and click the Display button and select a display format in the Display Properties dialog box that appears.

You can also edit the display properties of the text associated with the bus. Select only the text of the bus, then either choose Properties from the Edit menu, or choose Edit Properties from the right mouse button pop-up menu. You can also double-click the text. In the Edit Net Alias dialog box, you can change the Alias, Color, Rotation, or Font. Click OK to apply changes.

Placing bus entries

Bus entries are used to bring a net into a bus. They are optional. The only distinction between a bus entry and a wire segment is that two wires that touch are connected, whereas two bus entries that touch are not connected.

To place a bus entry

1. From the schematic page editor’s Place menu, choose Bus Entry
   or
   From the schematic page editor’s tool palette, click the bus entry tool.
The bus entry is attached to the pointer.

2 From the Edit menu, choose Rotate to rotate the bus entry 90° counterclockwise if the bus entry is not at the angle you need.

3 Use the mouse to position one end of the bus entry on the bus, then click the left mouse button to place the bus entry.

4 Repeat step 3 until all of the bus entries are placed.

5 Choose the selection tool or press Esc to dismiss the bus entry tool.

To connect multiple nets to a bus

1 Place a wire to connect the first bus entry to a net.

2 Place an alias on the wire using the lowest value in the bus range. For example, if you’re using a bus alias of A[0:3], the lowest value in the bus range is A0.

3 Select the wire, then press [Ctrl] while you drag a copy a specific distance so that it connects the next net to the bus. The alias value is increased by one.

4 From the Edit menu, choose Repeat. The wire and the incremented alias text are placed at the specified distance from the previous set.

5 Repeat step 4 for every bus entry in the bus, or repeat steps 3 and 4 as needed.

6 When you have finished connecting bus entries, press Esc.

Editing bus entries

To move a bus entry, select it and drag it to a new location. To rotate a bus entry, select it and choose Rotate from the Edit menu.
Ripping a subset of signals off the bus

You can rip a bus that is a subset of another bus similar to the way you connect a net to a bus. For example, if you want to rip ADDR[8..15] off of ADDR[0..15], place a bus entry so that it connects the two buses. Make sure that the name of the bus being ripped off uses a net alias that is a subset of the second bus.

You can route the ripped bus to any page in the design. Use hierarchical ports, hierarchical pins, and off-page connectors to connect the ripped bus to other schematic pages the same way you would with any other bus.
You can create a wide variety of graphic shapes to add to your schematic pages. You can work with the snap-to-grid option turned on or turned off. For close work, you may want to zoom in on your graphic using the Go To command on the View menu.

Before you begin drawing, you may want to specify default line and fill styles, because all lines and shapes you draw will use the current line style, and closed shapes that you draw will use the current fill style. You can use a variety of line or fill styles for any part. You can specify these styles in the Miscellaneous tab in the Preferences dialog box.

Note: If the pointer snap-to-grid option is cleared, then placed graphics and text snap to a finer grid that is one-tenth the size of pin-to-pin spacing.
Drawing tools

Capture has two tool palettes: one for the schematic page editor window, and one for the part editor window. Both tool palettes are movable and resizable, and display tooltips that identify each tool. The tool palettes are each divided into two groups of tools. The electrical tools are in the first group and the drawing tools are in the second group.

Figure 57  Schematic page editor tool palette

Figure 58  Part editor tool palette

General rules for all drawing tools:

- If you choose a drawing tool and press Esc before you begin drawing an object, the drawing tool changes to the selection tool.

- If you choose a drawing tool, start drawing an object, and then press Esc, the unfinished object is removed, and the drawing tool changes to the selection tool.
Drawing lines

You use the line tool to draw a single line. The line you draw adopts the current line style. If you want to draw a line with multiple contiguous segments, use the polyline tool.

To draw a line segment

1. From the Place menu, choose Line.
   or
   Choose the line tool on the tool palette.
2. Move the pointer to the line’s beginning.
3. Press and hold the left mouse button while moving the mouse to draw the line.
4. Release the left mouse button to end the line. The line displays in the selection color.
5. Choose the selection tool or press Esc to dismiss the line tool.

To resize a line

Use the selection tool to select a line. Edit handles appear at either end of the line. With the pointer on one of the two edit handles, press the left mouse button and drag the line. You can change the angle of the line in the process of resizing it.

Note: To place diagonal lines, hold down the Shift key while drawing a line with snap-to-grid selected.
Chapter 8  Adding and editing graphics and text

Drawing rectangles and squares

You use the rectangle tool to create orthogonal shapes. To create a square, hold down the Shift key before you begin drawing. Any rectangles or squares you create will have the current fill style and line style.

To draw a rectangle or a square

1. From the Place menu, choose Rectangle.
   or
   Choose the rectangle tool on the tool palette.
2. Move the pointer to one corner of the intended rectangle.
3. Press and hold the left mouse button while you drag the mouse. The rectangle changes shape as you move the mouse. Release the left mouse button when you have the correct shape. To draw a square, hold down the Shift key while you perform this step. The rectangle displays in the selection color.
4. Choose the selection tool or press Esc to dismiss the rectangle tool.

To resize a rectangle or square

Use the selection tool to select a rectangle or square. Edit handles appear on the four corners. With the pointer on one of the handles, press the mouse and drag the handle.
**Drawing circles and ellipses**

You use the ellipse tool to draw a closed ellipse; if you want to draw an arc, use the arc tool. To draw a circle, hold down the Shift key while you drag the mouse. Because they are closed shapes, circles and ellipses will have the current fill style. They will also have the current line style.

**To draw an ellipse or a circle**

1. From the Place menu, choose Ellipse.
   
   or

   Choose the ellipse tool on the tool palette.

2. Move the pointer to an edge of the intended ellipse.

3. Press and hold the left mouse button while you drag the mouse. The ellipse changes shape as you move the mouse. If you want to draw a circle, hold down the Shift key while you perform this step. Release the left mouse button when you have the correct shape. The ellipse appears in the selection color.

4. Choose the selection tool or press Esc to dismiss the ellipse tool.

**To resize an ellipse or circle**

Use the selection tool to select an ellipse or a circle. Edit handles appear on all four corners of the rectangle that encloses it. With the pointer on one of the handles, press the mouse and drag the handle.
Drawing arcs

You create an arc of any angle using the arc tool. Because it is a line, an arc adopts the current line style. If you want to create a full circle, use the ellipse tool.

Drawing an arc is done in three stages:

1. Specify the center of the arc with the first mouse click.
2. Specify the radius of the arc with the second mouse click.
3. Specify the arc segment endpoint with the third mouse click.

Capture draws the arc counterclockwise from the endpoint, and displays in the selection color.

To draw an arc

1. From the Place menu, choose Arc.
   or
   Choose the arc tool on the tool palette.
2. Move the pointer to establish the center of the arc, and press and hold the left mouse button.
3. Drag the mouse out from the center to establish the radius of the arc, then click the left mouse button to establish the location of one end of the arc.
4. Use the mouse to establish the other end of the arc and click the left mouse button. The arc is drawn counterclockwise from the endpoint, and displays in the selection color.
5. Choose the selection tool or press Esc to dismiss the arc tool.

To resize an arc

1. Use the selection tool to select an arc. Edit handles appear at the ends of the arc.
2. With the pointer on one of the handles, press the mouse and drag. The center remains the same. The other arc endpoint uses the new radius.
Drawing polylines and polygons

To draw a line with multiple contiguous segments, use the polyline tool. The line you draw adopts the current line style. Polygons can be created with the polyline tool, and they adopt the current fill style. To create a non-orthogonal polyline, hold down the Shift key while you draw.

**To draw a polyline**

1. From the Place menu, choose Polyline.
   or
   Choose the polyline tool on the tool palette.
2. Click the left mouse button to begin drawing, click to change directions, and double-click to end the final segment. To draw non-orthogonal polylines, press Shift. After you double-click, the polyline displays in the selection color.
3. Choose the selection tool or press Esc to dismiss the polyline tool.

**To draw a polygon**

1. Follow the instructions above, ending the line with a single mouse-button click at the beginning point. The polygon adopts the current line and fill style.

**To resize a polyline or polygon**

Use the selection tool to select a polyline or polygon. Edit handles appear at the ends of all the lines in the polyline/polygon. With the pointer on a handle, press the left mouse button and drag the handle.
Adding fill to an object

You can have closed shapes automatically filled in after you finish drawing them by defining a default fill. From the Options menu, choose Preferences, then choose the Miscellaneous tab. Click the Fill Style drop-down box to display the options. Note that you can specify separate options for the schematic page editor and the part editor. Select one of the options and click OK.

To add fill to an object

1. Select the object
2. From the Edit menu, choose Properties.
3. Select a fill style from the Fill Style drop-down box, then click OK.

Mirroring an object

You can mirror objects horizontally, vertically, or both horizontally and vertically. Some objects, such as text and bitmaps, cannot be mirrored. If the Mirror command appears dimmed on the Edit menu, the object cannot be mirrored.

To mirror an object

1. Select the object.
2. From the Edit menu, choose Mirror, then choose Mirror Horizontally, Mirror Vertically or Both. The object flips in the chosen direction.
Rotating an object

You can rotate objects by 90° increments. Some objects, such as bitmaps, cannot be rotated. If the Rotate command appears dimmed on the Edit menu, the object cannot be rotated.

To rotate an object
1. Select the object.
2. From the Edit menu, choose Rotate. The selection rotates 90° counterclockwise.

Moving an object
1. Move the mouse anywhere over the object, except over resize handles.
2. Press the left mouse button, without releasing it, and drag the object until it is where you want it.
3. Release the mouse button.

Cutting an object
Select the object. From the Edit menu, choose Cut. The object is removed from the schematic page and placed on the Clipboard.
Chapter 8  Adding and editing graphics and text

Copy an object

There are two ways to copy an object:

1. Select the object. From the Edit menu, choose Copy. The object remains on the schematic page and a copy of it is placed on the Clipboard. It can be pasted in Capture or in other Windows programs.

   or

2. Position the pointer on the object. Press the left mouse button, hold down the [Ctrl] key, and drag a copy of the object to the new location.

Tip After you copy an object using the second method, you can use the Repeat command (from the Edit menu) to place multiple copies of the object using the same spacing. This is a quick way to create an array of aligned objects.

Paste an object

To use the Paste command, an object must already be on the Clipboard via the Cut or Copy command. Place the pointer where you want the object to be pasted. From the Edit menu, choose Paste. The object is placed on the schematic page.

Note Capture can only paste text from Windows applications into the Place Text window, and not directly onto the page.

Delete a selected object

There are several ways to delete a selected object:

- From the Edit menu, choose Delete.
- From the right mouse button’s pop-up menu, choose Delete.
- Press [Delete].
- Press [→ Bksp].
Placing a bitmap

You can create a bitmap in another application and place it on a schematic page, on a library part, or in a custom title block.

To place a bitmap

1. From the Place menu, choose Picture. A standard Open dialog box appears.
2. Select the bitmap file. If the file is not listed in the File name text box:
   a. In the Look in drop-down list, select a new drive.
   b. Choose the Up One Level button.
   c. In the Files of type box, select the type of file you want to open.
3. Click OK. A rectangle representing the bitmap image is attached to the pointer.
4. Click the left mouse button to place the bitmap at the desired location. If you want to place multiple copies of the bitmap, repeat this step.
5. Press [Esc] or choose the selection tool.

To resize a bitmap

1. Select the bitmap so that it displays in the selection color with edit handles at the four corners.
2. Position the pointer over an edit handle and drag the edit handle. The bitmap’s size and shape change to accommodate the new dimensions. Using the [Shift] key constrains resizing the bitmap to proportional changes in the horizontal and vertical directions.

Note: Because some printers and plotters do not interpret bitmaps correctly, you should place one bitmap and print or plot it, to ensure that the output is what you want before you place multiple bitmaps.
Placing text

You can place text, in the font of your choice, on a schematic page or on a part to document your schematic page.

**To place text on a schematic page**

1. From the Place menu, choose Text.  
   *or*  
   Choose the text tool on the tool palette.
2. Enter the text. To type numbers using the numeric keypad on your keyboard, you must first enable the NumLock key.
3. Complete the dialog box selections by specifying font, color, and rotation.
4. Click OK to close the dialog box. A rectangle representing the text is attached to the pointer.
5. Click the left mouse button to place the text at the desired location. You can place multiple copies of the text by clicking the left mouse button at each location where you would like text.
6. When you are done placing text, choose End Mode from the right mouse button pop-up menu or press Esc.

**Tip** The font size and style of any text placed in the default font setting can be globally changed using the settings in the Design Properties dialog box. Changes to these design property settings will not affect any text on a design that is not set to the default font.

**Tip** If you have text in another Windows application, you can copy it to the Clipboard and paste it into the text dialog box using the Ctrl+C and Ctrl+V shortcut keys, respectively.

**To move text**

1. Select the text so that it displays in the selection color with edit handles at the four corners.
2. Position the pointer over the text—not an edit handle—and drag the text to the new location.
3. Release the mouse button to place the text.
4. Click an area where there are no parts or objects to deselect the text.
To move or copy text using the Clipboard

1. Select the text.
2. From the Edit menu, choose Cut. The text is placed on the Clipboard.
   or
   From the Edit menu, choose Copy. A copy of the text is placed on the Clipboard.
3. From the Edit menu, choose Paste. The text is attached to the pointer.
4. Move the pointer to the location where you want to place the text and click the left mouse button. The text is placed and displays in the selection color.
5. Click an area where there are no parts or objects to deselect the text.

To rotate text

1. Select the text so that it displays in the selection color with edit handles at the four corners.
2. From the Edit menu, choose Rotate. The text rotates 90° counterclockwise.
3. Repeat step 2 as necessary.
4. Click an area where there are no parts or objects to deselect the text.
The text bounding box

Text that you place wraps according to the dimensions of its bounding box.

To change how the text wraps

1. Select the text so that it displays in the selection color with edit handles at the four corners.
2. Position the pointer over an edit handle and drag the edit handle. The text inside the bounding box rewraps within the new dimensions.

Deleting text

To delete the text and its bounding box, select the text so that it displays in the selection color with edit handles at the four corners. Press either the [Delete] key or the [Bksp] key.

To delete text when it is highlighted in the Edit Text dialog box, press the [Delete] key, the [Bksp] key, or begin typing new text.

To delete individual words within the text, double-click the text, or select the text and choose Properties from the Edit menu. The Edit Text dialog box appears, with the text highlighted. Press one of the four arrow keys to remove the text highlighting. Double-click the word you want to remove. Press the [Delete] key or the [Bksp] key.

Modifying text

To add more text to text you have already placed, double-click the text, or select the text and choose Properties from the Edit menu. The Edit Text dialog box appears, with the text highlighted. Press one of the four arrow keys to remove the text highlighting. Type the additional text. When you are done, click OK.
Finding text

You can use the Find command to search for text in an entire project, in selected schematic pages, on one schematic page, or in the part editor.

To find text

1. In the project manager, select the root schematic folder (to search the entire project) or select specific schematic pages.
   or
   Make the schematic page editor or the part editor the active window.

2. From the Edit menu, choose Find. The Find dialog box appears.

3. Leave the asterisk in the Find What text box to locate all occurrences of all text.
   or
   Narrow the text search by entering specific text in the Find What text box.

4. Verify that the Match Case option is as you want it.

5. Select Text from the object types in the Scope area.

6. Click OK.

If you search the entire project or selected schematic pages from the project manager, the search results are listed in the browse window. If you search with either the schematic page editor window or the part editor window as the active window, the results of the search display in the selection color in either the schematic page editor window or the part editor window.
Replacing text

Schematic page editor or part editor text can be replaced by entering the replacement text from the keyboard, or copying the replacement text from another application.

To replace text

1. Select the text so that it displays in the selection color with edit handles at the four corners.
2. From the Edit menu, choose Properties. The Edit Text dialog box appears, with the text highlighted.
3. Enter the replacement text, then click OK.

Importing text

You can import text from any Windows program that copies text to the Clipboard.

To import text from other Windows applications

1. In the other Windows application, copy the text to the Clipboard using that program’s Copy command.
2. Make the schematic page editor or part editor the active window.
3. From the Place menu, choose Text. The Place Text dialog box appears.
4. Press $\text{Ctrl} + \text{V}$ to paste the text into the text box, then verify that the color, font, and rotation are as you want them and click OK. A rectangle representing the text is attached to the pointer.
5. Click the left mouse button to place the text at the desired location.
6. When you are done placing text, press $\text{Esc}$ or choose the selection tool.
Exporting text

You can export Capture text to any Windows program that uses the Clipboard. You must select the text within the Edit Text or Place Text dialog boxes. Otherwise, copying a text object treats the text as a graphic.

To export text to other Windows applications

1. In Capture, double-click the text you want to export. Capture displays the Edit Text dialog box.
2. Select the text.
3. From the Edit menu, choose Cut or Copy. The text is placed on the Clipboard.
4. Activate the other Windows application and use that application’s Paste command to place the text.

Character formatting

You may want the text to have a distinctive appearance, or to fit within a specific space. Capture supports TrueType® fonts. You can preview a sample of the selected font before you choose it. You can also select the default font that you set up in the Fonts tab in either the Design Template dialog box or the Design Properties dialog box (available from the Options menu).

To change fonts and point sizes

1. If you are placing the text, choose Text from the Place menu. The Place Text dialog box appears.
   or
   If the text has already been placed, double-click the text. The Edit Text dialog box appears.
2. In the Font group box, click the Change button. The Font dialog box appears.
3. Select a font, style, and size. Sample text displays in the Sample group box.
4. Click OK twice.
About screen fonts

For information about setting up your screen fonts, see Chapter 4, Setting up your project.
Using macros

In the schematic page editor, you can create a macro by recording a series of editing actions. For example, you can begin a macro recording, place a wire, place text that names the wire, then stop the macro recording. Macros are recorded at the command level (not at the keystroke level) and each macro is stored as a separate file. You can also create a macro in ASCII text, using valid Visual Basic syntax.

When you record a macro, Capture assigns it a temporary name, and treats it as a temporary macro. Temporary macros can be run during the current Capture session, but they are not saved for use in subsequent Capture sessions. You can make a temporary macro permanent by saving it using the Configure Macro dialog box (choose Configure from the Macro menu).

For samples of valid Visual Basic syntax, see Capture’s online help.
In general, you can record a macro command for each menu command available in the schematic page editor. However, because the macro commands are limited to the schematic page editor window, the following commands that result in moving to a new window are unavailable:

- Ascend
- Descend
- Edit Part in Place

When recording a macro, the Undo command is not recorded as a part of the macro. For this reason, you cannot create an undo macro using the Undo command.
**Recording a macro**

A location recorded within a macro is relative to the previous action, not relative to where you began recording the macro. For example, you can record a macro to place a wire, move the cursor down one grid space, then place another wire. When you run the macro at a different location on your schematic page, the macro places a wire, moves down one grid space, then places another wire below the original wire.

**To record a macro**

1. Click the left mouse button on the schematic page to set a location to begin recording the macro.
2. From the schematic page editor’s Macro menu, choose Record. The macro recorder tool palette containing three buttons displays, as shown.
3. Perform the series of edits that you want to record as a macro, using the three macro record buttons as necessary.
   - Use the left button to stop recording the macro.
   - Use the center button to pause recording. The pause mode is in effect until you click the center button again.
   - Use the right button to cause a command to begin recording in a “with dialog” mode. If a command is recorded in this mode, the value you enter while recording the macro is not saved. Instead, when the macro is run, the command displays a dialog box so that you can fill in a value. When recording, the “with dialog” mode is in effect until you click the right button again. Use this button again to stop recording in “with dialog” mode.
4. Choose the left macro record button to stop recording the macro.
Playing a macro

Choose Play from the Macro menu to play back the most recently recorded macro or any macro you choose in the Configure Macro dialog box.

To play a macro

1. Click the left mouse button on the schematic page to set a location to begin playing the macro.
2. From the schematic page editor’s Macro menu, choose Play.
   or
   From the Configure Macro dialog box, choose Play.
Configuring a macro

After you record a macro, you give it a name, and you can also assign it a menu entry, a shortcut key definition, and a description. Once you give a macro a name and save it, it automatically displays in the Macro name list box in the Configure Macro dialog box the next time you run Capture. The text you enter as the menu entry displays on the Macro menu, along with the macro’s shortcut key definition, if you specified one. The text you enter as the description displays in the Description text box in the Configure Macro dialog box when you highlight the macro name.

To configure a macro

1. From the schematic page editor’s Macro menu, choose Configure. The Configure Macro dialog box appears.
2. If the macro you want is not selected, select it.
3. In the Macro Name text box, enter a name for the macro and click the Save button. The Macro Name dialog box appears.
4. To assign a shortcut key, enter text corresponding to a shortcut key or key combination (for example, Ctrl+7) in the Keyboard Assignment text box.
5. To have the macro appear as an entry on the Macro menu, enter the appropriate text (for example, Wirenames) in the Menu Assignment text box.
6. To describe the macro, enter the appropriate text in the Description text box.
7. Click OK. The Save As dialog box appears.
8. Select a file location and filename, click the Save button, then click the Close button.

Note: After editing a macro, you must reconfigure it. Use the Add button in the Configure Macro dialog box to locate the macro on your system. Select it and click Open.
Configure Macro dialog box

**Macro Name** Displays the macro name. You can either select a macro from the macro name list box or type in a macro’s name. The macro shown in the Macro Name field is the macro that is run if you choose Play from the Macro menu or click the Run button in the Configure Macro dialog box.

**Configured Macros** Displays the currently configured macros and any currently available temporary recordings. Selecting a name from the list fills in the dialog box fields with the appropriate values.

**Close** Closes the dialog box. Since the changes you make in the dialog box are immediately saved to memory, these edits are not permanently saved to the file unless you use the Save command before you use the Close command.
Configuring a macro

Record    Closes the dialog box, displays the macro record dialog box, and records your editing actions until you click the Stop button in the macro record dialog box. A recording is temporary (only available for the current Capture session) unless you assign it a macro name and save it using either Save or Save As.

Play      Runs the active macro.

Add       Displays a dialog box that you use to add a macro you have created. The macro must be in ASCII text, and use valid Visual Basic syntax. A newly added macro is highlighted in the list of macros and becomes the active macro.

Remove    Removes a macro from the list of permanent macros, but does not remove the macro from your hard disk.

Save      Updates an existing macro on your hard drive or saves a temporary macro to your hard drive. Saving a macro adds it to the list of configured macros and makes it the active macro.

Save As   Displays a Macro Name dialog box that you use to assign the macro a name, keyboard assignment, menu assignment, and description. Saving a macro adds it to the list of configured macros and makes it the active macro.

Keyboard Assignment   Specifies the shortcut key associated with the macro. You can specify a shortcut key for a temporary macro recording or change the shortcut key used for an existing macro by entering the text equivalent of a keyboard sequence in the Keyboard Assignment text box.
**Menu Assignment**  Specifies the menu assignment associated with the macro. You can specify a menu assignment for a temporary macro recording or change the menu assignment used for an existing macro by entering a menu entry in the Menu Assignment text box.

**Description**  Specifies the description associated with the macro. You can specify a description for a temporary macro recording or change the description used for an existing macro by entering text in the Description text box.
Naming a macro

You can assign a macro a name of any length. Since periods aren’t allowed in macro filenames, don’t specify a file extension for your macro filename: Capture assigns an extension of .BAS to your macro filename. If you want, you can rename the file with a different file extension using the Rename command in Windows Explorer.

There are some restrictions regarding the names you give your macros. These restrictions are given below.

- You cannot use spaces in a filename.
- You cannot use the following filename extensions for your macro names, since they are reserved for Capture’s use: .DBK, .DLL, .DSN, .EXE, .INI, .OBK, and .OLB.
- You cannot use any of the names in Table 4 for your macro names, since they are reserved for use by Capture’s macro subroutines.

Table 4  Capture’s macro subroutines

<table>
<thead>
<tr>
<th>Copy</th>
<th>Cut</th>
<th>Delete</th>
</tr>
</thead>
<tbody>
<tr>
<td>DisplayPropertyEx</td>
<td>Drag</td>
<td>Duplicate</td>
</tr>
<tr>
<td>EndPlace</td>
<td>FindBookMarks</td>
<td>FindDRCMarks</td>
</tr>
<tr>
<td>FindHierarchicalPorts</td>
<td>FindNets</td>
<td>FindOffPageConnectors</td>
</tr>
<tr>
<td>FindParts</td>
<td>FindText</td>
<td>GetProperty</td>
</tr>
<tr>
<td>GoToAbsolute</td>
<td>GoToBookMark</td>
<td>GoToGridReference</td>
</tr>
<tr>
<td>GoToRelative</td>
<td>Group</td>
<td>MirrorHorizontal</td>
</tr>
<tr>
<td>MirrorVertical</td>
<td>Move</td>
<td>Paste</td>
</tr>
<tr>
<td>PlaceArc</td>
<td>PlaceBlock</td>
<td>PlaceBlockWithDialog</td>
</tr>
<tr>
<td>PlaceBookMark</td>
<td>PlaceBookMarkWithDialog</td>
<td>PlaceBus</td>
</tr>
<tr>
<td>PlaceBusEntry</td>
<td>PlaceEllipse</td>
<td>PlaceGround</td>
</tr>
<tr>
<td>PlaceGroundWithDialog</td>
<td>PlaceJunction</td>
<td>PlaceLine</td>
</tr>
<tr>
<td>PlaceNetAlias</td>
<td>PlaceNetAliasWithDialog</td>
<td>PlaceNextPolygonPoint</td>
</tr>
</tbody>
</table>
### Table 4  
**Capture’s macro subroutines (continued)**

<table>
<thead>
<tr>
<th>Function</th>
<th>Function</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>PlaceNextPolylinePoint</td>
<td>PlaceNoConnect</td>
<td>PlaceOffPage</td>
</tr>
<tr>
<td>PlaceOffPageWithDialog</td>
<td>PlacePart</td>
<td>PlacePartWithDialog</td>
</tr>
<tr>
<td>PlacePicture</td>
<td>PlacePin</td>
<td>PlacePinWithDialog</td>
</tr>
<tr>
<td>PlacePolygon</td>
<td>PlacePolyline</td>
<td>PlacePort</td>
</tr>
<tr>
<td>PlacePortWithDialog</td>
<td>PlacePower</td>
<td>PlacePowerWithDialog</td>
</tr>
<tr>
<td>PlaceRectangle</td>
<td>PlaceText</td>
<td>PlaceTextWithDialog</td>
</tr>
<tr>
<td>PlaceTitleBlock</td>
<td>PlaceTitleBlockWithDialog</td>
<td>PlaceWire</td>
</tr>
<tr>
<td>RemoveDisplayProperty</td>
<td>RemoveProperty</td>
<td>ReplacePart</td>
</tr>
<tr>
<td>Rotate</td>
<td>SelectAll</td>
<td>SelectBlock</td>
</tr>
<tr>
<td>SelectObject</td>
<td>SetColor</td>
<td>SetFillStyle</td>
</tr>
<tr>
<td>SetFont</td>
<td>SetFontEx</td>
<td>SetHatchStyle</td>
</tr>
<tr>
<td>SetLineStyle</td>
<td>SetLineWidth</td>
<td>SetProperty</td>
</tr>
<tr>
<td>ShowSpreadsheet</td>
<td>Ungroup</td>
<td>UnSelectAll</td>
</tr>
<tr>
<td>UnSelectObject</td>
<td>ViewGrid</td>
<td>ViewGridReference</td>
</tr>
<tr>
<td>ViewPalette</td>
<td>ViewStatusBar</td>
<td>ViewToolbar</td>
</tr>
<tr>
<td>ZoomAll</td>
<td>ZoomArea</td>
<td>ZoomIn</td>
</tr>
<tr>
<td>ZoomOut</td>
<td>ZoomScale</td>
<td>ZoomSelection</td>
</tr>
</tbody>
</table>
Assigning a shortcut key to a macro

To assign a shortcut key to a macro, enter an alphanumeric character (such as K) in the Keyboard Assignment text box of the Configure Macro dialog box, then save the macro. To enter a combination of keyboard keys and alphanumeric characters, add a plus sign (+), either with or without spaces, between the items (for example: ALT+2 or ALT + 2). Shortcut keys are not case-sensitive: you can specify ALT+2 or ALT+2.

To assist you in assigning shortcut keys to your macros, Capture has reserved the following shortcut-key starting sequences:

- C, T, R, L = [Ctrl]
- A, L, T = [Alt]
- S, H, I, F, T = [Shift]
- [Ctrl]+[Alt]
- [Ctrl]+[Shift]
- [Ctrl]+[Alt]+[Shift]
- [Alt]+[Shift]

To use one of the starting sequences, enter the letters on your keyboard that represent each key in the Keyboard Assignment text box, add a plus sign (+), then add an alphanumeric character (for example: CTRL+P). You have to use the starting sequences in the same order, and in the same format, as shown in the list above. For example, you cannot reverse the order of the keys, nor can you use CONTROL instead of CTRL. You cannot use a shortcut-key starting sequence by itself. For example, SHIFT by itself will not function as a shortcut key. Table 5 shows all of the alphanumeric characters, function keys, punctuation keys, special keys, and arrow keys that you can use with the shortcut key starting sequences listed above.

Any shortcut keys you assign to your macros take precedence over the shortcut keys assigned to other Capture functions. For example, you can use [Ctrl]+[Del] as a key combination for a macro, even though it is the key combination assigned to clear the Capture session log. To restore an original shortcut key assignment (in this example, restoring [Ctrl]+[Del] to its original function of clearing the session log), assign a different shortcut key to your macro using the Keyboard Assignment text box in the Configure Macro dialog box, click Save, then click Close.
Sample macros

Provided with Capture are a number of sample macros that you can use. These files are saved in the \CAPTURE\MACROS directory when you do a typical installation. Open them with a text editor to view or edit them.

---

Table 5  Valid shortcut keys

<table>
<thead>
<tr>
<th>Type of key</th>
<th>Available keys</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alphabetic character</td>
<td>A through Z, inclusive</td>
</tr>
<tr>
<td>Numeric character</td>
<td>0 through 9, inclusive</td>
</tr>
<tr>
<td>Function key</td>
<td>F1 through F24, inclusive</td>
</tr>
<tr>
<td>Punctuation key</td>
<td>!, @, #, $, %, ^, &amp;, *, (, )</td>
</tr>
<tr>
<td>Special key</td>
<td>Esc, Ins, Del,PgUp, PgDn, Home, End</td>
</tr>
<tr>
<td>Arrow key</td>
<td>←, →, ↑, ↓</td>
</tr>
</tbody>
</table>

Caution  Do not open a Capture macro with Visual Basic. Visual Basic will add formatting to the file if you save it.
Changing your view of a schematic page

There are several ways to change your view of a schematic page. They include zooming to a smaller or larger view of the schematic page, centering a view on a particular position, and moving to a different location. You can also choose whether or not to display a grid or grid references.
zooming

In the schematic page editor and in the part editor, you can look closely at a particular area by using the Zoom In command on the View menu. Conversely, you can change your viewing perspective to increase the portion of the drawing board that is visible by using the Zoom Out command. When you zoom in or out, Capture centers your view on the current pointer position, if possible. If the pointer is outside the window, or if you choose the Zoom In or Zoom Out toolbar button, Capture centers your view on any selected objects. Otherwise, Capture zooms in or out on the center of the active window.

To zoom in
1. From the View menu, choose Zoom, then choose In.  
or  
   Choose the zoom in tool on the toolbar.  
or  
   Type I.

The current zoom scale is multiplied by the zoom factor. With a zoom factor of two, zooming in makes the image twice as large and displays half the area of the previous view.

To zoom out
1. From the View menu, choose Zoom, then choose Out.  
or  
   Choose the zoom out tool on the toolbar.  
or  
   Type O.

The current zoom scale is divided by the zoom factor. With a zoom factor of two, zooming out halves the image size and shows twice the area of the previous view.

To change the zoom factor
1. From the Options menu, choose Preferences, then choose the Pan and Zoom tab.
2 In the Zoom Factor text box, enter the new zoom factor. Note that you can specify separate values for the schematic page editor and the part editor.

3 Click OK.

Zooming to a specified scale

The Zoom Scale dialog box provides predefined scales (25%, 50%, 100%, 200%, 300%, and 400%). You can also type in a custom scale value (as a percentage). The scaling limits the size of the schematic page that appears (for example, if 1 unit = .01", then you can display: 320" at 100%, 160" at 200%, 80" at 400%, and so on).

To zoom to a specific scale

1 From the View menu, choose Zoom, then choose Scale. The Zoom Scale dialog box appears.

2 Select one of the preset scales, or enter a custom scale.

3 Click OK.

Other viewing options

You can view a selected area or the entire page, or you can center your view.

To view a selected area

1 From the View menu, choose Zoom, then choose Area.
   or Choose the zoom area tool on the toolbar.

2 Move the pointer to one corner of the area to view.

3 Press and hold the left mouse button as you move the pointer to the opposite corner of the area to view.
4 Release the mouse button. The area expands to fill the window.
To view the entire page or part

1. From the View menu, choose Zoom, then choose All.
   or
   Choose the zoom all tool on the toolbar.
   The entire schematic page or part shrinks or expands to fit the window.

To center the view on an object or area

1. Select objects or an area.
2. From the View menu, choose Zoom, then choose Selection.

The display scrolls so that the selected objects or selected area is in the center of the window. The zoom scale does not change.

To center the view on your pointer

1. Press Shift+C.

The display scrolls so that the pointer’s selection is in the center of the window. The zoom scale does not change.
Moving to a new location

There are several different ways you can move to a new location on a schematic page. To move using the methods listed below, use the Go To command and dialog box. You can:

- Move to a particular set of X, Y coordinates or to an X, Y location offset from the pointer’s current position.
- Move to a grid reference area, as indicated by the horizontal and vertical grid reference headings.
- Move to a location previously marked by a bookmark.

From the View menu, choose Go To to display the Go To dialog box, which has three tabs labeled Location, Grid Reference, and Bookmark, shown below and on the next page.

Moving to an X, Y location

The X and Y coordinates of your pointer’s current location appear on the right side of the status bar.

To move to a specific location

1. From the View menu, choose Go To. The Go To dialog box appears.
2. Choose the Location tab.
3. Enter the X and Y values, select the Absolute option, then click OK. The coordinates are measured in inches or millimeters, depending on what you have configured in the Page Size tab on the Schematic Page Properties dialog box. Your pointer moves to the new coordinates.
To move a specific distance

1. From the View menu, choose Go To. The Go To dialog box appears.
2. Choose the Location tab.
3. Enter the X and Y values that you want the pointer to move, select the Relative option, then click OK. The jump distance is measured in inches or millimeters, depending on what you have configured in the Page Size tab on the Schematic Page Properties dialog box. Your pointer moves the specified distance.

**Go To dialog box, Location tab**

![Go To dialog box, Location tab](image)

**X** Specifies the X-axis coordinate for the jump.

**Y** Specifies the Y-axis coordinate for the jump.

**Absolute and Relative** Specifies the jump as absolute (to the indicated coordinates) or relative (the coordinates are offset to the pointer’s current position).
Jumping to a specific grid reference

Grid references appear on the left and upper edges of the schematic page.

To jump to a reference area

1. From the View menu, choose Go To. The Go To dialog box appears.
2. Choose the Grid Reference tab.
3. Select a horizontal grid reference from the Horizontal drop-down list.
4. Select a vertical grid reference from the Vertical drop-down list.
5. Click OK.

Go To dialog box, Grid Reference tab

![Go To dialog box]

Figure 61 Grid Reference tab of the Go To dialog box

**Horizontal** Specifies a horizontal grid reference for the jump.

**Vertical** Specifies a vertical grid reference for the jump.
Jumping to a marked location

To return repeatedly to a specific area of a schematic page, or to direct attention to a particular location, you can use a *bookmark*. To use a bookmark, you assign it a name and place it on a schematic page. When you want to return to it, use the Go To command. You can also reuse existing bookmarks by selecting them and moving them to new locations. Bookmarks are saved with your project.

**To place a bookmark**

1. From the Place menu, choose Bookmark. The Place Bookmark dialog box appears.
2. Enter the name of the bookmark, then click OK.
3. Position the pointer where you want the bookmark and click the left mouse button. The bookmark is placed, and displays in the selection color.
4. Choose End Mode from the right mouse button pop-up menu.
5. Click an area where there are no parts or objects to deselect the bookmark.

**To rename a bookmark**

1. Select the bookmark.
2. From the Edit menu, choose Properties. The Edit Bookmark dialog box displays.
3. Enter a new name in the text box.
4. Click OK.

**To move to a specific bookmark**

1. From the View menu, choose Go To. The Go To dialog box appears.
2. Choose the Bookmark tab.
3. Enter the name of the bookmark and click OK.
Go To dialog box, Bookmark tab

Name  Specifies a name of a bookmark for the jump.
Displaying the grid and grid references

You can hide the grid display and grid references, then display them again later.

**To display or hide the grid**

1. From the View menu, choose Grid.

**To display or hide the grid references**

1. From the View menu, choose Grid References.

---

**Note** The settings in the Grid Display tab in the Preferences dialog box (from the Options menu) control whether the grid appears as grid dots or lines. The Grid Display tab setting also controls whether the pointer snaps to grid.
Finding parts in a project

Using the Find command and a part property value, you can locate a part in a project, schematic folder, or on a schematic page. In the Find dialog box, you enter a property value string and specify that you want to find a part. Capture searches all the parts to find those with a property value that matches the string. If you aren’t sure of the exact property value string, you can enter wildcard characters to constrain the search list, then click OK. Valid wildcard characters are an asterisk (*) to match multiple characters and a question mark (?) to match individual characters.

To find a part on a schematic page
1. Open the schematic page.
2. From the Edit menu, choose Find.
3. Enter the property value string that defines the part you want to search for.
4. Select Parts from the object types in the Scope area.
5. Click OK to start the search. Parts that have a property value matching the property value string of step 3 are selected on the schematic page.

To find a part in a project
1. In the project manager, select the schematic folder or schematic pages you want to search.
2. From the Edit menu, choose Find.
3. Enter the property value string that defines the part you want to search for.
4. Select Parts from the object types in the Scope area.
5. Click OK to start the search. Parts that have a property value matching the property value string of step 3 are listed in the browse window.
6. Double-click on the part in the browse spreadsheet to open the schematic page editor with the found part displayed and selected.
Chapter 11, About libraries and parts, describes how the parts in a design are stored in the design cache, and how you can replace or update parts in the design cache.

Chapter 12, Creating and editing parts, describes how to create new parts and store them in a library, how to edit parts in a library, and how to edit parts after they are placed on a schematic page.
About libraries and parts

Capture’s libraries contain more than 30,000 parts. This chapter describes Capture’s libraries, and explains how parts, packages, and electrical symbols are stored in libraries.
Libraries

Libraries are files that contain reusable part data. They contain parts that you can place as instances on schematic pages. Libraries contain a variety of symbols (such as power symbols, ground symbols, and so on) and title blocks that you can reuse in your projects.

The relationship between the library and the parts and symbols it contains is similar to the relationship between a schematic folder and its contents. The contents of the library move with the library and are deleted with the library.

You can create custom libraries to store any combination of items. You can, for example, create a library to hold schematic pages that you use often. There is no need to create a library for a project, because the design cache holds all the parts and symbols used in the design.

When you work with a library in Capture, you use the project manager. The project manager lists the parts and symbols contained in the library.

To edit a part, double-click on it. The part opens in a part editor window.

To move a part to a different library, open the source library and the destination library in separate project manager windows. Select the part and drag it from one library to the other.

To copy a part to a different library, follow the same procedure but hold the Ctrl key down while you drag the part.

Because a library is a file, you can work with it in the Windows Explorer as well as in Capture. When you need to back up a library, use Windows Explorer to create a copy.

Caution If you edit a library provided by Capture, you should give it a new and unique name so that you will not copy over your changes when you receive updated libraries.

For information about printing a part, see Chapter 5, Printing and plotting. For general information about using the project manager, see Chapter 2, The Capture work environment.

Tip You can also use the Cut, Copy, and Paste commands on the Edit menu to move or copy parts between libraries.
Parts

Parts are the basic building blocks of a design. A part may represent one or more physical elements, or it may represent a function, a simulation model, or a text description for use by an external application. A part’s behavior is described by a PCB footprint, an HDL statement, or an attached schematic folder.

Parts usually correspond to physical objects—gates, chips, connectors, and so on—that come in packages of one or more parts. Packages that have more than one part are sometimes referred to as multiple-part packages. For simplicity, Capture usually refers to both parts and multiple-part packages as parts.

You can specify packaging information when you create a part, or you can change it in the part editor (from the Options menu, choose Package Properties).

Each part has graphics, pins, and properties that describe it. As you place the parts in a package to suit your design requirements, Capture maintains the identity of the single physical part—the package—for back annotation, netlisting, bills of materials, and processes that require it.

The parts in a package may have different pin assignments, graphics, and user properties. If all the parts in a package are identical except for the pin, the package is homogeneous. If the parts in a package have different graphics, numbers of pins, or properties, the package is heterogeneous.
About part instances and part occurrences

A part instance is a specific instantiation of a part. Since the part instance may be referenced in one or more schematic pages, any change you make to a part instance affects each schematic page that refers to that part instance. For flat and simple hierarchical designs, this is straightforward:

Each part instance has a unique reference designator and corresponding set of associated properties that apply each time the part instance is referenced.

In a complex hierarchy, a part instance that is referenced more than once in the design has only one reference designator and set of properties assigned to it, regardless of the number of times it is referenced. This could present a problem when you need to create a netlist for use with Layout or some other board layout tool. However, Capture uniquely annotates each occurrence of a part instance, so part occurrence refers to a particular instantiation of a part instance in the netlist.

A part instance may have occurrences. A part occurrence is a part that potentially holds property values for reuse of the schematic page. For example, a 74LS04 part placed in the Capture sample schematic HALFADD is reused. As a result, it requires two distinct annotations (one for the A side of the hierarchy, and another for the B side of the hierarchy). Both of these annotations are occurrence properties for a single part instance placed on a schematic page.

For more information on instances and occurrences, see Capture’s online help.
The design cache

When you place the first instance of a part in a design, a copy of the part is created in the design cache. The design cache stores one copy of every part used in the design. Normally, all instances of the part refer to this copy in the design cache.

An original cache part also retains a link to the library part on which it is based, so you can update all of the parts in the design cache to synchronize them with the parts in the libraries. This action is useful for updating your design if you have made changes to the library the parts came from.

Once you edit a part instance, the link to the original library no longer exists. This means that:

- The part instance is not affected by the Update Cache command.
- To restore its link with the original library, choose the Replace Cache command from the project manager’s Design menu.

By updating all instances of a part, you create a new part that replaces the old part in the design cache, and break the link with the original library. If you update only the currently selected part instance, you create a new part in the design cache for this one part instance, and the new part has no link to the original library.

To replace a design cache part instance with a different library part

1. Open the project containing the part instance you want to replace.
2. Open the design cache and select the part instance you want to replace.

Note: Updating or replacing a part in the design cache affects every instance of the part in the design, as long as the part instances have retained their links to their original libraries.
3 From the Design menu, choose Replace Cache. The Replace Cache dialog box appears.

![Replace Cache dialog box](Figure 63)

The text boxes in the Replace Cache dialog box contain the name of the part instance you are replacing and its original source library.

4 In the Part Name text box, type the exact name of the library part you want to use to replace the selected part instance, using appropriate upper case and lower case letters. (The part names are case sensitive.)

5 Use the Browse button to find the path and filename of the part’s library. Select the library name, and click Open. The path and library name appear in the Part Library text box.

6 Check an action. Preserve properties retains all instance and occurrence properties of the part, bringing in the graphics, pins, package properties from the library. Replace properties brings in graphics, pins, package properties, and user properties from the library, totally replacing the part in the design.

7 Click OK. Capture replaces the part instance you selected in step 2 with the library part you specified in steps 4, 5 and 6.

Tip: You can leave the Part Name and Part Library fields unchanged to update the part instance with its original version. This is useful if you have changed the part instance in the design cache and would like to use its original version, or if you have received an update to a library and want to use the new version of the library part.
To update selected parts in the design cache so they match their corresponding library parts

When you update parts in the cache, any user-defined properties are preserved. The properties associated with the part in the library are updated, including added and removed properties and property values.

1. If it’s not already open, open the project containing the parts you want to update.
2. Open the design cache and select the parts you want to update.
3. From the Design menu, choose Update Cache. Capture warns you that you will update the selected parts with parts from their original libraries.
4. Click Yes. Capture updates the parts you selected in step 2 with their corresponding library parts. Other projects that use these parts are not affected.

Note: User-defined properties include any new property you added to the part in the design as well as the Value, Part Reference, and PCB Footprint.
Chapter 11  About libraries and parts

Primitive and nonprimitive parts

A primitive part contains no hierarchy. A nonprimitive part has an underlying hierarchical description, such as an attached schematic folder. In Capture, this characteristic is defined in a property, called Primitive, on every part instance. When a part is specified as primitive, all of Capture’s tools treat it as such. You cannot descend into a primitive part, even if it has an attached schematic folder. You can change the Primitive property as often as you like during the design process. For example, you might create a part and attach a schematic folder whose schematic pages describe the part’s gates and wiring, then attach schematic folders to some of those parts to describe their transistors.

The following are some guidelines for using the Primitive property:

- Before you create a netlist for simulation, specify the parts as nonprimitive, so that Create Netlist can descend far enough to find the transistor-level descriptions.

- Before you create a netlist for board layout, specify the parts as primitive, so that Create Netlist stops at the gate-level descriptions.

For part instances that have their Primitive property set to Default, you can set them as primitive or nonprimitive on a project-wide basis using the Design Properties command on the Options menu. Choose the Hierarchy tab, select either Primitive or Nonprimitive in the Parts group box, then click OK. This is useful when you are describing and simulating your design at varying levels of abstraction (as when using top-down design).
In Capture you can create parts and add them to a new or existing library. You can also edit existing parts in a library or on a schematic page. All of these processes are described in this chapter.

To create or edit a part, you use the part editor. There are many different ways to access the part editor:

- To create a new part, open a new or existing library in the project manager with the library selected. From the Design menu, choose the New Part command.
- To edit an existing part, open a library in the project manager, then double-click on the part.
- To edit a part instance on a schematic page, select it. From the Edit menu, choose Part.
Parts and packages: homogeneous or heterogeneous

A part may be divided into several logical parts all contained in a single physical package. You can distribute the individual logical parts throughout your project, while maintaining the part’s identity as a single physical part.

Each logical part has graphics, pins, and properties that describe it. If you define a package in which all the logical parts are identical except the pins, the package is homogeneous. For example, a hex inverter is a homogeneous package. If the logical parts vary in graphics, number of pins, or properties, the package is heterogeneous. An example of a heterogeneous package is a relay with a normally open switch, a normally closed switch, and a coil.

Both homogeneous and heterogeneous packages may have shared pins, such as supply pins that are used by every logical part in the package. Often, these pins are invisible, but are connected by name to a power or ground net.
Creating a new part

You can create your own custom parts and save them in a library. A custom part can be a single part, or it can be a package that contains multiple parts. It can contain pins, graphics, text, and IEEE symbols. Graphics must be within the part’s body, while text and IEEE symbols can be either inside or outside the part’s body. Pins are attached to the part at the part body border, which defines the size and shape of the region in which you create the part body.

To create a part, you complete three processes:

- Define the part.
- Draw the part.
- Place pins on the part.

This section describes these processes.

Defining a part

Before you begin drawing a part, you must provide Capture with specific information about the part, such as the part’s name. If the part is a multiple-part package, you can specify how many parts are in the package and whether the part is homogeneous or heterogeneous. Once you provide this information, you can draw the part, place graphics, and place pins.

To define a new part

1. In the project manager, select the library you want to add the new part to.


Note  If you’re creating a multiple-part package, the part editor window contains the first part in the package. If you are creating a homogeneous part, all edits you make to this part (with the exception of changes to pin numbers) apply to all parts in the package. If you are creating a heterogeneous part, edits you make to this part apply to this part only. To edit a different part in the package, choose Next Part or Previous Part from the View menu.

To view all the parts in the package, choose Package from the View menu. You can edit a part by double-clicking on it in the package view.

To view all of the package information, choose Package from the View menu, then choose Properties from the Edit menu. The Package Properties spreadsheet appears, showing the order of the pins, the groups of pins that are swappable, the pin numbers, the pin names, the pin types (normal or convert), and whether the pins are marked as Ignore.
Chapter 12  Creating and editing parts

3 In the Name text box, type a name for the part you are creating. You can use the default settings for the other options on this dialog box, or you can change them to fit your requirements. For example, if this part is a multiple-part package, enter the number of parts in the package. All fields on the New Part Properties dialog box are described later in this section.

4 When the part is specified to your requirements, click OK.

The part editor window appears, showing a dashed outline, which is the part body border. Pins will be placed on the part outside of this region, touching the part body border. The part’s value displays below the part, and the part’s reference displays above the part. The part editor window’s title bar shows the name of the library, followed by the name of the part you are creating.

5 To change the size and shape of the part body border, select the border and drag the selection handles until the part body border is the size you want. You can resize the part body border later.

To draw the part

1 Once you have established the part’s border, you can use the drawing tools on the part editor’s tool palette to draw the part and place text on the part. All graphics that make up the part must fit within the boundaries of the part body border—with the exception of IEEE symbols and text. If you draw or place something other than IEEE symbols or text outside of the part body border, the part’s border expands to encompass the graphics.

Caution  Once you designate the package type as either Homogeneous or Heterogeneous and click OK to close the New Part Properties dialog box, the package type is set, and cannot be changed.

Note  For general information about adding graphics and text, and detailed information about placing IEEE symbols, see Adding graphics, text, and IEEE symbols to a part on page 217. For details about each of the graphic and text tools, see Chapter 8, Adding and editing graphics and text.
To place pins on the part

1. You can add pins to the part using the pin tool or the pin array tool. This is described in Placing pins on a part on page 12-218 later in this chapter.

2. When you are done creating the part, you must save it. From the File menu, choose Save.
   
   If you are creating this part in a new library that hasn’t yet been saved, the Save As dialog box appears, giving you the opportunity to name the library file. If you are creating this part in a library that already exists, the part is saved in that library.
Tip: After you have defined the part in the New Part Properties dialog box, you can edit the part (except for changing the Package Type) using the Edit Part Properties dialog box. From the View menu, choose Package, then from the Options menu, choose Package Properties.

**New Part Properties dialog box**

**Name** The name of the part. This is used as the default part value when the part is placed on a schematic page.

**Part Reference Prefix** Specifies the part reference prefix, such as C for capacitor or R for resistor.

**PCB Footprint** The PCB physical package name to be included for this part in the netlist. Orcad Layout uses this field to place the correct components on the printed circuit board.

**Create Convert View** Some library parts have a second form, such as a DeMorgan equivalent, as well as the standard representation. Select this option to give the part a alternative view. If a part has a convert view, you can switch between the part’s normal and convert views once the part is placed on a schematic page.

**Parts per Pkg** Specifies the number of parts in the package.

Caution: Once you decide if the part has a convert view, and click the OK button to close the dialog box, you cannot add or delete the convert view.

Note: Once the number of parts in a heterogeneous part is set, it cannot be changed.
Creating a new part

Homogeneous or Heterogeneous  If the part is a multiple-part package, this specifies whether all the parts in the package have the same graphical representation (homogeneous) or different graphical representations (heterogeneous).

Alphabetic or Numeric  If the part is a multiple-part package, this specifies whether parts in the package are identified by letter or number. For example:
- U?A (alphabetic)
- U?-1 (numeric—usually used for connectors)

Caution  If you use Alphabetic identifiers, you are limited to 26 parts per package that will use letters. Parts with more than 26 parts will use numbers as identifiers, instead of doubling up the letters, as in AA, AB, and so on.

Part Aliases  Displays a dialog box that you use to add or remove part aliases, which are duplicate copies of parts that use different names in a library. Part aliases use the same graphics, attached schematic folders, and properties as the originals, with the exception of the part values.

Attach Implementation  Displays a dialog box that you can use to attach a schematic folder, VHDL entity, netlist, project, or PSpice model, thus creating a hierarchy.

See Capture’s online help for more information on creating and using heterogeneous parts.

Note  The path and filename of the library that contains the part are displayed at the bottom left corner of the dialog box.

Tip  When you view a list of parts in a library, any parts that are placed via part alias display with lines through their centers.

Caution  An attached schematic folder or other file external to the project or library is not stored with the project or library. If you copy or move the project or library to a new location, you must also move or copy the attached object to keep them together. In addition, you may need to edit the path to the attached schematic folder or file if you move the project to a new location with a different directory structure.
Chapter 12  Creating and editing parts

Attaching a schematic folder to a part

Attaching a schematic folder to a part creates hierarchy in Capture. When you attach a schematic folder to a part, you specify the schematic folder’s name or, optionally, specify a project containing the schematic folder. If you don’t, Capture assumes the schematic folder is contained in the current project. If you attach a schematic folder to a part, you can move or copy the child schematic folder into the same library as the part after the schematic folder is created. This permits the part and attached schematic folder to be reused in other projects. If you specify an attached schematic folder, but the schematic folder has not yet been created, Capture creates the schematic folder when you descend the hierarchy on the part. To descend the hierarchy, you must define the part instance as nonprimitive.

To attach a schematic folder to a part

1  From the project manager’s Design menu, choose New Part with the library selected. The New Part dialog box appears.
   or
   From the part editor’s Options menu, choose Package Properties. The Edit Part Properties dialog box appears.

2  Click the Attach Implementation button. The Attach Implementation dialog box appears.

3  Enter the name of the child schematic folder.
   If the child schematic folder is not in the current project, use the Browse button to locate the project library, design, VHDL, or EDIF file where the schematic folder is located.

4  Click OK twice.
   Or

1  Select a part instance on a schematic page. From the schematic page editor’s Edit menu, choose Properties. The property editor appears.
Creating a new part

2 In the instance’s Implementation Type cell, select the appropriate implementation type.

3 In the instance’s Implementation cell, enter the name of the child schematic folder.
   If the child schematic folder is not in the current project, enter the path and filename of the library, design, VHDL, or EDIF file.

4 Click Apply.

Adding graphics, text, and IEEE symbols to a part

Once you have defined a part, you can draw an outline to reflect the part’s shape, and you can add graphics to add detail to the part. To add graphics to a part, you use the Line, Rectangle, Ellipse, Arc, Polyline, and Picture commands on the Place menu or the corresponding tools on the tool palette. You can also add text to the part using the Text command on the Place menu or the text tool on the tool palette.

A part can include IEEE symbols (shown in the lower right corner). Unlike graphics, IEEE symbols do not have to be within the part’s body.

To place an IEEE symbol

1 From the part editor’s Place menu, choose IEEE Symbol.
   or
   Choose the IEEE symbol tool from the part editor’s tool palette.

2 In the Place IEEE Symbol dialog box, select a symbol from the Symbol list box. The symbol appears in the preview box. When you have selected the symbol you want to place, click OK. The IEEE Symbol dialog box closes.

For details about each of the graphic and text tools, see Chapter 8, Adding and editing graphics and text.

When you place graphics in a part, they must be within the part’s body. If they don’t fit within the part’s body, the part body border expands to enclose the graphics.

Bit map images placed in part bodies create huge print and plot files, and can slow down screen redraws due to the increased volume of data.

Tip Like the schematic page editor, the part editor can display the part you are working on at several levels of detail. Just use the Zoom command on the View menu or the right mouse button pop-up menu.
An image of the IEEE symbol is attached to your pointer. You can press the right mouse button to display a pop-up menu with commands that you can use to change the appearance of the symbol before you place it. You can mirror the symbol horizontally or vertically, rotate the symbol, or choose another IEEE symbol to place.

3 Move the pointer on your part to where you want the symbol and click the left mouse button to place the symbol. You can place multiple instances of the symbol by clicking the left mouse button each place you want the symbol.

4 When you are done placing symbols, choose the selection tool or press Esc to dismiss the IEEE symbol tool.

**Placing pins on a part**

There are several ways you can place pins on a part. You can use the Pin command on the part editor’s Place menu or the pin tool on the tool palette to place individual pins; or you can use the Pin Array command on the Place menu or the pin array tool on the tool palette to place several pins at once.

Pins will always connect to the part body border (the dotted line around the part). If the edge of a part body coincides with this border, pins can connect directly to the part body. However, if the part body is inside this border, you can draw a line between the part body and the pin on the part body border to make the pin look as though it connects to the part body.

**To place a pin**

1 From the part editor’s Place menu, choose Pin.

or

From the part editor’s tool palette, choose the pin tool. The Place Pin dialog box appears with default settings.
2 Change any name, number, shape, or type settings you choose. When the pin is specified to your requirements, click OK.

If you create a power type pin, you have the option to set the pin to visible in the Place Pin dialog box. If you set the pin to visible here, you will not be able to override this pin property setting in the property editor.

To make all pin names or numbers visible or invisible, double-click outside the part in the part editor and set the properties in the User Properties dialog box to true to display them or false to make them invisible.

3 Using the pointer, drag the pin to the desired location along the part body border.

4 Click the left mouse button to place the pin. You can place multiple instances of the pin by clicking the left mouse button each time you want to place an instance of the pin. The pin number and name increment automatically if they end with a number.

5 Choose End Mode from the right mouse button pop-up menu, or press [Esc] when you are finished placing pins.

Tip To place multiple pins that are slightly different, you can click the right mouse button and choose the Edit Properties command.
**Place Pin dialog box**

![Place Pin dialog box](image)

**Name**  
The name of the pin.

If a pin connects to a bus, the pin should be named in the format `busname [range]`, for example `A[0..3]`. You can use two periods (..), a colon (:), or a dash (-) to separate the numbers in the range. Bus pins are expanded into separate pins in a netlist, just as a bus is separated into separate signals.

To enter a pin name with a bar over it (indicating negation), type a backslash character after each letter you want a bar over. For example, type `R\E\S\E\T\` to define the name: `RESET`.

**Number**  
The pin’s number.

**Width**  
If a pin connects to a wire, select Scalar. If a pin connects to a bus, select Bus.

---

**Note**  
Bus pins can only be used for simulation purposes. They will not netlist properly for board layout.

**Tip**  
You can make each part’s pin names visible or invisible. From the part editor’s Options menu, choose Part Properties. When the User Properties dialog box appears, set Pin Names Visible to either True or False.
Creating a new part

**Pin Visible**  This option is only available for power pins. If the check box is selected, the pin is visible when the part is placed on the schematic page. Otherwise, the pin is not visible on the schematic page. If you make power pins visible in this dialog box, you cannot change this property in the property editor.

**Shape**  The shape of the pin, as shown in Table 6.

**Table 6  Pin shapes**

<table>
<thead>
<tr>
<th>Shape</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dot</td>
<td>An inversion bubble.</td>
</tr>
<tr>
<td>Clock</td>
<td>A clock symbol.</td>
</tr>
<tr>
<td>Dot-Clock</td>
<td>A clock symbol with an inversion bubble.</td>
</tr>
<tr>
<td>Zero</td>
<td>A normal pin with a lead zero grid units in length.</td>
</tr>
<tr>
<td>Short</td>
<td>A normal pin with a lead one grid unit in length.</td>
</tr>
<tr>
<td>Line</td>
<td>A normal pin with a lead three grid units in length.</td>
</tr>
</tbody>
</table>

**Type**  The type of the pin, as described in Table 7.

**User Properties**  Displays the User Properties dialog box. You can use this dialog box to define additional properties for the pin.
Chapter 12    Creating and editing parts

Table 7   Pin types

<table>
<thead>
<tr>
<th>Pin type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>3-state</td>
<td>A 3-state pin has three possible states: low, high, and high impedance. In its high impedance state, a 3-state pin looks like an open circuit. For example, the 74LS373 latch has 3-state pins.</td>
</tr>
<tr>
<td>Bidirectional</td>
<td>A bidirectional pin acts as both input and output. For example, pin 2 on the 74LS245 bus transceiver is a bidirectional pin. The value at pin 1 (an input) determines the activity of pin 2, as well as others.</td>
</tr>
<tr>
<td>Input</td>
<td>An input pin is one to which you apply a signal. For example, pins 1 and 2 on the 74LS00 NAND gate are input pins.</td>
</tr>
<tr>
<td>Open collector</td>
<td>An open collector gate omits the collector pull-up. Use an open collector to make “wired-OR” connections between the collectors of several gates and to connect with a single pull-up resistor. For example, pin 1 on the 74LS01 NAND gate is an open collector gate.</td>
</tr>
<tr>
<td>Open emitter</td>
<td>An open emitter gate omits the emitter pull-down. The proper resistance is added externally. ECL logic uses an open emitter gate and is analogous to an open collector gate. For example, the MC10100 has an open emitter gate.</td>
</tr>
<tr>
<td>Output</td>
<td>An output pin is one to which the part applies a signal. For example, pin 3 on the 74LS00 NAND gate is an output pin.</td>
</tr>
<tr>
<td>Passive</td>
<td>A passive pin is typically connected to a passive device. A passive device does not have a source of energy. For example, a resistor lead is a passive pin.</td>
</tr>
<tr>
<td>Power</td>
<td>A power pin expects either supply voltage or ground. For example, on the 74LS00 NAND gate, pin 14 is VCC and pin 7 is GND.</td>
</tr>
</tbody>
</table>

Caution: Power pins set to visible in the library will not be global in nature when the part is placed in a design. You will have to connect these pins to a net. If you want a power pin to be visible on the schematic page and global in nature, set it to invisible in the library. After placing the pin, double-click on the part, and set power pins to be visible.

Note: Power pins that are invisible are not connected using wires and buses, but instead are connected globally via name.
To place several pins at once

1. From the part editor’s Place menu, choose Pin Array. 
   or 
   From the part editor’s tool palette, choose the pin array tool.

   The Place Pin Array dialog box appears. This dialog box is similar to the Place Pin dialog box, with these exceptions:
   - The Starting Name and Starting Number text boxes are used to specify a name and pin number that is incremented for each pin that is placed.
   - The Number of Pins, Increment, and Pin Spacing text boxes are used to specify how the pins are placed.

2. In the Starting Name text box, enter the name of the first pin. If the pin name ends in a digit (0–9), subsequent pin names in the array will be incremented by the value in the Increment text box.

3. In the Starting Number text box, enter the number of the first pin. Subsequent pin numbers will be incremented by the value in the Increment text box (if there is no value in the Increment text box, the pin names are incremented by 1). If you leave the Starting Number text box blank, the pins are not numbered.

4. In the Number of Pins text box, specify how many pins you want to place.

5. In the Increment text box, specify the number by which you want to increment the pin name (if it ends in a digit) and pin number for each pin in the array. If there is no value in the Increment text box, the pin names are incremented by 1.

6. In the Pin Spacing text box, specify the number of grid units you would like between each pin.

7. If necessary, change the default settings for Shape and Type to fit your requirements, then click OK.

Note: Pin name and number only increment if the starting name or number ends with a number. Otherwise, all of the pins in the array have identical names or numbers.

Note: You can specify a negative increment to decrement instead of increment the pin numbers.

Tip: For easy, accurate placement of pins, confine the movement of your cursor to the part body border.
8 Using the pointer, drag the pin array to the desired location along the part body border, then click the left mouse button to place the array. The array is positioned so that the first pin in the array is at the pointer.

9 When you are done placing arrays, choose End Mode from the right mouse button pop-up menu, or press [Esc].

You can place multiple copies of the array by clicking the left mouse button each time you want to place an array. Each time you place the array, the pin names and pin numbers are incremented based on the number of the last pin placed.

If the pin array is longer than the edge of the part body, the part body border expands to accommodate the extra pins.

Once you place an array of pins, you can edit their properties as a group by selecting the pins, then choosing Properties from the Edit menu. This opens the spreadsheet editor, which you can use to edit the information for the pins.
Creating a new part

Place Pin Array dialog box

**Starting Name**  The name of the first pin in the array. If the name ends with a digit (0–9), each pin in the array is incremented by the value specified in the Increment text box.

For a name with a bar over it (indicating negation), type a backslash character after each letter you want a bar over. For example, type R\E\S\E\T\ to define the name:

RESET

**Starting Number**  The number of the first pin in the array. Each pin in the array is incremented by the value specified in the Increment text box.

**Number of Pins**  The number of pins in the array.

**Increment**  The number by which to increment the pin name (if it ends in a digit) and pin number for each pin in the array. This can be a negative number.
**Pin Spacing**  The number of grid units between each pin in the array.

**Shape**  The shape of the pins in the array, as described in Place Pin dialog box on page 12-220.

**Type**  The type of the pins in the array, as described in Place Pin dialog box on page 12-220.

**Pins Visible**  This option is available only for power pins. If this option is selected, the pins are visible when the part is placed on the schematic page. Otherwise, the pins are not visible on the schematic page.

To make power pins visible for documentation purposes, from the Options menu, choose Design Properties. Select the miscellaneous tab of the Design Properties dialog box that appears, and select the check box (Display Invisible Power Pins (for documentation purposes)).
About power and ground pins

Both homogeneous and heterogeneous parts may have shared pins. A common use of shared pins is for supply pins (power or ground), which are referred to in Capture as power pins. Normally, power pins are invisible and global (meaning that they are connected to like-named power objects, power nets, and invisible power pins throughout the design).

Merely displaying an invisible power pin does not change its global nature; however, connecting a wire or other electrical object to a power pin isolates it from the design-wide (global) net. For information on displaying invisible power pins, see Displaying invisible power pins on page 12-228.

On heterogeneous parts, power pins usually do not appear on every part in the package. If you make the power pins visible, you must place them on at least one part in the package, then place that part in the design and connect wires to those pins in order for the power connections to appear in a netlist.

On homogeneous parts, power pins appear on every part in the package. The pin names are filled in automatically, but you must specify the pin numbers. To share the pins, make sure that the pin names and the numbers are the same for every part in the package.

Caution If you connect the same pin on multiple parts in a package, you can inadvertently short two nets. Use care to avoid this, and always run Design Rules Check before creating a netlist.
Displaying invisible power pins

Zero length power pins will only display their names and numbers. There won’t be an obvious point of connection. If you want to wire to a new zero length power pin, be sure snap-to-grid is turned on, and draw the wire to the edge of the border in the middle of the pin name.

If you connect to an invisible power pin that is displayed by this method, the pin is isolated from the design-wide power net. Otherwise, the power pins are global even though Capture displays them.

**Note**  You cannot connect to an invisible power pin that is displayed by this method.

**Note**  Power Pin Visible is one of the properties of your parts that can be turned on or off from inside the property editor.

You can display power pins on individual part instances or throughout a design. Merely displaying invisible power pins on the schematic page does not change their global nature. The method you choose to display power pins determines whether you can connect to them. Invisible power pins are always displayed in the part editor.

**To display invisible power pins on a part instance**

1. In the part editor, select a power pin.
2. From the Edit menu, choose Properties. The Pin Properties dialog box appears.
3. Select the Pin Visible option.
4. Click OK.

**To display invisible power pins throughout a design**

1. From the project manager’s Options menu, choose Design Properties, then choose the Miscellaneous tab.
2. Select the Display Invisible Power Pins (for documentation purposes only) option, then click OK.
Editing an existing part

You can edit an existing part in the library in which it resides, or you can edit a part after it is placed on a schematic page.

Editing a part in a library

Once you edit a part in a library, you can update existing projects with the new part using the Update Cache or Replace Cache commands on the project manager’s Design menu.

To edit a part in a library

1. From the File menu, choose Open. A standard Open dialog box appears.
2. Choose the library containing the part you want to edit. The library opens, showing all its parts.
3. Double-click on the part you want to edit. The selected part appears in the part editor.
4. Edit the part.
   You can resize it, add or delete graphics or symbols, and add or delete pins. These processes are all described in Creating a new part earlier in this chapter. You can also edit the part’s properties. Editing properties is described in Chapter 2, The Capture work environment.
5. When you are done editing the part, you must save it. From the File menu, choose Save. The part is saved in the library.

Tip In the project manager, you can create a new part from an existing part by dragging a copy of the part (press the [Ctrl] key while you drag the part) to a new library and then editing the part.

You can also create an alias of the part by changing to package view in the part editor, choosing Package Properties from the Options menu, then choosing the Part Alias button. Once you create a part alias, you must save the part to have the alias show up in the library. In the library, part aliases display with lines through their part icons.

Tip If you need to know a part’s library of origin, you can select the part in the project manager, then select Replace Cache from the Design menu. The part name and the library and path are listed in the dialog box that appears. Click Cancel to return to the project manager.

Tip You can discover the library of origin for multiple parts by creating a cross reference report.
Chapter 12  Creating and editing parts

Editing a part on a schematic page

Once you edit a part on a schematic page, you can apply the edits to all instances of the same part in the project, or you can apply the edits only to the particular part instance you edit.

Caution  Once you edit a part instance on a schematic page, it is no longer linked to its corresponding library part. In addition, a new part (with _n appended to the original part name) appears in the design cache. This means that you can’t perform an Update Cache on an edited part, since there is no link to the original library.

To edit a part instance on a schematic page

1  Select a part instance on a schematic page.
2  From the Edit menu, choose Part.
   The library part that was used to define the part instance appears in the part editor.
3  Edit the part.
   You can resize it, add graphics or symbols, and add or delete pins. These processes are all described in Creating a new part earlier in this chapter. You can also edit the part’s properties. Editing properties is described in Chapter 2, The Capture work environment.
4  When you are done editing the part, you must close it and save the changes on the schematic page. From the File menu, choose Close.

A dialog box appears asking if you would like to:

- Update only the part instance being edited (Update Current).
- Update all instances of the part in the project (Update All).
- Discard the edits to the part and return to the schematic page editor (Discard).
- Cancel the close operation and return to the part editor to continue making changes to the part (Cancel).
After you choose a response, the part editor window closes. Depending on your response, the change is reflected in the selected part or in all instances of the selected part.

A new part (with \_n appended to the part name) appears in the design cache, indicating that the link to the library part no longer exists.

To display invisible power pins on a part instance

1. In the part editor, select a power pin.
2. From the Edit menu, choose Properties. The Pin Properties dialog box appears.
3. Select the Pin Visible option.
4. Click OK.

Displaying power pins in this manner breaks their global nature. In order for these pins to be included in a netlist, you must wire them into the circuit.

Editing part properties

Use these instructions when you need to edit properties for an individual part. When you need to edit properties for several parts, you can save time by using the spreadsheet editor. For more information, see Editing properties on page 2-29.

Once you’ve added properties to a part on a schematic page, its properties no longer match the properties of the same part residing in the library. This part is unique in that it has properties assigned specifically to it that are not inherited from the library part definition.

If you add a user-defined property to one part in a homogeneous multiple-part package, all parts in the package inherit the property and its value. If you add a user-defined property to one part in a heterogeneous multiple-part package, the other parts in the package are not affected.

For information on adding properties to part instances, see Chapter 2, The Capture work environment.
You can also edit properties on part packages, in which case the changes appear on every part in the package, and on every part instance.

To edit properties of a library part

1. With the part open in the part editor, choose Part Properties from the Options menu. The User Properties dialog box appears.

2. Make your changes in the dialog box and click OK. The changes are reflected in the library, but they are not permanent until you save the part.

**Default part properties**

These are the default properties that are listed in the User Properties dialog box.

**Implementation path** The filename and directory to the child schematic.

**Implementation type** Specifies the implementation type: <none>, Schematic View, VHDL, EDIF, Project.

**Implementation** The name of the child schematic part.
Editing an existing part

**Name**  The name and normal or convert view. This property is read-only.

**Part Reference**  The part reference prefix and the reference designator. The reference designator for parts is a question mark (?), indicating a part reference that is not annotated. The property is read-only.

**Pin Names Rotate**  Specifies whether pin names rotate with the pins. Select True for rotated, False for not rotated.

**Pin Names Visible**  Specifies whether pin names are visible in the schematic page editor. Select True for visible, False for invisible.

**Pin Numbers Visible**  Specifies whether pin numbers are visible in the schematic page editor. Select True for visible, False for invisible.

**Reference**  The part reference prefix. This property is read-only.

**Schematic**  The name of a part’s schematic folder. This property is read-only in the part editor. It is an editable user property on parts in the schematic editor.

**Schematic Library**  The name of a schematic folder’s library. This property is read-only in the part editor. It is an editable user property on parts in the schematic editor.

**Value**  The part value. If this is not specified when you place the part in a schematic folder, Capture uses the part name.

*Note*  You cannot remove a read-only property, but you can make it visible or invisible.
Chapter 12    Creating and editing parts

Viewing parts in a package

For a package containing multiple parts, you can use the Package command on the View menu to view all the parts in the package at once. You can then choose which part in the package to edit. If the package is homogeneous, you can only edit pin names and pin numbers, since each part in a package must have the same graphic representation. If the package is heterogeneous, you can make each part in the package graphically distinct.

To view a package

1. From the part editor’s View menu, choose Package. The package view window (shown below) replaces the part editor window.

Tip When editing a multi-part package, a quick way to move from one part in a package to another is to use the Next Part and Previous Part commands on the View menu.

2. You can move from part to part using the arrow and Tab keys. The current selection is indicated by a thicker black line.

Double-clicking on any of the parts in the package closes the package view window and opens the part in the part editor window.

Figure 68  Part editor in Package View
Editing parts in a package

For a package containing multiple parts, you can use the Package Properties spreadsheet to edit all the pins in a given package in the package at once. If the package is homogeneous, you can only edit pin names and pin numbers, since each part in a package must have the same graphic representation. If the package is heterogeneous, you can make each part in the package graphically distinct. When a normal and convert part are both available, the normal and convert names and types will appear on the spreadsheet.

To edit parts in a package

1. From the part editor’s View menu, choose Package. The package view window replaces the part editor window.
2. From the Edit menu, choose Properties. The Package Properties spreadsheet appears.
3. Edit the pin location, pin order, pin group (for pin swapping), pin number, pin name, pin type, and whether the pin is to be ignored (for shared pins) as needed.
4. After editing pin numbers and names, click the Validate button to assure each pin is unique.
5. Click OK.
Chapter 12  Creating and editing parts

Editing part and package properties in the part editor

When you view a part or part package in the part editor, you can easily edit properties for the part or the entire package.

To edit part properties in the part editor

1. Click on a part in the schematic page editor.
2. From the Edit menu, choose Part. The part appears in the part editor window.
3. Double-click in the window away from the part. The User Properties dialog box appears.

The Display button opens the Display Properties dialog box, in which you can set the display properties of any of the part properties listed. You can apply any of the user properties to individual sections of a part or part package.

To edit package properties in the part editor

1. Click on a part in the schematic page editor.
2. From the Edit menu, choose Part. The part appears in the part editor window.
3. From the View menu, choose Package. All parts in the package appear in the part editor window.
4. Double-click away from the parts in the part editor window to open the Edit Part Properties dialog box.

Or

1. Click on a part in the schematic page editor.
2. From the Edit menu, choose Part. The part appears in the part editor window.

Any changes you make in the Edit Part Properties dialog box apply to the entire package. For more information about the Edit Part Properties dialog box, see Capture’s online help.
3 The Edit Part Properties dialog box appears when you choose Package Properties from the Options menu while in Part view.

![Edit Part Properties dialog box](image)

**Name**  Specifies the part’s name. This is used as the default part value when the part is placed on a schematic page. Part names can be up to 31 characters long.

**Part Reference Prefix**  Specifies the part reference prefix, such as "C" for capacitor or "R" for resistor.

**PCB Footprint**  Specifies the PCB name to be included for this part in the netlist. Contains a value for a device consisting of zero or more pads, other objects, and a name.

**Create Convert View**  Specifies whether the part has a convert. You might use the convert to define a DeMorgan equivalent. A part with this option specified will have two views (a normal and a convert) you can switch between once the part is placed.

**Parts per Pkg**  If there are multiple parts in the package, specifies the number of part in the package.
Chapter 12  Creating and editing parts

**Package Type**  If the part is a package, specifies whether all the parts in the package have the same graphical representation (homogeneous) or different graphical representations (heterogeneous).

The package type can only be set at creation time. These options are not available when you edit the part later.

**Part Numbering**  If the part is a multiple-part package, specifies whether parts in the package are identified by letter or number, such as U?A (alphabetic) or U?1 (numeric).

**Part Aliases**  Displays the Part Aliases dialog box to add or remove aliases. Part aliases show up in a library represented by the part symbol with a horizontal line through the center.

**Attach Implementation**  Displays the Attach Implementation dialog box so you can attach a schematic folder to create hierarchy. You must specify the schematic folder’s name, but you only need to specify the schematic folder’s library or path name if the schematic folder is not in the current project.
Viewing a part’s convert

A convert view is an alternate view of a part. It can be used for things such as a DeMorgan equivalent of a part. If a part has a convert view, you can easily switch between the normal view and convert view in the part editor.

To view a part’s convert

1. From the part editor’s View menu, choose Convert.
2. To go back to the normal view of the part, choose Normal from the View menu.

Note: If you’re editing a part that doesn’t have a convert view, the Convert command is not available.

Note: In the package properties spreadsheet, both normal and convert views of a part are displayed when a convert view exists.
Chapter 12  Creating and editing parts
Part Four
Processing your design

Chapter 13, About the processing tools, provides general guidelines for processing your design and describes when to use Capture’s different processing tools.

Chapter 14, Preparing to create a netlist, describes the tools you use to prepare a design for creating a netlist. It describes the Annotate, Update Properties, Design Rules Check, and Back Annotate tools.

Chapter 15, Creating a netlist, explains how to create a netlist using the Create netlist tool.

Chapter 16, Creating reports, explains how to create reports using the Bill of Materials and Cross Reference tools.

Chapter 17, Exporting and importing schematic data, describes the Export Properties and Import Properties tools used to move data into and out of Capture.

Chapter 18, Generating a part, explains how to create a part and an associated symbol from your FPGA/CPLD.

Chapter 19, Using Capture with Orcad Layout, explains how to perform forward annotation, back annotation, and cross probing using Capture and Layout.
Chapter 20, Using Capture with PSpice, describes intertool communication between Capture and PSpice, and explains how to use this feature to debug your Capture schematic interactively.
A design process typically involves placing and connecting parts in the schematic page editor, then using Capture’s tools to specify how parts are to be packaged and uniquely identified. You add information for simulation, synthesis, board layout, purchasing, or other external functions, then create a netlist and incorporate back annotation information from external applications.

As shown in the figure at right, you use Annotate, Design Rules Check, and Cross Reference to package the parts in your project and to check that there are no invalid conditions. In practice, you might run these tools several times before moving on to the next phase.

You can add properties to parts or pins, or change their values (see The property editor on page 2-34). If you prefer editing in a full-featured spreadsheet or database program, use Export Properties to write data out and Import Properties to read it back in.
Use Create Netlist to convey project information to Layout, PSpice, or Express Simulate. Layout can create a back annotation file detailing packaging changes that are needed because of routing or manufacturing constraints. Use Back Annotate to incorporate this information into your Capture project. Use Bill of Materials to create a list of the parts.

After you do this, you may need to make additional changes to your project, then repeat some or all phases of the design process. In addition, you may want to analyze your project using intertool communication to communicate interactively with Layout for cross probing, with Express Simulate to view signals in Capture as their states change during simulation, or with PSpice to view wave forms.

**Tools overview**

*Note* You won’t be able to use any of these tools to modify a schematic design attached to a hierarchical block if the design is external to the current project.

After you finish placing and connecting parts in the schematic page editor, use the project manager’s Tools menu commands to help you complete the design process.
### Table 8  Capture tools overview

<table>
<thead>
<tr>
<th>Command</th>
<th>Overview</th>
<th>Described in</th>
</tr>
</thead>
<tbody>
<tr>
<td>Annotate</td>
<td>Packages parts by resolving part references and pin numbers, or removes packaging information by resetting part references to their unassigned values.</td>
<td>Chapter 14, Preparing to create a netlist</td>
</tr>
<tr>
<td>Back Annotate</td>
<td>Swaps pins or gates, or changes packaging, based on a swap file created by you or your board layout program.</td>
<td>Chapter 14, Preparing to create a netlist</td>
</tr>
<tr>
<td>Update Properties</td>
<td>Adds properties, or changes the values of properties, based on an update file you create.</td>
<td>Chapter 14, Preparing to create a netlist</td>
</tr>
<tr>
<td>Design Rules Check</td>
<td>Reports and flags violations of electrical rules and other design constraints. Starts by removing existing DRC markers.</td>
<td>Chapter 14, Preparing to create a netlist</td>
</tr>
<tr>
<td>Create Netlist</td>
<td>Creates a file that lists the logical interconnections between signals and pins in one of more than thirty standard formats.</td>
<td>Chapter 15, Creating a netlist</td>
</tr>
<tr>
<td>Cross Reference</td>
<td>Reports the schematic page and location of parts (used in developing or documenting a project).</td>
<td>Chapter 16, Creating reports</td>
</tr>
<tr>
<td>Bill of Materials</td>
<td>Creates a formatted list of electrical and other parts in the project. Optionally adds information, based on an include file you create.</td>
<td>Chapter 16, Creating reports</td>
</tr>
<tr>
<td>Export Properties</td>
<td>Creates a tab-delimited list—for manipulation in a spreadsheet or database program—of properties and values for each part in the project.</td>
<td>Chapter 17, Exporting and importing schematic data</td>
</tr>
</tbody>
</table>
About the processing tools

Chapter 13

Table 8  Capture tools overview

<table>
<thead>
<tr>
<th>Import Properties</th>
<th>Adds properties, or changes the values of properties, based on a tab-delimited list in the format created by the Export Properties command.</th>
<th>Chapter 17, Exporting and importing schematic data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generate Part</td>
<td>Creates a part and an associated symbol that represents your FPGA/CPLD.</td>
<td>Chapter 18, Generating a part</td>
</tr>
</tbody>
</table>

Updating instances and occurrences

Several of Capture’s tools give you the choice of updating instances or occurrences. The type of property you update depends on the type of project in which you are working. Capture automatically selects the preferred updating choice in each of the dialog boxes for Annotate, Update Properties, and Export Properties.

Table 9  Updating instances or occurrences

<table>
<thead>
<tr>
<th>Project type</th>
<th>Update instances</th>
<th>Update occurrences</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCB</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Schematic</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>FPGA</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>PSpice</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>

If you are working within a PCB or Schematic project, then choose to update occurrences when you use the Annotate, Update Properties, and Export Property tools.

If you are working with an FPGA project, or a PSpice project, then choose to update instances with the Annotate, Update Properties, and Export Properties tools.

Back Annotate also updates occurrence properties.

The EDIF 2 0 0, VHDL, and Verilog netlist formats generate true hierarchical netlists. When a design is netlisted with one of these formats, the instance property
values on nets and parts are used. All other netlist formats in Capture produce flat netlists, and use occurrence property values.

The instance property value shines through to the occurrences as long as the occurrence property values have not been edited in any way. When you explicitly edit an occurrence property value, or Capture modifies it via one of the tools, the instance value is overridden by the occurrence value. Only the occurrence value will be placed in the netlist.
Chapter 13  About the processing tools
Preparing to create a netlist

Annotating

After you place parts on a schematic page, all parts need to be uniquely identified using the Annotate command on the project manager’s Tools menu. This tool assigns unique part references to each part in a project. You use Annotate after you’ve placed all parts and before you use other Capture tools. You can annotate incrementally (so that previously assigned part references are not changed), or you can annotate unconditionally, changing all the parts across all the schematic pages processed. Using the Annotate tool, intersheet references can be added to off-page connectors and hierarchical ports. Intersheet references indicate the source and destination of schematic page and schematic symbols in your design.

Caution After you have created a netlist and read it into Layout, if you make further changes to your Capture design, only use the Incremental reference update option in the Annotate dialog box when you annotate. Do not use the Unconditional reference update option.

Note Annotate also assigns individual parts to a multiple-part package, thereby assigning unique pin numbers to each part in a multiple-part package. This process is sometimes called packaging. For more information on controlling packaging in multiple-part packages, see Capture’s online help.
Parts are updated in the order in which they appear on a schematic page, going from left to right and top to bottom, as shown in Figure 70 and Figure 71.

**To annotate**

1. In the project manager, select the schematic pages on which to annotate.
2. From the project manager’s Tools menu, choose Annotate.
   or
   Choose the annotate tool from the toolbar.
   The Annotate dialog box displays.
3. Set the options in this dialog box as necessary. You can specify whether to update the entire project or just the schematic pages selected in the project manager, whether to update the part references that haven’t yet been updated, update all part references, or reset part references so that they have question marks in their names. These options are described in the section *Annotate dialog box*.
4. When the Annotate dialog box has the settings you want, click OK to begin the update.

---

**Note**  Parts must be set to primitive in order for Capture to annotate them. You can set the primitivity of parts individually, or globally in the Hierarchy tab of the Design Properties dialog box. Choose Design Properties from the Options menu to display this dialog box.
Annotate dialog box

Scope  Specifies whether to update all the part references in the design or just those on the selected schematic pages.
Chapter 14  Preparing to create a netlist

**Action**  Specifies the action to be taken on reference designators or intersheet references in the selected schematic pages. Designs can be annotated unconditionally (affecting currently annotated parts), annotated incrementally (affecting only unannotated parts), or have all annotations reset. Intersheet references can either be added to or removed. Only one action can be specified at a time.

**Mode**  Specifies whether to update the instance properties of the parts or nets, or occurrence properties of the parts or nets. The preferred mode is set automatically by Capture, and depends on the type of project you are using.

**Physical Packaging**  Specifies the properties that must match for Capture to group parts in a single package. See Capture’s online help for information on how the Annotate tool packages individual parts into multiple-part packages, as well as information about combined property strings.

**Reset reference numbers to begin at 1 in each schematic**  If this option is selected, Capture numbers part references beginning with 1 in each schematic folder. If you don’t instruct Capture to begin the reference numbers at 1, it looks at the selected schematic pages, finds the highest part reference number, and begins numbering from that number.

**Do not change the page number**  The schematic pages are renumbered during annotation, based on their order in the project manager. If you select this option, the pages are not renumbered.

---

**Caution**  This can result in duplicate reference numbers if the highest numbered part for each reference prefix is not represented in the schematic pages you have selected. If you suspect you have duplicate reference numbers, run Design Rules Check before you attempt to create a netlist.

**Tip**  The properties that contain the page number (Page Number and Page Count) are part of the title block. If you create a custom title block, you can give it these two properties, so that they are updated when you run Annotate.
Updating properties

If you need to edit the properties for a few parts or nets, you can do so in the schematic page editor. If, however, you want to make the same changes to a number of parts or nets, in a number of different designs, the Update Properties tool is much quicker and easier than hand-editing each property you’d like to change. You can use Update Properties to edit any properties except part reference, net name, and net ID.

You can also use Update Properties to add properties. In essence, it is a search-and-add-or-replace tool.

To update properties, you create a file, called an update file, with one line for each part or net to change. The leftmost column identifies the part or net (by specifying the property value to match), and the remaining columns provide the new property value. The format of the update file is described in Update file format on page 14-255.

To update part or net properties

1 Using a text editor, create an update file, as described in Property Update File on page 14-254.

2 To process only part of your design, select the pages to process in the project manager.

3 From the project manager’s Tools menu, choose Update Properties.

   The Update Properties dialog box displays.

4 Set the options in this dialog box as necessary. You can specify whether to process the entire project or just the schematic pages selected in the project manager, and whether to update parts or nets. You can customize your update further by specifying that your comparison and update strings be converted to uppercase. You can also have Capture create a report file listing the properties that it changes. You must specify the name of the update file containing the properties to match and the text to place in the
specified properties. These options and others are described in the section Update Properties dialog box.

5 Click the Browse button to the right of the Property Update File text box to locate your update file.

6 When the dialog box has the settings you want, click OK. Capture updates the properties you specified. If you set up the dialog box to create a report file, you can use a text editor to view the file when the Update Properties tool is done.
**Update Properties dialog box**

**Scope**  Specifies whether to process the project or what is selected.

**Mode**  Specifies whether to update the instance properties of the parts or nets, or occurrence properties of the parts or nets. The preferred mode is set automatically by Capture, and depends on the type of project you are using.

**Update parts or Update nets**  Specifies whether to update the properties of parts or nets.

**Use case insensitive compares**  Matches the combined property string with update properties without regards to case sensitivity.
Chapter 14  Preparing to create a netlist

Convert the update property to uppercase
Converts the update property to uppercase before it is placed in an object’s property.

Unconditionally update the property  By default, a property is updated only if it is empty: properties with values are not updated. If this option is selected, the specified property is changed, regardless of whether it’s empty.

Do not change updated properties visibility
Specifies that the visibility of the updated properties is not changed.

Make the updated property visible/ invisible
Specifies that the updated property is to be made visible or invisible. Instance properties can be changed, but the visibility of occurrence properties cannot be changed.

Create a report file  Specifies whether or not Capture creates a report file. If you select this option, enter the name of the report file in the Report File text box.

Report File  Specifies a report filename and path, if the Create a report file option is selected.

Property Update File  The name of the update file containing the properties to match, the properties to update, and the values to use to update the properties. Update Part Properties looks for a file with an extension of .UPD, but any file extension can be specified.
Update file format

The update file is an ASCII text file that you create to specify the properties to match, the properties to update, and the values to use to update the properties. The file can include comments—any text to the right of a semicolon is ignored by the Update Properties tool.

The first line of the update file has this format:

```
CombinedPropString PropToUpdate1 PropToUpdate2 ...
```

The first field is a combined property string specifying which properties to combine into a match string (note that property names in a property string must be enclosed in braces). The remaining fields in the first line are the properties to update on each part or net. The combined property string and the property names entered in these fields must be enclosed in quotation marks.

Subsequent lines of the update file have this format:

```
MatchString1 Update1 Update2 ...
MatchString2 Update1 Update2 ...
```

The match string is compared with the values of the properties specified by the combined property string in the first line. The update fields are the values to place in the properties specified in the first line, if the match string matches the expanded combined property string. These values must also be enclosed in quotation marks. For example:

```
"{Value}" "PCB Footprint"
"74LS00" "14DIP300"
"74LS138" "16DIP300"
"74LS163" "16DIP300"
"8259A" "28DIP600"
```

This shows that for every object whose Value property matches the string listed in the first column, the object’s PCB Footprint property is updated with the string in the right column. In this example, each time a part has a value of 74LS00, the part’s PCB Footprint property value is changed to 14DIP300; each time a part has a Value of 74LS138, the part’s PCB Footprint property value becomes 16DIP300, and so on.

You can also use Import Properties and Export Properties on the Tools menu, or use Capture CIS, to make changes.
Chapter 14  Preparing to create a netlist

Checking for design rules violations

Caution  You should ALWAYS run Design Rules Check before you create a netlist.

Note  When Design Rules Check checks for unconnected nets, it looks for nets with less than two connection points. Thus, a net can still have unconnected endpoints (dangling endpoints) that aren’t reported by Design Rules Check.

The Design Rules Check tool scans schematic designs and checks for conformance to basic design and electrical rules. The results of this check are marked on the schematic pages with DRC markers, and are also listed in a report. This makes it easy to locate and fix design or electrical errors. You can search for DRC markers using the Browse command on the project manager’s Edit menu, and then double-click on any item in the resulting list to go immediately to the location of the marker on your schematic page. Once you are viewing the marker on the schematic page, you can display the marker’s text by double-clicking on it.

You can specify the conditions that cause errors to be generated. Optional checks performed by the Design Rules Check tool include off-grid parts; unconnected nets, pins, ports, and off-page connectors; identical part references; type mismatch parts; and design elements that are not compatible with Orcad’s Schematic Design Tools (SDT 386+) product.

The Design Rules Check is helpful in preparing your project for use with other tools. For example, you can use the Design Rules Check tool to catch problems such as bus contention or shorted power pins before you generate a netlist to be used by simulation or synthesis tools.

The Design Rules Check reports two categories of electrical rules violations:

- Errors that should be fixed.
- Warnings of situations that may or may not be acceptable in your project.
You can control whether electrical rules violations are reported as errors or warnings in the ERC Matrix tab of the Design Rules Check dialog box. Errors are always marked with DRC markers on the schematic page. Warnings are also marked with DRC markers if you select the Create DRC markers for warnings option in the Design Rules Check dialog box. In the report generated by Design Rules Check, however, the problems are categorized as WARNING or ERROR so that you can immediately identify the more critical problems.

Once the Design Rules Check begins, it first removes existing DRC markers from the schematic pages being processed. This means that each time you run this process, the error markers on your schematic pages reflect the current state of your project. You can also use the Design Rules Check tool to remove DRC markers from schematic pages, but not do any further checking. Just select the Delete existing DRC markers option on the Design Rules Check dialog box.

To check for design rules violations

1. In the project manager, select the schematic pages that you want to check for design rules violations.
2. From the project manager’s Tools menu, choose Design Rules Check.
   or Choose the design rules check tool from the toolbar.
   The Design Rules Check dialog box appears.
3. Select the settings you want in the Design Rules Check tab and in the ERC Matrix tab. For information about the settings in these tabs, see Design Rules Check dialog box, Design Rules Check tab on page 14-259 and Design Rules Check dialog box, ERC Matrix tab on page 14-262.
4. When both tabs of the Design Rules Check dialog box have the settings you want, click OK.

Note If you run a Design Rules Check on a single schematic page, Capture checks all pages in the entire schematic folder---not just the page you have selected---which ensures that all nets on the schematic page are valid.

If you select the Check hierarchical port connections option, Capture also checks the attached schematic folders.
Chapter 14  Preparing to create a netlist

As Capture checks your project, it displays status information about the check. If you stop the design rules check midstream (by choosing the Cancel button in the status information dialog box), the schematic pages that have already been processed will have DRC markers marking any error situations that were encountered.

Once the design rules check is complete, there are three ways to view the results:

- You can double-click on the file in the project manager to bring it up in the text editor.
- You can open the DRC report file by using a text editor or word processor. This file has a default extension of .DRC. The session log also contains the same information.
- You can use the Browse command on the project manager’s Edit menu to display a list of all DRC markers in the project.

This list gives information about each error and warning. Each DRC marker on a schematic page displays this same information. Once this list displays in the browse window, you can double-click on an item to go directly to it on its schematic page. Once you are viewing the marker on the schematic page, you can display the marker’s text by double-clicking on it. You can also use the schematic page editor’s Find command to find specific DRC markers. To do this, you must enter the text associated with the marker.

Tip. To view the information contained in a DRC report with an external text editor or word processor, set up a file association using the Open With dialog box in Windows Explorer. By doing this, you can open the DRC report by double-clicking on it in Windows Explorer.
Checking for design rules violations

Design Rules Check dialog box, Design Rules Check tab

The Design Rules Check tab contains options for things to include in the report generated by Design Rules Check. You can specify if you want to create DRC markers on the selected schematic pages for both errors and warnings, create DRC markers just for errors, or delete existing DRC markers instead of adding new ones. Note that if you select the option to delete existing DRC markers, the options that customize the DRC report become dimmed and aren’t available for selection.

![Design Rules Check dialog box](image)

**Figure 74** Design Rules Check tab of the Design Rules Check dialog box

**Scope** Specifies whether to process the entire project or just the selected schematic page or pages.

**Note** If you run a Design Rules Check on a single schematic page, Capture checks all pages in the entire schematic folder. Select the Check hierarchical port connections option to check the attached schematic folders.
**Mode**  Specifies whether to update the instance properties of the parts or nets, or occurrence properties of the parts or nets. The preferred mode is set automatically by Capture, and depends on the type of project you are using.

**Action**  Specifies whether to check for design rules violations or just delete existing DRC markers. Note that if you select the Check design rules option, Capture deletes existing DRC markers before it begins the design rules check.

**Report**  All the remaining options on the dialog box are report options, and leave messages and reports in the session log. Selected report options are also included in the specified report file.

**Create DRC markers for warnings**  Design Rules Check always places DRC markers on the schematic page for errors defined in the ERC Matrix tab. If you select this option, it also places DRC symbols on the schematic page for warnings defined in the ERC Matrix tab.

**Check hierarchical port connections**  Verifies that hierarchical pins on schematic pages in the parent schematic folder match hierarchical ports on schematic pages in the child schematic folder. Errors are generated if a hierarchical pin specified on a schematic page in a parent schematic folder doesn’t have a corresponding hierarchical port *with an identical name* on a schematic page in the child schematic folder; if the number of hierarchical pins and hierarchical ports are different between the parent and child schematic folders; and if the type of the hierarchical pins and hierarchical ports doesn’t match.

**Check off-page connector connections**  Verifies that off-page connector names on a schematic page match those on other schematic pages.
**Check unconnected nets**  Checks for these conditions: nets that aren’t connected to at least two pins or hierarchical ports; nets that don’t have a driving signal; and two nets with the same name in a schematic folder, but no off-page connector or hierarchical port to connect them.

**Check SDT compatibility**  Checks for compatibility with Orcad’s SDT product in case you plan on saving the project in SDT format. See Capture’s online help for information about the rules you should follow if you are planning to use a Capture project in SDT.

**Report identical part references**  Checks for unique part references, and reports parts that use the same part reference. For example, Capture considers two U1’s to be identical, two U1A’s to be identical, and U1 and U1A to be identical.

**Report invalid packaging**  Reports parts that are packaged into the same physical package, but whose package properties conflict (primarily source package and PCB footprint).

**Report hierarchical ports and off-page connectors**  In the report file, lists all hierarchical ports and off-page connectors.

**Report off-grid objects**  In the report file, lists the names and locations of objects that are off grid.

**Report all net names**  In the report file, lists the names of all nets. If a net is attached to another net of a different name, then this option will report the alternative net name as well.

**Tip**  Report all net names can be used to locate nets that have been inadvertently shorted to other nets.
Chapter 14    Preparing to create a netlist

Report File  The name of the report file containing the information prepared by Design Rules Check. This file usually has an extension of .DRC. For an example of the report generated by the Design Rules Check tool, see Sample Design Rules Check report on page 14-263.

View Output  Specifies to view the result of the DRC check in a text editor.

Design Rules Check dialog box, ERC Matrix tab

Tip  You can also type W for warning, E for error and N for an empty intersection. In addition, you can use the arrow keys to select other intersections.

Figure 75  ERC tab of the Design Rules Check dialog box

You use the ERC matrix to set the electrical rules that Design Rules Check uses when testing connections between pins, hierarchical ports, and off-page connectors. All types of pins, hierarchical ports, and off-page connectors are listed in the columns and rows in the table. A test is represented by the intersection of a row and
column. Either the intersection is empty, or it contains a W, or it contains an E.

- An empty intersection represents a valid connection, in which case nothing is reported if you specify a report file.
- A W represents a warning.
- An E represents an error.

You can cycle through these settings by pointing to an intersection and clicking the mouse button until the desired setting appears. For all rows except the Unconnected row, the DRC reports an error or warning for any net that has two connections as specified in the ERC matrix. For example, consider the dialog box above. If a net has an output pin and a bidirectional pin, a warning is issued based on the W in the intersection of the Output row and the Bidirectional column. For the Unconnected row, the DRC checks to see if the specified pin or port type is unconnected.

**Sample Design Rules Check report**

******************************************************************************
*  Design Rules Check
******************************************************************************

Checking for Invalid Pins in Package

ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/UIC/9 Nets: "N00035_178" and "N00035". : EX6B, EX6B.SCH (5.20, 2.50)

ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/UIC/10 Nets: "N00037_179" and "N00037". : EX6B, EX6B.SCH (5.20, 2.70)

ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/UIC/8 Nets: "N00013" and "SUM". : EX6B, EX6B.SCH (6.40, 2.60)

ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U2D/9 Nets: "Y" and "N00013". : EX6B, EX6B.SCH (4.00, 3.10)

ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U2D/8 Nets: "N5056796111_183" and "N5056796111". : EX6B, EX6B.SCH (4.00, 2.10)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U2C/5 Nets: 'X' and 'CARRY_IN'. : EX6B, EX6B.SCH (3.50, 1.90)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U2C/6 Nets: 'X_BAR_177' and 'X_BAR'. : EX6B, EX6B.SCH (3.50, 2.90)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U3D/12 Nets: 'X' and 'CARRY_IN'. : EX6B, EX6B.SCH (4.00, 1.90)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U3D/13 Nets: 'N5056796111_183' and 'N5056796111'. : EX6B, EX6B.SCH (4.00, 2.10)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U3D/11 Nets: 'N00035_178' and 'N00035'. : EX6B, EX6B.SCH (5.20, 2.00)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U4B/4 Nets: 'Y' and 'N00013'. : EX6B, EX6B.SCH (5.20, 3.80)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U4B/5 Nets: 'X' and 'CARRY_IN'. : EX6B, EX6B.SCH (5.20, 4.00)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U4B/6 Nets: 'N00025' and 'N00015'. : EX6B, EX6B.SCH (6.40, 3.90)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U4A/1 Nets: 'Y' and 'N00013'. : EX6B, EX6B.SCH (4.00, 3.10)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U4A/2 Nets: 'X_BAR_177' and 'X_BAR'. : EX6B, EX6B.SCH (4.00, 3.30)
ERROR [DRC0031] Same Pin Number connected to more than one net. halfadd_B/U4A/3 Nets: 'N00037_179' and 'N00037'. : EX6B, EX6B.SCH (5.20, 3.20)

Checking Schematic: halfadd_A EX6B

Checking Electrical Rules
Checking for Invalid References
Checking for Duplicate References

Checking Schematic: halfadd_B EX6B

Checking Electrical Rules
Checking for Invalid References
Checking for Duplicate References
Checking for design rules violations

[DRC0010] Duplicate reference halfadd_B/U2C: EX6B, EX6B.SCH (3.30, 2.20)
[DRC0010] Duplicate reference halfadd_B/U2D: EX6B, EX6B.SCH (3.80, 2.40)
[DRC0010] Duplicate reference halfadd_B/U3D: EX6B, EX6B.SCH (4.30, 1.80)
[DRC0010] Duplicate reference halfadd_B/U4A: EX6B, EX6B.SCH (4.30, 3.00)
[DRC0010] Duplicate reference halfadd_B/U4B: EX6B, EX6B.SCH (5.50, 3.70)
[DRC0010] Duplicate reference halfadd_B/U1C: EX6B, EX6B.SCH (5.50, 2.40)

--------------------------------------------------
Checking Schematic: FULLADD
--------------------------------------------------
Checking Electrical Rules
Checking for Invalid References
Checking for Duplicate References
Chapter 14  Preparing to create a netlist

Back annotating

Using Back Annotate, you can import changes created by external tools, such as a PCB layout application. Capture uses a simple file format (see Swap file format on page 14-269) to allow gate swapping, pin swapping, changing pins, and changing part references. If the external tool creates a back annotation file, edit the file to match the format described in Swap file format in this section. Back Annotate only updates occurrence property values.

When should you use Back Annotate? After you’ve completed your schematic design, or while you are routing a printed circuit board, you might discover that you can reduce via count, track length, or routing complexity by exchanging two gates of one part. You would use the PCB layout tool to rewire the board to exchange (or swap) the connections of U1A and U1B. To ensure that your project reflects the rewired board, you create a swap file using the PCB layout tool and then run Capture’s Back Annotate. When you look at the schematic page, you will see that U1A is where U1B was before, and vice versa.

To back annotate

1. Generally, a swap (or back annotation) file is created by another application such as Orcad Layout. Alternatively, you can create a back annotation file using a text editor, following the format described in Swap file format later in this section.

2. To process only part of your project, select the pages to process in the project manager.

3. From the project manager’s Tools menu, choose Back Annotate.

or

Choose the Back Annotate tool from the toolbar.

The Back Annotate dialog box appears.

Note: The Back Annotate tool passes through all the parts, pins, and nets of the design once. As each is encountered, a search is made in the swap file for a match. When a match is found, the part, pin, or net property is updated.
4 Set the options in this dialog box as necessary. You can specify whether to process the entire project or just the selected schematic pages. You can also specify the name of the swap file containing the gates and pins to swap. These options are described in the section Back Annotate dialog box.

5 Use the Browse button to locate the current back annotation file. The Browse dialog box looks for a file with an extension of .SWP, but any file extension can be specified.

6 When the dialog box has the settings you want, click OK. Capture swaps the gates and pins you specified.
Chapter 14  Preparing to create a netlist

Back Annotate dialog box

Scope  Specifies whether to process the entire project or just the selected schematic page or pages.

Mode  Specifies whether to update the instance properties of the parts or nets, or occurrence properties of the parts or nets. The preferred mode is set automatically by Capture, and depends on the type of project you are using.

Back Annotation File  Specifies the swap file. For more information, see Swap file format.
Swap file format

A swap file is an ASCII text file containing old and new part references. A swap file is typically created by another application, such as Orcad Layout. You can also create a swap (.SWP) file using a text editor that can save the file in ASCII format. The file can include comments; any text to the right of a semicolon is ignored by the Back Annotate tool. Each line in a swap file, unless preceded by a semicolon, causes one action. The elements of each line may be separated with any number of space or tab characters. In general, the first element of the line specifies the type of swap. If no swap type is specified, CHANGEREF is assumed. The other swap types are GATESWAP, PINSWAP, and CHANGEPIN.

The following example illustrates a swap file. The comments to the right of the semicolons describe what the swap file will do.

CHANGEREF U1 U2 ;Change part reference U1 to U2
U1C U2C ;Change part reference U1C to U2C
GATESWAP U1 U2 ;Swap parts U1 and U2
GATESWAP U1A U1B ;Swap gates UA and U1B
CHANGEPIN U7 1 2 ;Change pin 1 to pin 2
CHANGEPIN U7 2 1 ;Change pin 2 to pin 1
CHANGEPIN U5B "D0" "D1" ;Change pin named D0 to D1
CHANGEPIN U5B "D1" "D0" ;Change pin named D1 to Do

Note that there are two CHANGEPIN commands for each pin swap. If you entered just one line to change pins, for example:

CHANGEPIN U7 1 2

The original pin 1 is changed to pin 2; however, if you already have a pin 2, you will end up with two of them, unless you change the original pin 2 to something else. For this reason, a second line is needed to go with the first line. The complete command lines needed to perform a pin swap between pins 1 and 2 are:

CHANGEPIN U7 1 2
CHANGEPIN U7 2 1

Note: Orcad Layout creates a combined swap and update file. See Capture's online help for more information on creating a combined swap and update file.

Note: Swap files created by Orcad’s PCB 386+ are was/is files. These files contain no keyword identifiers; therefore, each line is assumed to be a CHANGEREF instruction. In the swap file example above, the line without a keyword identifier (the second line) is an example of how changes are specified in a was/is file generated by PCB 386+.
With the exception of the PINSWAP command, the commands in a swap file are was/is based. That is, the commands specify what the original values were and what the new values will be. For this reason, unlike some board layout programs, you cannot specify intermediate steps for the commands, except for PINSWAP.

The PINSWAP command works off the present state of the pin. For this reason, you can perform intermediate steps, such as:

```
PINSWAP U1 1 2 ;First swap
PINSWAP U1 2 3 ;Second swap
```

After both lines of the example above are processed, what was pin 1 is now pin 2, what was pin 2 is now pin 1, and what was pin 3 is now pin 2. The series of changes is shown in the following figure.

For PINSWAP and CHANGEPIN, the part reference must be specified in the swap file, as well as the old and new values. Pin swaps are limited to pins of the same type and shape on the same part. For example, you can swap pins on U5B, but you cannot swap a pin on U5B with a pin on U5C.

```
GATESWAP U1C U2B; Swap gates U1C and U2B
```
Creating a netlist

After you create a project, you can create a netlist to exchange schematic information with other EDA tools. You can choose from more than 30 industry-recognized netlist formats. Your choice of netlist depends on the destination application.

Using the Create Netlist tool

Before you create a netlist, be sure your project is complete, has been annotated (using Capture’s Annotate command), and is free from electrical rule violations. Chapter 14, Preparing to create a netlist, describes how to use Capture’s tools to prepare your design before you create a netlist.

To create a netlist

1. In the project manager, select your design.

For information on creating a Capture netlist for use with Layout, see Chapter 19, Using Capture with Orcad Layout.
Chapter 15  Creating a netlist

2 From the Tools menu, choose Create Netlist. The Create Netlist dialog box displays.

![Create Netlist dialog box](image)

**Figure 77  Create Netlist dialog box**

3 Choose a netlist format tab.

4 In the Netlist File text box, enter a name for the output file. If the selected format creates an additional file (such as a map file or pinlist file), enter its filename in the second text box.

5 If necessary, set the Part Value and PCB Footprint combined property strings to reflect the information you want in the netlist.

6 If necessary, set the format-specific options in the Options group box, and click OK to close the Netlist Options dialog box.

7 Click OK to create the netlist.
Netlist format files

Capture includes over 30 netlist format file types. They include:

Table 10  Netlist format file types

<table>
<thead>
<tr>
<th>Accel</th>
<th>Algorex</th>
<th>Allegro</th>
</tr>
</thead>
<tbody>
<tr>
<td>AlteraADF</td>
<td>AppliconBRAVO</td>
<td>AppliconLEAP</td>
</tr>
<tr>
<td>Cadnetix</td>
<td>Calay</td>
<td>Calay 90</td>
</tr>
<tr>
<td>Case</td>
<td>CBDS</td>
<td>ComputerVision</td>
</tr>
<tr>
<td>DUMP</td>
<td>EDIF (flat)</td>
<td>EDIF 2 0 0 (hierarchical)</td>
</tr>
<tr>
<td>EEDESIGNER</td>
<td>FutureNet</td>
<td>HiLo</td>
</tr>
<tr>
<td>INF</td>
<td>IntelADF</td>
<td>Intergraph</td>
</tr>
<tr>
<td>Layout</td>
<td>Mentor</td>
<td>MultiWire</td>
</tr>
<tr>
<td>OHDL</td>
<td>PADS 2000</td>
<td>PADSPCB</td>
</tr>
<tr>
<td>PCAD</td>
<td>PCADnlt</td>
<td>PCBII</td>
</tr>
<tr>
<td>PDUMP</td>
<td>PLDNet</td>
<td>ProteI2</td>
</tr>
<tr>
<td>PSpice</td>
<td>RacalRedac</td>
<td>RINF</td>
</tr>
<tr>
<td>Scicards</td>
<td>SPICE</td>
<td>Tango</td>
</tr>
<tr>
<td>Telesis</td>
<td>Vectron</td>
<td>Verilog</td>
</tr>
<tr>
<td>VHDL</td>
<td>VST Model</td>
<td>WinBoard</td>
</tr>
</tbody>
</table>

For information about the characteristics, formatting options, and an example of each netlist format, see Capture’s online help.
Netname resolution

In your schematic designs, you can assign a variety of netnames and aliases to signals that are connected. A netlist, however, needs exactly one name for each net.

If the Create Netlist tool encounters multiple names for a single net, higher priority netnames override lower priority netnames. Priority is determined by the source of the name, ranked from highest to lowest, as follows:

- Named nets
- Hierarchical port names
- Off-page connectors
- Power object names
- Aliases
- System-generated names

If there are any conflicts at any level of the comparison (if, for example, there are two power objects on a bus), they are resolved according to these rules:

- Between netnames of equal precedence, priority follows alphabetical order.
- If the net is a bus, the net alias assigned to the greatest number of bus members has highest priority.

A net may change names several times as Create Netlist works. For example, a net may start with an alias of Battery on one page, become ToBattery from an off-page connector, change again to become DC as a hierarchical port is encountered, and finally change to BatteryBackup when Create Netlist finds a named net with higher priority.

**Note** If you have connected two power symbols, like +5V and Vcc, together with a wire, the netlist will show +5V because its name comes before Vcc alphabetically.
Capture provides two report tools that you can use to produce lists of the things contained in your project: Bill of Materials and Cross Reference.

### Creating a bill of materials

You can use the Bill of Materials command from the project manager’s Tools menu to create a bill of materials in a file which you can then print using a word processor or text editor. The bill of materials includes the properties item, quantity, reference, and part value. You can customize the report to include other properties.

**To create a bill of materials**

1. If desired, use a text editor to create an include file, as described in [Include file format on page 16-279](#).

**Tip** A bill of materials includes parts that don’t have pins. This makes it possible to include non-electrical parts such as screws, washers, and other hardware that you may have in your project. These parts won’t, however, appear in a netlist because they don’t have pins.
Chapter 16    Creating reports

2 From the project manager’s Tools menu, choose Bill of Materials. The Bill of Materials dialog box displays.

3 Fill in this dialog box as desired. If you want to customize the information contained in the bill of materials report, fill in the information in the Line Item Definition area. If you are using an include file, be sure to check the Merge an include file with report check box, enter the combined property string, and specify the name of the include file.

4 Click OK when you are ready to create the report.

5 After the bill of materials is generated, you can double-click on its name in the Output folder in the project manager to view it in the text editor. The best way to view a bill of materials is to open it in a spreadsheet program such as Microsoft Excel.
Creating a bill of materials

**Bill of Materials dialog box**

**Scope**  Processes the entire design or selected schematic pages.

**Mode**  Specifies whether to update the instance properties of the parts or nets, or occurrence properties of the parts or nets. The preferred mode is set automatically by Capture, and depends on the type of project you are using.

**Header**  Text placed at the top of the first page. If this text box is left blank, there is no header on the first page. You can use this to specify column headers to match the data reported as defined by the combined property string. If you want the header items separated by tabs, use the \t
character sequence in the header text box, then insert corresponding tabs in the Combined property string text box.

**Note** If your include file uses the value property as the match string, then you only need `{value}` in this combined property string.

**Combined property string** Specifies which properties are included in or excluded from the bill of materials, and formats the output according to the tabs you insert and the order in which you specify the properties. When you specify the combined property string, you enclose property names in curly braces. When the Bill Of Materials is run, the properties in the curly braces are substituted with property values for the part (or left empty if the property is empty or doesn’t exist on the part). The properties are left justified and separated by the characters you type outside the curly brackets. To insert a tab, use `\t`.

```
{Reference}\t{Value}
```

prints a part’s reference, a tab character, and the part’s value.

**Place each part entry on a separate line** Select this item if you want each part to be listed on a separate line.

**Merge an include file with report** Select this item if you want to use an include file.

**Combined property string** Specify the property to use to match the property value specified in quotes on each line of the include file. This is the search string, and is compared with match strings specified in the include file.

**Report File** The name of the file to contain the bill of materials report.
Include file format

You can use an include file to have Bill of Materials add additional information to each line of the bill of materials. You create an include (.INC) file using any text editor that saves files in ASCII format.

The first line of an include file is a header. The bill of materials is always keyed to the part value, so the first line begins with a pair of single quotes with no spaces or other characters between them. The rest of the first line contains any information you want to include to make the file and the bill of materials more readable—this usually consists of headers for the values in the rest of the file. If the include file has combined property strings separated by spaces, then the properties you specify in curly braces have to be separated with spaces also.

The rest of the file contains a separate line for each part. Each line must begin with the property value (as specified in the Include File Combined property string in the Bill of Materials dialog box) enclosed in single quotes. This is the match string, and is compared with the search string specified in the Include File combined property string in the Bill of Materials dialog box. Following the property value (and on the same line) is the information that you want to add to the bill of materials. You can separate the part value from the additional information by any number of spaces or tab characters—Capture will align the first nonblank character in each line when it creates the bill of materials.

The following example illustrates an include file.

```
" DESCRIPTIONPART ORDER CODE
"1K" Resistor 1/4 Watt 5% 1000011003
"4.7K" Resistor 1/4 Watt 5% 1000014703
"22K" Resistor 1/4 Watt 5% 1000012204
"1uF" Capacitor Ceramic Disk 1000211006
".1uF" Capacitor Ceramic Disk 1000211007
```

Tip You can use an include file from Orcad’s Schematic Design Tools (SDT 386+) without modifying it.
In the example above, the first column contains the match strings. If a match string matches the Include File Combined property string for the current part, the rest of the line (in the example above, the second and third columns) is tacked on to the end of the line item in the bill of materials.

To get a property formatted bill of materials using the sample include file, enter \{value\} in the include file match string and add \t to the end of the Header and Line Item combined property string.

Creating a cross reference report

The Cross Reference tool creates a report of all parts with their part references and part names. You may specify that the report also give the coordinates of each part.

**To create a cross reference report**

1. From the project manager’s Tools menu, choose Cross Reference. The Cross Reference Parts dialog box displays.
2. Fill in this dialog box as desired. If you want to customize the information contained in the cross reference report, fill in the information in the Report area.
3. Click OK when you are ready to create the report.
Cross Reference Parts dialog box

- **Scope**  Specifies whether to process the entire design or just the selected schematic page or pages.

- **Mode**  Specifies whether to update the instance properties of the parts or nets, or occurrence properties of the parts or nets. The preferred mode is set automatically by Capture, and depends on the type of project you are using.

- **Sorting**  Specifies whether to sort output by part value or part reference.

- **Report the X and Y coordinates of all parts**  If you check this option, the report includes the X and Y coordinates of all parts.

Figure 79 Cross Reference Parts dialog box
Report unused parts in multiple part packages  If you check this option, the report identifies unused parts in multiple part packages.

Report File  The name of the file to contain the cross reference report.
Exporting and importing schematic data

Exporting and importing designs

You use the Export Design command to export a design or library in an EDIF or a DXF format. You use the Import Design command to import a design or library in MicroSim Schematics, EDIF, or custom format.
Chapter 17  Exporting and importing schematic data

Exporting designs

You can export either designs or libraries.

To export a design or library
1  Open the project containing the design or library to export.
2  If you are exporting a design, select the design’s folder.
   or
   If you are exporting a library, select the library’s folder.
3  From the project manager’s File menu, choose Export Design. The Export Design dialog box displays.

   ![Export Design dialog box](image)

   **Figure 80 Export Design dialog box**

4  Choose either the EDIF or the DXF tab.
5  Specify a path and filename in the Save As text box.
6  If you are using the DXF tab:
   a  Select the option to save the entire design or the current page. If you are exporting the entire design, you must have at least one of the schematic pages open to use this option.
   b  Select or clear the Include Border and Include Title Block check boxes.
Exporting and importing designs

Click OK to export the design or library to a file. The data that is exported is as it appears, similar to printing a page.

If you are using the EDIF tab:

- Locate and select a configuration (.CFG) file.
- Click OK to export the design or library to a file.

Importing designs

You can import either designs or libraries.

1. Make sure that no other projects are open before you begin.

2. From the project manager’s File menu, choose Import Design. The Import Design dialog box appears.

3. Choose the PSpice, EDIF, or PDIF tab.

4. Locate and select the file to import in the Open text box.

5. Specify a path and filename in the Save As text box.

For more information about translating MicroSim Schematics designs and libraries, see the book Converting MicroSim Schematics Designs to OrCad Capture Designs Quick Start.

Note: Use the PSpice tab for importing MicroSim Schematics designs and libraries. Use the custom tab for using custom designed schematic translators.
6 If you’re using the PSpice tab, follow these steps:
   a Click the appropriate Browse button to locate MSIM.INI file.
   b Select the Translate Hierarchy option, the Consolidate all Schematic files into one Design file option, and the Create Simulation Profile for Root Schematic Only option, as appropriate.

7 If you’re using the EDIF tab, locate and select a corresponding configuration (.CFG) file.

8 Click OK. The design or library is imported into your project.

Exporting and importing properties

You use the Export Properties and Import Properties commands to change properties of parts, pins, and flat nets in a spreadsheet application, a database application, or in a text editor that preserves tab characters. First export the properties to a property file, edit the property file in the application of your choice, then import the edited properties.

Exporting properties

You can export properties from a design or a library.

To export properties

1 Open the project containing the part properties to export.

2 If you are exporting properties from a design, select the schematic folders or schematic pages containing the properties to export.
or
If you are exporting properties from a library, select the parts to export. If you edit an Orcad-supplied library, be sure to assign a new library name so that you don’t lose your changes when you upgrade your software.

3 From the project manager’s Tools menu, choose Export Properties. The Export Properties dialog box appears.

![Export Properties dialog box](Figure 82 Export Properties dialog box)

4 Specify whether the property file is to include all documents in the file, or just the documents you selected.

5 Specify whether you want to export properties for pins as well as parts or flat nets.

6 Specify whether you want to export instance properties or occurrence properties.

7 Note the location of the export file in the Export File text box, then click OK to create the property file.

Tip Capture can import properties with or without quotation marks around each field in the property file. The fields must be tab-delimited, though—all other characters, including commas and spaces, are treated as part of a field’s text. Be sure your spreadsheet or database application can save in a tab-delimited format.
Property file format

When you export properties, Capture creates a tab-delimited list of keywords, identifiers, and properties, each of which is enclosed in double quotation marks. The first line of a property file begins with either the keyword DESIGN or the keyword LIBRARY, to identify the data as being from either a design or a library. Subsequent lines of the property file begin with one of the following keywords: HEADER, PART, PIN, or SYMBOL.

If you export both parts and pins, each PART line is followed by a PIN line. If you export symbols, there are no PIN lines following the SYMBOL lines, since symbols have no pins.

The HEADER lines are compiled from a superset of the property names found on parts (and pins, if applicable) from the whole page, or from the whole library. This means that if part 1 has properties named A, B, and C, part 2 has properties named D, E and F, and a pin has properties named G, H, and I, then the HEADER line will have (after the first two columns) nine columns titled A, B, C, D, E, F, G, H, and I.

Editing a property file

You can edit a property file in a spreadsheet or database application, or in a text editor as long as it doesn’t convert the tabs to spaces. Depending on which application you use, the property file content is in rows and columns of cells or fields, or as lines of text. There are a few restrictions on the changes you can make in a property file:

- You must not change or delete the first line.
- You must not change or delete the first field in any line.
- Do not delete a field from a HEADER line without also deleting the corresponding fields from subsequent lines.

Note: Export Properties and Import Properties use a reference designator as a match string. Therefore these tools cannot be used to annotate your design. If you want to swap part references, create a back annotation file, and then use Back Annotation.
Keeping these restrictions in mind, you can generally make the following changes:

- Add a field to a HEADER line and subsequent lines (add a column). This adds a property to parts and pins with a value in this field. The name of the property is the string in the HEADER line, and the value assigned to the part or pin is the string in the corresponding field. If the corresponding field is empty, Capture adds a property with no value and displays the property name as a placeholder.
- Change a property value to <null>. This deletes any existing property.
- Delete a field from a HEADER line and subsequent lines (delete a column). This has no effect on any part or pin. Deleting columns for properties you don’t want to change may make the property file easier to edit. If you delete a field from a HEADER line without also deleting the corresponding fields from subsequent lines, Capture reports an error when you import the property file.
- Change the value of a field. This resets the value of the property on all objects to which it refers.

Caution: Column deletion must be done with care. Columns may be deleted only from the HEADER line. For example, if you want to delete column 3 from a property file, but accidentally include column 3 of the DESIGN line, Capture reports an error when you import the property file.
You can use the Import Properties command to import a file that you created with the Export Properties command and edited using a spreadsheet, database, or text editor application.

To import properties

1. Open the project manager with the design or library holding the parts you want to import.
From the project manager’s Tools menu, choose Import Properties. The Import Properties dialog box appears.

Figure 83 Import Properties dialog box

Select the property file. If the property file is not listed, select a new drive or new directory in the Look in drop-down list box, or select the type of file you want to open in the Files of type box.

Keep in mind that if you edit an Orcad-supplied library, you should assign a new library name to avoid overwriting your changes when you upgrade your software.

Click OK to apply the properties.

If Capture finds errors in the property file, the project or library remains unchanged.
Generating a part

After you create and complete a project, you can create a part and an associated symbol that represents your FPGA or CPLD. Then you can use the symbol you generate to represent the actual component (FPGA or CPLD) in schematic designs for other projects.

Capture reads a variety of PLD vendor pin reports to create library parts for the Capture schematic system. Most PLD vendor pin reports describe the pin number, signal name, and direction (or mode) of a package pin programmed by the place-and-route process.

When you create a new part, Capture creates a new schematic library (.OLB) and part based on the pins defined in the report file. Pins are sorted alphabetically by name, with the input type pins located on the left side, and output or bidirectional pins on the right side. Capture references the part file in the Outputs folder of the project manager.
Using the Generate Part tool

You can use the Generate Part command to create a new part or update the pin numbers of an existing library part (see page 297).

Generate a new part

You can use the symbol you generate to represent the actual component (FPGA or CPLD) in schematics for other projects, including PCB designs.
To generate a new part

1. From the Tools menu in the project manager, choose Generate Part. The Generate Part dialog box appears.

   ![Generate Part dialog box](Figure 84)

2. Use the Browse button to locate the netlist file.

   When you use the Browse button to select a netlist file, Capture fills in the Part name and Part Library fields. Capture also selects a Vendor file type based on the file extension of the netlist.

   If you type the netlist file name, you’ll also need to select a Vendor file type for the netlist, enter the Part name, and enter the Part library.

3. Select the Create new part option.
4 In the Sort Pins group box, select either Ascending order or Descending order.

5 If you want to specify additional pins for the part, select the Specify the number of additional pins on part check box and enter the number of pins you want to add.

The part generator creates a part with the number of pins equal to the number of input and output ports in the netlist. However, if you are using a specific device for your FPGA/CPLD component that differs from the netlist ports, you can specify the number of pins on the device. This is important if you plan to use the symbol on a PCB schematic page.

6 From the Implementation Type drop-down list, choose one of the following:

- <none>. Primitive library part.
- EDIF. Non-primitive library part. Contents defined by an EDIF netlist generated by a third-party EDA tool.
- Project. Primitive library part. Associated with the Simulation Resources of an FPGA or CPLD project (which creates a hierarchy of projects) for system-level simulation.
- VHDL. Non-primitive library part. Contents defined by a VHDL model.

The most common implementation type used with the parts created from PLD vendor pin reports is either <none> or Project.

7 Enter a name for the attached object in the Implementation name text box.

8 In the Implementation file text box, enter or browse for the library or file of the attached object.
9 Click OK. Capture generates a library with the file PARTNAME.OLB and references it in the project manager’s Outputs folder.

**Update the pin numbers of an existing part**

Use the Update pins on existing part in library option when you have an engineering change order (ECO) from a programmable logic project and need to update the part symbol in the system schematic.

1 From the Tools menu in the project manager, choose Generate Part. The Generate Part dialog box appears.

![Generate Part dialog box](image-url)

**Figure 85 Generate Part dialog box**
2 Use the Browse button to locate the netlist file. When you use the Browse button to select a netlist file, Capture fills in the Part name and Part library fields. Capture also selects a Vendor file type based on the file extension of the netlist. If you type the netlist name, you’ll also need to select a Vendor file type for the netlist, enter the Part name, and enter the Part library.

3 Select the Update pins on existing part in library option.

4 Click OK.
Using Capture with Orcad Layout

Orcad Layout communicates interactively with Capture. This chapter explains how to use Capture with Layout to perform back annotation, forward annotation, and cross probing.

When you make changes to your board in Layout, you can back annotate some of that information to Capture using the Backannotation File (.SWP) option in Layout’s Generate Reports dialog box.

Select the Run ECO to Layout option in Capture’s Create Netlist dialog box to automatically communicate changes you made in your Capture design to Layout. If the Layout file is open when you update the netlist file, Layout displays a dialog box asking if you want to load the new netlist file. If the Layout file is not open when the netlist changes, Layout prompts you to load the modified netlist when you reopen the Layout file.

You can also perform cross probing with Capture and Layout. With cross probing, you can select a part or net on a Capture schematic page or Layout board, and the

Tip You can also use Layout’s AutoECO command to forward annotate design properties, part information, and netlist changes to Layout from Capture. For information on using this command, see AutoECO in Capture’s online help.
corresponding object in the other application is highlighted.

Moving a design from Capture into Layout is a three-part process:

- Create a valid Capture design with footprints that Layout supports.
- Generate a netlist in the Layout format.
- Create a Layout board file. You can also transmit information concerning parts, nets, and pins by creating user-defined properties on the parts, nets, or pins.

Maintaining the integration between your Layout board and your Capture design requires that you periodically perform these tasks:

- Create an Orcad Backannotation File (.SWP) in Layout.
- Perform a back annotation in Capture using the back annotation file.
- Use Layout’s AutoECO command to forward annotate any edits you make in your Capture design into Layout.

When you add new parts to your Capture design, use the Incremental reference update option in the Update Part References dialog box (as opposed to the Unconditional reference update option) when you update part references.

Any connections added to or deleted from your Layout board are not back annotated into Capture. For this reason, when you want to modify connections, make the changes in Capture and forward annotate them to Layout.

Changes in reference designators must be done in Layout and back annotated with Capture.

Caution: Layout uses reference designators as identification for forward and back annotation. For this reason, all changes to reference designators must be made in Layout and back annotated to Capture. Similarly, if you change existing reference designators in your Capture design and forward annotate them into your Layout board, your board will no longer be usable.
Preparing your Capture design for use with Layout

Preparing a Capture design for Layout is a two-part process. First, you must create a valid design. Then, you need to create a netlist in an .MNL file format in Capture that you can read into Layout.

To prepare your Capture design

If you want to send part or net information from a Capture schematic design, add a user-defined property with a name from the property tables and assign a value to the property. The property name must be in uppercase, as given in the tables.

1. On your schematic page, select the objects you want to send to Layout, then right-click and choose Edit Properties from the pop-up menu. The property editor appears.

2. Click the down arrow on the Filter by drop-down list to expand the list, and select Layout. The property editor spreadsheet displays properties available in Layout. The property value cells for each object on the schematic page appear white with hash marks, indicating that these properties are not yet assigned to the part or net.

3. Assign values to the properties of the selected objects on the schematic by clicking on a cell, typing in the value, and pressing Enter or clicking Apply. The hash marks disappear and the property is applied to the object when you click Apply or close the property editor. The layer names and via names you use must be among the standard Layout layer and via names. Pin numbers for pin names where no numbers exist must match the pad names on the Layout footprint.

4. Assign PCB footprints to each of your schematic parts. Use only Layout footprint names, selecting from those shown in the Orcad Layout Footprint Libraries, or those in your custom footprint libraries.

Note: For information about simple and complex hierarchical designs, see Chapter 6, Design structure.
Keep in mind that Layout cannot accept PCB footprint names or par values that include spaces or tabs.

To add user-defined Layout part properties to an object

1. Select a part, net, or pin on the schematic page.
2. From the Edit menu, choose Properties. The property editor appears.
3. In the property editor, select all objects to which you want to add a user-defined part. If you want to add a property that already exists, skip to step 5.
4. Click the New Column or New Row button in the upper left area of the property editor. You can add a value to every object you have selected at the time you create the property in the Add New Column or Add New Row dialog box (depending on whether the property editor spreadsheet is pivoted).
5. Enter values for those properties you want to add to the selected objects, then click OK. After you close the property editors, the properties are added to the part.
Creating a netlist for use in Layout

After you prepare your design in Capture and it is free from design rules violations, you can create a netlist (.MNL) file for use with Layout. A copy of the LAYOUT.INI file must exist in the same directory as CAPTURE.EXE to generate a netlist.

To create a netlist for use in Layout

1. Open the Capture design.
2. Select the design in the project manager and, from the Tools menu, choose Create Netlist. The Create Netlist dialog box appears.
3. Select the Layout tab.
4. In the PCB Footprint group box, ensure that {PCB Footprint} appears in the Combined property string text box.
5. In the Netlist File text box, ensure that the path to the netlist file is correct. The netlist takes the name of the Capture project and adds a .MNL extension.
6. Click OK. Capture processes the netlist, then creates a .MNL file and saves it in the directory specified in step 5.

Tip: Save your Capture design before creating a netlist.

For information about combined property strings, see Capture’s online help.

Note: You may choose to exit Capture at this time. It is not necessary to run Capture and Layout simultaneously to take advantage of forward annotation. It takes a minimum of 64 MB of RAM to run both Capture and Layout.
Loading a new netlist into Layout

You can bring Capture netlist information into layout in two ways:

- Choose one of the AutoECO options to merge the netlist with the board file
- Select the Run ECO to Layout option in Capture’s Create Netlist dialog box to automatically communicate modifications to Layout

If the board file is open in Layout when you update the netlist file, Layout automatically displays a dialog box asking if you want to load the new netlist file. If the board file is not open when the netlist changes, Layout prompts you to load the modified netlist when you re-open the board file.

Use the following procedure to forward annotate information from Capture to Layout.

**In Capture**

1. In the project manager, open the design for which you are going to create a netlist.
2. From the Tools menu, choose Create Netlist.
3. In the Create Netlist dialog box, choose the Layout tab.
4. Select the Run ECO to Layout option.
5. In the Netlist File text box, enter a name for the output file using an .MNL file extension.
6. Click OK. The Create Netlist dialog box closes and creates the .MNL file.

**In Layout**

7. From the session frames’s File menu, choose New.
8. In the Load Template File dialog box, select a technology file (.TCH), then click OK.
9 In the Load Netlist File dialog box, select the netlist file with the .MNL file extension that you created in step 6, then click OK.

10 In the Save MAX Board dialog box, select a name for a new output file with a .MAX file extension, then click OK.

If AutoECO is unable to find a designated footprint, a dialog box opens so that you can link footprints with components. For more information, see the Link Footprint to Component dialog box topic in Layout’s online help.
Chapter 19    Using Capture with Orcad Layout

Back annotating board information from Layout

When you add new parts to your Capture design, use the Incremental reference update option in the Update Part References dialog box (as opposed to the Unconditional reference update option) when you update part references.

In Layout, you can back annotate board changes for Capture using the Orcad Backannotation File (.SWP). Once the .SWP file is created, the current Layout file no longer contains swap information. A copy of the board file is saved as BACKANNO.MAX.

To back annotate

1. From Layout’s Auto menu, choose Back Annotate. A dialog box appears that prompts you to save the Layout design. Saving the design maintains the link between Layout and Capture.
2. From Capture’s Tools menu, choose Back Annotate. The Back Annotate dialog box appears.
3. Ensure that the Process entire design option is enabled.
4. Choose the Browse button, locate and select the back annotation file you created in Layout (design_name.SWP), then click OK. The Layout information is back annotated to the design in Capture.

Caution  Layout uses reference designators as identification for forward and back annotation. For this reason, all changes to reference designators must be made in Layout and back annotated to Capture. Similarly, if you change existing reference designators in your Capture design and forward annotate them into your Layout board, your board will no longer be usable.

Caution  Don’t create a second .SWP file without back annotating the first .SWP file to Capture; otherwise, the swap information in the first .SWP is overwritten by the second .SWP file.

Caution  If you have renamed your components in your Layout board and created a .SWP file, those changes in reference designators are removed from the current board file (.MAX). Only the BACKANNO.MAX file retains the information on the original and current reference designators, but it is overwritten once you generate another .SWP file. So, if you want to retain the information on original and current reference designators, rename the BACKANNO.MAX file.

Caution  If you have renamed your components in your Layout board and created a .SWP file, those changes in reference designators are removed from the current board file (.MAX). Only the BACKANNO.MAX file retains the information on the original and current reference designators, but it is overwritten once you generate another .SWP file. So, if you want to retain the information on original and current reference designators, rename the BACKANNO.MAX file.
Forward annotating schematic data to Layout

A copy of the LAYOUT.INI file from the Layout directory must exist in the same directory as CAPTURE.EXE to correctly perform forward annotation to Layout.

To forward annotate

1. From Capture’s Tools menu, choose Create Netlist. The Create Netlist dialog box appears.
2. Choose the Layout tab, then click OK.
3. In Layout’s session frame, choose Tools, then ECO’s, then one of the AutoECO options. The File A dialog box appears.
4. Select a .MAX file to which you want to add the new schematic information, then choose the Open button. The File B dialog box appears.
5. Locate and select the netlist (.MNL) that you created in step 2, then choose the Open button. The Output report dialog box appears.
6. Specify a name for the output report (usually design_name.LIS) and a location, then choose the Save button. The output report displays in a text editor and the Merged Output Binary dialog box appears.
7. Specify a name and a location for the merged board, then choose the Save button. Layout merges the files based on the type of AutoECO you chose.
8. Read the output report carefully. The changes listed there should match the edits you made to your Capture design.

Note For information on Layout’s AutoECO options, see AutoECO in Capture’s online help.

Note You can also bring Capture netlist information into Layout by using the Run ECO to Layout option in the Layout tab in the Create Netlist dialog box. For information on this option, see the OrCAD Layout User’s Guide.
Cross probing between Capture and Layout

Using cross probing, you can select an object in Layout or Capture and have the corresponding object highlight in the other application. For example, you can select a net on a schematic page in Capture and see the corresponding track highlighted in Layout.

Enabling intertool communication between Capture and Layout

To use cross probing, you must have the same design open in Layout as in Capture. In Capture you must enable intertool communication (ITC). It is not necessary to enable ITC in Layout, because cross probing is always active in Layout.

To enable ITC in Capture

1. From Capture’s Options menu, choose Preferences. The Preferences dialog box appears.
2. Choose the Miscellaneous tab, select Enable intertool communication, then click OK.

Tip: You use Layout’s Half Screen command (from the Window menu) to tile the Capture and Layout windows so that you can view both on your screen.

Tip: Only enable ITC when you want to cross probe. If you leave ITC enabled while editing your design, Capture’s performance is reduced.

Note: It is necessary to run Capture and Layout simultaneously to use cross probing. It takes a minimum of 64 MB of RAM to run both Capture and Layout.
Cross probing from Capture to Layout

When ITC is enabled in Capture and you select certain items on your schematic page, cross probing highlights the corresponding items in Layout. If you select a part or gate in a multiple-part package in Capture, cross probing highlights the corresponding module in Layout. If you select a wire segment or net in Capture, cross probing highlights the corresponding net (in its entirety) in Layout.

Any action you perform to select an object on your Capture schematic page (selecting using the mouse, using the Find command, or performing a browse of parts) causes the corresponding object in Layout to be highlighted. For more information, see Table 12.

Table 12  Cross probing from Capture to Layout

<table>
<thead>
<tr>
<th>Selecting this in Capture</th>
<th>Highlights this in Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part</td>
<td>Corresponding component</td>
</tr>
<tr>
<td>Gate (multiple parts per package)</td>
<td>Corresponding component</td>
</tr>
<tr>
<td>Wire segment</td>
<td>Entire net</td>
</tr>
<tr>
<td>Net</td>
<td>All routes for the net</td>
</tr>
<tr>
<td>Pin on part</td>
<td>Corresponding component</td>
</tr>
</tbody>
</table>

To select an object in Capture for cross probing with Layout

1. Open a Capture schematic page and a matching Layout design.
2. Choose Half Screen from Layout’s Window menu, then position the Capture and Layout session frames so that you can see both.
3. From Capture’s Options menu, choose Preferences. The Preferences dialog box appears.
4. Choose the Miscellaneous tab, select Enable intertool communication, then click OK.
5. Select an object in Capture. The corresponding object is highlighted on the board in Layout.

Note: When you use block selection in Capture, cross probing only highlights the last item selected in the block. There is no way to predict the order in which items are selected in a block selection.
Cross probing from Layout to Capture

When ITC is enabled in Capture, selecting objects in Layout causes Capture to highlight the corresponding items in the schematic page editor. Selecting a component (or a component pad) causes Capture to highlight all the parts included in that module. Selecting a track or net causes Capture to highlight the corresponding net on the schematic page.

Any action you perform to select an object on your Layout board (selecting using the mouse, using query, or using the Find command) causes the corresponding object on the Capture schematic page to be highlighted. For more information, refer to Table 13.

Table 13  Cross probing from Layout to Capture

<table>
<thead>
<tr>
<th>Selecting this in Layout</th>
<th>Highlights this in Capture</th>
</tr>
</thead>
<tbody>
<tr>
<td>Component</td>
<td>All parts in the package</td>
</tr>
<tr>
<td>Track</td>
<td>Corresponding wire connection</td>
</tr>
<tr>
<td>Net</td>
<td>Corresponding nets</td>
</tr>
<tr>
<td>Pad on component</td>
<td>Corresponding part (if the Manual Route tool is selected in Layout, the net is highlighted)</td>
</tr>
</tbody>
</table>

To select an object in Layout for cross probing with Capture

1. Open a Capture design and a matching Layout design.
2. Choose Half Screen from Layout’s Window menu, then position the Capture and Layout session frames so that you can see both.
3. From Capture’s Options menu, choose Preferences. The Preferences dialog box appears.
4. Choose the Miscellaneous tab, select Enable intertool communication, then click OK.
5. Select an object in Layout. The corresponding object is highlighted on the schematic page in Capture.

Note  In Capture, the schematic folder automatically opens and displays the schematic page on which the corresponding part is located. Scroll the window until the selected part is visible.
General rules

After creating your design in Capture and your board in Layout, be sure to back annotate into Capture. From that point on, if you wish to make changes in the reference designators, gate swaps or pins swaps, do them in Layout and back annotate the results to Capture. If you need to change connections, do these in Capture, and forward annotate the changes into Layout.
Overview

This chapter provides guidelines for preparing your schematic for simulation and references further information contained in the PSpice User’s Guide.

A design that is targeted for simulation with PSpice will have:

- Parts that have PSpice simulation models available and configured (see the Creating parts for models chapter in the PSpice User’s Guide).

- Sources of stimulus to the circuit (see the Preparing a design for simulation chapter in the PSpice User’s Guide).
Chapter 20    Using Capture with PSpice

Specifying simulation model libraries

Refer to the Creating and editing models chapter of the PSpice User’s Guide for information about creating and configuring simulation model libraries. Most of the parts that you intend to simulate must have a simulation model defined.

To check if a part has a simulation model defined

1 Double-click the part on the schematic page to display the property editor spreadsheet. If a simulation model is available for a part, the part will have:

   • A PSpiceTemplate property specifying the PSpice simulation netlisting syntax for the part.
   • The implementation type set to PSpiceModel.
   • An implementation property specifying the name of the model or subcircuit.

The simulation model specified by the implementation property must be contained in a model library that is configured.
Creating a design for PSpice A/D simulation

When creating designs for PSpice A/D simulation, use Capture’s Analog or Mixed-Mode Project Wizard to assist you in setting up your project. Only use parts from libraries specifically created for PSpice, or your own libraries. You can find these libraries in your PSPICE directory.

For analog circuits, use the “0” ground symbol found in SOURCE.OLB, or use one of the other ground symbols and rename it to “0.”

To create a new PSpice A/D design

1. From the File menu, point to New and choose Project. The New Project dialog box appears.
2. Enter a name for your new PSpice project. This name will also serve as the design’s name.
3. Click the Browse button to specify the new location for your project and design.
4. Select Analog or Mixed A/D.
5. Click OK. The Create PSpice Project dialog box appears.
6. Select the option to create the project based on an existing project, or create a blank project.
7. Click OK. When you choose the first option to create it based upon an existing project and then specify a project (.OPJ) file, you can create a new and distinct project that has all of the elements of the existing project, including simulation profiles, local simulation files, libraries, include files, marker files, configured libraries, and designs.
Editing simulation models from Capture

You can define and edit simulation models directly from Capture.

Models can be defined using the Model Editor. The Model Editor is useful for characterizing specific models from data sheet curves. It includes a text editor that is useful if model parameters are already defined (for example, models from a vendor) or if the model is not supported for extraction by the Model Editor.

Refer to the Creating and editing models chapter in the PSpice User's Guide.
Adding and defining stimulus

The Stimulus Editor is a utility that enables you to set up and verify the input waveforms for a transient analysis. You can create and edit voltage sources, current sources, and digital stimuli for your circuit. Menu prompts guide you to provide the necessary parameters, such as the rise time, fall time, and period of an analog repeating pulse, or the complex timing relations with repeating segments of a digital stimulus. Graphical feedback enables you to verify the waveform.

Placing stimulus sources

Stimulus sources come from the \LIBRARY\PSPICE\SOURCSTM.OLB library and are one of:
- VSTIM—voltage stimulus source for transient analysis
- ISTIM—current stimulus source for transient analysis
- DIGSTIMn—digital stimulus source

You can place any of these sources in the same way you place any other part.

Using the Stimulus Editor

For information on using the Stimulus Editor, refer to the Transient Analysis chapter in the PSpice User’s Guide or to the Stimulus Editor topics in the PSpice online help.
Setting up and running analyses

Refer to your PSpice User’s Guide for information about setting up and running the many different analysis types supported by PSpice A/D.

After creating a simulation profile, you can start the simulator directly from Capture by choosing Run from the PSpice menu.

For more information, refer to the Starting a simulation section of the Setting up analyses and starting simulation chapter in the PSpice User’s Guide.
You can use the waveform analysis features of PSpice to view and perform waveform analysis of the simulation results.

For more information, refer to the Analyzing waveforms chapter of the PSpice User’s Guide, or the PSpice online help.

You can configure PSpice to automatically show waveform results when the simulation has finished, or to monitor waveforms as the simulation progresses.

These procedures are outlined in the Analyzing waveforms chapter in the PSpice User’s Guide.

You can place markers on your schematic page to indicate the points for which you want to see waveforms displayed in PSpice.

You can use the Markers dialog box to:

- Display and hide markers on your design
- Go to a marker on a schematic page
- Remove one or markers

The Markers dialog box is available from the project manager and the schematic page editor. From the project manager, choose Marker List from the PSpice menu. From a PSpice schematic page, point to Markers on the PSpice menu and choose List.

For more information on markers, refer to the PSpice User’s Guide.
Configuring the display of simulation results

To configure what results PSpice displays, select the Probe Window tab when editing the simulation profile. You are given the following choices:

- **Display Probe Windows When the Profile is Opened**—This causes the simulation results to be automatically added and Probe windows displayed whenever the simulation is opened in PSpice.

- **Display Probe Window**—Specifies the following options:
  - **During Simulation**—This opens a Probe window as soon as the simulation sweep begins, so you can watch the waveforms develop as the simulation progresses.
  - **After Simulation has Completed**—This opens a Probe window upon completion of the simulation, when all of the data is available.

- **Show Frame**—Specifies the following options:
  - **All Markers on Open Schematics**—when a Probe window is automatically opened, it will display traces corresponding to any markers in currently open schematics in Capture.
  - **Last Plot**—reconstructs the Probe window that was last used to view results of this simulation profile.
Creating designs for PSpice simulation and board layout

When creating designs for both simulation and printed circuit board layout, some of the parts you use will be for simulation only (for example, simulation stimulus parts like voltage sources), and some of the parts you use will have simulation models that only model some of the pins of the real device.

Parts that are to be used for simulation, but not for board layout, have a PSpiceOnly property. To see an example of this, double-click a VDC voltage source to display the property editor spreadsheet.

You can add this (or any) properties to your own custom parts.

To specify part properties

1. In the schematic page editor, select the part.
2. From the Edit menu, choose Properties to display the property editor spreadsheet.
3. Add a new property named PSpiceOnly, and set its value to True.
4. Click OK.

For more information on defining properties on part symbols, see Editing parts on page 7-125.
Handling unmodeled pins

Some parts used in PSpice simulation designs have unmodeled pins that have no electrical significance in a PSpice simulation, but must be connected to a PCB layout design. Unmodeled pins have a FLOAT property with a value of “Unmodeled.” If unmodeled pins are connected to any other pins, a netlist is generated with a large resistor connected from the set of pins to ground. Unmodeled pins must not be referenced in a part’s PSpiceTemplate property.

Place an instance of PM-741 from the PSpice OPAMP.OLB library to see its two unmodeled pins, “OS1” and “OS2.” Double-click the “OS1” or “OS2” pin to bring up the property editor. Capture shows the FLOAT property on the two pins as “Unmodeled.” Only the +, -, OUT, V+, and V- pins are referenced in the part’s PSpice property.

To view a simulation model for a part

1. In the schematic page editor, click the part to select it.
2. From the Edit menu, choose PSpice Model to display the Model Editor and view an instance of the simulation model definition.
3. Exit the Model Editor without saving, to avoid creating a copy of the model.
Displaying bias point information

After simulating your analog or mixed design in PSpice, you can display bias point information on your schematic page in Capture. Bias voltages appear next to corresponding nets (nodes), and bias currents appear next to corresponding device pins. This data on your schematic helps you quickly focus in on potential problem areas of your design.

PSpice calculates and saves the bias point currents and voltages for every simulation. Capture reads all of this information and can display currents on all pins that have models or voltages for every net in your circuit.

Displaying bias point values

You can enable the display of bias information for all nets and pins in the circuit, or just on selected nets and pins. You can also disable bias point display on large digital designs where the legibility of the schematic might be reduced, for example.

To enable or disable the display of all bias information

1. From the PSpice menu in Capture, point to Bias Points and choose Enable.
2. If you want to disable bias point display, clear the selection.

To enable or disable the display of all bias current points

1. From the PSpice menu in Capture, point to Bias Points and choose Enable Bias Current Display.
2. If you want to disable display of bias current points, clear the selection.

For more information on using bias point displays in a PSpice design in Capture, see the Bias point display book in Capture’s online help (Contents tab).
To enable or disable the display of all bias voltage points

1. From the PSpice menu in Capture, point to Bias Points and choose Enable Bias Voltage Display.
2. If you want to disable the display of bias voltage points, clear the selection.

To enable or disable the display of selected bias current points

1. In Capture, click on a pin, or hold the [Ctrl] key and click on several pins to select them. You can also click on a part to select all of the pins for that part.
2. From the PSpice menu, point to Bias Points and choose Toggle Selected Bias Current. If you want to disable the display, clear the selection.

To enable or disable the display of selected bias voltage points

1. In Capture, click on a wire, or hold the [Ctrl] key and click on several wires to select them.
2. From the PSpice menu, point to Bias Points and choose Toggle Selected Bias Voltage. If you want to disable the display, clear the selection.

To enable display of bias points after disabling selected bias point displays

1. From the Edit menu, choose Select All.
2. Click the Toggle Selected Bias Voltage toolbar button three times: once to enable the bias displays that were previously disabled, once more to disable all bias point displays, and a third time to enable them all.
Glossary

alias  See net alias, part alias.

ANSI  Acronym for American National Standards Institute, an organization formed by industry and the U.S. government to develop trade and communication standards. Internationally, ANSI is the American representative to the ISO (International Standards Organization). See also ASCII.

architecture  VHDL term that describes the behavior of a VHDL design unit (an entity/architecture pair). The architecture can also serve to connect other VHDL design units.

ascend  In a hierarchical design, to move from the child schematic folder to the parent schematic page. This is done in the schematic page editor using the Ascend Hierarchy command on the View menu. See also child, descend, parent.

ASCII  Acronym for American Standard Code for Information Interchange; a seven-bit code—based on the first 128 characters of the ANSI character set—that assigns numeric values to letters of the alphabet, the ten decimal digits, punctuation marks, and other characters such as Backspace, Carriage Return, and Line Feed. ASCII is the most widely used character-coding set, and as such enables different applications and computers to exchange information. See also ANSI.

AutoECO  Acronym for automatic engineering change order. Layout’s AutoECO command translates schematic netlist information from Capture to Layout. See also forward annotate.
**back annotate**
To apply modifications to part properties in a design, such as updating part references and pin numbers, swapping gates, or swapping pins. Parts are back annotated in the project manager, using the Gate and Pin Swap command or the Update Properties command on the Tools menu. In Layout: to transmit data, such as gate and pin swaps, back to the schematic pages. See also *forward annotate*.

**bitmap**
Bitmaps are graphic images made up of pixels, which are tiny dots on a computer screen. Each pixel in a bitmap is represented by a number between 0 and 255, inclusive, with 0 being the darkest (no luminance) and 255 being the lightest (full luminance). Bitmaps have a .BMP extension, and can be placed on a schematic page using the Picture command on the schematic page editor’s Place menu.

**bookmark**
Just as you can place a bookmark in a book to mark a specific page, you can place a bookmark on a schematic page to mark a location you would like to return to. To place a bookmark, use the Bookmark command on the Place menu in the schematic page editor. To go to a bookmark when in the schematic page editor, use the Go To command on the View menu. To go to a bookmark when in the project manager, use the Browse command on the Edit menu to display bookmarks in the browse window, then choose a bookmark. To edit a bookmark, double-click on it.

**browse spreadsheet**
This window displays the results of queries done using the Browse command on the Edit menu. You can double-click on an object in the browse window to go to that item on its schematic page.

**bus**
A group of scalar signals (wires) that is never connected to a net. A bus name defines the bus signals and connects those signals to the corresponding nets. For example, the bus name A[0:3] defines a four-signal bus and connects the four signals A[0], A[1], A[2], and A[3] with nets A0, A1, A2, and A3. See also *bus pin, bus entry*. 
**bus entry** A bus entry is used to tie a signal to a bus. The advantage of using bus entries instead of wires is that two bus entries can be connected at the same point on a bus without connecting the signals. If two wires are run directly to a bus at the same location, the signals are connected. See also *bus, bus pin*.

**bus pin** A pin width that can carry multiple signals, as opposed to a scalar pin that only carries one signal. A bus pin represents all the pins for a bus, and they use the same naming conventions as buses. See also *bus, bus entry*.

**CAGE code** An acronym for *Commercial and Government Entity Code*. A number—provided by the federal government to its suppliers—that can be present in the title block of a schematic page.

**child** In a hierarchical design, a schematic folder whose circuitry is represented by a hierarchical block on the parent schematic page. To move from parent to child is to descend the hierarchy. A child contains circuitry referenced by its parent. See also *ascend, descend, parent*.

**complex hierarchy** A design in which two or more hierarchical blocks (or parts with attached schematic folders) reference the same schematic folder. See also *hierarchical design, simple hierarchy*.

**convert** An alternate form—such as a DeMorgan equivalent—that can be stored with each part. See also *DeMorgan equivalent*.

**cross probing** When intertool communication is enabled in Capture, selecting objects causes the corresponding objects to be highlighted in Layout. Also, selecting objects in Layout causes the corresponding objects to be highlighted in Capture. Both applications must be open. See also *intertool communication*.

**DeMorgan equivalent** An electrically-equivalent part based on the DeMorgan rules of equivalence. These rules represent the duality of AND and OR in Boolean expressions: if all AND operations are changed to OR operations, all OR operations are changed to AND operations, and all variables and constants are negated, then the value of the expression remains unchanged. A DeMorgan equivalent can be stored in the convert of a part. See also *convert*. 
descend  In a hierarchical design, to open and view the child schematic folder represented by a hierarchical block on the parent schematic page. To descend a hierarchical design, you select a hierarchical block in the schematic page editor, then choose the Descend Hierarchy command on the View menu. See also ascend, child, parent.

design cache  A local library contained in each project that contains all the parts and symbols used in the project.

design rules check (DRC)  This tool, on the project manager’s Tools menu, checks a design or part of a design for conformance to a set of configurable design criteria and electrical rules.

document  A schematic folder, schematic page, library, part, or symbol. Each of these is part of a project.

EDA  Acronym for Electronic Design Automation. Software and hardware tools used to ascertain the viability of an electronic design. These tools perform simulation, synthesis, verification, analysis, and testing of a project.

EDIF  Acronym for Electronic Design Interchange Format. A standard published by the EIA (Electronic Industries Association) that defines semantics and syntax for an interchange format that communicates electronic designs.

equivalent  See convert, DeMorgan equivalent.

ERC  Acronym for Electrical Rules Check, a subset of the Design Rules Check tool. The ERC matrix is used by Design Rules Check to check for when evaluate connections between pins, off-page connectors, hierarchical ports and hierarchical pins.

flat design  A schematic structure with no hierarchy (no hierarchical blocks; no parts with attached schematic folders). A flat design can include schematic pages in which output signals of one schematic page connect laterally to input signals of another schematic page through objects called off-page connectors. You place these objects using the Off-Page Connector command on the Place menu in the schematic page editor. Flat designs are practical for small designs with few schematic pages. See also hierarchical design, complex hierarchy, simple hierarchy, off-page connector.

forward annotate  The process of sending netlist data in the form of an .MNL file from Capture to Layout.
**graphic object**  An object drawn or placed on a schematic page or part—such as an arc, line, rectangle, ellipse, polygon, bitmap, text, or title block—that has no electrical connectivity.

**grid reference**  The border around a schematic page that acts as a visual reference for the grid. Grid references can be used as a destination for the Go To command on the View menu, and can be set to visible or hidden in both the Design Template and Schematic Page Properties dialog boxes.

**heterogeneous package**  A package with multiple parts that are graphically different or contain different numbers of pins (for example, a relay). See also homogeneous package.

**hierarchical block**  A symbol placed on a parent schematic page that refers to a child schematic folder. Hierarchical pins are placed within a hierarchical block, and hierarchical ports that refer to the hierarchical pins are placed on a schematic page within the child schematic folder. See also hierarchical pin, hierarchical port.

**hierarchical design**  A design in which design modules are interconnected vertically with hierarchical blocks (or parts with attached schematic folders). At least one module, the root module, contains symbols representing other schematic folders. See also complex hierarchy, simple hierarchy, flat design, design module.

**hierarchical pin**  A symbol, placed within a hierarchical block, that represents a signal connected to a like-named hierarchical port on another schematic page. See also hierarchical block, hierarchical port.

**hierarchical port**  A symbol, placed outside a hierarchical block, that represents a signal connected to a like-named hierarchical pin. Hierarchical ports can also connect to like-named hierarchical ports. See also hierarchical block, hierarchical pin.

**homogeneous package**  A package with multiple parts that are graphically identical. See also heterogeneous package.

**HPGL**  Acronym for Hewlett-Packard Graphics Language, which is a plotter protocol.

**IEEE**  Acronym for Institute of Electrical and Electronics Engineers.
**inherent property**  One of the set of properties required for a given object. Unlike user-defined properties, inherent properties cannot be removed.

**instance**  A part or symbol placed on a schematic page. See also *instance property*, occurrence.

**instance property**  A property that is attached to an instance, as opposed to a property that is attached to an occurrence or added to a part in a library. Instance properties can be overridden by occurrence properties, which are not reflected on the instance. See also *instance*, occurrence.

**intertool communication (ITC)**  A capability that allows Orcad EDA tools to share information for display and transfer. See also *cross probing*.

**junction**  A junction, shown as a small dot, is placed at the connection point where two perpendicular wires or buses cross, to give visual confirmation that the items are electrically connected. If you draw a wire across another wire at a 90-degree angle, the wires are not electrically connected unless you create a junction by clicking the left mouse button on the existing wire as you draw the new wire across it.

**library**  A collection of often-used parts, graphics, schematic pages, and symbols.

**location**  An X, Y coordinate on a schematic page or part. You can move to a location using the Go To command on the View menu in the schematic page editor.

**macro**  A series of commands you can record, then execute by pressing one key or a combination of keys. Macros greatly reduce the number of keystrokes required to perform complex or repetitive actions.

**mirror**  To flip along the X (horizontal) or Y (vertical) axis, or both.

**named net**  A net with more than one net alias where you choose which net will be used in the netlist.

**net**  The wires, buses, parts, and symbols that are logically connected via net names, aliases, off-page connectors, and hierarchical ports.
net alias  A name used to specify signal connections between unconnected wires or buses. For example, if you have wires in two remote locations in a schematic folder, you can assign each wire an alias (such as ABC) to connect the signals without physically drawing a wire between them.

netlist  A file that lists the interconnections of the project components by the names of the connected signals, parts, and pins.

nonprimitive  A part with an underlying hierarchy, such as an attached schematic folder.

occurrence  An instance placed on a schematic page with one or more sets of unique property values that may differ from other occurrences of the same instance. An occurrence typically appears in a complex hierarchy where a schematic is reused. Each use of the schematic is an occurrence, while the schematic itself is the instance. See also instance, occurrence property.

occurrence property  A property attached to an occurrence, as opposed to a property attached to an instance or added to a part in a library. Occurrence properties override instance properties, but are not reflected on the instance. See also instance, occurrence.

off-page connector  An object that conducts signals between schematic pages within the same schematic folder. See also flat design.

package  A physical part that contains more than one logical part. For example, a 2N3905 transistor, a fuse, and a 74LS00 are packages. Each part in a package has a unique part reference comprised of an alphanumeric prefix common to all the parts in the package, and a letter unique to each part. For example, a 74LS00 with a part reference prefix of U15 would have four parts with part references of U15A, U15B, U15C, and U15D. See also homogeneous part, heterogeneous part.

pan  To change the portion of the schematic page or part being viewed by dragging objects from one location to another. As you drag an object, the schematic page or part pans across the active window.
**parent**  A schematic page containing a hierarchical block that references another schematic folder (called a child). See also child, hierarchical block.

**part**  A part is a basic building block of a project that may represent one or more physical elements, or a function, a simulation model, or a text description for use by another application. A part’s behavior is described by a SPICE model, an attached schematic folder, HDL statements, or other means. Parts usually correspond to physical objects (gates, connectors, and so on) that come in packages of one or more parts. You can think of these packages as physical parts and the parts you place on a schematic page as logical parts. Physical parts with more than one logical part are sometimes referred to as “multiple-part packages.” For simplicity, Capture usually refers to both as parts. See also package.

**part alias**  A duplicate copy of a part that uses a different name. A part alias uses the same graphics, attached schematic folders, and properties as the original, with the exception of the part value.

**part editor**  The editor used to create and edit parts and symbols.

**part instance**  An instance of a part. See also instance.

**part primitive**  See primitive.

**PCB**  Acronym for printed circuit board.

**pin**  A pin acts as a point of connectivity for the part it is attached to. In addition to input and output pins, there are also 3-state, bidirectional, open collector, open emitter, passive, and power pins. If a pin connects to a wire, it is a scalar pin; if it connects to a bus, it is a bus pin. See also hierarchical pin.

**pin swap**  The exchange of identical pins in order to decrease route lengths.

**pin-to-pin spacing**  The physical spacing between pins on a device.

**polygon**  A graphic object made up of polylines (multiple contiguous segments) whose beginning and end are attached to form a closed shape that can be filled. See also polyline.
**polyline** A line with multiple contiguous segments. You place a polyline using the Polyline command on the Place menu.

**port** A VHDL term for an interface element of a VHDL entity. Serves as a communication channel between VHDL design units. Capture part pins and hierarchical ports will produce a VHDL port. See also *hierarchical port*.

**primitive** A part or hierarchical block with no underlying hierarchy.

**project** A single file that includes all of the schematic folders, schematic pages, parts, and symbols that make up a project. You can view these project elements in the project manager. A basic project contains one schematic folder and one schematic page, while a complicated project may contain an unlimited number of schematic folders, each with many schematic pages.

**project manager** The Capture window used to perform project-wide tasks, such as locating objects, creating a netlist, or generating reports. This window displays the structure of the schematic folders and schematic pages contained in a design. See also *hierarchical design*, *simple hierarchy*.

**property** A characteristic of an object that can be edited. A property consists of a name and a value. Examples of property names are part value and color. Their respective property values can be something such as capacitor and red.

**root schematic folder** The schematic folder at the top of a hierarchical design. The root schematic folder contains a backslash in its folder icon in the project manager. A project has only one root schematic folder.

**scalar** A pin width that carries only one signal, as opposed to a bus pin that can carry multiple signals.

**schematic design** A graphical representation of a circuit using a set of electronic symbols, hierarchical blocks, and connections. Typically used by system and programmable logic designers to express a structural design description.

**schematic folder** A collection of all schematic pages at the same level of hierarchy in a design. In the project manager, a schematic folder behaves like a container. See also *flat design*, *hierarchical design*, *schematic page*, *root schematic folder*.
schematic page  The pages on which a design is drawn. Schematic pages display in a window, called the schematic page editor, in which you can place parts and draw wires.

schematic page editor  The editor used to create and edit schematic pages.

session frame  The window in which various tool elements—such as the session log, project manager, schematic page editor, and part editor—run.

session log  A window that displays text messages generated by Capture, such as errors and informational messages. The session log starts empty with each new session, but you can save its contents to a text file.

signal  An electrical impulse of a predetermined voltage, current, polarity, and pulse width. Also, a VHDL term for a local circuit node that is not visible outside a VHDL design unit. A wire or bus that is not connected to a hierarchical port will produce a VHDL signal.

simple hierarchy  A design in which there is a one-to-one correspondence between hierarchical blocks (or parts with attached schematic folders) and the schematic folders they reference. Each hierarchical block (or part with an attached schematic folder) represents a unique schematic folder. See also hierarchical design, complex hierarchy.

source library  The path and filename where a part’s definition resides. A filename with an .OLB extension indicates that the part was placed “as is” from the library. A filename with a .DSN extension indicates that the part no longer matches the original library part, and the changed part’s definition only resides in the project where the part was edited.

spreadsheet editor  A window used to edit the properties of multiple objects at once.

symbol  A power or ground object, an off-page connector, a hierarchical port, or a title block.

tabbed dialog box  A dialog box that has different views that can be displayed by clicking on tabs at the top of the dialog box.

TrueType  A font (typeface) that appears in a printout exactly the way it appears on the screen. TrueType fonts are scaleable to any font size, and several of these type of fonts are installed automatically when you install Windows.
user-defined property  A property you add to an object. Unlike inherent properties, user-defined properties can be removed. See also inherent property.

vertex  The point at which the sides of an angle meet. You create this by drawing a wire or line in one direction, then changing direction to create an L-shaped or V-shaped wire or line.

wildcard  A symbol, usually used in searches, that represents a missing or unknown character or sequence of characters. In Capture, valid wildcard characters are an asterisk (*) to match multiple characters and a question mark (?) to match individual characters.

X axis  The horizontal or left-to-right direction in a two-dimensional system of coordinates. The X axis is perpendicular to the Y axis.

Y axis  The vertical or bottom-to-top direction in a two-dimensional system of coordinates. The Y axis is perpendicular to the X axis.

zoom  To change the view of a window, making the objects appear larger or smaller. When you zoom out, the objects are smaller and you see more of the schematic page or part. When you zoom in, the objects are larger, but you see less of the schematic page or part.

zoom factor  The amount by which the zoom scale is multiplied or divided when you choose Zoom In or Zoom Out on the schematic page editor’s View menu. The Zoom factor is normally 2, but you can change it using the Preferences command on the Options menu. For example, a zoom scale of two makes the image of the screen twice as large when you zoom in and half as large when you zoom out.

zoom scale  The relative size of the image on the screen, as a percentage of the normal size. For example, a zoom scale of 250% means the image on the screen is two and one-half times as large as normal.
Index

A
adding macros, 181
Annotate
   Annotate command, 250
toolbar, 17
Annotate dialog box, 249-250
annotation
   back, 306
   forward, 307
Arc command
tool palette button, 22
Archive Project command, 61
arcs
drawing, 162
resizing, 162
area selection, 28
attached implementation, 127, 137, 215
attached schematic folders, 111, 127, 137, 208, 215-216
descending, 208, 216
homogeneous package, 208, 216
in complex hierarchical designs, 109
in simple hierarchical designs, 107
attaching implementations to hierarchical blocks, 134
auto recovery, 58, 73, 75
AutoECO, 299
autoscrolling, defining, 69

B
Back Annotate command
toolbar, 17
back annotation, 306
BACKANNO.MAX file, 306
backslash, in root module folder icon, 7, 107
descending, in root module folder icon, 7, 107
bias point display
current, 323
disable, 323
enable, 323
toggle, 324
voltage, 324
bias point displays, 323
bidirectional, pin type, 221
Bill of Materials
command, 243-244, 275
toolbar, 18
dialog box, 277
include file format, 279
bitmaps
placing, 167
plotting, 101
Index

resizing, 167
Bookmark command, 195
bookmarks
jumping to, 195
placing, 195
properties, 30
renaming, 195
border visibility
defining for new designs, 84
Browse spreadsheet editor, 32
copying values within, 33
creating properties, 33
removing user-defined properties, 34
Bus command, 152
tool palette button, 20
bus entries, placing, 153
Bus Entry command, 153
tool palette button, 20
buses
editing, 148
names, 148, 152
placing, 148
user-defined properties, 30

C
CAPSYM.OLB, 112
Capture SDT Compatibility, 89
CAPTURE.INI, 123
character formatting, 173
circles
drawing, 161
resizing, 161
Clear Session Log command, 14
Close Project command, 59
colors
defining for graphics, 73
defining for objects, 67
defining for VHDL syntax, 76
defining preferences, 66
commands
Annotate, 17
Arc, 22
Back Annotate, 17
Bill of Materials, 18
Bus, 20
Bus Entry, 20
Clear Session Log, 14
Close Project, 59, 61
Copy, 16
Create Netlist, 17
Cross References, 18
Cut, 16
Design Properties, 63
Design Rules Check, 17
Design Template, 63
Ellipse, 21
Exit, 59
Export Design, 284, 295
Export Properties, 286
Find, 14
Ground, 20
Group, 29
Help Topics, 18
Hierarchical Block, 21
Hierarchical Pin, 21
Hierarchical Port, 21
IEEE Symbol, 22
Import Design, 285
Import Properties, 290
Junction, 20
Line, 21
Net Alias, 20
New, 16
No Connect, 21
Off-Page Connector, 21
Open, 16, 55
Part, 20
Paste, 17
Pin, 23
Pin Array, 23
Polyline, 21
Power, 20
Preferences, 63
Print, 16
Rectangle, 21
Redo, 17, 49
Repeat, 49
Save, 16, 58-59
Schematic Page Properties, 63
Select All, 28
Status Bar, 26
Text, 22
Tool palette, 24
Toolbar, 18
Undo, 17, 49
Ungroup, 29
Wire, 20
Zoom All, 17
Index

Zoom Area, 17
Zoom In, 17
Zoom Out, 17
complex hierarchy, 109
Configure Macro dialog box, 180
configuring macros, 179
Connectivity change, 151
Convert command, 214, 239
convert view of a part, 214, 239
Copy command, 166, 169, 173
toolbar, 16
Create Netlist
command, 208, 216, 243–244
toolbar, 17
dialog box, 272
format files, 273
creating macros, 175
cross probing, 308
Capture to Layout, 309
Layout to Capture, 310
Cross Reference
command, 244
toolbar, 18
dialog box, 281
custom libraries, 202
custom parts, 211
Cut command, 165, 173
toolbar, 16

D
De Morgan equivalent, 214
defining
auto recovery interval, 73
autoscrolling, 69
Capture settings, 63
colors, 66
colors for graphics, 73
colors for VHDL syntax, 76
fill style for graphics, 73
fonts for VHDL syntax, 76
grid display, 68
grid references, 93
highlighting for VHDL syntax, 76
line style for graphics, 73
line width for graphics, 73
macros
for display on Macro menu, 182
names, 180, 183
shortcut keys, 179, 181, 185
panning, 69
project manager fonts, 73
schematic page size, 92
schematic page units, 92
session log fonts, 73
text editor preferences, 76
TrueType fonts as strokes, 73
zoom factor, 69
deleting an object, 166
descending into attached schematic folders, 208, 216
deselecting, 27
design cache, 206
Design Cache folder, 6
design folder, 6
design process, 243
Design Properties
command, 63
dialog box
Fonts tab, 89
Hierarchy tab, 89
Miscellaneous tab, 91
SDT Compatibility tab, 89
dialog box, Hierarchy tab, 208
Design Resources folder, 6, 53–54, 285
Design Rules Check
command, 244
toolbar, 17
scope, 259
design rules violations, checking for, 244
design structure
complex hierarchical, 109
flat, 106
hierarchical, 107
simple hierarchical, 107
Design Template
command, 63
dialog box
Fonts tab, 79
Grid Reference tab, 84
Hierarchy tab, 86
Page Size tab, 82
SDT Compatibility tab, 87
Title Block tab, 80
dialog box, Hierarchy tab, 208
designator, 248
designs
exporting to a file, 284, 295
importing to a project, 285
opening, 55
Index

dialog boxes
  Configure Macro, 180
  Export Design
    DXF tab, 284
    EDIF tab, 284
  Exporting Properties, 287
  Import Design
    Custom tab, 285
    EDIF tab, 285
    PSpice tab, 285
  Import Properties, 291
  Macro Name, 179
displaying invisible power pins, 228
drag, maximum number of objects displayed, 71
drawing
  adding fill, 164
  arcs, 162
  circles, 161
  ellipses, 161
  lines, 159
  polygons, 163
  polylines, 163
  rectangles, 160
  squares, 160
  DRC markers, 245
  properties, 30
drivers
  plotter, 95
  printer, 95
  DXF, 283

E

ECO, 299
  Run ECO to Layout, 299
EDIF, 283
  configuration files, 285-286
  editing, 30
  ground symbols, 131
  hierarchical blocks, 138
  off-page connectors, 147
  power symbols, 131
  properties, 30
  property files, 288
  user-defined properties, 30
Ellipse command
  tool palette button, 21
  ellipses
drawing, 161

resizing, 161
Exit command, 59
Export Design
  command, 284
dialog box
  DXF tab, 284
  EDIF tab, 284
Export Properties
  command, 244, 286
dialog box, 287
exporting
designs, 284, 295
  libraries, 284, 295
  properties, 244, 286
text, 173
extensions for filenames
  .INI, 63
  .OLB, 81

F

file extensions
  .INI, 63
  .OLB, 81
  .SWP, 306
file formats
  DXF, 283
  EDIF, 283
  include file, Bill of Materials
    command, 279
  netlist format files, 273
  property file, 288
  PSpice, 283
  Schematics, 283
File tab, 9
file types
  back annotation files, 306
  netlist files, 303
  swap files, 306
files
  auto recovery, 73
  BACKANNO.MAX, 306
  DXF, 283
  EDIF, 283
  configuration files, 285-286
  LAYOUT.INI, 303
  MSIM.INI, 286
  opening, 55
  property, 288
Index

PSpice, 283
MSIM.INI, 286
Schematics, 283

fill style, 157
  defining for graphics, 73
fill, adding to a graphic object, 164
Filter list, 301
Find command, 14
  finding
    parts in a design, 198
    parts on a schematic page, 198
flat designs, 106
  off-page connectors, 106
folders
  Design Cache folder, 6
  design folder, 6
  Design Resources, 53–54, 285
  Design Resources folder, 6
  Library, 285
  Library folder, 6
  Outputs folder, 6
  schematic folders, 6
  schematics, 51

fonts
  changing placed text, 173
  defining for existing designs, 89
  defining for new designs, 79
  defining for VHDL syntax, 76
  project manager, 73
  session log, 73
  TrueType, 73
footprint, 127, 272, 303
format files
  netlist, 273
forward annotation, 307

G
Gate and Pin Swap
  command, 244
Generate Part
  command, 295
global power pins, 91
globals, 127, 221, 227
Go To
  command, 192
  dialog box
    Bookmark tab, 196

Grid Reference tab, 194
Location tab, 193
Grid command, 197
grid display
  dots or lines, 68
  setting visibility, 68
  snap-to-grid, 68
grid references
  defining for new designs, 84
  displaying or hiding, 197
Grid References command, 197
grid spacing, defining, 62
Ground command, 129
tool palette button, 20
ground pins, 227
ground symbols, placing, 131
Group command, 29
grouping, 29

H
Help Topics command
toolbar, 18
heterogeneous package, 203, 208–210
Hierarchical Block command
tool palette button, 21
hierarchical blocks
  attached implementation, 134, 137
  complex hierarchical designs, 109
  hierarchical designs, 107
  nets between schematic folders and schematic pages, 110
  placing, 138
  simple hierarchical designs, 107
  user-defined properties, 30
hierarchical designs, 107
  complex, 109
  hierarchical blocks, 107
  simple, 107
Hierarchical Pin
  command, 142
  tool palette button, 21
hierarchical pins, 111
  nets between schematic folders and schematic pages, 110
  off-grid, 141
Hierarchical Port command, 139
tool palette button, 21
hierarchical ports, 111
Index

nets between schematic folders and schematic pages, 110
placing, 139
properties, 30
hierarchy, 107, 208, 216
attached implementation, 127, 134, 215
complex, 109
defining for existing designs, 89
defining for new designs, 86
Hierarchy tab, 9
placing hierarchical blocks, 134
simple, 107
highlighting
defining for VHDL syntax, 76
homogeneous package, 203, 209–210
attaching schematic folders, 208

I
IEEE Symbol command, 217
tool palette button, 22
IEEE symbols
adding to a part, 217
Import Design
command, 285
dialog box
Custom tab, 285
EDIF tab, 285
PSpice tab, 285
Import Properties
command, 244, 290
dialog box, 291
importing
designs, 285
libraries, 285
properties, 244, 290
text, 172
include file format, 279
input, pin type, 221
instance properties, 31
instances, 31, 35–36
in the property editor, 36
intertool communication (ITC)
enabling in Capture, 308
enabling in Layout, 308

J
jumping
to a bookmark, 195
to a grid reference, 194
to a marked location, 195
to a new location, 192
Junction command
tool palette button, 20
junctions, 149

L
LAYOUT.INI file, 303
libraries, 202
copying parts to a different library, 202
custom, 202
exporting to a file, 284, 295
importing to a project, 285
moving parts to a different library, 202
opening, 55
Library folder, 6, 285
Line command
tool palette button, 21
line style, 157
defining for graphics, 73
line width, defining for graphics, 73
lines
drawing, 159
resizing, 159

M
Macro Name dialog box, 179
macros
adding, 181
configuring, 179
creating, 175
defining
for display on Macro menu, 182
shortcut keys, 181, 185
defining shortcut keys, 179
naming, 180, 183
playing, 178
recording, 177
removing, 181
saving, 181
shortcut key assignments, 185
temporary, 175
Mirror command, 164
Most Recently Used (MRU) list, 119
MRU list, 119
multiple objects, selecting, 27
multiple-part packages, 203
  creating, 211

N
naming macros, 180, 183
Net Alias command
  tool palette button, 20
net aliases, 148, 152
  creating, 150
  editing, 151
net names, 148
netlist
  creating, 244
  creating for Layout, 303
  creating for simulation, 271
  format files, 273
netname
  resolution, 274
nets
  hierarchical blocks, between schematic folders
    and schematic pages, 110
  hierarchical pins, between schematic folders
    and schematic pages, 110
  hierarchical ports, between schematic folders
    and schematic pages, 110
  off-page connectors, between schematic pages
    in a single schematic, 110
  properties, 30
  user-defined properties, 30
New command
  toolbar button, 16
New Part command, 211
New Part Properties dialog box, 214
Next Part command, 234
No Connect command, 132
  tool palette button, 21
nonprimitive parts, 118, 208, 216

O
occurrence properties, 31
occurrences, 31-32, 35-36
  in the property editor, 36
Off-Page Connector command, 144
  tool palette button, 21
off-page connectors, 112
  in flat designs, 106
  example, 113
  nets between schematic pages in a single
    schematic, 110
  placing, 147
  properties, 30
  open collector, pin type, 221
  Open command, 55
    toolbar button, 16
  open emitter, pin type, 221
  output, pin type, 221
  Outputs folder, 6

P
Package command, 234-235
package view, part editor, 12
packages, 117, 203
  editing, 235
  heterogeneous, 203, 209
  homogeneous, 203, 209
  attaching schematic folders, 208
  plotting, 97
  printing, 97
  user-defined properties, 30
  viewing, 234
page size
  defining for new designs, 82
panning, defining, 69
Part command, 119
  tool palette button, 20
part editor, 12
  package view, 12
  part view, 12
  tool palette, 22, 157
part instances, 206
  editing, 230
  user-defined properties, 30
part reference, 248
part view, part editor, 12
parts
  attached schematic folders, 107, 109, 111
  convert view, 214, 239
  copying to a different library, 202
  editing
    in a library, 229
    on a schematic page, 230
  finding, 198
  heterogeneous package, 203, 209
  homogeneous package, 203, 209
attaching schematic folders, 208
IEEE symbols, placing, 217
instances, 206
instances and occurrences, 204
library of origin, 229
moving to a different library, 202
multiple-part packages, 203
packages, 203
part body, 211
part body border, 211
part reference, 215
PCB footprint, 214
pins, placing, 218
plotting, 97
printing, 97
properties, 30
user-defined properties, 30
passive, pin type, 221
Paste command, 166
tool bar, 17
PCB footprint property, 127, 272, 303
PCB footprints, 301
Picture command, 167
Pin Array command, 223
tool palette button, 23
Pin command, 218
tool palette button, 23
pin names rotate, 233
pin names visible, 219, 233
pin numbers visible, 219, 233
pins
connecting to wires, 149
ground, 227
invisible, displaying, 228
name, 220
number, 220
placing multiple, 223
placing on a part, 218
power, 227
properties, 30
shape, 221
shared, 209, 227
types, 221
user-defined properties, 30
visibility, 220, 227
width, 220
pin-to-pin spacing, defining for new designs, 82
Place Ground Symbol dialog box, 130
Place Off-Page Connector dialog box, 146
Place Part dialog box, 121
Place Pin Array dialog box, 225
Place Pin dialog box, 220
Place Power Symbol dialog box, 130
placing
bitmaps, 167
bus entries, 153
ground symbols, 131
hierarchical blocks, 138
hierarchical pins, 142
off-page connectors, 147
power symbols, 131
text, 168
playing macros, 178
plotting, 95
bitmaps, 101
drivers, 95, 101
HPGL emulation, 101
parts or packages, 97
pen colors, 101
previewing, 99
rendering TrueType fonts as strokes, 73
scaling output, 100
schematic pages, 96
polygons
drawing, 163
resizing, 163
Polyline command
tool palette button, 21
polylines
drawing, 163
resizing, 163
pop-up menus, 10
power
pins, 227
type, 221
visibility, 91, 127
symbols, 131
Power command, 128
tool palette button, 20
Preferences
command, 63
dialog box
Colors tab, 27
Colors/Print tab, 66
Grid Display tab, 68
Miscellaneous tab, 73
Pan and Zoom tab, 69
Index

Select tab, 28, 71
Text Editor tab, 76
dialog box, Pan and Zoom tab, 188
prepare design for Layout, 301
previewing print output, 99
Previous Part command, 234
primitive parts, 118, 208
Primitive property, 127, 208, 216
  Default option, 208, 216
  on hierarchical blocks, 136
Print command, 96
toolbar, 16
print options, 66
Print Preview command, 99
Print Setup command, 95
printing, 95
  disabling printing of individual objects, 66
drivers, 95
  parts or packages, 97
previewing, 99
  rendering TrueType fonts as strokes, 73
scaling output, 100
schematic pages, 96
session log, 98
setting up, 95
text editor, 98
Programmer’s editor, 13
project manager
  File tab, 9
  folders
    Design Cache folder, 6
design folder, 6
  Design Resources folder, 6
  Library folder, 6
  Outputs folder, 6
font, 73
Hierarchy tab, 9
pop-up menus, 10
schematic folders, 6
schematic pages, 6
toolbar, 18
projects
  adding files, 57
archiving, 61
closing, 59
deleting files, 57
  folders
    Design Resources, 53–54, 285
    Library, 285
    schematics, 51
opening, 55
saving, 58
properties
  add Layout properties, 301
copying, 33
  creating, 33, 43
deleting, 44
displaying, 45
  editing, 30, 44, 243
ing  302
etting a property file, 288
exporting, 288
exporting to a file, 244
importing, 290
importing from a file, 244
Layout net properties, 302
Layout part properties, 302
Layout pin properties, 302
removing, 34
replacing values, 34
spreadsheet editor, 243
user-defined, 30
properties, adding user-defined, 302
property editor, 35, 126
  creating a new property, 43
deleting a property, 44
displaying properties, 44
ing  302
etting a property value, 44
ing  302
editing values for all instances and occurrences
  filters, 37
  key points regarding, 43
property editor filter, 301
property file format, 288
PSpice, 283, 313–322
R
recording macros, 177
Rectangle command
tool palette button, 21
rectangles
drawing, 160
resizing, 160
Redo command, 49
toolbar, 17
redoing actions, 49
reference designator, 248
removing macros, 181
Repeat command, 49
repeating actions, 49
Replace Cache command, 205
replacing a part instance in the design cache, 205
reports
  bill of materials, 244, 275
cross reference, 244
reversing actions, 49
root module, 7, 107
Rotate command, 165
Run ECO to Layout, 299

S
Save command, 58–59
toolbar button, 16
saving macros, 181
scaling
  plotter output, 100
  printer output, 100
schematic folders, 6, 51
  attaching to a part, 216
schematic page editor, 11
  displaying the property editor, 35
tool palette, 157
Schematic Page Properties command, 63
dialog box
  Grid References tab, 93
  Miscellaneous tab, 93
  Page Size tab, 92
schematic page size
  defining for new designs, 82
schematic pages, 6
  creation date, 93
  defining grid references, 93
  defining page size, 92
  defining units, 92
  modification date, 93
plotting, 96
printing, 96
Schematics, 283
screen fonts, 174
scrolling
  defining auto scroll percent, 69–70
  scroll percent, 69
SDT compatibility with Capture, 87, 89
Select All command, 28
selecting
  all objects, 28
  area, 28
deselecting, 27
  multiple objects, 27
  one object, 27
selection border, intersect or enclosed, 71
selection color, 27
selection options
  defining, 71
session frame, 4
session log, 14
  font, 73
  printing, 98
shared pins, 209, 227
shine through, 204
shortcut key assignments for macros, 185
simple hierarchy, 107
  example, 113
simulation
  creating a netlist for, 271
snap-to-grid
toolbar, 18
snap-to-grid, defining, 68
spreadsheet editor, 243
squares
  drawing, 160
  resizing, 160
status bar, 25
  visibility, 26
Status Bar command, 26
swapping gates or pins, 244
symbol, 12
symbol editor, 12

T
tab spacing, defining for text editor, 76
temporary macros, 175
text
  bounding box, 170
  character formatting, 173
deleting, 170
  editing, 170
exporting, 173
finding, 171
importing, 172
moving, 168
placing, 168
rendering TrueType fonts as strokes, 73
replacing, 172
Index

rotating, 169
Text command, 168, 173
tool palette button, 22
text editor, 13
defining preferences, 76
printing, 98
three-state, pin type, 221
title block
properties, 30
title block date format, 90
title blocks, 202
choosing, 80
default information, 80
defining for new designs, 80
settings, 80
visibility, 80
defining for new designs, 84
tool palette
part editor, 19, 157
IEEE Symbol command, 22
Pin Array, 23
Pin command, 23
schematic page editor, 19, 157
Arc command, 22
Bus command, 20
Bus Entry command, 20
Ellipse, 21
Ground command, 20
Hierarchical Block, 21
Hierarchical Pin, 21
Hierarchical Port, 21
Junction command, 20
Line command, 21
Net Alias command, 20
No Connect command, 21
Off-Page Connector command, 21
Part command, 20
Polyline command, 21
Power command, 20
Rectangle command, 21
selection tool, 20
Text command, 22
Wire command, 20
visibility, 24, 71
Tool palette commands, 24
toolbar, 16
Annotate command, 17
Back Annotate command, 17
Bill of Materials command, 18
Copy command, 16
Create Netlist command, 17
Cross References command, 18
Cut command, 16
Design Rules Check command, 17
Help Topics command, 18
MRU list, 17
New command, 16
Open command, 16
Paste command, 17
Print command, 16
project manager tool, 18
Redo command, 17
Save command, 16
snap-to-grid tool, 18
Undo command, 17
visibility, 18
Zoom All command, 17
Zoom Area command, 17
Zoom In command, 17
Zoom Out command, 17
U
Undo command, 49
toolbar, 17
undoing actions, 49
ungroup, 29
Ungroup command, 29
unit of measure
defining for new designs, 82
Update Cache command, 207
Update Part References command, 244
Update Properties command, 244
dialog box, 253
updating
part references, 244
properties, 244
selected parts in the design cache, 207
user-defined properties, 30
V
VHDL files
creating, 13
opening, 55
viewing, 13
VHDL syntax
Index

defining colors, 76
defining fonts, 76
defining highlighting, 76
viewing
centering, 191
entire page or part, 191
selected area, 189
visibility
power pins, 91, 127
status bar, 26
tool palette, 24, 71
toolbar, 18

W
window
active, 4
part editor, 12
project manager, 6
schematic page editor, 11
session frame, 4
session log, 14
text editor, 13
Wire command, 149
tool palette button, 20
wires
editing, 148
placing, 148

Z
Zoom All command, 191
toolbar, 17
Zoom Area command, 189
toolbar, 17
zoom factor, 188
defining, 69-70
Zoom In command, 188
toolbar, 17
Zoom Out command, 188
toolbar, 17
zoom scale, 189
zooming, 69, 188