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About This Manual

Use thismanual asatutoria to familiarize yourself with the LabVIEW graphical programming
environment and the basic LabVIEW features you use to build data acquisition and instrument
control applications.

This manual contains exercises that you can use to learn how to develop basic applicationsin
LabVIEW. These exercisestake ashort amount of timeto complete and help you get started with
LabVIEW.

The end of each chapter includes a summary of the main concepts taught in that chapter. Use
these summaries to review what you learned.

Related Documentation

Thefollowing documents contain information that you may find helpful asyou read thismanual:

e LabVIEW Installation Guide—Refer to this guide for information about installing
LabVIEW, modules and toolkits, drivers, and hardware.

e LabVIEW Help—Usethe LabVIEW Help to access information about LabVIEW
programming concepts, step-by-step instructions for using LabVIEW, and reference
information about LabVIEW Vs, functions, palettes, menus, tools, properties, methods,
events, dialog boxes, and so on. The LabVIEW Help also liststhe LabVIEW documentation
resources available from National Instruments. Accessthe LabVIEW Help by selecting
Help»LabVIEW Help.

e LabVIEW Quick Reference Card—Use this card as a reference for information about
keyboard shortcuts and help resources.

© National Instruments | ix



Getting Started with
LabVIEW Virtual Instruments

LabVIEW programs are called virtual instruments, or VIs, because their appearance and
operation imitate physical instruments, such as oscilloscopes and multimeters. LabVIEW
contains a comprehensive set of tools for acquiring, analyzing, displaying, and storing data,
aswell astoolsto help you troubleshoot code you write.

In LabVIEW, you build a user interface, or front panel, with controls and indicators. Controls
are knobs, push buttons, dials, and other input mechanisms. Indicators are graphs, LEDs, and
other output displays. After you build the front panel, you add code using Vs and structures to
control the front panel objects. The block diagram contains this code.

You can use LabVIEW to communicate with hardware such as data acquisition, vision, and
motion control devices, aswell as GPIB, PXI, VXI, RS232, and R$485 instruments.

Building a Virtual Instrument

In the following exercises, you will build aVI that generates asignal and displaysthat signal in
agraph. After you complete the exercises, the front panel of the VI will look similar to the front
panel in the following figure.

You can complete the exercises in this chapter in approximately 40 minutes.

Figure 1-1. Front Panel of the Acquiring a Signal VI
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Chapter 1 Getting Started with LabVIEW Virtual Instruments

Launching LabVIEW

The Getting Started window appears when you launch LabVIEW. Use this window to create
new projects and open existing files. Y ou also can access resources to expand the capability of
LabVIEW and information to help you learn about LabVIEW.

The Getting Started window disappears when you open an existing file or create anew fileand
reappears when you close al open front panels and block diagrams. You a so can display the
window from the front panel or block diagram by selecting View»Getting Started Window.

Opening a New VI from a Template

LabVIEW providesbuilt-intemplate VIsthat includethe subV1s, functions, structures, and front
panel objects you need to get started building common measurement applications.

Complete the following steps to create a V1 that generates a signal and displaysit in the front
panel window.

1. Launch LabVIEW.
2. Select File»New to display the New dialog box.

3. FromtheCreate New list, select VI»From Template»Tutorial (Getting Started)»
Generate and Display. Thistemplate VI generates and displays asignal.

A preview and abrief description of thetemplate V1 appear in the Description section. The
following figure shows the New dialog box and the preview of the Generate and Display
template VI.

1-2 | ni.com



Getting Started with LabVIEW

Figure 1-2. New Dialog Box
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4. Click the OK button to create a VI from the template. You also can double-click the name
of thetemplate VI in the Create New list to create a VI from atemplate.

LabVIEW displays two windows: the front panel window and the block diagram window.
5. Examine the front panel window.
Theuser interface, or front panel, appearswith agray background and includes controlsand

indicators. Thetitle bar of the front panel indicates that this window is the front panel for
the Generate and Display V1.

\é Note If thefront panel is not visible, you can display the front panel by selecting
Window»Show Front Panel. You also can switch between the front panel window
and block diagram window at any time by pressing the <Ctrl-E> keys. The <Ctrl>
key in keyboard shortcuts corresponds to the (Mac OS X) <Command> key or
(Linux) <Alt> key.
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Chapter 1 Getting Started with LabVIEW Virtual Instruments

6. Select Window»Show Block Diagram and examine the block diagram of the VI.

The block diagram appears with awhite background and includes Vs and structures that
control the front panel objects. Thetitle bar of the block diagram indicates that thiswindow
isthe block diagram for the Generate and Display VI.

7. Onthefront panel toolbar, click the Run button, shown below. You aso can pressthe

<Ctrl-R> keystorunaVl.

A sine wave appears on the graph in the front panel window.
8. Stopthe VI by clicking the front panel ST OP button, shown below.

STOR

Adding a Control to the Front Panel

Front panel controls simulate the input mechanisms on a physical instrument and supply datato
the block diagram of the VI. Many physical instruments have knobs you can turn to change an
input value.

Complete the following steps to add a knob control to the front panel.

@ Tip Throughout these exercises, you can undo recent edits by selecting Edit»Undo
or pressing the <Ctrl-Z> keys.

1. IftheControlspalette, showninFigure 1-3, isnot visiblein the front panel window, select
View»Controls Palette.

@ Tip You can right-click any blank spacein the front panel or the block diagram to
display atemporary version of the Controls or Functions palette. The Controls or
Functions palette appears with a thumbtack icon in the upper |eft corner. Click the
thumbtack to pin the palette so it is no longer temporary.
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Getting Started with LabVIEW

2. If youareanew LabVIEW user, the Controls palette opens with the M oder n palette,
shown in the following figure, visible by default. If you do not see the Moder n palette,
click Moder n on the Controls palette to display the Moder n palette.

Figure 1-3. Controls Palette
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Move the cursor over theicons on the M oder n palette to locate the Numeric Controls
palette.

When you move the cursor over icons on the Controls palette, the name of the subpalette,
control, or indicator appearsin atip strip below the icon.

A=

Note Some palette objects display ashort name on the palette that is different from
the name that appearsin the tip strip. The short name abbreviates the name of the

palette object so that it fitsin the space available on the palette. If you have difficulty
finding a palette object by its short name, use the Sear ch button on the Controls or
Functions paette to find the pal ette object by name.

Click the Numeric Controlsicon to display the Numeric Controls palette.

Click the Knob control onthe Numeric Contr ols pal ette to attach the control to the cursor,

and then add the knob to the front panel to the left of the waveform graph.
You will use thisknob in alater exercise to control the amplitude of asignal.

Select FilenSave Asand savetheVI asAacquiring a Signal.viinaneasily accessible
location.
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Chapter 1 Getting Started with LabVIEW Virtual Instruments

Changing a Signal Type
The block diagram has a blue icon labeled Simulate Signal. This icon represents the Simulate
Signal Express VI. An Express V1 is acomponent of the block diagram that you can configure

to perform common measurement tasks. The Simulate Signal Express VI simulates asinewave
by default.

Complete the following steps to change this signal to a sawtooth wave.
1. Display theblock diagram by pressing the <Ctrl-E> keys or by clicking the block diagram.

Locate the Simulate Signal Express VI, shown below. The Simulate Signal Express VI
simulates a signal based on the configuration that you specify.

.

[+ ¥
Simulate Signal
Sine ¥

2. Right-click the Simulate Signal Express VI and select Properties from the shortcut menu
to display the Configure Simulate Signal dialog box. (Mac OS X) Press <Ctrl>-click to
perform the same action as right-click.

@ Tip You also can double-click the Express V1 to display the Configure Simulate
Signal dialog box.

3. Select Sawtooth from the Signal type pull-down menu.

Thewaveform on the graph inthe Result Preview section changesto asawtooth wave. The
Configure Simulate Signal dialog box should appear similar to the following figure.
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Getting Started with LabVIEW

Figure 1-4. Configure Simulate Signal Dialog Box
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4. Click the OK button to save the current configuration and close the Configure Simulate
Signal dialog box.

5. Move the cursor over the down arrows at the bottom of the Simulate Signal Express VI.
The down arrowsindicateyou canreveal hidden inputsand outputs by extending the border
of the Express V1.

6. When adouble-headed arrow appears, shown below, click and drag the border of the
Express V1 to add two rows. When you release the border, the Amplitude input appears.
In Figure 1-4, noticethat Amplitudeisan optionin the Configure Simulate Signal dialog
box. When inputs, such as Amplitude, appear on the block diagram and in the
configuration dialog box, you can configure the inputs in either location.

—

Sawtooth v
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——
1 I
i ) i
_____ i )
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Chapter 1 Getting Started with LabVIEW Virtual Instruments

Wiring Objects on the Block Diagram

To usetheknob to change the amplitude of the signal, you must connect two objects on the block
diagram.

Complete the following steps to wire the knob to the Amplitude input of the Simulate Signal
ExpressVI.

1. Ontheblock diagram, move the cursor over the Knob terminal, shown below.

3
4

e
L

The cursor becomes an arrow, or the Positioning tool, shown below. Use the Positioning
tool to select, position, and resize objects.

%]

é Note You canresizeonly loopsand structureson the block diagram. Go to thefront
pandl to resize objects you have added to the front panel.

2. Usethe Positioning tool to select the Knob terminal and make sure it isto the left of the
Simulate Signal Express VI and inside the gray loop, shown below.

|

The terminals inside the loop are representations of front panel controls and indicators.
Terminals are entry and exit ports that exchange information between the front panel and
block diagram.

3. Deselect theKnob terminal by clicking ablank space on the block diagram. If you want to
use a different tool with an object, you must deselect the object to switch the tool.

4. Movethe cursor over the arrow on the Knob terminal, shown below.

The cursor becomes awire spool, or the Wiring tool, shown below. Use the Wiring tool to
wire objects together on the block diagram.

1-8 | ni.com



Getting Started with LabVIEW

5. When the Wiring tool appears, click the arrow on the Knob terminal and then click the
arrow onthe Amplitudeinput of the Simulate Signal Express V1, shown below, to wirethe
two objects together.

[ Simulate Signal
Sawkooth H
_i error ouk ¥
A wire appears and connects the two objects. Data flows along this wire from the Knob
terminal to the Express V1.
6. Select FilenSaveto savethe VI.
Running a VI

Running a V| executes the solution.

Complete the following steps to run the Acquiring a Signal VI.

1
2.

Display the front panel by pressing the <Ctrl-E> keys or by clicking the front panel.
Click the Run button or press the <Ctrl-R> keysto run the V1.

To indicate that the V1 is running, the Run button changes to a darkened arrow, shown
below. You can change the value of most controls while aVI runs, but you cannot edit the
V1 in other ways while the VI runs.

Move the cursor over the knob, hold the mouse button down, and turn the knob to adjust

the amplitude of the sawtooth wave.

The amplitude of the sawtooth wave changes as you turn the knob. Asyou change the
amplitude, the cursor displays atip strip that indicates the numeric value of the knob. The
y-axis on the graph scales automatically to account for the change in amplitude.

Click the STOP button, shown below, to stop the VI.

STOF

The STOP button stops the VI after the loop completesits current iteration. The Abort
Execution button, shown below, stopsthe VI immediately, before the VI finishes the
current iteration. Aborting a VI that uses external resources, such as external hardware,
might leave the resources in an unknown state by not resetting or rel easing them properly.
Design the VIs you create with a stop button to avoid this problem.

© National Instruments | 1-9



Chapter 1 Getting Started with LabVIEW Virtual Instruments

Modifying a Signal

Complete the following steps to scale the signal by 10 and display the resultsin the front panel

graph.

1. Intheblock diagram, use the Positioning tool to click the wire that connects the Simulate
Signal Express VI to the Waveform Graph terminal, shown below.

Simulate Signal
SawtEaEH ——
error out ¥

3

Pressthe <Delete> key to delete thiswire.

3. If the Functions palette, shown in the following figure, is not visible, select View»
Functions Palette to display it. The Functions palette opens with the Programming
palettevisible by default. Select the Expr ess palette by clicking Expresson the Functions
palette.
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Figure 1-5. Functions Palette
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Select a VL.

Onthe Arithmetic & Comparison palette, select the Formula Express VI, shown below,
and placeit on the block diagram between the Simulate Signal Express VI and the
Waveform Graph terminal. You can move the Waveform Graph terminal to theright to
make more room between the Express VI and the terminal.

Formula

The Configure Formula dialog box appears when you place the Express V1 on the block
diagram. When you place an Express VI on the block diagram, the configuration dial og box
for that VI aways appears automatically.
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Note If you place an object too close to another object on the block diagram,
automatic wiring might wire the two objects together. Delete the wiresif the
automatic wiring iswrong. To configure automatic wiring, select Tools»Options
then select Block Diagram from the Category list. Remove the checkmark from the
Enable auto wiring checkbox to turn off automatic wiring.

VW

5. Click the Help button, shown below, in the bottom right corner of the Configure Formula
dialog box to display the LabVIEW Help topic for this Express V1.

The Formula hel p topic describes the Express V|1, the configuration dial og box options, and
the inputs and outputs of the Express V1. Each Express VI has a corresponding help topic
you can access by clicking the Help button in the configuration dialog box or by
right-clicking the Express VI and selecting Help from the shortcut menu.

6. Inthe Formula topic, find the dialog box option whose description indicates that it entersa
variable into the formula.

7. Minimizethe LabVIEW Help to return to the Configur e For mula dialog box.

8. ChangethetextintheL abel column of thedialog box option you read about, shown below,
from x1 to sawtooth to indicate theinput value to the Formula Express V1. When you
click in the Formula text box at the top of the Configure Formula dialog box, the text
changes to match the label you entered.

Input Label

|

9. Definethe value of the scaling factor by entering *10 after Sawtooth in the Formula
text box.

You can usethe I nput buttonsin the configuration dialog box or you canusethe *, 1, and 0
keyboard buttons to enter the scaling factor. If you use the I nput buttonsin the
configuration dialog box, LabVIEW places the formulainput after the Sawtooth input

in the Formula text box. If you use the keyboard, click in the Formula text box after
Sawtooth and enter the formula you want to appear in the text box. The Configure
Formula dialog box should appear similar to the following figure.
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Figure 1-6. Configure Formula Dialog Box
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10.

11.
12.

the upper right corner turns from green to gray and displaysthe text Invalid
Formula.

Click the OK button to save the current configuration and close the Configure Formula
dialog box.

Move the cursor over the arrow on the Sawtooth output of the Simulate Signal Express V1.

When the Wiring tool appears, click the arrow on the Sawtooth output and then click
the arrow on the Sawtooth input of the Formula Express VI, shown below, to wire the
two objects together.

.

3 o
Simulate Signal Formula
Sawkeoth an
error out ¥ ~ by

"
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13. UsetheWiring tool to wire the Result output of the Formula Express VI to the Waveform

Graph terminal.

Examine the wires connecting the Express VIs and terminals. The arrows on the Express
Vs and terminalsindicate the direction that the data flows along these wires. The block
diagram should appear similar to the following figure. Use the block diagram figuresas a
reference. The arrangement of objects on your block diagram does not need to match the
figure exactly.

Figure 1-7. Block Diagram of the Acquiring a Signal VI

.

(d id
Simulate Signal Farmula waveform Graph
Knob Sawkooth Sawkooth

3 error out H Result Y
L = |

e F

skop

m B =

e

@ Tip You canright-click any wireand select Clean Up Wir e from the shortcut menu

to have LabVIEW automatically find aroute for the wire around existing objects on
the block diagram. LabVIEW also routes awire to decrease the number of bendsin
the wire. You also can click the Clean Up Diagram button on the block diagram
toolbar to have LabVIEW automatically reroute al existing wires and rearrange
objects on the block diagram to generate a cleaner look.

14. Pressthe <Ctrl-S> keys or select File»Save to save the V1.

Displaying Two Signals on a Graph

To compare the signal generated by the Simulate Signal Express VI and the signal modified by
the Formula Express V1 on the same graph, use the Merge Signals function.

Complete the following steps to display two signals on the same graph.

1

In the block diagram, move the cursor over the arrow on the Sawtooth output of the
Simulate Signal Express V1.

Use the Wiring tool to wire the Sawtooth output to the Waveform Graph terminal. The
Merge Signals function, shown below, appears where the two wires connect.

==

A functionisabuilt-in execution element, comparableto an operator, function, or statement
in atext-based programming language. The Merge Signals function takes the two separate
signals and combines them so that both can display on the same graph.
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The block diagram should appear similar to the following figure.
Figure 1-8. Block Diagram Showing the Merge Signals Function

5.

Simulate Signal Formula

‘Waveform Graph
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- el

Press the <Ctrl-S> keys or select File»Save to save the V1.
Return to the front panel, run the VI, and turn the knob control.

Thegraph plotsthe original sawtooth wave and the scal ed sawtooth wave with 10 timesthe
amplitude, as you specified in the Formula Express V1. The maximum value on the y-axis
automatically scales as you turn the knob.

Click the ST OP button to stop the V1.

Customizing a Knob Control

The knob control changes the amplitude of the sawtooth wave, so labeling it Amplitude
accurately describes the behavior of the knob.

Complete the following steps to customi ze the appearance of the knob.

1

Right-click the front panel knob and select Properties from the shortcut menu to
display the Knob Properties dialog box. Click the Appear ance tab to display the
Appear ance page.

In the Label section on the Appear ance page, delete the label knob, and enter
Amplitude in the text box.

© National Instruments | 1-15



Chapter 1 Getting Started with LabVIEW Virtual Instruments

The Knob Properties dialog box should appear similar to the following figure.
Figure 1-9. Knob Properties Dialog Box
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Click the Scale tab. In the Scale Style section, place acheckmark in the Show color ramp
checkbox.

The knob in the front panel window updates to reflect these changes.

Click the OK button to save the current configuration and close the Knob Properties
dialog box.

Savethe VI.

Reopen the Knob Properties dialog box and experiment with other properties of the knob.
For example, on the Scale page, try changing the colors for the Marker text color by
clicking the color box.

Click the Cancel button to avoid applying any changes you made while experimenting. If
you want to keep the changes you made, click the OK button.
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Customizing a Waveform Graph

The waveform graph indicator displays the two signals. To indicate which plot is the scaled
signal and which isthe smulated signal, you can customize the plots.

Complete the following steps to customize the appearance of the waveform graph indicator.

1. Inthefront panel window, move the cursor over thetop of the plot legend on the waveform
graph.
Though the graph has two plots, the plot legend displays only one plot.

2. When adouble-headed arrow appears, shown in the following figure, click and drag the
border of the plot legend to add oneitem to the legend. When you rel ease the mouse button,
the second plot name appears.

Figure 1-10. Expanding a Plot Legend
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Amplitude
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0.0E+0 2.0E-2 4.0E-2 6,0E-2 8.0E-2 1.0E-1
Tirne:

3. Right-click the waveform graph and select Properties from the shortcut menu to display
the Graph Properties dialog box.

4. Onthe Plots page, select Sawtooth from the top pull-down menu. In the Color s section,
click the Line color box to display the color picker. Select anew line color.

5. Select Sawtooth (Formula Result) from the top pull-down menu.

6. Place acheckmark in the Do not use waveform namesfor plot names checkbox. This
action lets you edit the labels on the graph.

7. Inthe Nametext box, delete the current label and change the name of thisplotto scaled
Sawtooth.

8. Click the OK button to save the current configuration and close the Graph Properties
dialog box.

The plot color and plot legend change.
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9. Reopen the Graph Properties dialog box and experiment with other properties of the
graph. For example, on the Scales page, try disabling automatic scaling and changing the
minimum and maximum value of the y-axis.

10. Click the Cancel button to avoid applying any changes you made while experimenting. I
you want to keep the changes you made, click the OK button.

11. SaveandclosetheVI.

Summary

The following topics are a summary of the main concepts you learned in this chapter.

Front Panel

The front panel isthe user interface of a V1. Y ou build the front panel by using controls and
indicators, which are the interactive input and output terminals of the V1, respectively. Controls
and indicators are located on the Controls palette.

Controls are knabs, push buttons, dials, and other input mechanisms. Controls simulate
instrument input mechanisms and supply data to the block diagram of the VI.

Indicators are graphs, LEDs, and other displays. Indicators simulate instrument output
mechanisms and display data the block diagram acquires or generates.

Block Diagram

The block diagram contains the graphical source code, also known as G code or block diagram
code, for how the VI runs. The block diagram code uses graphical representations of functions
to control the front panel objects. Front panel objects appear as icon terminals on the block
diagram. Wires connect control and indicator terminalsto Express Vs, Vls, and functions. Data
flowsthrough the wiresin the following ways: from controlsto VIsand functions, from ViIsand
functions to indicators, and from Vs and functions to other VIs and functions. The movement
of data through the nodes on the block diagram determines the execution order of the VIsand
functions. This movement of data is known as dataflow programming.

Front Panel and Block Diagram Tools

The Positioning tool appearswhen you move the cursor over an object in the front panel window
or on the block diagram. The cursor becomes an arrow that you can use to select, position, and
resize objects. The Wiring tool appears when you move the cursor over aterminal of ablock
diagram abject. The cursor becomes a spool that you can use to connect objects on the block
diagram through which you want data to flow.

Running and Stopping a VI

Running a V| executes the solution of the VI. Click the Run button or press the <Ctrl-R> keys
torunaVI. The Run button changes to adarkened arrow to indicate the VI is running. Y ou can
stopaVI immediately by clicking the Abort Execution button. However, aborting aV| that uses
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external resources might |eave the resourcesin an unknown state. Design the VIsyou createwith
a stop button to avoid this problem. A stop button stopsa VI after the VI completesits current
iteration.

Express Vls

Use Express Vislocated on the Functions palette for common measurement tasks. When you
place an Express VI on the block diagram, the dialog box you use to configure that Express VI
appears by default. Set the options in this configuration dialog box to specify how the Express
V| behaves. Y ou a so can double-click an Express V1 or right-click an Express VI and select
Properties from the shortcut menu to display the configuration dialog box. If you wire datato
an Express V1 and run it, the Express V1 displaysreal datain the configuration dialog box. I
you close and reopen the Express V1, the V1 displays sample datain the configuration dialog box
until you runthe VI again.

Express Vs appear on the block diagram as expandable nodes with icons surrounded by ablue
field. You can resize an Express V| to display itsinputs and outputs. Theinputsand outputs you
can display for the Express VI depend on how you configure the V1.

LabVIEW Documentation Resources

The LabVIEW Help containsinformation about LabVIEW programming concepts, step-by-step
instructions for using LabVIEW, and reference information about LabVIEW Vs, functions,
palettes, menus, tools, properties, methods, events, dialog boxes, and so on. The LabVIEW Help
asoliststheLabVIEW documentation resourcesavailablefrom National | nstruments. To access
help information for Express Vs, click the Help button in the configuration dialog box while
you configure an Express V1. Y ou aso can access the LabVIEW Help by right-clicking aV| or
function on the block diagram or on a pinned pal ette and selecting Help from the shortcut menu
or by selecting Help»L abVIEW Help.

After youinstall aLabVIEW add-on such as atoolkit, module, or driver, the documentation for
that add-on appearsin the LabVIEW Help or appears in a separate help system you access by
selecting Help»Add-On Help, where Add-On Help isthe name of the separate help system for
the add-on.

Property Dialog Boxes

Use property dialog boxes or shortcut menusto configure how controls and indicators appear or
behave in the front panel window. Right-click acontrol or indicator on the front panel and select
Pr opertiesfrom the shortcut menu to access the property dialog box for that object. Y ou cannot
access property dialog boxes for a control or indicator when a VI isrunning.

© National Instruments | 1-19



Chapter 1 Getting Started with LabVIEW Virtual Instruments

Shortcuts
This chapter introduced the following keyboard shortcuts.

Note The<Citrl>key in shortcuts correspondsto the (Mac OS X) <Command> key
or (Linux) <Alt> key.

Shortcut Function
<Ctrl-R> RunsaVI.
<Ctrl-Z> Undoes the last action.
<Ctrl-E> Switches between the block diagram and the front panel
window.
<Ctrl-S> SavesaVl.
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Y ou can choose one of many LabVIEW template VIsto use as a starting point when building
Vls. However, sometimes you need to build aVI for which atemplate is not available. This
chapter teaches you how to build and customize a VI without using a template.

Building a VI from a Blank VI

In the following exercises, you will open ablank V1 and add structures and Express VIsto the

block diagram to build anew V1. Youwill build aVI that generates asignal, reduces the number
of samplesinthesignal, and displaystheresulting datain afront panel table. After you complete
the exercises, the front panel of the VI will look similar to thefront panel in thefollowing figure.

You can complete the exercises in this chapter in approximately 45 minutes.

Figure 2-1. Front Panel of the Reduce Samples VI
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Opening a Blank VI

If no template is available for the VI you want to build, you can start with a blank VI and add
Express Vs to accomplish a specific task.
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Complete the following steps to open ablank V1.

1

In the Getting Started window, click the Create Project button to display the Create
Project dialog box.

The Create Project dialog box provides common starting points for LabVIEW projects.
Select Blank VI from thelist of items and click Finish.

A blank front panel window and block diagram window appear.

Display the block diagram.

If the Functions paletteis not visible, right-click any blank space on the block diagram to
display atemporary version of the Functions palette. Click the thumbtack, shown below,
in the upper left corner of the Functions palette to pin the palette so it is no longer

temporary.

Adding an Express VI That Simulates a Signal

Complete the following steps to find the Express VI you want to use and add it to the block
diagram.

1

Select Help»Show Context Help from the front panel or the block diagram to display the
Context Help window, shown in Figure 2-2. You also can click the Show Context Help
Window button, shown below, on the front panel or block diagram toolbar to display the
Context Help window.

Figure 2-2. Context Help Window

Context Help =

To get helpful information about a node,

move the cursor anta it

x :[%— xy
Add
-
EREE >
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@ Tip You also can press the <Ctrl-H> keys to display the Context Help window.

(Mac OS X) Press the <Command-Shift-H> keys.

On the Functions palette, select the Express» nput palette and move the cursor over
one of the Express VIs on the I nput palette.

When you move the cursor over a VI, the Context Help window displays information
about that V1.
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Use the information that appears in the Context Help window to find the Express V1 that
can simulate a sine wave signal.

Keep the Context Help window open. The context help provides useful information asyou
complete the rest of this exercise.

Select the Express V1 that can simulate asinewave signal and placeit on the block diagram.
The Configure Simulate Signal dialog box appears.

Move the cursor over the various options in the Configure Simulate Signal dialog box,
such asFrequency (Hz) and Amplitude. Read theinformation that appearsin the Context
Help window.

Configure the Simulate Signal Express V1 to generate a sine wave with a frequency of
10.7 Hz and an amplitude of 2.

Thesignal in the Result Preview window changes to reflect the configured sine wave.

Click the OK button to save the current configuration and close the Configure Simulate
Signal dialog box.

Movethe cursor over the Simulate Signal Express VI and read the information that appears
in the Context Help window.

The Context Help window displays information about how you configured the Simulate
Signal Express VI in addition to the standard context help description.

Savethe V] asReduce Samples.vi inan easily accessible location.

Searching the Help and Modifying a Signal

Completethefollowing stepsto usethe LabVIEW Help to search for the Express V| that reduces
the number of samplesin asignal.

1

On the block diagram, move the cursor over the Simulate Signal Express VI to display the
Context Help window and click the Detailed help link to display the Simulate Signal
Express VItopic inthe LabVIEW Help. You might have to enlarge or scroll down in the
Context Help window to see the Detailed help link.

You also can access the LabVIEW Help by right-clicking a VI or function on the block
diagram or on a pinned palette and selecting Help from the shortcut menu or by selecting
Help»LabVIEW Help.

Click the Sear ch tab, enter sample compressionintheTypeintheword(s)tosearch
for text box, and press the <Enter> key. You can place quotation marks around the phrase
to search for the exact phrase. For example, you can enter "sample compression" to
narrow the search results.

Thisword choice reflects what you want this Express VI to do—compress, or reduce, the
number of samplesinasignal.

You aso can click the Index tab to search keywords and concepts.

Double-click the Sample Compr ession topic in the search results to display the topic that
describes the Sample Compression Express V1.

After you read the description of the Express V1, return to the block diagram.
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5. Pressthe <Ctrl-Space> keys to open the Quick Drop dialog box. (Mac OS X) Pressthe
<Command-Shift-Space> keys.

When you know which item you want to add to the block diagram or front panel, you can
use the Quick Drop diaog box to quickly find the item and add it to the block diagram or
front panel.

@ Tip You can speed up theinitial launch of the Quick Drop dialog box by enabling
the Load palettes during launch radio button on the Controls/Functions Palette
page of the Options dialog box. Selecting to load palettes while LabVIEW launches
might slow down the launching of LabVIEW dlightly.

6. Enter sample Compression intothe Quick Drop dialog box, press <Enter>, and place
the Sample Compression Express V1 on the block diagram.

7.  Configure the Sample Compression Express VI to reduce the signal by afactor of 25, and
set the reduction method to M ean.

8. Click the OK button to save the current configuration and close the Configure Sample
Compression dialog box.

9. UsetheWiringtool to wirethe Sine output of the Simulate Signal ExpressV1 tothe Signals
input of the Sample Compression Express V1.

Customizing a User Interface from the Block Diagram

Inthe previous exercises, you added controlsand indicatorsto the front panel using the Controls
palette. Y ou also can create controls and indicators from the block diagram.

Complete the following steps to create controls and indicators from the block diagram.

1.  Ontheblock diagram, right-click the M ean output of the Sample Compression Express V|1
and select Create»Numeric Indicator from the shortcut menu to create a numeric
indicator. A Mean indicator shown below, appears on the block diagram.

2. Right-click the M ean output of the Sample Compression Express VI and select I nsert
Input/Output from the shortcut menu to insert the Enable input.

In previous exercises, you learned to add inputs and outputs by expanding the Express VI
using the down arrows. Using the shortcut menu isadifferent way to display and select the
inputs and outputs of an Express VI.
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Right-click the Enable input and select Create»Control from the shortcut menu to create
aswitch. A Boolean control, shown below, appears on the block diagram.

Ensble

TF

Control terminals have athicker border than indicator terminals. Also, an arrow appearson
theright of the terminal if the terminal is acontrol, and an arrow appears on the left of the
terminal if the terminal is an indicator.

Right-click the wire that connects the Sine output of the Simulate Signal Express VI to the
Signalsinput of the Sample Compression Express V| and select Create»Graph I ndicator
from the shortcut menu.

Usethe Wiring tool to wire the M ean output of the Sample Compression Express V1 to the
Sine graph indicator.

The Merge Signals function appears.

Arrange the objects on the block diagram so they appear similar to the following figure.

Figure 2-3. Block Diagram of the Reduce Samples VI
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Display the front panel.

The controls and indicators you added appear in the front panel with labelsthat correspond
to the inputs and outputs from which you created the controls and indicators.

Note You might need to scroll or resize the front panel to see all controls and
indicators.

Savethe VI.
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Configuring a VI to Run Continuously until the User
Stops It

In the current state, the VI runs once, generates one signal, and then stops running. To run the
VI until acondition occurs, you can use a While Loop.

Complete the following steps to add a While Loop to the block diagram.
1. Display thefront panel and run the VI.

The V1 runs once and then stops. The front panel does not have a stop button.
2. Display the block diagram.

Click the Sear ch button, shown below, on the Functions palette, and enter while inthe
text box. LabVIEW searches as you type the first few letters and displays any matchesin

the search results text box.

If there are objects with the same name, use the information in the brackets to the right of
each object name to decide which object to select. Some objects are located on multiple
pal ettes because you can use them for multiple applications.

4. Double-click While L oop <<Execution Control>> to display the Execution Control
subpal ette and temporarily highlight the While Loop on the subpal ette.

5. Select the While Loop on the Execution Control palette.

6. Move the cursor to the upper left corner of the block diagram. Click and drag the cursor
diagonally to enclose all the Express Vs and wires, as shown in the following figure.

Figure 2-4. Placing the While Loop around the Express Vs

- & - =

! 1
| |
! 1
! 1
! 1
! 1
! 1
! 1
! 1
! 1
! 1
! 1
! 1
! 1
: 1
! » ¥ Sample i
1 Simulate Signal Compression \
i Sine Signals Mean \
\ Enable !
! Mean (122 I

1
! 1
| |
! 1
! 1
! 1
! 1
: 1

1

2-6 | ni.com



9.

Getting Started with LabVIEW

Rel ease the mouse to place the While Loop around the Express VIs and wires.

The While Loop, shown below, appears with a STOP button wired to the conditional
terminal. This While Loop is configured to stop when the user clicks the ST OP button.

o B

Display the front panel and run the VI.

The VI now runs until you click the STOP button. A While Loop executes the VIs and
functions inside the loop until the user clicks the STOP button.

Click the STOP button and save the V1.

Using the Error List Window

If aVI contains an indicator you do not want to use, you can delete it.

Complete the following steps to remove the M ean indicator from the front panel.

1

Display the front panel and move the cursor over the M ean indicator until the Positioning
tool appears.

Click the M ean indicator, shown below, to select it and press the <Delete> key.

Display the block diagram.

A wire appears as a dashed black linewith ared x in the middle, shown below. The dashed
black line is a broken wire. The Run button, shown below, appears broken to indicate the
V1 cannot run.

Click the broken Run button to display the Error list window.

TheError list window listsal errorsin the VI and provides details about each error. You
can usethe Error list window to locate errors.

Intheerrorsand warningslist, select thewire: has loose ends error and click the
Help button to display more information about the error.

@ Tip You also can move the Wiring tool over abroken wireto display atip strip that

describeswhy the wireis broken. Thisinformation also appearsin the Context Help
window when you move the Wiring tool over a broken wire.
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6. Intheerrorsand warningslist, double-click thewire: has loose ends error to
highlight the broken wire.

7. Pressthe <Ctrl-B> keysto delete the broken wire.

Pressing the <Ctrl-B> keys deletes a// broken wires on the block diagram. You can press
the <Delete> key to delete only the selected wire.

8. Select View»Error List to display the Error list window. No errors appear in theerrors
and warningsfield.

@ Tip You also can press the <Ctrl-L> keys to display the Error list window.

9. Click the Close button to close the Error list window.
The Run button no longer appears broken.

Controlling the Speed of Execution

To plot the points on the waveform graph more slowly, you can add atime delay to the block
diagram.

Complete the following steps to control the speed at which the VI runs.

1. Ontheblock diagram, search for the Time Delay Express VI, shown below, on the
Functions palette and place it inside the While Loop.

- [E

Time Delay

3

You can use the Time Delay Express VI to control the execution rate of the VI.
2. Enter 0.25 inthe Timedelay (seconds) text box.

Thistime delay specifies how fast the loop runs. With a 0.25 second time delay, the loop
iterates once every quarter of a second.

3. Clickthe OK button to savethe current configuration and closethe Configure Time Delay
dialog box.

Display the front panel and run the V1.
5.  Click the Enable switch and examine the change on the graph.

If the Enable switch is on, the graph displays the reduced signal. If the Enable switch is
off, the graph does not display the reduced signal.

6. Click the STOP button to stop the V1.

2-8 | ni.com



Getting Started with LabVIEW

Using a Table to Display Data
Complete the following steps to display a collection of mean valuesin afront panel table.
1. Display thefront panel.

2. Onthe Controls palette search for the Express Table indicator and add it to the right of
the waveform graph.

3. Display the block diagram.
LabVIEW wired the Table terminal to the Build Table Express VI.

4. |f theBuild Table Express VI and the Table terminal are not selected already, click an open
areaon the block diagram to the left of the Build Table Express VI and the Table terminal.
Drag the cursor diagonally until the selection rectangle encloses the Build Table Express
V1 and the Table terminal, shown below.

’ Signals =
Table [ gL

i

1
1
1
i
1
\ Build Table
1
1
1
1
1
1

A moving dashed outline, called a marquee, highlights the Build Table Express V1, the
Tableterminal, and the wire joining the two.

5. Drag the objects into the While Loop to the right of the Sample Compression Express V1.

If you drag objects near the border of the While Loop, the loop resizes to enclose the Build
Table Express VI and the Table terminal after you release the mouse button.

6. UsetheWiringtool to wirethe M ean output of the Sample Compression ExpressV1 tothe
Signalsinput of the Build Table Express VI.

7. Theblock diagram should appear similar to the following figure.
Figure 2-5. Block Diagram of the Reduce Samples VI
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8.
9.

10.

11
12.

13.

Display the front panel and arrange the controls and indicators as shown in Figure 2-1.
Run the V1.
Click the Enable switch.

If the Enable switch is on, the table displays the mean values of every 25 samples of the
sinewave. If the Enable switch is off, the table does not record the mean values.
Stop the VI.

Experiment with properties of the table by using the Table Properties dialog box. For
example, try changing the number of columnsto one.

Save and closethe V1.

Searching for Examples

To learn more about how you can use acertain V1, you can search for and view an example that
usesthe VI.

Complete the following steps to find and open an example that uses the Amplitude and Level
Measurements Express V1.

1
2.

Select Help»LabVIEW Help to display the LabVIEW Help.

Click the Sear ch tab. Inthe Typein thewor d(s) to sear ch for text box enter amplitude
and level measurements express VI andpressthe<Enter>key. (Mac OS X and
Linux) Choose the Full Text option in the Sear ch Options section of the Search the
LabVIEW Help dialog box to narrow the search results.

@ Tip (Windows) Before you search, you can narrow the search results by placing a

checkmark in the Sear ch titles only checkbox near the bottom of the help window.
You also can use operators such as AND, OR, and NEAR in the Typein theword(s) to
sear ch for text box to narrow the search results.

(Windows) Click the L ocation column header to sort the search results by content type.
Reference topics contain reference information about LabVIEW objects such as Vs,
functions, palettes, menus, and tools. How-To topics contain step-by-step instructions for
using LabVIEW. Concept topics contain information about LabVIEW programming
concepts.

@ Tip You canusethe Favoritestab of the LabVIEW Help to save and quickly access

4.

help topics you use often. When you view a help topic you may want to access later,
navigate to the Favorites tab and click the Add button.

Double-click the Amplitude and L evel M easurements Express VI search result to
display the reference topic that describes the Amplitude and L evel Measurements Express
VI.
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After you read the description of the Express VI, click the Open example button in the
Example section near the bottom of the topic to open an example that uses the Amplitude
and Level Measurements Express VI.

Runthe VI and movethe vertical pointer slides. The amplitude and frequency of the signal
change as you move the vertical pointer slides.

Stop the VI.
Select Window»Show Block Diagram and read the block diagram comments.

Close the example VI and return to the Amplitude and Level Measurements Express VI
topicin the LabVIEW Help.

Click the Find related examples button to open the NI Example Finder and display alist
of examples similar to the example that uses this V1. The NI Example Finder searches
among hundreds of examples, including all installed examples and the exampleslocated on
theNI Developer Zoneatni . com/zone. You can modify an exampletofit an application,
or you can copy and paste from one or more examplesinto a VI that you create.

Note Always select File»Save As when you save a modified example to avoid

overwriting the example program in the NI Example Finder.

You aso canright-click a VI or function on the block diagram or on a pinned pal ette and
select Examples from the shortcut menu to display a help topic with links to examples for
that VI or function. To launch the NI Example Finder and browse or search exampl es, select
Help»Find Examples.

Note Notall VIshave an example.

11

After you experiment with the NI Example Finder and the example Vs, close the
NI Example Finder.

Summary

The following topics are a summary of the main concepts you learned in this chapter.

Using the LabVIEW Help Resources

In this chapter, you learned to use the help resources in the following ways:

The Context Help window displays basic information about LabVIEW objects when you
move the cursor over each object. Objects with context help information include Vs,
functions, structures, palettes, dialog box components, and so on. To access the Context
Help window, select Help»Show Context Help or press the <Ctrl-H> keys.

(Mac OS X) Press the <Command-Shift-H> keys.

When you move the cursor over an Express VI on the block diagram, the Context Help
window displays a brief description of the Express VI and information about how you
configured the Express V1.
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e TheLabVIEW Help contains detailed information about LabVIEW objects. To access the
LabVIEW Help topic for an object, move the cursor over the object and click the Detailed
help link in the Context Help window. You also can right-click an object on the block
diagram or on a pinned palette and select Help from the shortcut menu.

e Tonavigate the LabVIEW Help, use the Contents, I ndex, and Sear ch tabs. Use the
Contentstab to get an overview of the topics and structure of the help. Use the I ndex tab
to find atopic by keyword. Use the Sear ch tab to search the help for aword or phrase.

e If youfind an object in the LabVIEW Help you want to use, you can click an Add to the
block diagram button to place the object on the block diagram.

¢ Onthe Search tab of the LabVIEW Help, use operators such as AND, OR, and NEAR to
narrow the search results. To search for an exact phrase, place quotation marks around the
phrase. Before you search, you also can narrow the search results by placing a checkmark
in the Sear ch titles only checkbox near the bottom of the help window.

e Onthe Search tab of the LabVIEW Help, you can click the L ocation column header above
thelist of search resultsto sort the results by content type. Reference topics contain
referenceinformation about LabVIEW objects such as Vs, functions, pal ettes, menus, and
tools. How-To topics contain step-by-step instructionsfor using LabVIEW. Concept topics
contain information about LabVIEW programming concepts.

Customizing the Block Diagram Code

Y ou can use many controls, indicators, Express Vs, and structures to customize a V1. The
following examples review afew common ways to customize Vs, including creating controls
and indicators, configuring when a VI stops, correcting broken wires, and displaying datain a
table.

Creating Controls and Indicators

Create controls and indicators on the block diagram by right-clicking the Express VI input,
output, or wire, selecting Cr eate from the shortcut menu, and selecting among the available
options. LabVIEW wires the control or indicator you created to the input, output, or wire you
right-clicked.

Control terminals have athicker border than indicator terminals. Also, an arrow appears on the
right of theterminal if the terminal isacontrol, and an arrow appears on the |eft of the terminal
if theterminal is an indicator.

Controlling When a VI Stops Running

Use aWhile Loop to run the code enclosed within the loop continually. A While Loop stops
running when a stop condition occurs. After you place or move an object in aWhile Loop near
the border, the loop resizes to add space for that object.

The Execution Control paletteincludes objects you can useto control the number of timesa V|
runs, aswell asthe speed at which the VI runs.
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Errors and Broken Wires

The Run button appears broken when the VI you are creating or editing contains errors. If
the Run button is still broken when you finish wiring the block diagram, the V1 is broken and
cannot run.

Click the broken Run button or select View»Error List tofind out why a V1 isbroken. You can
usetheError list window to locate errors. Click the Help button for more information about the
error. Double-click the error in the errorsand war nings field to highlight the problem causing
the error.

A broken wire appears as adashed black linewith ared x in the middle. Broken wires occur for
avariety of reasons, such asif you delete wired objects. The VI cannot run if the block diagram
contains broken wires.

Move the Wiring tool over a broken wire to display atip strip that describes why the wireis
broken. Thisinformation also appearsin the Context Help window when you move the Wiring
tool over a broken wire. Right-click the wire and select List Errorsfrom the shortcut menu to
display the Error list window. Click the Help button for more information about why the wire
is broken.

Displaying Data in a Table

Thetable indicator displays generated data. Use the Build Table Express VI to build a table of
generated data.

Using the NI Example Finder

Use the NI Example Finder to browse or search examplesinstalled on your computer or on the
NI Developer Zone at ni .com/zone. These examples demonstrate how to use LabVIEW to
perform awide variety of test, measurement, control, and design tasks. Select Help»Find
Examplesto launch the NI Example Finder.

Examples can show you how to use specific VIs or functions. You can right-click aVI or
function on the block diagram or on a pinned palette and select Examples from the shortcut
menu to display a help topic with links to examples for that VI or function. You can modify an
example VI to fit an application, or you can copy and paste from one or more examplesinto a
VI that you create.

Always select File»Save As when you save a modified example to avoid accidentally
overwriting the example program in the NI Example Finder.
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Shortcuts
This chapter introduced the following keyboard shortcuts.

Note The <Ctrl> key in these shortcuts corresponds to the (Mac OS X)
<Command> key or (Linux) <Alt> key.

Shortcut Function
<Ctrl-N> Opens anew, blank VI.
<Ctrl-H> Shows or hides the Context Help window.

(Mac OS X) Press the <Command-Shift-H> keys.

<Ctrl-Space> Displays the Quick Drop diaog box.

(Mac OS X) Press the <Command-Shift-Space> keys.
<Ctrl-B> Deletes all broken wiresinaVlI.
<Ctrl-L> Displaysthe Error list window.
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Analyzing and Saving a
Signal

LabVIEW includes a set of Express VIsthat help you analyze signals. This chapter teaches you
how to use LabVIEW to perform abasic analysis of asignal and how to save the analyzed data
to afile.

= Note Theexercisesin this chapter use Express Vs that are available only in the
LabVIEW Full and Professional Development Systems.

Building an Analysis VI

Inthe following exercises, youwill build aVI that generatesasignal, filtersthe signal, indicates
if the signal exceeds a certain limit, and records the data. After you complete the exercises, the
front panel of the VI will look similar to the front panel in the following figure.

You can complete the exercises in this chapter in approximately 40 minutes.

Figure 3-1. Front Panel of the Save Data VI
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Modifying a VI Created from a Template
Complete the following steps to create a V1 that generates, analyzes, and displays asignal.
1. Select FilexNew to display the New dialog box.

2. Fromthe Create New list, select VI»From TemplatesTutorial (Getting Started)»
Generate, Analyze, and Display. Thistemplate VI simulates asignal and analyzesit for
its root mean square (RMS) value.

3. Click the OK button or double-click the name of the template to create a VI from the
template.

4. |f the Context Help window isnot visible, pressthe <Ctrl-H> keysto display the window.
(Mac OS X) Press the <Command-Shift-H> keys.

5. Display the block diagram by pressing the <Ctrl-E> keys.
Move the cursor over the Amplitude and Level Measurements Express V1, shown below.

»
[ ¥
Amplitude and
Lewvel

Measurements
’ Signals
RMS ¥

The Context Help window displays information about the behavior of the Express V1.

Keep the Context Help window open. It will provide useful information as you complete
the rest of this exercise.

7. Display the front panel and remove the RM S indicator, shown below.

RMS

—

You will not usethe RM Sfunctionality of the Amplitude and L evel M easurements Express
VI for thisexercise. However, you can use the Generate, Analyze, and Display template VI
with the RM S functionality in the future to reduce devel opment time.

8. Display the block diagram and remove any broken wires that result from removing the
RM Sindicator. To remove all broken wires from the block diagram, you can press the
<Ctrl-B> keys.

9. Thenreturnto thefront panel window and right-click the waveform graph indicator. Select
Properties from the shortcut menu. The Graph Properties dialog box appears.

10. Onthe Appearance page, place acheckmark in the Visible checkbox in the L abel section
and enter unfiltered Signal inthe text box.

11. Click the OK button to save the configuration and close the Graph Properties dialog box.
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12. RuntheVI.
The signal appears in the graph.
13. Click the STOP button to stop the V1.

Adding a Signal

The Simulate Signal Express VI simulates a sine wave by default. Y ou can customize the
simulated signal by changing the options in the Configure Simulate Signal dialog box.

Complete the following steps to create an additional simulated signal that adds uniform white
noise to the sine wave.

1. Ontheblock diagram, use the Positioning tool to select the Simulate Signal Express V1.

Hold down the <Ctrl> key and click and drag to create an additional Simulate Signal
Express VI on the block diagram. (Mac OS X) Hold down the <Option> key and drag.
(Linux) You also can hold down the middle mouse button and drag.

2. Releasethemouse buttonto placethe copied Simulate Signal ExpressV 1 below theoriginal
Simulate Signal Express V1. LabVIEW updates the name of the copied Simulate Signal
Express VI to Simulate Signal 2.

3. Double-click the Simulate Signal2 Express V| to display the Configure Simulate Signal
dialog box.

Select Sine from the Signal type pull-down menu.
Enter 60 in the Frequency (Hz) text box.

4
5

6. Enter 0.1 inthe Amplitude text box.

7. Place acheckmark in the Add noise checkbox to add noise to the sine signal.
8. Sdect Uniform White Noise from the Noise type pull-down menu.

9. Enter 0.1 inthe Noise amplitude text box.

10. Enter -1 in the Seed number text box.

11. Inthe Timing section, select the Run asfast as possible option.

12. Inthe Signal Name section, remove the checkmark from the Use signal type name
checkbox.

13. Enter 60 Hz and Noise inthe Signal name text box.

When you change the signal name in the Configure Simulate Signal dialog box,
LabVIEW changesthe name of the signal output on the block diagram. Changing thesignal
name makes it easier for you to identify the signal type when you view the Express VI on
the block diagram.

The Result Preview section displays arandom signal. The Configure Simulate Signal
dialog box should appear similar to the following figure.
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Figure 3-2. Configure Simulate Signal Dialog Box
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Click the OK button to save the current configuration and close the Configure Simulate
Signal dialog box.

Adding Two Signals

To add two signals together to create one signal, you can use the Formula Express V1. Rather
than displaying two signals on one graph, the Formula Express V| adds both signal s together to
create asingle signal on the graph. Y ou can use this Express V1 to add noise to asignal.

Complete the following steps to add the 60 Hz and Noise signal to the Sine signal.

1

3-4

In the block diagram window, triple-click the wire that connects the Sine output of the
Simulate Signal ExpressV| to the Signalsinput of the Amplitude and Level Measurements
Express VI and to the Unfiltered Signal indicator. Remove the wire.

On the Functions palette, click the Sear ch button to search for the Formula Express V1,
shown below, and add it to the block diagram between the Simulate Signal ExpressVIsand
the Amplitude and Level Measurements Express V1. The Configure Formula dial og box

appears.
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Farmula

Note LabVIEW displaysafolder glyph to the left of subpalettesin the search

10.

11.
12.

results and displays alight blue glyph to the left of Express ViIsin the search results.

IntheLabel column, changethelabel for X1 to sine andthelabel for X2t0 60 Hz and
Noise.

The FormulaExpress V1 automatically entersthefirst input, Sine, in the For mula text box.

Click the + button and then the X2 button to add Sine and 60 Hz and Noise together in the
For mula text box.

Click the OK button to save the current configuration and close the Configur e Formula
dialog box.

Use the Wiring tool to wire the Sine output of the Simulate Signal Express V1 to the Sine
input of the Formula Express V1.

Wire the 60 Hz and Noise output of the Simulate Signal2 Express VI to the 60 Hz and
Noise input of the Formula Express V1.

Wire the Result output of the Formula Express VI to the Unfiltered Signal indicator and
to the Signalsinput of the Amplitude and Level Measurements Express VI.

Display the front panel by pressing the <Ctrl-E> keys.

Run the V1.

The signal with added noise appears in the graph.

Click the STOP button to stop the VI.

Select File»Save Asand save the VI asanalysis.vi inan easily accessible location.

Filtering a Signal

Y ou can use the Filter Express VI to process signals through filters and windows.

Complete the following steps to configure the Filter Express V1 to filter the signal using an
infinite impulse response (I1R) filter.

1

Display the block diagram window and remove the wire that connects the Result output of
the Formula Express V1 to the Signalsinput of the Amplitude and Level Measurements
Express V1.

Remove all broken wires that result from removing the wire.
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3.

N o g &

10.

11.

Search for the Filter Express V1, shown below, and add it to the block diagram between the
Simulate Signal 2 Express VI and the Amplitude and Level Measurements Express V1. The
Configure Filter dialog box appears.

’ Lz:i‘ ’
3 M

Filker
k-

In the Filter Specifications section, change the Cutoff Frequency (Hz) to 25.
Click the OK button to save the configuration and close the Configure Filter dialog box.
Display the front panel.

Click the Unfiltered Signal waveform graph indicator and press the <Ctrl> key while you
drag with the Positioning tool to create an additional waveform graph indicator.

Triple-click the Unfiltered Signal 2 label above the new waveform graph indicator and
enter Filtered Signal to changethelabel of theindicator. You also can change the
label on the Appear ance page of the Graph Properties dialog box.

Ontheblock diagram, wirethe Result output of the Formula Express V| to the Signal input
of the Filter Express V1.

Wirethe Filtered Signal output of the Filter Express VI to the Signalsinput of the
Amplitude and Level Measurements Express VI and to the input of the Filtered Signal
waveform graph indicator.

Select File»Save. The block diagram of the Analysis VI should appear similar to the
following figure.

Figure 3-3. Block Diagram of the Analysis VI
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Modifying the Appearance of Graphs

Y ou can use the Display For mat page of the Graph Properties dialog box to specify how the
scales of the x-axis and y-axis appear on the graph.

Complete the following steps to change the format of the x-axis and y-axis of the Unfiltered
Signal and Filtered Signal graphs.

1

o~ wDN

o

10.
11
12.

In the front panel window, right-click the Unfiltered Signal graph indicator and select
Properties from the shortcut menu. The Graph Properties dialog box appears.

On the Display Format page, select Time (X-Axis) from the top pull-down menu.
Select the Default editing mode option.
Inthe Typelist, select Automatic for matting.

IntheDigitsfield, enter 6 and select Significant digitsfrom the Precision Type pull-down
menu.

Place a checkmark in the Hide trailing zer os checkbox.

Select Amplitude (Y-Axis) from the top pull-down menu and repeat steps 3 through 6 so
the y-axis configuration matches the x-axis configuration.

On the Scales page, select Amplitude (Y-AXxis).

Remove the checkmark from the Autoscal e checkbox.

Enter -2.5 inthe Minimum text box and 2 . 5 in the Maximum text box.

Click the OK button to save the configuration and close the Graph Properties dialog box.
Repeat steps 1 through 11 to configure the Filtered Signal graph indicator.

The x-axis and the y-axis on the Unfiltered Signal and Filtered Signal graph indicators
change to reflect the new configuration.

Analyzing the Amplitude of a Signal

Y ou can use the Amplitude and Level Measurements Express V1 to analyze the voltage
characteristics of asignal.

Complete the following steps to reconfigure the Express VI to measure the peak-to-peak
amplitude values of the signal.

1

On the block diagram, double-click the Amplitude and Level Measurements Express V1 to
display the Configure Amplitude and L evel M easur ements dialog box.

In the Amplitude M easur ements section, remove the checkmark from the RM'S
checkbox.

Place a checkmark in the Peak to peak checkbox. Peak to peak appearsin the Results
section with the corresponding value of the measurement.
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4.

Click the OK button to save the current configuration and close the Configure Amplitude
and Level M easurements dialog box.

The RM S output of the Amplitude and Level Measurements Express VI changes to reflect
the new Peak to Peak output, shown below.

|

Amplitude and
Lewvel
Measurements

’ Signals
Peak to Peak ¥

W]

You will use the Peak to Peak output in alater exercise.

Controlling the Speed of Execution

To plot the points on the waveform graphs more slowly, you can add a time delay to the block
diagram. A time delay slows the speed at which aVI runs.

Complete the following steps to control the speed at which the VI runs.

1
2.

On the block diagram, search for the Time Delay Express V1.

Place the Time Delay Express VI inside the While Loop. The Configure Time Delay
dialog box appears.

Enter 1.000 inthe Time delay (seconds) text box and click the OK button.
Display the front panel and run the VI. The VI runs more slowly.

The loop iterates once every second.

Stop the VI.

Another way to control the speed of the VI is to alter the rate of data acquisition. On the
block diagram, double click the Simulate Signal Express VI to display the Configure
Simulate Signal dialog box. Locate the Timing section in the dialog box. The Timing
section containsanumber of waysto alter therate of dataacquisition and the speed at which
aVI runs.

For example, one of the default settings of the VI is Simulate Acquisition Timing. This
means that the VI mimics the acquisition rate of ahardware device. You can select Run as
fast aspossibleto display datamore quickly. Inthe Samples per second (Hz) text box, the
default valueis 1000, while the default value in the Number of Samplestext box is

100. This means that the VI will output 100 data points spanning 0.1 second. You can
change these values to change the amount of datathe VI displays, aswell astherate at
which the V1 displays the data.
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Adding a Warning Light
If youwant avisual cuetoindicatewhen avalue exceeds a specified limit, you can useawarning
light.

Complete the following steps to add awarning light to the V1.

1. Display the Controls palette by right-clicking any blank space in the front panel window.

2. Onthe Express paette, select the L EDs palette.

3. Select theround LED indicator and add it to the front panel to the Ieft of the waveform
graphs.

4. Double-click the Boolean label abovethe LED and enter warning to change the label of
the LED.

You will usethis LED in alater exercise to indicate when avalue has exceeded its limit.
5. Select File»Save Asto display the Save As dialog box.

6. Read the various dialog box options. Select the Copy and Substitute copy for original
optionsto create a copy of the origina VI and immediately edit the copy.

7. Click the Continue button and savethe VI aswarning Light.vi inaneasly accessible
location.

Setting a Warning Level Limit

To specify the value at which you want the LED to light, use the Comparison Express VI.

Complete the following steps to compare the peak-to-peak value to alimit you set.

1. Ontheblock diagram, search for the Comparison Express VI and placeit to theright of the
Amplitude and Level Measurements Express VI. The Configure Comparison dialog box
appears.

2. Inthe Compare Condition section, select the > Greater option.

3. Inthe Comparison Inputs section, select Value and enter 2 in the Value numeric control
to assign a constant value at which you want the LED to light.

4. Click the OK button to save the current configuration and close the Configure
Comparison dialog box.

The name of the Comparison Express VI changesto reflect the operation of the Express V1,
shown below. Greater indicates that the Express V| does a greater than comparison.

’ ’
3 M

Greater

5. WirethePeak to Peak output of the Amplitude and Level Measurements Express V1 to the
Operand 1 input of the Greater Express V1.

6. Move the cursor over the wire that connects the Peak to Peak output to the Operand 1
input.
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7. When the Positioning tool appears, right-click the wire that connects the Peak to Peak
output to the Operand 1 input and select Create»Numeric Indicator from the shortcut
menul.

A Peak to Peak terminal, shown below, appears on the block diagram. If the Peak to Peak
terminal appears to be on top of the wires between the Express VIs, move the Express Vis
and Peak to Peak terminal around to create more space. For example, move the Peak to
Peak terminal into blank space above the Express Vls.

IDE|

Tip You also can press <Ctrl> and drag a rectangle in open space to add more
working space to the front panel or block diagram.

Warning the User

After you specify the values at which you want the LED to light, you must wire the LED to the
Greater Express V1.

Complete the following steps to provide avisual cue when the peak-to-peak value of the signal
exceeds a specified limit.

1. Intheblock diagram window, move the War ning terminal to the right of the Greater
Express V1. Make sure the War ning termina isinside the While Loop, as shown in the
following figure.

Figure 3-4. Block Diagram of the Warning Light VI
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Wire the Result output of the Greater Express VI to the War ning terminal.
The block diagram should appear similar to Figure 3-4.

Note Red coercion dots appear automatically at the Peak to Peak and Warning

6.

input terminalsto aert you that you wired two different data types together and
LabVIEW converted the value passed into the node to a different representation. The
block diagram places the coercion dots on the border of the terminal where the
conversion takes place. For this exercise, the conversion does not affect how the VI
runs. Refer to the LabVIEW Help for more information about coercion dots.

Display the front panel.

A numericindicator |abeled Peak to Peak appearsin thefront panel window. Thisindicator
displays the peak-to-peak value of the signal.

RuntheVI.

When the peak-to-peak value exceeds 2 . 0, the Warning indicator lights.
Click the STOP button to stop the VI.

Savethe VI.

Configuring a VI to Save Data to a File

To store information about the dataa VI generates, use the Write To Measurement File
Express V1.

Completethefollowing stepsto build aV1 that saves peak-to-peak values and other information
toaLabVIEW datafile.

1

Search for the Write To Measurement File Express VI and add it to the block diagram below
and to the right of the Amplitude and Level Measurements Express V1.

The Configure Write To M easurement File dialog box appears.

The Filename text box displaysthe full path to the output file, test . 1vm. A . 1vmfileis
atab-delimited text measurement file you can open with a spreadsheet application or a
text-editing application. LabVIEW saves data with up to six digits of precisonina . 1vm
file. LabVIEW savesthe . 1vm filein the default LabvIEW Data directory. LabVIEW
installsthe LabvIEW Data directory in the default file directory of the operating system.
When you want to view the data, use the file path displayed in the Filename text box to
accessthe test . lvm file.

IntheConfigureWriteto M easurement Filedialog box, locatethe I f afilealready exists
section and select the Append to file option to write all the datatothe test . 1vm file
without erasing any existing datain thefile.

In the Segment Header s section, select the One header only option to create only one
header in the file to which LabVIEW writes the data.
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4.

Enter the following text in the File Description text box: Sample of peak to peak
values. LabVIEW appends the text you enter in this text box to the header of thefile.

Click the OK button to save the current configuration and close the Configure Write To
M easur ement File dialog box.

Saving Data to a File
When you run the VI, LabVIEW savesthe datato the test . 1vm file.

Complete the following steps to generate the test . 1vm file.

1

S AN

6.

On the block diagram, wire the Peak to Peak output of the Amplitude and Level
Measurements Express VI to the Signals input of the Write To Measurement File
Express V1.

Select File»Save Asand save the VI as save Data.vi inan easily accessible location.
Display the front panel and run the VI.
Click the front panel STOP button.

Toview the datayou saved, openthe test . 1vmfileinthe LabvIEW Data directory with
a spreadsheet or text-editing application.

Thefile has a header that contains information about the Express V1.
Close the file after you finish looking at it and return to the Save Data V1.

Adding a Button That Stores Data When Clicked

If you want to store only certain data points, you can configure the Write To Measurement File
Express VI to save peak-to-peak values only when a user clicks a button.

Complete the following steps to add a button to the VI and configure how the button responds
when auser clicksit.

1

Display the front panel and search the Controls palette for arocker button. Select one of
the rocker buttons and place it to the right of the waveform graphs.

Right-click the rocker button and select Properties from the shortcut menu to display the
Boolean Properties dialog box.

Change the label of thebuttontowrite to File.

On the Oper ation page of the Boolean Propertiesdiaog box, select L atch when pressed
from the Button behavior list.

Usethe Operation page to specify how abutton behaveswhen auser clicksit. To see how
the button reacts to a click, click the button in the Preview Selected Behavior section.

Click the OK button to save the current configuration and close the Boolean Properties
dialog box.

Savethe VI.
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Saving Data When Prompted by a User

Complete the following stepsto build a V1 that logs data to a file when the user clicks a button
on the front panel.

1

In the block diagram window, double-click the Write To Measurement File Express VI to
display the Configure Write To Measur ement File dial og box.

Change thefilename test . 1vm in the Filename text box to Selected Samples.lvm
to save the datato adifferent file.

Click the OK button to save the current configuration and close the Configure Write To
M easurement File dialog box.

Right-click the Signals input of the Write To Measurement File Express VI and select
Insert Input/Output from the shortcut menu to insert the Comment input.

Right-click the Comment input of the Write To Measurement File Express VI and select
Select | nput/Output»Enable from the shortcut menu to replace the Comment input with
the Enable input.

Theinputsand outputs of an Express V| appear in apredetermined order when you add new
inputs and outputs. To select a specific input, you might need to add an input first, and then
changetheinput to the specific one you want to use by right-clicking theinput and selecting
Select Input/Output from the shortcut menu.

Move the Write to File terminal to the left of the Write To Measurement File Express V1.
Wirethe Writeto File terminal to the Enable input of the Write To Measurement File
ExpressVI.

The block diagram should appear similar to the following figure.

Figure 3-5. Block Diagram of the Save Data VI
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Viewing Saved Data

Complete the following steps to view the datathat you savetothe selected Samples.lvm
file.

1. Display thefront panel and run the VI. Click the Write to File button several times.
2. Click the STOP button.
3. Opentheselected samples.lvm filewith aspreadsheet or text-editing application.

Theselected Samples.lvmfilediffersfromthetest.lvmfile test.lvmrecorded
all the data generated by the Save Data VI, whereas Selected Samples.1lvm recorded
data only when you clicked the Write to File button.

Close the file after you finish looking at it.
5. Saveand closetheVI.

Summary

The following topics are a summary of the main concepts you learned in this chapter.

Controls and Indicators

Y ou can configure front panel controls and indicators to perform tasks depending on what you
want aVI to do. In this chapter, you learned to use controls and indicatorsin the following ways:

e You can build Visthat perform atask when certain conditions occur, such as displaying a
warning light when a value exceeds a certain limit.

¢ Youcanhbuild Visthat et users control when an Express VI executes by using buttons and
the Enable input. You can configure the buttons to operate in one of six ways using the
Operation page of the Boolean Properties dialog box.

Filtering Data

The Filter Express VI processes signals through filters and windows. Y ou can use the Filter
Express VI to remove noise from asignal.

Saving Data

The Write To Measurement File Express VI saves datathat aV1 generates and analyzesto a
.1vm, . tdm, Or . tdms measurement file. The text-based measurement file (. 1vm) isa
tab-delimited text file you can open with a spreadsheet application or atext-editing application.
LabVIEW saves datawith up to six digits of precisionina . 1vm file. In addition to the dataan
Express VI generates, the . 1vm file includes headers that contain information about the data,
such asthe date and time LabVIEW generated the data. The binary measurement file (. tdm) is
abinary filethat contains waveform data. Binary . tdm files provide higher accuracy for
floating-point numbers, take up less space on disk, and perform faster than text-based
measurement files (. 1vm). The TDM Streaming file (. tdms) isabinary filethat providesfaster
writing performance than the . tdm file format and allows asimpler interface for defining
properties.
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LabVIEW ingtallsthe LabvIEW Data directory in the default file directory of the operating

system to help you organize and locate the datafilesLabVIEW generates. Refer tothe LabVIEW
Help for more information about writing data to and reading data from . 1vm and . tdm files.
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and Communicating with
Instruments (Windows)

LabVIEW has the capability to connect and interact with alarge number of hardware devices.
This chapter introduces you to two Express Vs that make acquiring data and communicating
with traditional, third-party instruments easier.

Hardware and Software Requirements

Inthefirst exercise, you use the DAQ Assistant Express V1 to acquire datawith aDAQ device.
This exercise requires data acquisition hardware and that you have NI-DAQmMX installed. Refer
to the NI-DAQmx Readme for more information about platforms supported by NI-DAQmx
software.

Refer to the Taking M easur ements book on the Contentstab in the LabVIEW Help for
information about acquiring data and communicating with instruments on al platforms.

@ Note With NI-DAQmx 7.4 or later you can create NI-DAQmx simulated devices
in MAX. An NI-DAQmx simulated device is a software replica of a DAQ device.
Refer to the Measurement & Automation Explorer Help for NI-DAQmx for detailed
instructionson creating an NI-DAQmx simul ated devicethat you can useto complete
thefirst exercise.

In the second exercise, you use the NI Instrument Driver Finder to find and install instrument
drivers. To use the Instrument Driver Finder, you must have Internet access. In the second
exercise, you aso use the Instrument I/O Assistant Express VI to communicate with a
traditional, third-party instrument. This exercise requires an instrument and that you have the
Instrument I/O Assistant installed.

Refer to the Controlling I nstruments book on the Contentstab in the LabVIEW Help for more
information about communicating with instruments.

Note LabVIEW supportsthe DAQ and Instrument 1/O Assistants used in this

chapter on Windows only. The Instrument Driver Finder isavailable on Windowsand
Linux.

© National Instruments | 4-1



Chapter 4 Hardware: Acquiring Data and Communicating with Instruments (Windows)

Acquiring a Signal in NI-DAQmx

You will usethe DAQ Assistant Express VI to create atask in NI-DAQmx. NI-DAQmXx isa
programming interface you can use to communicate with data acquisition devices. Refer to the
Getting Started with LabVIEW»Getting Started with DAQ»Taking an NI-DAQmx
Measurement in LabVIEW book on the Contentstab in the LabVIEW Help for information
about additional ways to create NI-DAQmX tasks.

In thefollowing exercises, you will create an NI-DAQmX task that continuously takes avoltage
reading and plots the data on a waveform graph.

You can complete the exercises in this chapter in approximately 30 minutes.

Creating an NI-DAQmx Task

In NI-DAQmX, atask isacollection of one or more channels, which containstiming, triggering,
and other properties. Conceptually, atask represents a measurement or generation you want to
perform. For example, you can create atask to measure temperature from one or more channels
onaDAQ device.

Complete the following steps to create and configure a task that reads a voltage level from a

DAQ device.

1. Openanew, blank VI.

2. Ontheblock diagram, display the Functions palette and select Express»| nput to display
the Input palette.

3. Sdlect the DAQ Assistant Express VI, shown below, on the I nput palette and placeit on
the block diagram. The DAQ Assistant launches and the Create New Express Task dialog
box appears.

DA Assistank

Click Acquire Signals»Analog I nput to display the Analog I nput options.
5. Select Voltage to create a new voltage analog input task.

The dialog box displays alist of channels on each installed DAQ device. The number of
channels listed depends on the number of channels you have on the DAQ device.

6. Inthe Supported Physical Channelslist, select the physical channel to which the device
connectsthesignal, such asai0, and then click the Finish button. The DAQ Assistant opens
anew dialog box, shown in the following figure, that displays options for configuring the
channel you selected to complete a task.
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Figure 4-1. Configuring a Task Using the DAQ Assistant
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7.

10.
11.

12.

Inthe DAQ Assistant dial og box select the Configur ation tab and locate the Voltage I nput
Setup section.

Locate the Settingstab. In the Signal I nput Range section enter 10 for the Max valueand
enter -10 for the Min value.

Locate the Timing Settings section at the bottom of the Configuration page. From the
Acquisition Mode pull-down menu, select N Samples.

Enter avalue of 1000 in the Samplesto Read text box.

Click the OK button to save the current configuration and close the DAQ Assistant.
LabVIEW buildsthe V1.

Savethe VI asrRead Voltage.vi inan easly accessible location.

Graphing Data from a DAQ Device

Y ou can use thetask you created in the previous exercise to graph the dataacquired from aDAQ
device.

Completethe following stepsto plot the datafrom the channel on awaveform graph and change
the name of the signal.

1

On the block diagram, right-click the data output and select Create»Graph I ndicator
from the shortcut menu.

Display the front panel and run the VI three or four times. Observe the waveform graph.
Voltage appearsin the plot legend at the top of the waveform graph.

On the block diagram, right-click the DAQ Assistant Express VI and select Properties
from the shortcut menu to open the DAQ Assistant.

Right-click Voltagein thelist of channels and select Rename from the shortcut menu to
display the Rename a channel or channels dialog box.

@ Tip You aso can select the name of the channel and press the <F2> key to display

the Rename a channel or channels dialog box.

In the New Name text box, enter First Voltage Reading, and click the OK button.

Inthe DAQ Assistant dialog box, click the OK button to save the current configuration and
close the DAQ Assistant.

Display the front panel and run the V1.
First Voltage Reading appearsin the waveform graph plot legend.
Savethe VI.
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Editing an NI-DAQmx Task

Y ou can add a channel to the task so you can compare two separate voltage readings. Y ou also
can customize the task to acquire the voltage readings continuously.

Complete the following steps to add a new channel to the task and acquire data continuously.

1

Intheblock diagram window, double-click the DAQ Assistant ExpressV1 to openthe DAQ
Assistant.

Click the Add Channels button, shown below, and select Voltage to display the Add
Channels To Task dialog box.

+
Add Channels

Select any unused physical channel inthe Supported Physical Channelslist, and click the
OK button to return to the DAQ Assistant.

Rename the channel second voltage Reading.

In the Timing Settings section of the Configuration page, select Continuous Samples
from the Acquisition Mode pull-down menu.

When you set timing and triggering optionsin the DAQ Assistant, these options apply to
all the channelsin thelist of channels.

Click the OK button to save the current configuration and close the DAQ Assistant. The
Confirm Auto Loop Creation dialog box appears.

Click the Yes button. LabVIEW places a While Loop around the DAQ Assistant Express
V1 and the graph indicator on the block diagram. A stop button appears wired to the stop
input of the DAQ Assistant Express V1. The stopped output of the Express VI iswired to
the conditional terminal of the While Loop. The block diagram should appear similar to the
following figure.

Figure 4-2. Block Diagram of the Read Voltage VI

stop (F) [+ w
. [+
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LrrLd DA Assiskant
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|

If an error occurs or you click the stop button while the VI is running, the DAQ Assistant
Express V1 stops reading data and the stopped output returns a TRUE value and stops the
While Loop.
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Visually Comparing Two Voltage Readings

Because you have two voltage readings displayed on a graph, you can customize the plots to
distinguish between the two.

Complete the following steps to customize the plot color of the front panel waveform graph.
1. Expand the plot legend of the waveform graph to display two plots.
2. RuntheVI.

Two plots appear on the graph and the plot legend displays both plot names.

3. Click theicon that isto the right of First Voltage Reading in the plot legend and select
Color from the shortcut menu. Using the color picker, select a color, such asyellow, so the
plot is easy to read.

Change the plot color of Second Voltage Reading.
Stop the VI.

Savethe VI.

Closethe VI. The Getting Started window opens.

N o g &

Communicating with an Instrument: Using
Instrument Drivers and the Instrument I/O
Assistant

Aninstrument driver isaset of software routinesthat control a programmableinstrument. Each
routine corresponds to a programmatic operation such as configuring, reading from, writing to,
and triggering the instrument. Instrument drivers simplify instrument control and reduce test
program development time by eliminating the need to learn the programming protocol for each
instrument. Usean instrument driver for instrument control when possible. National Instruments
provides thousands of instrument drivers for awide variety of instruments.

In the following exercises, you will use instrument drivers and the Instrument 1/0 Assistant to
communicate with an instrument. You must have an instrument installed to fully complete the
following exercises.
= Note These exercises refer to traditional, third-party instruments. Refer to
ni.com/modularinstruments for moreinformation about communicating with
NI modular instruments.
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Getting Started with the Instrument Driver Finder

Use the NI Instrument Driver Finder to search for and install LabVIEW Plug and Play
instrument drivers without leaving the LabVIEW development environment.

@ Tip YoualsocanvisittheNI Instrument Driver Network atni . com/idnet tofind
adriver for aninstrument, request adriver for aninstrument, and read helpful articles
and tutorials about using instrument drivers.

Complete the following steps to launch and configure the NI Instrument Driver Finder.

1. From the Getting Started window, click Find Driversand Add-ons and click the
Connect to Instrumentslink. You also can launch the Instrument Driver Finder by
selecting Help»Find Instrument Driversor Tools» nstrumentation»Find | nstrument
Drivers.

2. Click theLogin button to sign-in using your NI.com profile. If you do not haveanni . com
profile, skip to step 4.

3. If youadready haveanni.com profile, enter your email address and password and click
the L ogin button.

4. If youdonot haveanni . com profile, select the No, | need to create a profile option and
click the Create Profile button. This action launches a browser window where you can
createanni . com profile. After you create aprofile, return to the Instrument Driver Finder
window and login with your new information.

You are now ready to search for, install, and use instrument drivers with the Instrument Driver
Finder.

Finding and Installing Instrument Drivers

Compl ete the following steps to search for and install an instrument driver using the Instrument
Driver Finder.

1. Onthe Configure Search page, click the Scan for I nstruments button. This action
prompts the NI Instrument Driver Finder to search for connected instruments. All results
display under the Connected Instruments folder in the left-hand sidebar. If you do not
currently have an instrument connected, the Instrument Driver Finder will return aresult
that reads <no connected instrument detected>.

2. Expand the Connected | nstruments folder to display the search results and select an
instrument from the list.

3. Select amanufacturer from the Manufacturer pull-down menu, and enter any keywords
in the Additional Keywords section. Then click the Sear ch button.
A list of availableinstrument drivers appears on the Sear ch Resultspage. Thedriver result
for the most recent version of LabVIEW appearsfirst in the list.

If your search does not return any results, a sidebar with search tips appears. Refer to the
IDNet website at ni . com/idnet for more information about searching for instrument
drivers.
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VW

Note The NI Instrument Driver Finder displays driversonly for LabVIEW 7.0 or
later. If you need to download an older version of an instrument driver, go to the
IDNet website at ni . com/idnet to search for and download instrument drivers
compatible with older versions of LabVIEW.

Select the driver you want to install and then click the Install button.

After thedriver installs successfully, the I nstrument Driver Installation window appears.
Thiswindow contains options for exploring and using the new driver. After installing, the
new driver also appearsin the Configur e Sear ch page under the Installed I nstrument
Driver folder.

Click the Install another driver button and click the Back button to return to the
Configure Sear ch window.

é Note You also can create your own instrument drivers. Refer to the Controlling

Instruments»Using I nstrument Driver sbook onthe Contentstab inthe LabVIEW
Help for more information about creating instrument drivers.

Using Instrument Drivers

After installing an instrument driver, you can explore example programs to learn more about
using the instrument driver.

1

4-8

Double-click the newly installed instrument driver inthe Installed I nstrument Driver
folder to display the Start Using Instrument Driver page.

The Start Using Instrument Driver page alows you to explore and customize the new
driver. The following are recommendations to help you start using the new driver.

e Toview the new driver in the Project Explorer window, click the Open Project
button. In the Project Explorer window, you can explore the Vs, folders, and
supplemental files that make up the driver. You also can access the driver readmefile
in the Project Explorer window.

« Toview thedriver's palette, click the Open Palette button. From the palette, you can

select and add the driver VIsto the front panel and the block diagram.

«  Toview an example program, double-click on the listed example programsin the

Examples section of the Start Using I nstrument Driver page.

Note Not all drivershave al options available. For example, if adriver does not
have a project file, the Open Project button appears dimmed. Refer to the IDNet
website at ni . com/idnet for more information about al instrument drivers.

ni.com
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Selecting an Instrument Using the Instrument 1/O
Assistant

If adriver isnot available for an instrument, you can use the Instrument 1/O Assistant Express
VI to communicate with the instrument.

Note You must have the Instrument 1/O Assistant installed to use the Instrument
1/0 Assistant Express VI. You install the Instrument 1/O Assistant from the National
Instruments Device Drivers CD.

Complete the following steps to use the Instrument 1/O Assistant Express V1 to select an
instrument.

1. Turnon the instrument you want to use. The instrument must be powered on to use the
Instrument I/O Assistant Express V1.

2. Openanew VI and display the block diagram window.

From the I nput palette, select the Instrument 1/0 Assistant Express VI and add it to the
block diagram. The I nstrument /O Assistant dialog box appears.

4. If the help isnot visible to the right of the dialog box, click the Show Help button, shown
below, in the upper right corner of the Instrument 1/0 Assistant dialog box.

7

Show Help

The help appearsto the right of the dialog box. The top help window contains how-to
information about using the Instrument 1/O Assistant. The bottom help window provides
context-sensitive help about components in the dialog box.

5. Click the Select Instrument link in the top help window and follow the instructionsin the
help window to select the instrument with which you want to communicate.

6. If necessary, configure the properties of the instrument.

If you want to minimize the help window, click the Hide Help button, shown below, inthe
upper right corner of the Instrument 1/0 Assistant dialog box.

&
Hide Help

Acquiring and Parsing Information for an Instrument

After you select the instrument, you can send commands to the instrument to retrieve data. In
this exercise, you will learn to use the Instrument I/0O Assistant Express V1 to acquire and parse
identification information for an instrument.
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Complete the following steps to communicate with the instrument.

1. Inthelnstrument I/O Assistant dialog box, click the Add Step button, expand the
pull-down menu, and click the Query and Par se step.

2. Enter *IDN? in the Enter a command text box.
*TDN? isaquery that most instrumentsrecognize. Theresponseisan identification number
string that describes the instrument. If the instrument does not accept this command, refer
to the reference manual for the instrument for alist of commands the instrument does
accept.

3. Click the Run this step button, shown below.

s Run this step

The Instrument I/0O Assistant sends the command to the instrument, and the instrument
returnsits identification information.

4. Select ASCII only from the pull-down menu below the Byteindex column of the response
window to parse the instrument name as an ASCII string. You also can use the Instrument
1/0 Assistant to parse ASCII numbers and binary data.

5. Click the Parsing help button, shown below, in the I nstrument /0O Assistant dialog box
to display information about parsing data.

Parsing help

6. Inthe ASCII representation column of the response window, click the value you want to
parse.

7. Enter aname for the token, or parsed data selection, in the Token name text box.

The name that you entered in the Token nametext box is the output of the Instrument I/0
Assistant Express V1, shown below.

[+ ¥
Instrument IfC
Assistant

error out ¥
Tokenhame M
d errarin

Wiring a Command to an Instrument

After you acquire data from the instrument, you can add an input parameter to an instrument
command. The parameter becomes an input to the VI or function.

Complete the following steps to add a parameter to a command.
1. Click the Add Step button, expand the pull-down menu, and click the Write step.
2. Enter *IDN? inthe Enter a command text box.
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3. Highlight the command in the Enter a command text box and click the Add parameter
button to add a parameter to the command.

Enter a default value for the parameter in the Test value text box.

5. Enter aname for the parameter in the Parameter name text box. You use this name to
reference the parameter in the application.

6. Click the OK button to save the current configuration and close the Instrument 1/O
Assistant dialog box.

Summary

The following topics are a summary of the main concepts you learned in this chapter.

DAQ Assistant Express VI

Y ou can use the DAQ Assistant Express VI to interactively build measurement channels or
tasks.

Add the DAQ Assistant Express V1 to the block diagram to configure channels and tasksfor use
with NI-DAQmx for data acquisition. NI-DAQmX is a programming interface you can use to
communicate with data acquisition devices. You can use the DAQ Assistant Express VI to
control devices supported by NI-DAQmX.

Refer to the Getting Started with LabVIEW»Getting Started with DAQ»Taking an
NI-DAQmx Measurement in LabVIEW book on the Contentstab in the LabVIEW Help for
information about the DAQ Assistant.

Refer to the NI-DAQmx Readme for information about devices supported by NI-DAQmx. If
NI-DAQmx does not support the device you want to use, refer to the Taking M easur ements
book onthe Contentstabinthe LabVIEW Helpfor information about using Traditional NI-DAQ
(Legacy) for data acquisition.

Tasks in NI-DAQmMx

In NI-DAQmMX, atask isacollection of one or more virtual channelswith timing, triggering, and
other properties. Conceptually, atask represents a measurement or generation you want to
perform.

For example, you can configure a collection of channels for analog input operations. After you
create atask, you can access the single task instead of configuring the channelsindividually to
perform anal og input operations. After you create atask, you can add or remove channels from
that task.

Refer to the Taking M easur ements book on the Contentstab in the LabVIEW Help for more
information about channels and tasks.
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Instrument Drivers

Use the NI Instrument Driver Finder to search for and install LabVIEW Plug and Play
instrument drivers without leaving the LabVIEW development environment.

Aninstrument driver isaset of software routines that control a programmabl e instrument. Each
routine corresponds to a programmatic operation such as configuring, reading from, writing to,
and triggering the instrument. Use an instrument driver for instrument control when possible.

National Instruments provides thousands of instrument driversfor awide variety of instruments.

Refer to the Controlling Instruments»Using | nstrument Driver sbook on the Contentstabin
the LabVIEW Help for more information about the Instrument Driver Finder.

You aso can visit the NI Instrument Driver Network at ni . com/idnet tofind adriver

for an instrument, or you can create your own instrument drivers. Refer to the Controlling
Instruments»Using I nstrument Drivers book on the Contentstab in the LabVIEW Help for
more information about creating instrument drivers.

Instrument I/O Assistant Express VI

If adriver isnot available for an instrument, you can use the Instrument I/O Assistant Express
VI to communicate with the instrument. Y ou can use the Instrument 1/0 Assistant to
communicate with message-hased instruments and graphically parse the response. Start the
Instrument 1/0 Assistant by adding the Instrument I/O Assistant Express VI to the block
diagram or by double-clicking the Instrument 1/0O Assistant Express VI icon on the block
diagram.

Refer to the Instrument I/0O Assistant Help for information about communicating with an
external device. Display the Instrument I/0 Assistant Help by clicking the Show Help buttonin
the Instrument 1/0O Assistant dialog box.
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Using Other LabVIEW
Features

The previous chaptersin this manual introduce you to most of the LabVIEW features you need
to build common measurement applications. As you familiarize yourself with the LabVIEW
environment, you might find that you need to enhance Vs or that you need more fine-tuned
control of the processes the Vs perform. This chapter introduces you to some of the concepts
you should be familiar with as you start using other LabVIEW features. Refer to the
Fundamentals book on the Contentstab in the LabVIEW Help for more information about
these concepts. The Concepts books contain information about LabVIEW programming
concepts, and the How-T o books contain step-by-step instructions for using LabVIEW.

All Controls and Indicators

The controls and indicators located on the Expr ess subpalette of the Controls paette are a
subset of the complete set of built-in controls and indicators available in LabVIEW. On other
subpalettes you can find all the controls and indicators that you can useto create the front panel.
However, subpalettes other than the Expr ess subpal ette categorize controls and indicators by
functionality instead of having a subpalette for controls and a subpalette for indicators.

For example, thetop level of the Express subpalette has a Numeric Controls subpalette and a
Numeric Indicator s subpalette. On the M oder n, Classic, and System subpal ettes, these
controls and indicators are located on the Numer ic subpal ette because they are all numeric
objects.

Click the Customize button on the pinned Contr ols pal ette and select Change Visible Palettes
from the shortcut menu to display the Change Visible Palettes dialog box. Then place
checkmarks in the checkboxes next to the categories you want to view on the Controls palette.

Refer to the Fundamental s»Building the Front Panel book on the Contentstab in the
LabVIEW Help for more information about using the complete set of built-in controls and
indicators availablein LabVIEW.

All Vils and Functions

The Express Vs and structures |ocated on the Expr ess subpalette of the Functions palette are
asmall subset of the complete set of built-in VIs, functions, and structures availablein
LabVIEW.
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Click the Customize button on the pinned Functionspal ette and sel ect Change Visible Palettes
from the shortcut menu to display the Change Visible Palettes dialog box. Then place
checkmarksin the checkboxes next to the categories you want to view on the Functions palette.

LabVIEW uses colored icons to distinguish between functions, Vs, and Express VIs. Icons for
functions have pale yellow backgrounds, most iconsfor Vs have white backgrounds, and icons
for Express Vs appear surrounded by pale bluefields.

Express Vs appear on the block diagram as expandable nodes with icons surrounded by ablue
field. Unlike Express VIs, most functions and Vs on the block diagram appear as icons rather
than expandable nodes.

Vlis

Y ou can use an existing V1 or aVI you create as a subV1. When you place aV1 on the block
diagram, the VI isasubV1. When you double-click asubV1, its front panel appears, rather than
adialog box in which you can configure options.

Theicon for a V1 appearsin the upper right corner of the front panel and block diagram. This
icon is the same as theicon that appears when you place the VI on the block diagram. You can
use the default icon or create a custom icon using the | con Editor.

Refer to the Fundamentals»Creating VIsand SubVIs book on the Contentstab in the
LabVIEW Help for more information about creating Vs, configuring them as subVls, and
creating icons.

You aso can save the configuration of an Express VI as asubV|I. Refer to the Fundamental s»
Building the Block Diagram book on the Contentstab in the LabVIEW Help for more
information about creating subVIs from Express Vis.

Functions

Functions are the fundamental operating elements of LabVIEW. Unlike Vs, functions do not
have front panels or block diagrams. Functions provide the basic building blocks for
programming a V|, interfacing with hardware and software, and performing other essential tasks
in LabVIEW. Refer to the Fundamental s»Building the Block Diagram book on the Contents
tab inthe LabVIEW Help for more information about functions.

Data Types

On the block diagram of a VI, the terminals for the front panel objects are different colors. The
color and symbol of aterminal indicate the data type of the corresponding control or indicator.
Colors aso indicate the data types of wires, inputs, and outputs. The color of inputs and outputs
of Express Vlsindicate what type of datathe input or output accepts or returns.

Data types indicate which objects, inputs, and outputs you can wire together. For example, a
switch has agreen border, so you can wire aswitch to any Express VI input with agreen label.
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A knob has an orange border, so you can wire a knob to any Express VI input with an orange
label. However, you cannot wire aknob to an input with agreen label. The wiresyou create are
the same color asthe terminal.

Express Vs generate and acquire data using the dynamic data type. The dynamic data type
appears as adark blue terminal, shown below. Most Express Vs accept or return dynamic data.
You can wire dynamic datato any indicator or input that accepts numeric, waveform, or Boolean
data. Wire dynamic data to an indicator that can best present the data. Such indicators include
graphs, charts, and numeric indicators.

)
Most other VIsand functionsin LabVIEW do not accept dynamic data. To use a built-in VI or
function to analyze or process dynamic data, you must convert the dynamic data to numeric,
Boolean, waveform, or array data.

Use the Convert from Dynamic Data Express V1 to convert dynamic data to numeric, Boolean,
waveform, and array datafor use with other VIs and functions. When you wire dynamic datato
an array indicator, LabVIEW inserts the Convert from Dynamic Data Express V1 on the block
diagram.

Usethe Convert to Dynamic Data Express V1 to convert numeric, Boolean, waveform, and array
data to dynamic data for use with Express Vls.

Refer to the Fundamentals»Building the Block Diagram book on the Contentstab in the
LabVIEW Help for more information about data types.
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When to Use Other LabVIEW Features

The Express Vs, structures, and controls and indicators located on the Expr ess subpal ettes of
the Controls and Functions palettes provide the functionality you need to build common
measurement applications. The following list describes the applications that require you to use
the Vs, functions, structures, controls, and indicators located on subpal ettes other than the
Expr ess subpalette.

Programmatically control properties and methods for the LabVIEW environment,
Vls, and controls and indicator s—You can control programmatically how a V| behaves
when it runs, set the appearance of a control or indicator, or control how the LabVIEW
environment behaves. Refer to the Fundamental s»Programmatically Controlling VIs
book on the Contentstab in the LabVIEW Help for more information about these features.

Call codewritten in text-based languages—You can use LabVIEW to communicate with
applications written in atext-based programming language, such as C or C++. Refer to the
Fundamentals»Calling Shared Librariesin LabVIEW book on the Contentstabinthe
LabVIEW Help for more information about these features.

Communicate with VIsacross a networ k—You can call a V| that resides on another
computer running LabVIEW. Refer to the Fundamentals»Transferring Data over a
Networ k book onthe Contentstabinthe LabVIEW Help for moreinformation about these
features.

Shar e data within an application or across a networ k—You can create configured
softwareitems called shared variablesto share dataamong Vs or between locations on the
block diagram that you cannot connect with wires. Refer to the Fundamentals»
Transferring Data over a Network book on the Contentstab in the LabVIEW Help for
more information about these features.

Publish VIson the Web—You can publish the front panel of any VI on the Web, where
users can interact with the front panel. Refer to the Fundamentals»Transferring Data
over a Network book on the Contentstab in the LabVIEW Help for more information
about these features.

Savedatato avariety of file formats—In addition to the text-based measurement file
format, you can create files that other applications can use, such astext files and
spreadsheet files. Refer to the Fundamentals»File I/0O book on the Contentstab in the
LabVIEW Help for more information about these features.

Customize menus—You can configure which menu items appear when auser runsa V1.
You al so can create custom menus. Refer to the Fundamentals»Creating VIsand SubVls
book on the Contentstab in the LabVIEW Help for more information about these features.

Use LabVIEW projects—You can create projects to group together LabVIEW files and
files not specific to LabVIEW, create build specifications, and deploy or download filesto
multiple targets from one location. Use the Create Project dialog box to select templates
and sample projects that help you get started with LabVIEW projects.

You must use a project to build applications and shared libraries. You also must use a
project to work with an RT, FPGA, PDA, Touch Panel, DSP, or embedded target. Refer to
the specific module documentation for more information about using projects with these
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targets. Refer to the Fundamentals»Wor king with Projects and Tar gets book on the
Contentstab in the LabVIEW Help for more information about using LabVIEW projects.

Accessother Windowsapplications—You canuseLabVIEW asa.NET or ActiveX client
to access the objects, properties, methods, and events associated with .NET server or
ActiveX applications. Refer to the Fundamentals»Windows Connectivity book on the
Contentstab in the LabVIEW Help for more information about these features.

Write mathematical formulas, equations, and scripts—You can use various nodes to
perform mathematical operations on the block diagram. You also can use the LabVIEW
MathScript text-based language to write mathematical functions and scripts. Refer to the
Fundamentals»For mulasand Equationsbook onthe Contentstabinthe LabVIEW Help
for more information about these features.
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Technical Support and
Professional Services

Log into your National Instrumentsni . com User Profile to get personalized access to your
services. Visit thefollowing sections of ni . com for technical support and professional services:

e Support—Technical support at ni . com/support includes the following resources:

Self-Help Technical Resour ces—For answers and solutions, visit ni . com/
support for software drivers and updates, a searchable KnowledgeBase, product
manuals, step-by-step troubleshooting wizards, thousands of example programs,
tutorials, application notes, instrument drivers, and so on. Registered users also
receive access to the NI Discussion Forums at ni . com/ forums. NI Applications
Engineers make sure every question submitted online receives an answer.

Standar d Service Program M ember ship—This program entitles membersto direct
access to NI Applications Engineers via phone and email for one-to-one technical
support, aswell as exclusive access to self-paced online training modulesat ni . com/
self-paced-training. All customersautomatically receive a one-year
membership in the Standard Service Program (SSP) with the purchase of most
software products and bundles including NI Developer Suite. NI aso offersflexible
extended contract options that guarantee your SSP benefits are avail able without
interruption for as long as you need them. Visit ni . com/ssp for more information.

For information about other technical support optionsin your area, visit ni . com/
services, or contact your local officeat ni.com/contact.

e Training and Certification—Visit ni . com/training for training and certification
programinformation. You can also register for instructor-led, hands-on courses at locations
around the world.

e System Integration—If you havetime constraints, limited in-housetechnical resources, or
other project challenges, National Instruments Alliance Partner members can help. Tolearn
more, call your local NI office or visitni .com/alliance.

You also can visit the Worldwide Offices section of ni . com/niglobal to access the branch
office Web sites, which provide up-to-date contact information, support phone numbers, email
addresses, and current events.

© National Instruments | A-1


http://www.ni.com
http://www.ni.com
http://www.ni.com/support
http://www.ni.com/support
http://www.ni.com/support
http://www.ni.com/forums
http://www.ni.com/self-paced-training
http://www.ni.com/self-paced-training
http://www.ni.com/ssp
http://www.ni.com/services
http://www.ni.com/services
http://www.ni.com/contact
http://www.ni.com/training
http://www.ni.com/alliance
http://www.ni.com/niglobal

Glossary

A

automatic scaling

B

block diagram

Boolean controls and
indicators

broken Run button

broken VI

Ability of scalesto adjust to the range of plotted values. On graph
scales, autoscaling determines maximum and minimum scale val ues.

Pictorial description or representation of aprogram or algorithm. The
block diagram consists of executable icons called nodes and wires
that carry data between the nodes. The block diagram is the source
code for the VI. The block diagram resides in the block diagram
window of the V1.

Front panel objects to manipulate and display Boolean (TRUE or
FALSE) data.

Button that replacesthe Run button when aV I cannot run because of
errors.

V1 that cannot run because of errors; signified by a broken arrow in
the broken Run button.
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Glossary

C

channel

checkbox

conditional terminal

Context Help

window

control
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1. Physica—A terminal or pin at which you can measure or generate
an analog or digital signal. A single physical channel can include
more than one terminal, asin the case of adifferential analog input
channel or adigital port of eight lines. A counter also can bea
physical channel, although the counter name is not the name of the
termina where the counter measures or generates the digital signal.

2. Virtual—A collection of property settingsthat can include aname,
aphysical channel, input terminal connections, the type of
measurement or generation, and scaling information. You can define
NI-DAQmXx virtual channels outside atask (global) or inside a task
(local). Configuring virtual channelsisoptional in Traditional
NI-DAQ (Legacy) and earlier versions, but isintegral to every
measurement you take in NI-DAQmx. In Traditional NI-DAQ
(Legacy), you configure virtual channelsin MAX. In NI-DAQmX,
you can configure virtual channels either in MAX or in your
program, and you can configure channels as part of atask or
separately.

3. Switch—A switch channel represents any connection point on a
switch. It can be made up of one or more signa wires (commonly
one, two, or four), depending on the switch topology. A virtual
channel cannot be created with a switch channel. Switch channels
may be used only in the NI-DAQmx Switch functionsand VIs.

Small square box in adialog box which you can select or clear.
Checkboxes generally are associated with multiple options that you
can set. You can select more than one checkbox.

Terminal of aWhile Loop that contains a Boolean value that
determinesif the VI performs another iteration.

Window that displays basic information about LabVIEW objects
when you move the cursor over each object. Objects with context
help information include Vs, functions, constants, structures,

palettes, properties, methods, events, and dialog box components.

Front panel object for entering datato aV| interactively or toasubV|
programmatically, such as a knob, push button, or dial.



Controls palette

current V1

D
DAQ

DAQ Assistant

DAQ device

data acquisition

(DAQ)

dataflow

datatype

default

device

drag

Getting Started with LabVIEW

Palette that contains front panel controls, indicators, and decorative
objects.

V1 whose front panel, block diagram, or Icon Editor is the active
window.

See data acquisition (DAQ).

A graphical interface for configuring measurement tasks, channels,
and scales.

A device that acquires or generates data and can contain multiple
channels and conversion devices. DAQ devicesinclude plug-in
devices, PCMCIA cards, and DAQPad devices, which connect to a
computer USB or |EEE 1394 port. SCX| modules are considered
DAQ devices.

1. Acquiring and measuring analog or digital electrical signalsfrom
sensors, acquisition transducers, and test probes or fixtures.

2. Generating analog or digital electrical signals.

Programming system that consists of executable nodes that execute
only when they receive al required input data. The nodes produce
output data automatically when they execute. LabVIEW isa
dataflow system. The movement of data through the nodes
determines the execution order of the VIsand functions on the block
diagram.

Format for information. In LabVIEW, acceptable datatypesfor most
Vs and functions are numeric, array, string, Boolean, path, refnum,
enumeration, waveform, and cluster.

Preset value. Many VI inputs use adefault valueif you do not specify
avalue.

An instrument or controller you can access as a single entity that
controls or monitors real-world 1/0 points. A device oftenis
connected to a host computer through some type of communication
network. See also DAQ device and measurement device.

To use the cursor on the screen to select, move, copy, or delete
objects.
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Glossary

driver

dynamic data type

E

Error list window

error message

Express VI

For Loop

front panel

function

Functions palette

G

Genera Purpose
Interface Bus

G-4 | nicom

Software that controls a specific hardware device, such asa DAQ
device.

Datatype used by Express Vs that includes the data associated with
asignal and attributesthat provide information about the signal, such
asthe name of the signal or the date and time LabVIEW acquired the
data. Attributes specify how the signal appears on a graph or chart.

Window that displays errors and warnings occurring ina V1 and in
some cases recommends how to correct the errors.

Indication of a software or hardware malfunction or of an
unacceptable data entry attempt.

A subV| designed to aid in common measurement tasks. You
configure an Express VI using a configuration dialog box.

Iterative loop structure that executes its subdiagram a set number of
times. Equivalent to text-based code: For i = 0 to n - 1,
do....

Interactive user interface of a V1. Front panel appearance imitates
physical instruments, such as oscilloscopes and multimeters.

Built-in execution element, comparable to an operator, function, or
statement in a text-based programming language.

Palette that contains Vs, functions, block diagram structures, and
constants.

GPIB. Synonymous with HP-IB. The standard bus used for
controlling electronic instruments with a computer. Also called
| EEE 488 bus because it is defined by ANSI/IEEE

Standards 488-1978, 488.1-1987, and 488.2-1992.



graph

110

icon
indicator

instrument driver
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2D display of one or more plots. A graph receivesand plotsdataasa
block.

Input/Output. The transfer of data to or from a computer system
involving communications channels, operator input devices, and/or
data acquisition and control interfaces.

Graphical representation of anode on ablock diagram.

Front panel object that displays output, such asagraph or LED.

A set of high-level functions that control and communicate with
instrument hardware in a system.

Instrument 1/0 Assistant  Add-on launched from the Instrument 1/0 Assistant Express VI that

|abel

LabVIEW

LED

legend

M
MAX

Measurement &
Automation Explorer

measurement device

communicates with message-based instruments and graphically
parses the response.

Text object used to name or describe objects or regions on the front
panel or block diagram.

Laboratory Virtual Instrument Engineering Workbench. LabVIEW is
agraphical programming language that usesiconsinstead of lines of
text to create programs.

Light-emitting diode.

Object agraph or chart owns to display the names and plot styles of
plots on that graph or chart.

See Measurement & Automation Explorer.

The standard National Instruments hardware configuration and
diagnostic environment for Windows.

DAQ devices such asthe E Series multifunction 1/0 (M10O) devices,
SCXI signal conditioning modules, and switch modules.

© National Instruments | G-5



Glossary

menu bar

NI-DAQ

NI-DAQmMx

node

numeric controls and
indicators

@)

object

Operating tool
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Horizontal bar that lists the names of the main menus of an
application. The menu bar appears below the title bar of awindow.
Each application has a menu bar that is distinct for that application,
although some menus and commands are common to many
applications.

Driver software included with all NI DAQ devices and signal
conditioning components. NI-DAQ isan extensivelibrary of VIsand
ANSI C functions you can call from an application development
environment (ADE), such as LabVIEW, to program an NI
measurement device, such asthe M Series multifunction 1/0 (MIO)
DAQ devices, signal conditioning modules, and switch modules.

Thelatest NI-DAQ driver with new Vs, functions, and devel opment
tools for controlling measurement devices. The advantages of
NI-DAQmx over earlier versions of NI-DAQ include the DAQ
Assistant for configuring channels and measurement tasks for your
device for usein LabVIEW, LabWindows™/CVI™, and
Measurement Studio; NI-DAQmx simulation for most supported
devices for testing and modifying applications without plugging in
hardware; and a simpler, moreintuitive API for creating DAQ
applications using fewer functions and Vs than earlier versions of
NI-DAQ.

Program execution element. Nodes are analogous to statements,
operators, functions, and subroutines in text-based programming
languages. On a block diagram, nodes include functions, structures,
and subVls.

Front panel objects to manipulate and display numeric data.

Generic term for any item on the front panel or block diagram,
including controls, indicators, structures, nodes, wires, and imported
pictures.

Tool to enter data into controls or to operate them.



P

palette

plot

Positioning tool

project

Project Explorer
window

Propertiesdialog
boxes

pull-down menus

PXI1

RMS

sample

scae

shortcut menu

Getting Started with LabVIEW

Displays objectsor toolsyou can use to build thefront panel or block
diagram.

Graphical representation of an array of data shown either on agraph
or achart.

Tool to move and resize objects.

A collection of LabVIEW files and files not specific to LabVIEW
that you can use to create build specifications and deploy or
download files to targets.

Window in which you can create and edit LabVIEW projects.
Dialog boxes accessed from the shortcut menu of a control or
indicator that you can use to configure how the control or indicator

appearsin the front panel window.

Menus accessed from amenu bar. Pull-down menu items are usually
general in nature.

PCI eXtensions for Instrumentation. A modular, computer-based
instrumentation platform.

Root Mean Square.

Single analog or digital input or output data point.

Part of graph, chart, and some numeric controls and indicators that
containsaseries of marksor pointsat known intervalsto denote units
of measure.

Menu accessed by right-clicking an object. Menu items pertain to
that object specificaly.
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Glossary
string

structur

e

subpalette

subVI

task

template VI

terminal

tip strip

tool

toolbar

Traditional NI-DAQ

(Legacy)

G8 |

ni.com

Representation of avalue as text.

Program control element, such as a Flat Sequence structure, Stacked
Sequence structure, Case structure, For Loop, While Loop, or
Timed Loop.

Palette that you access from another palette that is above the
subpalette in hierarchy.

V1 used on the block diagram of another V1. Comparable to a
subroutine.

A collection of one or more channels, timing, triggering, and other
propertiesin NI-DAQmx. A task represents a measurement or
generation you want to perform.

V1 that contains common controls and indicators from which you can
build multiple Vis that perform similar functions. Access template
Vs from the New dialog box.

Object or region on a node through which data pass.

Small yellow text banners that identify the termina name and make
it easier to identify terminals for wiring.

Special cursor to perform specific operations.
Bar that contains command buttons to run and debug Vls.

An older driver with outdated APIs for developing data acquisition,
instrumentation, and control applications for older National
Instruments DAQ devices. You should use Traditional NI-DAQ
(Legacy) only in certain circumstances. Refer to the NI-DAQ
Readme for more information about when to use Traditional
NI-DAQ (Legacy), including a complete list of supported devices,
operating systems, and application software and language versions.



\
VI

virtual instrument
)

VXI

W

waveform
waveform chart
While Loop
wire

Wiring tool

Getting Started with LabVIEW

See virtual instrument (VI).

Programin LabVIEW that models the appearance and function of a
physical instrument.

VME eXtensions for |nstrumentation (bus).

Multiple voltage readings taken at a specific sampling rate.
Indicator that plots data points at a certain rate.

L oop structure that repeats a section of code until a condition occurs.
Data path between nodes.

Tool to define data paths between terminals.
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Index

A

acquiring
information for instruments, 4-9
signals, 4-2

Acquiring a Signal VI block diagram
(figure), 1-14
adding
See also creating
channels to tasks, 4-5
controls from the block diagram, 2-5
controlsto the front panel, 1-4
graph indicators, 2-5
inputsto Express Vls, 1-7, 2-4, 3-13
multiple signals, 3-4
numeric indicators, 2-4
signals, 3-3
visual cues on front panel, 3-9
warning lights, 3-9
Amplitude and Level Measurements Express
VI, 3-2
analyzing voltage, 3-7
analyzing signals, 3-7
applications
building, 5-4
communicating with across
networks, 5-4
Arithmetic & Comparison palette, 1-11

B

blank Vls, 2-2

block diagram, 1-4, 1-18
customizing, 2-12
indicators, 3-14
placing objects from help, 2-12
showing, 1-6

broken
Run button, 2-7
wires, 2-7, 2-13

Build Table Express VI, 2-9

building
applications, 5-4
shared libraries, 5-4

Vis, 1-1
buttons

adding, 3-12

Run, 1-4

C

calling code from text-based languages, 5-4,
5-5
changing signal types, 1-6
channels, 4-2
adding to tasks, 4-5
renaming, 4-4
communicating
with instruments, 4-6
with LabVIEW applications across
networks, 5-4
Comparison Express VI, 3-9
configuration dialog boxes, 1-19
configuring
controls, 1-19
indicators, 1-19
Context Help window, 2-11
button, 2-2, 3-2
displaying configuration of Express
Vls, 3-2
displaying errors, 2-13
figure, 2-2
showing, 2-2
controlling
execution speed, 2-8
Vls programmatically, 5-4
controls, 1-18, 3-14
adding from the block diagram, 2-5
adding to the front panel, 1-4
configuring, 1-19
creating, 2-5, 2-12
customizing, 1-15
datatypes, 5-3
numeric, 5-1
palette, 1-4
Controls palette, 1-4
figure, 1-5
showing all categories, 5-1
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Index

Convert from/to Dynamic Data Express
Vs, 5-3
creating
See also adding
controls, 2-5, 2-12
graph indicators, 2-5
indicators, 2-12
NI-DAQmX tasks, 4-2
customizing
block diagrams, 2-12
controls, 1-15
front panels, 2-4
indicators, 1-17
menus, 5-4
simulated signals, 3-3

D
DAQ Assistant Express VI, 4-2, 4-11
DAQ devices, 4-2
data
displaying
from DAQ devices, 4-4
intables, 2-9, 2-13
dynamic, converting from and to, 5-3
graphing from DAQ devices, 4-4
saving
to afile, 3-11, 3-12
when prompted by a user, 3-13
storing, 3-12
dataflow, 1-9, 1-14, 1-18
data types
dynamic, 5-3
overview, 5-3
deleting wires, 1-10
deselecting objects, 1-8
diagnostic tools (NI resources), A-1
displaying
datafrom DAQ devices, 4-4
datain tables, 2-9, 2-13
errors in Context Help window, 2-13
signasinagraph, 1-14
documentation
introduction to this manual, ix
NI resources, A-1
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drivers
instrument, 4-6
NI resources, A-1
dynamic data, converting from and to, 5-3

E
Error list window, 2-7, 2-13
errors, 2-13
displaying in Context Help
window, 2-13
list, 2-7, 2-13
window, 2-7, 2-13
example Vis
NI Example Finder, 2-11
examples (NI resources), A-1
Execution Control palette, 2-6
execution speed, controlling, 2-8
ExpressVls, 1-19
Amplitude and Level Measurements,
32,37
Build Table, 2-9
Comparison, 3-9
configuration dialog boxes, 1-19
Convert from/to Dynamic Data, 5-3
DAQ Assistant, 4-2, 4-11
Filter, 3-5
Formula, 1-11
inputs, 1-19
Instrument I/O Assistant, 4-8, 4-12
Scaling and Mapping, 1-11
Simulate Signals, 1-6
Time Delay, 2-8
Write To Measurement File, 3-11, 3-14

F
files
grouping, 5-4
saving to other formats, 5-4
Filter Express VI, 3-6
Formula Express VI, 1-11, 3-4
front panel, 1-3, 1-18, 2-9
Acquiring aSignal VI (figure), 1-1
adding
controls, 1-4
visual cues, 3-9



controls, 1-18, 3-14

customizing, 2-4

indicators, 1-18

modifying, 2-7

showing, 1-9

Warning Light VI (figure), 3-1
functions, 5-2

Merge Signals, 1-14, 2-5
Functions palette

figure, 1-11

showing all categories, 5-2

G
Getting Started window, 1-2, 3-2
graph indicators, creating, 2-5
graphing
datafrom DAQ devices, 4-4
two signals, 1-14
grouping files, 5-4

H
help
Context Help window, 2-2, 2-11, 3-2
LabVIEW Help, 1-19
searching, 2-3, 2-10, 2-12
LabVIEW resources, 1-19, 2-11
searching, 2-3, 2-10, 2-12
technical support, A-1

I

indicators, 1-18, 3-14, 5-1
adding numeric, 2-4
configuring, 1-19
creating, 2-12
customizing, 1-17
datatype, 5-3
numeric, 5-1
removing, 2-7

Input palette, 2-2

inputs, Express VI, 1-19

Instrument Driver Network, 4-6

instrument drivers, 4-6
finding, 4-12
installing, 4-12
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NI resources, A-1

Instrument I/O Assistant Express VI,

4-8, 4-12

instruments
acquiring information, 4-9
communicating, 4-6
parsing information, 4-9
selecting, 4-9

introduction to this manual, ix

K
knob control, customizing (figure), 1-16
KnowledgeBase, A-1

L

LabVIEW
help resources, 2-11
other features, 5-1
projects, 5-4

LabVIEW Help, 1-19
searching, 2-3, 2-10, 2-12

LEDs, palette, 3-9

LVM. See lvmfiles

Ivmfiles, 3-12, 3-14

M

manual. See documentation
marquee, 2-9
menus, customizing, 5-4
Merge Signals function, 2-5
figure, 1-15
modifying
front panels, 2-7
signals, 1-10, 2-3

N
National |nstruments support and services,
A-1
New dialog box, 1-2, 3-2
figure, 1-3
NI Example Finder, 2-11
NI Instrument Driver Finder, 4-12
NI Instrument Driver Network, 4-6
NI support and services, A-1

© National Instruments | -3



Index

NI-DAQmX tasks, 4-11
creating, 4-2

numeric controls, 5-1
palette, 1-5

O
objects
deselecting, 1-8
wiring on the block diagram, 1-8
Operating tool, 1-9
outputs, Express VI, 1-19

P

palettes
Arithmetic & Comparison, 1-11
Controls, 1-4
Execution Control, 2-6, 2-12
Functions, 1-10
Input, 2-2
LEDs, 3-9
searching, 2-6
showing al categories, 5-1, 5-2

parsing information for instruments, 4-9
placing objects on the block diagram from the

help, 2-12
Positioning tool, 1-8
programmatically controlling Vs, 5-4

programming examples (NI resources), A-1

projects, 5-4
property dialog boxes, 1-19, 1-20
publishing VIs on the Web, 5-4

R

related documentation, ix
removing indicators, 2-7
Run button, 1-4
broken, 2-7, 2-13
running Vs, 1-9
continuoudly, 2-6

S
saving data
different file formats, 5-4

I-4 | ni.com

Save Data V1 block diagram
(figure), 3-13
tofiles, 3-11, 3-12, 3-14

when prompted by user, 3-13, 3-14

searching
examples, 2-11
help, 2-3, 2-10, 2-12
palettes, 2-6
selecting
instruments, 4-9
objects, 1-8
shared libraries, building, 5-4
signas
acquiring, 4-2
anayzing, 3-7
changing type, 1-6
graphing, 1-14
modifying, 1-10, 2-3
Simulate Signal Express VI, 1-6
simulated signals, customizing, 3-3
software (NI resources), A-1
subVls, 5-2
support, technical, A-1
system requirements, ix

T
tables, 2-9
displaying data, 2-13
tasks
adding new channels, 4-5
NI-DAQmXx, 4-11
TDM. See .tdm files
tdmfiles, 3-14
tdmsfiles, 3-14
technical support, A-1
template Vs, 1-2

text-based languages, calling code, 5-4, 5-5

Time Delay Express VI, 2-8
tools
Operating, 1-9
Positioning, 1-8
Wiring, 1-9

training and certification (NI resources), A-1

troubleshooting (NI resources), A-1



U
user interface. See front panel
\Y
virtual instruments. See VlIs
Vs, 1-1
blank, 2-1
building, 1-1
customizing menus, 5-4
icons, 5-2
new, 2-1

programmeatically controlling, 5-4
publishing on the Web, 5-4
running, 1-9
continuoudly, 2-6
subVls, 5-2
template, 1-2
voltage, analyzing, 3-7

w
Warning Light VI block diagram
(figure), 3-10
warning lights, adding, 3-9
Web resources, A-1
While Loop, 2-7
wires
broken, 2-7, 2-13
deleting, 1-10
wiring
objects on the block diagram, 1-8
tool, 1-8
Write to Measurement File Express VI, 3-12,
3-14
saving data, 3-12
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