CIS 1100
Introduction to Computer Programming
Adam Mally

www.cis110.com
What is Computing?
Computing: internet, e-mail, network...
Computing: Productivity...
Computing: Entertainment...
Computing: Entertainment...
“Computer science is no more about computers than astronomy is about telescopes”

- Edsger Dijkstra
Cutting Edge Computer Science
Mapping the Epigenome

DNA contains the genetic blueprint for all human cells, but the reading and execution of the blueprint inside each cell is controlled in part by chemical markers attached to the DNA. Scientists have begun to map some of these epigenetic markers, including CpG methylation.

CpG methylation

DNA is a code written with four letters: A, T, C, and G. Each standing for one nucleotide. In CpG methylation, a small marker called a methyl group attaches to the DNA at a CpG site, where a G and a C nucleotides sit next to each other.

Chromosome 22

Of the 22 pairs of chromosomes in the human genome, 22 is the second smallest, containing only about 2 percent of DNA in the genome.

Genes

Some of the known genes from Chromosome 22 that fall within the tested areas are shown outside the chart. CpG methylation is one of several epigenetic factors that is.

Reading the chart

The outer ring represents 56 million base pairs in Chromosome 22. Orange marks highlight areas of the chromosome that were tested for CpG methylation in a pilot study by the Human Epigenomics Project.

Measuring CpG methylation

Bar charts indicate the average amount of CpG methylation found within the tested areas. Each chart covers 100,000 base pairs. Some charts have been shifted, shown with connecting lines.

AMOUNT OF METHYLATION

0 to 20%
20 to 80%
80 to 100% of CpG sites

Variation among tissues

Each concentric ring of bar charts represents a different tissue, from muscle cells to sperm cells. Methylation levels that are significantly above or below the average level across all of the tissues are highlighted, indicating possible cell-specific differences.
Chinook

- Chinook is the World Man-Machine Checkers Champion, developed by researchers at the University of Alberta.

- It earned this title by competing in human tournaments, winning the right to play for the (human) world championship, and eventually defeating the best players in the world.

- Visit http://www.cs.ualberta.ca/~chinook/ to play a version of Chinook over the Internet.

- The developers have fully analyzed the game of checkers and have the complete game tree for it.
  - Perfect play on both sides results in a tie.

- “One Jump Ahead: Challenging Human Supremacy in Checkers” Jonathan Schaeffer, University of Alberta (496 pages, Springer. $34.95, 1998).
Autonomous Cars

As of 2016

Legend
With Driver: Enacted | Executive Order | In Progress
Driverless: Enacted | Executive Order | In Progress
Driverless assuming already enacted with driver

Penn’s Autonomous Car
2011 Jeopardy!

- In February 2011, IBM Watson bested Brad Rutter (biggest all-time money winner) and Ken Jennings (longest winning streak)
- IBM is currently applying Watson’s technology to medical diagnosis and legal research
Robot Soccer

Aibo League

UPennalizers
Robot Soccer Team
Areas in Computer Science

- Artificial Intelligence
- Robotics
- Human-Computer Interaction
- Computer Graphics
- Computer Vision
- Operating Systems
- Computer Networking
- Databases
- Computer Security
- Ubiquitous Computing
What is Computer Science?

Computer science is the study of solving problems using computation

- Computers are part of it, but the emphasis is on the problem solving aspect

Computer scientists work across disciplines:

<table>
<thead>
<tr>
<th>Mathematics</th>
<th>Geoscience</th>
<th>Medicine/Surgery</th>
</tr>
</thead>
<tbody>
<tr>
<td>Biology (bioinformatics)</td>
<td>Archeology</td>
<td>Engineering</td>
</tr>
<tr>
<td>Chemistry</td>
<td>Psychology</td>
<td>Linguistics</td>
</tr>
<tr>
<td>Physics</td>
<td>Sociology</td>
<td>Art</td>
</tr>
<tr>
<td>Geology</td>
<td>Cognitive Science</td>
<td>...</td>
</tr>
</tbody>
</table>
Computing is important
Annual **Total** U.S. STEM Jobs Thru 2022 vs. Recent College Grads

- **Total Job Openings**
- **Bachelors Degrees Awarded**

Data Sources:
Computing is Consistently Ranked Among the Best Occupations

CS-Related Jobs Highlighted in Red

The 25 Best Jobs of 2017

<table>
<thead>
<tr>
<th>Rank</th>
<th>Job Title</th>
<th>#6 Statistician</th>
<th>#7 Pediatrician</th>
</tr>
</thead>
<tbody>
<tr>
<td>#1</td>
<td>Software Developer</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#2</td>
<td>Dentist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#3</td>
<td>Physician’s Assistant</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#4</td>
<td>Nurse Practitioner</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#5</td>
<td>Orthodontist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#6</td>
<td>Statistician</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#7</td>
<td>Pediatrician</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#8</td>
<td>Obstetrician and Gynecologist</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#8</td>
<td>Oral and Maxillofacial Surgeon</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#8</td>
<td>Physician</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

CS Careers Rank Highly In:

- Job satisfaction
- Salary
- Work/life balance
- Growth potential
- Employment rate
- Work environment
Computer science tops list of best major for jobs

BY RACHEL GOTTFRIED

Computer science graduates now get more offers of employment than any other major. This is the first time since 2008 that computer science has topped the list: previously, accounting majors had the highest offer rate.

In 2011, 56.2% of computer science majors received job offers, compared to only 53.8% of accounting majors. The offer rate for computer science majors increased 13.8% this year from the previous year.

Computer science and accounting majors are in high demand because both are needed in a wide range of industries.

“There are many different companies that need to hire computer scientists,” said Mimi Collins, director of communications at the National Association of Colleges and Employers.

“They aren’t tied to one particular industry—majors like nursing do not enjoy that benefit.”

Although this is good news for computer science grads, it might not be for the computer industry. According to Collins, “One computer science graduate may have 10 offers as opposed to one accounting graduate that’s getting five offers.” So, computer science majors may be getting more offers, but this is only because there is a shortage of people who graduate with such a degree.

According to Collins, companies like to hire recent graduates because they have the latest skills.

“Things change very quickly, especially in computer science,” said Collins. “Many organizations have a formal track where they want to bring in new college graduates and train them the way they want them to be trained.”

Annabelle Evans graduated as a computer science major from the University of Southern California in 2008. “When I picked my major, I knew there wouldn’t be a lack of jobs as a computer scientist, but I had no idea it would be this much.” Evans now works at Google.
Administrivia
Overview

CIS 110: Introduction to Programming and Computer Science

Goals:
- How can we use computers to solve problems?
- How can we formulate problems so that we can solve them via computation?

Topics:
- Programming in Java
- Computer organization and assembly language
- Applications to science, engineering, and art

“Computers are incredibly fast, accurate, and stupid; humans are incredibly slow, inaccurate, and brilliant; together they are powerful beyond imagination.” — Albert Einstein
The Basics

Instructor: Adam Mally

- Adam’s Regular Office Hours: Mondays 4-5pm and Wednesdays 3-4pm EDT
- Please do not email; post a private message to Ed Discussion instead with a subject starting with “[PROF]”

TA Office Hours:

- Help with debugging
- Bring your laptop or use lab computers
- All office hours are posted on the course web site
- Enter the office hours queue [here]
  - Put a link to your own Zoom meeting room
- Only use Ed Discussion, office hours, or email to contact your TAs

Full details: www.cis110.com
Grading

Grade Breakdown:
   Homeworks: 60%
   Exam 1: 15%
   Exam 2: 15%
   Attendance/Record Viewing: 10%

Exam 1: *Thursday June 13 on Gradescope*

Exam 2: *Wednesday July 3 on Gradescope*

Notes:
- You can check your grades on GradeScope
Course Materials

Course Website: www.cis110.com
- Programming assignments and checklists
- Assignment submission & grades
- Lecture slides
- Discussion board (Piazza)

Textbook: Sedgewick and Wayne

skim before lecture; read thoroughly afterwards
Homework Programming Assignments

Due: 11:59pm on Monday/Tuesday nights on GradeScope
◆ 4 late days to use throughout semester (max 2 per homework)
◆ No other late submissions allowed
◆ See course webpage for other policies

Computing equipment:
◆ Your desktop/laptop
◆ Setting up the software will be described in HW0
Advice

- Start on HWs early! Debugging can take time.
- Back up your work like crazy.
- Office hours are less crowded if you attend shortly after assignments are released.
- Do not hesitate to ask for help. If you have been trying to debug something for an hour and are getting frustrated, remember that we are there to help you.
- Your best sources for help are the instructors, the TAs and Piazza.
- Please read and follow the collaboration policy.
- Do not use Stack Overflow or other online discussion boards.
Getting Started in Java

CIS 110
Your First Program

```java
public class HelloWorld {
    public static void main(String[] args) {
        System.out.println("Hello, World");
    }
}
```

Compilation completed.

**Section 1.1**
Your First Program

Program Name

```java
public class HelloWorld {
    public static void main(String[] args) {
        System.out.println("Hello, World");
    }
}
```

Section 1.1
Your First Program

Scaffolding

```
public class HelloWorld {
    public static void main(String[] args) {
        System.out.println("Hello, World");
    }
}
```

Section 1.1
Your First Program

Print the text "Hello, World".

Section 1.1
Your First Program

Statements end with a ;

Section 1.1
Your First Program

Compile to translate to machine code

```
public class HelloWorld {
    public static void main(String[] args) {
        System.out.println("Hello, World");
    }
}
```

Section 1.1
Your First Program

Run the compiled program

```java
public class HelloWorld {
    public static void main(String[] args) {
        System.out.println("Hello, World");
    }
}
```

Welcome to DrJava. Working directory is /Users/bjbrown/introcs

> run HelloWorld
Hello, World

Section 1.1
Why Java?

Java

```java
public class Hello World {
    public static void main(String[] args) {
        System.out.println("Hello, World.");
    }
}
```

C/C++

```c
#include <stdio.h>

int main(int argc, char** argv) {
    printf("Hello, World.
");
    return 0;
}
```

Matlab

```matlab
disp('Hello, World.)
```

JavaScript

```javascript
document.write("Hello, World.");
```

Fortran

```fortran
PROGRAM HELLO
PRINT *, 'Hello, World.'
END
```

OCaml

```ocaml
print_endline "Hello, World."
```

Lisp

```lisp
(princ "Hello, World.")
```

sh

```sh
echo Hello, World.
```

Logo

```logo
print [Hello, World.]
```

Java is:

- Widely used
- Practical for many problems
- Includes most modern language abstractions

"There are only two kinds of [programming] languages: the ones people complain about and the ones nobody uses." - Bjarne Stroustrup

Your computer speaks this
Navigating Codio
When you first open a project:

The filetree
All files you use will live here.
You can click on them to show them in the editor.

Looks like you don't have any files open right now.
Click a file from the file tree to open it, or create a new file.

Some other things to try...
- Open a Terminal window: Tools->Terminal menu or Shift+Alt+T
- Open any file by typing its name File->Open File menu or Ctrl+O
- Create multiple code editing panels: View->Panels
- Information about the Box: Project->Box Info menu
- Install languages, databases and other software: Tools->Install Software menu
- Uploading your Box public keys to GitHub or BitBucket: Codio->Account menu then select Applications
- Find and upload your public keys to any remote server: Codio->Account menu then select SSH Keys
Looks like you don't have any files open right now.
Click a file from the file tree to open it, or create a new file.

Some other things to try...

- Open a Terminal window: Tools > Terminal menu or Shift+Alt+T
- Open any file by typing its name File > Open File menu or Ctrl+O
- Create multiple code editing panels: View > Panels
- Information about the Box: Project > Box Info menu
- Install languages, databases and other software: Tools > Install Software menu
- Uploading your Box public keys to GitHub or BitBucket: Codio > Account menu then select Applications
- Find and upload your public keys to any remote server: Codio > Account menu then select SSH Keys
CREATE NEW FILE

CURRENT PATH
Root folder

FILE NAME
HelloWorld.java

OK CANCEL
HelloWorld.java (an empty file) is now open in the editor for editing!

The new file appears in the filetree!

The editor

HelloWorld.java (an empty file) is now open in the editor for editing!
This is the Syllabus page of the website

CIS 110 - Introduction to Computer Programming

CIS 110 Syllabus

- This is a tentative syllabus and schedule. Topics, reading assignments, and due dates are subject to change. This syllabus will be updated throughout the semester, so please reload this page before lectures to get the up to date version.
- Lecture recordings are available to registered students on the course canvas page. Recordings are added within an hour of lecture's end.

<table>
<thead>
<tr>
<th>Date</th>
<th>Topics</th>
<th>Example Code</th>
<th>HW Assigned</th>
<th>HW Due</th>
<th>Lecture Recording</th>
<th>Module Videos</th>
<th>Announcements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wed, Jan 20, 2021</td>
<td>Introduction</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>First Day of Classes!</td>
</tr>
<tr>
<td>Fri, Jan 22, 2021</td>
<td>Drawing</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mon, Jan 25, 2021</td>
<td>Variables &amp; Types</td>
<td>HelloWorld Java</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Name: Harry Smith
PennKey: sharry
Execution: java HelloWorld
Prints "Hello, World!". By tradition, this is everyone's first program.

public class HelloWorld {
    /**
     * This is a comment, it is not code.
     */

    // this is also a comment
    public static void main(String args[]) {
    }
}
```java
/* Name: Harry Smith
 * PennKey: sharry
 */

public class HelloWorld {
    /**
     * This is a comment
     */

    // this is also a comment
    public static void main(String args[]) {
    }
}
Our First Program
public class HelloWorld {
    /**
     * This is a comment, it is not code.
     */

    // this is also a comment

    public static void main(String args[]) {

        Code goes here!
    }
}
public class HelloWorld {

    /**
     * This is a comment, it is not code.
     */

    // this is also a comment

    public static void main(String args[]) {
        Code goes here!
    }
}
public class HelloWorld {

    /**
     * This is a comment, it is not code.
     */

    // this is also a comment

    public static void main(String args[]) {

        // Code goes here!

    }

}
public class HelloWorld {
    /**
     * This is a comment, it is not code.
     */
    // this is also a comment

    public static void main(String args[]) {

    }
}

Code goes here!
This is called “the body of our main method.”
The filetree
All files you use will live here.
You can click on them to show them in the editor.

Compile button
Click this button to compile all .java files in your filetree.

View Running Program Button
Shows you the visual output of your program.

Looks like you don't have any files open right now.
Click a file from the file tree to open it, or create a new file.

Some other things to try...
- Open a Terminal window: Tools->Terminal menu or Shift+Alt+T
- Open any file by typing its name File->Open File menu or Ctrl+O
- Create multiple code editing panels: View->Panels
- Information about the Box: Project->Box Info menu
- Install languages, databases and other software: Tools->Install Software menu
- Uploading your Box public keys to GitHub or BitBucket: Codio->Account menu then select Applications
- Find and upload your public keys to any remote server: Codio->Account menu then select SSH Keys
After clicking the Compile button...

Welcome to the Codio Terminal!

Documentation: https://help.ubuntu.com/

https://docs.codio.com/project/ide/boxes/#overview

Your Codio Box domain is: boxer-chicago.codio.io

Last login: Wed Mar 18 13:09:10 2020 from 192.168.10.41
javac -cp :junit-platform-console-standalone-1.3.2.jar:cis110.jar *.java
codio@boxer-chicago:~/workspace$ javac -cp :junit-platform-console-standalone-1.3.2.jar:cis110.jar *.java
codio@boxer-chicago:~/workspace$ 

**The Terminal**
This is space where we can write individual commands to communicate with the computer.
Running our program

We typed "java" followed by our program's name ("HelloWorld"). The output is:

```
Hello, World!
```

The Output
Whatever we asked our program to print will appear on the following line(s). In this case, our program prints “Hello, World!”
Computational Art

Examples
Protobyttes by Ira Greenberg
Shepard Fairey
Abstract Art
Procedural Art
More Procedural Art

How do I draw a pair of buttocks?

I'm trying to develop a function which 3D plot would have a buttocks like shape.

Several days of searching the web and a dozen my of own attempts to solve the issue have brought nothing but two pitiful formulas below.

They have some resemblance to the shape I want, though not quite.

Could you help me to obtain a proper formula?

Here are those bad solutions I've got myself:

```
ParametricPlot3D[
{Sin[y] Sqrt[1 - (Abs[x] - 1)^2],
 Cos[y] Sqrt[1 - (Abs[x] - 1)^2], x}, {x, -10, 10}, {y, -3 Pi, 3 Pi},
AspectRatio -> Automatic]
```
Red & Blue States
Summertime,
And the livin' is easy
Fish are jumpin'
And the cotton is high

Your daddy's rich
And your mamma's good lookin'
So hush little baby
Don't you cry

One of these mornings
You're going to rise up singing
Then you'll spread your wings
And you'll take to the sky

But till that morning
There's a'nothing can harm you
With daddy and mamma standing by

Summertime,
And the livin' is easy
Fish are jumpin'
And the cotton is high

Your daddy's rich
And your mamma's good lookin'
So hush little baby
Don't you cry

Lyrics by George Gershwin
Box Office Earnings

nytimes.com
February 23, 2008
Drawing in Java Using the PennDraw Library: MyHouse.java

CIS 110
Explanatory Comment

```java
public class MyHouse {
    public static void main(String[] args) {
        // set the size of the window to 500 pixels by 500 pixels
        PennDraw.setCanvasSize(500, 500);
        PennDraw.clear(PennDraw.BLUE); // draw a blue sky
    }
}
```

Your Textbook: Replace StdDraw with PennDraw

PennDraw is “StdDraw 2.0”
public class MyHouse {
    public static void main(String[] args) {
        // set the size of the window to 500 pixels by 500 pixels
        PennDraw.setCanvasSize(500, 500);
        PennDraw.clear(PennDraw.BLUE); // draw a blue sky
Color the entire window blue

Comment indicates purpose

```java
public class MyHouse {
    public static void main(String[] args) {
        // set the size of the window to 500 pixels by 500 pixels
        PennDraw.setCanvasSize(500, 500);
        PennDraw.clear(PennDraw.BLUE); // draw a blue sky
    }
}
```
Can replace BLUE with BLACK, CYAN, DARK_GRAY, GRAY, GREEN, LIGHT_GRAY, MAGENTA, ORANGE, PINK, RED, WHITE, or YELLOW

**Color the entire window blue**

```java
public class MyHouse {
    public static void main(String[] args) {
        // set the size of the window to 500 pixels by 500 pixels
        PennDraw.setCanvasSize(500, 500);

        PennDraw.clear(PennDraw.BLUE); // draw a blue sky
    }
}
```
Set the color to grass green

```plaintext
// draw a green field
PennDraw.setPenColor(0, 170, 0);
PennDraw.filledRectangle(0.5, 0.25, 0.6, 0.3);
```
Colors

Composed of three elements:

1. Red
2. Green
3. Blue

Values from 0 .. 255
### Why 0 ... 255?

Each color is represented by 32 bits:

```
0000 0000 0000 0000 0000 0000 1111 1111
```

- **IGNORE**: 0
- **RED**: 0
- **GREEN**: 0
- **BLUE**: 255

Notice there are 8 bits per color component.

The maximum value (all 1’s) that can be represented in 8 bits is 255 in decimal.

Therefore, the range for each color component is 0 (off) ... 255 (full).

<table>
<thead>
<tr>
<th>Decimal</th>
<th>Binary</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>00000000</td>
</tr>
<tr>
<td>1</td>
<td>00000001</td>
</tr>
<tr>
<td>2</td>
<td>00000010</td>
</tr>
<tr>
<td>3</td>
<td>00000011</td>
</tr>
<tr>
<td>4</td>
<td>00000100</td>
</tr>
<tr>
<td>5</td>
<td>00000101</td>
</tr>
<tr>
<td>6</td>
<td>00000110</td>
</tr>
<tr>
<td>7</td>
<td>00000111</td>
</tr>
<tr>
<td>8</td>
<td>00001000</td>
</tr>
<tr>
<td>9</td>
<td>00001001</td>
</tr>
<tr>
<td>10</td>
<td>00001010</td>
</tr>
<tr>
<td>11</td>
<td>00001011</td>
</tr>
<tr>
<td>12</td>
<td>00001100</td>
</tr>
<tr>
<td>13</td>
<td>00001101</td>
</tr>
<tr>
<td>14</td>
<td>00001110</td>
</tr>
<tr>
<td>15</td>
<td>00001111</td>
</tr>
<tr>
<td>16</td>
<td>00010000</td>
</tr>
<tr>
<td>17</td>
<td>00010001</td>
</tr>
<tr>
<td>18</td>
<td>00010010</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
</tr>
<tr>
<td>255</td>
<td>11111111</td>
</tr>
</tbody>
</table>
Set the color to grass green

```java
// draw a green field
PennDraw.setPenColor(0, 170, 0);
PennDraw.fillARectangle(0.5, 0.25, 0.6, 0.3);
```
Solid rectangle

```java
// draw a green field
PennDraw.setPenColor(0.170, 0);
PennDraw.filledRectangle(0.5, 0.25, 0.6, 0.3);
```
// draw a green field
PennDraw.setPenColor(0, 170, 0):
PennDraw.filledRectangle([0.5, 0.25], [0.6, 0.3])
Coordinate System

\[ (0, 0) \]

\[ +y \]

\[ +x \]

\[ 1.0 \]
Draw a solid triangle with corners at (0.255, 0.7), (0.745, 0.7), (0.49, 0.9)

```
PennDraw.filledPolygon(0.255, 0.7, 0.745, 0.7, 0.49, 0.9);
```
Set line thickness (default is 0.002)

```java
PennDraw.setPenRadius(0.005); // thicken the pen for outline drawing
```
Draw a rectangle outline

```java
PennDraw.rectangle(250 / 500.0, 260 / 500.0, 120 / 500.0, 90 / 500.0);
```