CIS 110
Introduction to Computer Programming

www.cis110.com
What is Computing?
Computing: internet, e-mail, network...
Computing: Productivity…
Computing: Entertainment…
Computing: Entertainment...
“Computer science is no more about computers than astronomy is about telescopes”

- Edsger Dijkstra
Cutting Edge Computer Science
Mapping the Epigenome

DNA contains the genetic blueprint for all human cells but the reading and execution of the blueprint inside each cell is controlled in part by chemical markers attached to the DNA. Scientists have begun to map some of these epigenetic markers, including CpG methylation.

DNA is a code written with four bases: A, T, C, and G. Each standing for one nucleotide.

In CpG methylation, a small marker called a methyl group attaches to the DNA at a CpG site, where a C and a G nucleotide sit next to each other.

Reading the chart

The outer ring represents 35 million base pairs in Chromosome 22. Orange marks highlight areas of the chromosome that were tested for CpG methylation in a pilot study by the Human Epigenome Project.

Measuring CpG methylation

Bar charts indicate the average amount of CpG methylation found within the tested areas. Each chart covers 100,000 base pairs. Some charts have been offset, shown with connecting bars.

AMOUNT OF METHYLATION
0% to 20%
20% to 80%
80% to 100% of CpG sites

Chromosome 22

Of the 23 pairs of chromosomes in the human genome, 22 is the second smallest, containing only about 2 percent of DNA in the genome.

Gray and white bands on the circular chart correspond to these bands on the chromosome.
Chinook

- Chinook is the World Man-Machine Checkers Champion, developed by researchers at the University of Alberta.
- It earned this title by competing in human tournaments, winning the right to play for the (human) world championship, and eventually defeating the best players in the world.
- Visit http://www.cs.ualberta.ca/~chinook/ to play a version of Chinook over the Internet.
- The developers have fully analyzed the game of checkers and have the complete game tree for it.
  - Perfect play on both sides results in a tie.
- “One Jump Ahead: Challenging Human Supremacy in Checkers” Jonathan Schaeffer, University of Alberta (496 pages, Springer. $34.95, 1998).
Autonomous Cars

Legend
With Driver: Enacted | Executive Order | In Progress
Driverless: Enacted | Executive Order | In Progress
Driverless assuming already enacted with driver
2011 Jeopardy!

• In February 2011, IBM Watson bested Brad Rutter (biggest all-time money winner) and Ken Jennings (longest winning streak)
• IBM is currently applying Watson’s technology to medical diagnosis and legal research
Robot Soccer

UPennalizers
Robot Soccer Team
Areas in Computer Science

- Artificial Intelligence
- Robotics
- Human-Computer Interaction
- Computer Graphics
- Computer Vision
- Operating Systems
- Computer Networking
- Databases
- Computer Security
- Ubiquitous Computing
What is Computer Science?

- Computer science is the study of solving problems using computation.
- Computers are part of it, but the emphasis is on the problem solving aspect.

Computer scientists work across disciplines:

- Mathematics
- Biology (bioinformatics)
- Chemistry
- Physics
- Geology
- Geoscience
- Archeology
- Psychology
- Sociology
- Cognitive Science
- Medicine/Surgery
- Engineering
- Linguistics
- Art
- …
Computing is important
Annual Total U.S. STEM Jobs Thru 2022 vs. Recent College Grads

Data Sources:
Computing is Consistently Ranked Among the Best Occupations

CS-Related Jobs Highlighted in Red

The 25 Best Jobs of 2017

<table>
<thead>
<tr>
<th>Rank</th>
<th>Job</th>
<th>Rank</th>
<th>Job</th>
</tr>
</thead>
<tbody>
<tr>
<td>#1</td>
<td>Software Developer</td>
<td>#6</td>
<td>Statistician</td>
</tr>
<tr>
<td>#2</td>
<td>Dentist</td>
<td>#7</td>
<td>Pediatrician</td>
</tr>
<tr>
<td>#3</td>
<td>Physician’s Assistant</td>
<td>#8</td>
<td>Obstetrician and Gynecologist</td>
</tr>
<tr>
<td>#4</td>
<td>Nurse Practitioner</td>
<td>#8</td>
<td>Oral and Maxillofacial Surgeon</td>
</tr>
<tr>
<td>#5</td>
<td>Orthodontist</td>
<td>#8</td>
<td>Physician</td>
</tr>
</tbody>
</table>

CS Careers Rank Highly In:

- Job satisfaction
- Salary
- Work/life balance

- Growth potential
- Employment rate
- Work environment
many different companies ... need to hire computer scientists. They aren't tied to one particular industry.
Computing has consequences
Bitcoin and Ethereum are by far the largest proof-of-work based coins; it is also worth considering their combined ranking.
Jackie Wang

“This Is a Story About Nerds and Cops”: PredPol and Algorithmic Policing
Administrivia
Overview

CIS 110: Introduction to Programming and Computer Science

Goals:
- How can we use computers to solve problems?
- How can we formulate problems so that we can solve them via computation?

Topics:
- Programming in Java
- Computer organization and assembly language
- Applications to science, engineering, and art

“Computers are incredibly fast, accurate, and stupid; humans are incredibly slow, inaccurate, and brilliant; together they are powerful beyond imagination.” — Albert Einstein
The Basics

Instructor: Eric Fouh
- Eric’s Regular Office Hours: TBA
- efouh@seas.upenn.edu

Instructor: Harry Smith
- Harry’s Regular Office Hours: TBA
- sharry@seas.upenn.edu

Only email the instructors for personal or sensitive communication; everything else should be sent through Piazza.

TA Office Hours:
- Help with debugging
- Office Hours on OHQ.io, Mon-Thurs 3:30pm-9:30pm
- Only use Piazza, office hours, or email to contact your TAs.
  - Do not email a TA unless you’ve spoken with them directly about it ahead of time.

Full details: www.cis110.com
Grading

Grade Breakdown:
- Homeworks: 64%
- Exam 1: 11%
- Exam 2: 11%
- Recitation Attendance and Code Reviews - 8%
- Check-in Quizzes : 6%

Exam 1: Oct 26\textsuperscript{th} (6:00-8:00pm)

Exam 2: Dec 3\textsuperscript{rd} (6:00-8:00pm)

Notes:
- You can check your grades on GradeScope
Course Materials

Course Website:  www.cis110.com
- Programming assignments and checklists
- Course schedule
- Lecture slides

Interactive lecture notes available in Codio soon
Homework Programming Assignments

**Due: 11:59pm on Thursday nights on GradeScope**

- 4 late days to use throughout semester (max 2 per homework)
- No other late submissions allowed
- Lowest homework dropped
- See course webpage for other policies

Computing equipment:

- Your desktop/laptop
- Codio
Advice

- Start on HWs early! Debugging can take time.
- Back up your work like crazy.
- Office hours are less crowded if you show up early in the week.
- Do not hesitate to ask for help. If you have been trying to debug something for an hour and are getting frustrated, remember that we are there to help you.
- Your best sources for help are the instructors, the TAs and Piazza.
- Please read and follow the collaboration policy.
- Do not use Stack Overflow or other online discussion boards.
Action Items

1. Register for Piazza!
2. Register for Codio!
3. Familiarize yourself with the course rhythm:
   1. Lecture MWF
   2. HWs due Thursdays (usually)
   3. Rinse and repeat
Navigating Codio
When you first open a project:

The filetree

All files you use will live here.

You can click on them to show them in the editor.

Looks like you don’t have any files open right now.
Click a file from the file tree to open it, or create a new file.

Some other things to try:

- Open a Terminal window: Tools > Terminal menu or Shift + Alt + T
- Open any file by typing its name File > Open File menu or Ctrl + O
- Create multiple code editing panels: View > Panels
- Information about the Box: Project > Box info menu
- Install languages, databases and other software: Tools > Install Software menu
- Uploading your Box public keys to Github or S3Bucket: Codio > Account menu then select Applications
- Find and upload your public keys to any remote server: Codio > Account menu then select SSH Keys
Looks like you don't have any files open right now.

Click a file from the file tree to open it, or create a new file.

Some other things to try...

- Open a Terminal window: Tools->Terminal menu or Shift+Alt+T
- Open any file by typing its name File->Open File menu or Ctrl+O
- Create multiple code editing panels: View->Panels
- Information about the Box: Project->Box Info menu
- Install languages, databases and other software: Tools->Install Software menu
- Uploading your Box public keys to GitHub or BitBucket: Codio->Account menu then select Applications
- Find and upload your public keys to any remote server: Codio->Account menu then select SSH Keys
CREATE NEW FILE

CURRENT PATH
Root folder

FILE NAME
Hello World.java
The new file appears in the filetree!

The editor
HelloWorld.java (an empty file) is now open in the editor for editing!
CIS 110 - Introduction to Computer Programming

CIS 110 Syllabus

- This is a tentative syllabus and schedule. Topics, reading assignments, and due dates are subject to change. This syllabus will be updated throughout the semester, so please reload this page before lectures to get the up to date version.
- Lecture recordings are available to registered students on the course canvas page. Recordings are added within an hour of lecture’s end.

<table>
<thead>
<tr>
<th>Date</th>
<th>Topics</th>
<th>Exam Code</th>
<th>HW Assigned</th>
<th>HW Due</th>
<th>Lecture Recording</th>
<th>Module Videos</th>
<th>Announcements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wed, Jan 20, 2021</td>
<td>Introduction</td>
<td>HelloWorld java</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>First Day of Classes!</td>
</tr>
<tr>
<td>Fri, Jan 22, 2021</td>
<td>Drawing</td>
<td></td>
<td>World!</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mon, Jan 25, 2021</td>
<td>Variables &amp; Types</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

This is the Syllabus page of the website
/** Name: Harry Smith
 * PennKey: sharry
 * Execution: java HelloWorld
 * Prints "Hello, World!". By tradition, this is everyone's first program.
 */

public class HelloWorld {
    /**
     * This is a comment, it is not code.
     */

    // this is also a comment
    public static void main(String args[]) {
    }
}
/* Name: Harry Smith
 * PennKey: sharry
 * Execution: java HelloWorld
 * Prints "Hello, World!". By tradition, this is everyone's first
 */

public class HelloWorld {
    /**
     * This is a comment
     */

    // this is also a comment
    public static void main(String args[]) {
    }
}
Learning Objectives

● To be familiar with the structure of a Java program
● To be familiar with print commands
● To be familiar with comments
● To write a program that prints something
● To recognize and fix common syntax errors
public class HelloWorld {
    /**
     * This is a comment, it is not code.
     */

    // this is also a comment

    public static void main(String args[]) {
        // Code goes here!
    }
}
public class HelloWorld {
    /**
     * This is a comment, it is not code.
     */

    // this is also a comment

    public static void main(String args[]) {
        // Code goes here!
    }
}
```
public class HelloWorld {
    /**
     * This is a comment, it is not code.
     **/
    // this is also a comment

    public static void main(String args[]) {

    }
}
```

- **Class Name** (must match the filename)
- **Comments** (notes, not run as code!)
public class HelloWorld {
    /**
     * This is a comment, it is not code.
     */
    // this is also a comment

    public static void main(String args[]) {
        // Code goes here!
        // This is called “the body of our main method.”
    }
}
Anatomy of a Java program

Java keywords. Beyond the scope of this course

A Java program is a **class**. More on classes later

The name of your program

The main **method** declaration. More on this later

```java
public class MyClass {
    public static void main(String[] args) {
        // Put your code here!
    }
}
```

Curly braces are used to start and end class definitions and method definitions

every open curly brace { must have a matched close curly brace }

Java keywords. Beyond the scope of this course

A Java program is a **class**. More on classes later

The name of your program

The main **method** declaration. More on this later

```java
public class MyClass {
    public static void main(String[] args) {
        // Put your code here!
    }
}
```

Curly braces are used to start and end class definitions and method definitions

every open curly brace { must have a matched close curly brace }
Print commands

- Display information on the screen
- Two types of print commands:
  - `System.out.println(value)`: prints the value followed by a new line (ln)
  - `System.out.print(value)`: prints the value without advancing to the next line
Print text

- prints out the characters between the first " and the second " followed by a new line

```
System.out.println("Hello world");
```

A semicolon ends the command (statement)

```
jshell> System.out.println("Hello world ");
Hello world
```

```
jshell> 
```
public class MyClass
{
    public static void main(String[] args)
    {
        System.out.println("Hello world!");
    }
}
Comments

- `//` is used to mark the beginning of a comment (single-line)
- `/* ... */` is used for multi-line comments
- The compiler (program that runs your program!) skips comments
- Comments are used to make notes to ourself and to annotate the code

```java
/* MyClass.java
   Programmer: My Name
   Date:
*/

int max = 10; // this keeps track of the max score
```
The filetree

All files you use will live here.

You can click on them to show them in the editor.

Compile button
Click this button to compile all .java files in your filetree.

View Running Program Button
Shows you the visual output of your program.

Looks like you don’t have any files open right now.
Click a file from the file tree to open it, or create a new file.

Some other things to try...
- Open a Terminal window: Tools > Terminal menu or Shift+Alt+T
- Open any file by typing its name in File > Open File menu or Ctrl+O
- Create multiple code editing panels: View > Panels
- Information about the Box: Project > Box Info menu
- Install languages, databases and other software: Tools > Install Software menu
- Uploading your Box public keys to GitHub or BitBucket: Codio > Account menu then select Applications
- Find and upload your public keys to any remote server: Codio > Account menu then select SSH Keys
The Terminal
This is space where we can write individual commands to communicate with the computer.
The Output
Whatever we asked our program to print will appear on the following line(s). In this case, our program prints “Hello, World!”

Running our program
We typed “java” followed by our program’s name (“HelloWorld”). Then we hit enter.
Syntax Errors

- The compiler report errors
- Most common errors are syntax errors
- A syntax error is reported when the code is not correctly written
- Common Syntax errors:
  - Missing a semicolon (;) at the end of a statement
  - Open curly brace (\{), or quote (\"), or parenthesis (\() without a matching closing brace (\}), quote (\") or parenthesis (\))