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Session Outline

1. Infroduction to Ellipsometry.

2. Classification of Samples.
— Transparent
— Semi-absorbing
— Absorbing
— Bare substrates, and coated samples.

3. Oscillator Models and Genosc Layer.
— Types of oscillators.

Learning Outcomes:
« Basic operation of WVASE software.
« Fundamentals of spectral interpretation.
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WV ASE Software

Opening Screen.

Selected Type nm_Angle Data @
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Five Empty Windows. Click inside each.
How to use these windows?
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Experimental Data Window
Use to open data files.

2 .AS.E. for Wind =]
— — Window  Global
) Range Select  Angles Delete Data Change —

= = =] P Experimental Data:1_caf2 substrate =] @

Open Exp. File Ctrl+0 | CaF2 substrate o
- L] selected Type nm Angle Data 4
Append Exp. File #E. 30244 4500 16.359¢0.20 180.1+1.08
Merae Exp. File #E:306.17 45.00 16.376£0.19 180.36+1.03
ge bxp #E:310 45.00 16.36+0.18 180.07+1.02
Sort Appended Files #E.313.92 45.00 16.3720.18 180.08+1.02
#E:317.95 45.00 16.232:0.18 180.2+1.04 )
Save Exp. File #E:322.08 45.00 16.329:0.13 180.2410.79 NGl il
#E:326.32 45.00 16.295:0.12 180.16£0.72 ) —
CompleteEASE Data Transfer > #E:330.67 45.00 16.262£0.11 180.21:0.65 &P Experimental Data: = |-
#E- 33514 4500 16.22240.11 180.15+0.60 =
Comment Data #E:339.73 45.00 16.2580.10 180.37+0.54 Selected Type nm Angle Data [
#E:344.44 4500 16.235£0.09 180.14+0.49
Information Ctrl+1 #E:349.3 45.00 16.238£0.09 179.99+0.49
#E:354.29 45.00 16.215£0.09 180.32+0.50
Copy to Clipboard #E: 35942 45.00 16.207+0.08 180.2+0.47
#E:364.71 45.00 16.18120.16 179.97+0.95
Exit #E:370.15 45.00 16.203£0.15 180.23+0.85 File , Open Exp. File Ctls0
#E:375.76 45.00 16.137£0.18 180.1+0.98
#E:381.54 45.00 16.12£0.14 160.240.77 Bangelelect G ppendiEcpahilE
il #E- 3875 4500 161540 12 180 26+0 64 Angles Merge Exp. File
#E:393.65 45.00 16.122+0.10 180.16+0.54 Tt .
#E:400 45.00 16.1160.09 180.13£0.49 [ : 2

—I f #E:406.56 45.00 16.126+0.08 180.25+0.47 | Change Data Type Save Exp. File
From upper-left. : - )

£E-413.33 45.00 16.11110.07 180.14:0.45 CompleteEASE Data Transfer ,
#E 42034 45.00 16.1:0.07 180.25£0.39

#E- 42759 45.00 16.08550.07 180.02£0.37
#E-435.00 45.00 16.06350.06 180.17:0.36 et Cirle1
#E- 44286 45.00 16.07610.06 180.11:0.34
#E-450.91 45.00 16.057£0.05 180.14£0.30
£F 45926 45 00 16 04+0 05 180 140 29

#E467.92 45.00 16.03740.04 180.120.24
#E-476.92 45.00 16.02610.05 180.11:0.26 . .
£E- 486.27 45.00 16.01740.05 180.11£0.27 Or rlght—C“Ck to Open
£E-496 45.00 16.003:0.05 180.0540.27

#E 50612 45.00 16.01410.05 180.1£0.27

#E 516,67 45.00 15.99450.04 180.04£0.24

#E-527.66 45.00 15.98540.04 180.120.24

Comment Data

Copy to Clipboard

#E:539.13 45.00 15.97120.04 180.07:0 24 -
I_A'J - =J
————— Exp E 50° ]
el — —-Exp E 55° -

©2014 J.A. Woollam Co., In



—

J.A. Woollam Co., Inc.

Graph Window

Displays graphs of Experimental Data

File Edit Data | J5tyle Window Global

@ Model: . ?@ @ Experimental Data:1_caf2 substrate ?@
DEE CaF2 substrate ol
Tan(Psi) Selected Type nm Angle Data A
Cos(Delta) #E: 30244 4500 16.359+0.20 180.1+1.08
<els #E:306.17 45.00 16.376+£0.19 180.36+1.03
#E: 310 45.00 16.36+0.18 180.07+1.02
<e2> #E:313.92 45.00 16.3724£0.18 180.08+1.02
<n> #E:317.95 4500 16.2324.0.18 180.241.04
<> #E:322.08 45.00 16.329£0.13 180.24+0.79
#E:326.32 4500 16.29540.12 180.16+0.72
Re(rho) #E:330.67 45.00 16.262+0.11 180.21+0.65
Im(rho) #E:335.14 45.00 16.22240.11 180.15+0.60
. #E:339.73 45.00 16.258+0.10 180.37+0.54
Cos(2*Psi) H - 244 A4 AL AN AE AL A A0 AOA 4410 4D k%
[ Sin(2*Psi)Cos{Del —
& Genersted Daf " o) cos(Delta) s @ =] | & 6rpn o o)
Sin(2*Psi)Sin(Delta) P
Type nm Angl Transmission | Expe”mental Data
Reflection 18
Absorption | I |
Transmitted Phase 15L |
Depolarization | |
& it Jones Matrix Quality M= @ » 121 B
[eH]
Meutron Reflectivity ke bt F q
L] =
R* K4 o 9 .
E=] e s M e Y
c 7 -0 1
[i] .
= ——Exp E 45°
N P Exp E 80° b
3L — — Exp E 85° .
i - - ExpEG&0° 1
0 PRt et B L -
200 400 600 800 1000

Wavelength (nm)

Select “Type” to change graphs.

©2014 J.A. Woollam Co., Inc. www.jawoollam.co



1 CaF2 Substrate.dat

Step 1.
» Select Experimental Data Window.
»Open data file: 1 _CaF2 Substrate.dat

Step 2:
Select Graph Window
»Plot ¥ and A data.
»Y¥ and A? What are these?
»What do they mean?

Learning Outcomes:
« Use Experimental Data and Graph Windows.
* Open data files. Display graphs of ¥ and A.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



%EJ.A. Woollam Co., Inc.
Ellipsometry Measurement

1. linearly polarized light ...
E p-plane

s-plane 3. elliptically polarized light!

plane of incidence i ] - “—"/‘//~////////

2. reflect off sample ...

= Ellipsometry measures the change in polarization state of
light reflected from a surface.

= Sample properties cause the change.
= Polarization is rotated, and becomes elliptical.

Next: What is polarized light? What is Ellipsometry?

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Units: Wavelength, Photon Energy, & Wavenumber

., Light Wave.
JAW

= Wavelength, & (unitsin A, nm, or microns)
= Photon Energy (eV). “Electron Volts”

= Wavenumber (cm). Used Mid to Far IR.
= Unit conversions:

Z

£, = 12;00 | £ - 1;40 | £, = 1.240 e 10000
A nm A A

4m 4m

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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What is Polarization@

= “Shape’” of the beam as it propagates
towards us. (Looking down z-axis).

Y

" Electric field, E(z,1) Y

Direction Looking Down Z-Axis:

of propagation Linear Polarization

= Polarization state defined by orientation &
phase of the E-field vector.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Polarized Light

= Polarization can be linear,
circular or elliptical.

= Superposition of two orthogonal
ight beams (components).

ANIMATIONS FROM WWW.ENZIM.HU
ACCESSED JUNE 6, 2012

©2014 J.A. Woollam Co., Inc. www.jawoollam.com


http://www.enzim.hu/

%EJ.A. e niCo! Inc.
What is Polarization@

Polarization: Describes “shape” of electric
field along the direction of travel.

= Linear: arbitrary amplitudes, in-phase.
= Circular: equal amplitudes, 90° phase difference.
= Elliptical: arbitrary amplitudes, arbitrary phases.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



%EJ.A. Woollam Co., Inc.
Intensity and Polarization

= Light Intensity = “Size” of the Ellipse.
— One Number Describes Wave Amplitude (E).

— Intensity is proportional to E2..."Brightness”. | « E? =(E,* + Eyz)
Y Y E
More
Less E Different Size
Intense (Intensity). Intense
X X

Same Shape!
(Polarization)

= Polarization = “Shape” of Ellipse.
— 2 numbers required: ellipse Azimuth and Ellipticity.
— Independent of ellipse size. Independent of intensity
— Ellipsometry always measures 2 numbers: ¥ & A.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



%ﬁj A. Woollam Co., Inc.
Light and Polarization

= For more deftails...

Polarization

| ]
| “Light
Lz

©1997, 330 pages

| Polarized Light

THIRD EDITION

-,

Dennis H. Goldstein

!
(aC) CRC P\
|
A

©2011, 750 pages

Principles of

Optics

7th (expanded) edition

Max Born and
Emil Wolf

Electromagnetic Theory of Propagation,
Interference and Diffraction of Light

©1999, 950 pages

©2014 J.A. Woollam Co., Inc.

www.jawoollam.com
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Elipsometry: Angle & Plane of Incidence

1. linearly polarized light ...

E  p-plane

s-plane Surface 3. elliptically polarized light !
“Normal” olane E
Vector PP
s-plan{

plane of incidence 1 H—L/J///Z/////

2
2. reflect off sample ... 7

1. Angle of Incidence.
Measured from Sample Normal.
2. Plane of Incidence.

Defined by incident beam, reflected beam, and sample
normal.

3. Polarization Components

p- and s- are parallel and perpendicular to plane of
incidence.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Ellipsometry Measurement
o

= Measures change in polarization of reflected light.

E  p-plane ‘
tany"e'

i(sin—sin) 'S out {i6% _

i ~ p-plane (l

L it
plane of incidence ) ,/

in
p

Er

s-plane

Change in Polarization represented as
Ratio of Light-Out to Light-In
Eout
t i — t i
p= EOU ( 5 ) ESU Esm i(58“t—5SUt—5:)n+5;n)
‘Eln e 5 5 ) ESOU'[ Elpn
EX

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Ellipsometry Equation

I For Reflection, use the following Definitions: I
EOUt _
r ‘ P A :5refl _§|n Interference

p Ein p p p
E)

‘EOUt f i

_ grefl  &in

p =l A, =6 -5
in
E.

Rewriting, we get the Ellipsometry Equation: )
J J : ~ » Can determine

(. _ T :
p:_pe'(Ap As):tan(qj)em _ D Optical constants &

r, 775 Film Thickness

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Summary: Ellipsomertry Experiment

— Light is reflected from a surface of interest.
— The polarization state of incident light is known.
— The polarization state of reflected/transmitted light is measured.

— An ellipsometer determines the change in polarization from the
sample. ¥ and A values.

1. linearly polarized light ...
E p-plane

s-plane
3. elliptically polarized light!

p-plane 4 E

plane of incidence ) ‘—U‘//‘///_/////

2. reflect off sample ...

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Ellipsometer: Block Diagram

= Every Ellipsometer contains the following components

Light Receiver
Source Detector Head
Polarization Polarization

nerator Analyzer

Source

Head\

= SE also needs wavelength selection.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Woollom Ellipsometers: Configurations

Rotating Analyzer

VASE®,
VUV-VASE® — -
Rotating Compensator
M-2000®
IR-VASE®
alpha-SE®
RC2®
S /] &
o K &°
& & 8 o
O 9 S
¥ K R
o & &

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Beginner:

General SE References

1. H.G. Tompkins, and W.A. McGahan, Spectroscopic Ellipsometry and Reflectometry, John Wiley & Sons, 1999.

Intermediate:

2. Hiroyuki Fujiwara, Spectroscopic Ellipsometry: Principles and Applications, John Wiley & Sons, 2007.

Advanced:

3. Ellipsometry at the Nanoscale, Lasurdo and Hingerl, eds., Springer-Verlag, 2013

4. Handbook of Ellipsometry, Tompkins and Irene, eds., William Andrew Publishing, 2005.

5. R.M.A. Azzam and N.M. Bashara, Ellipsometry and Polarized Light, Elsevier, 1977.

’ v’, b .
SPECTROSCOPIC
ELLIPSOMETRY

Principles and Applications

(nk)
L ~—l=

©2014 J.A. Woollam Co., Inc.

Handbook (n
Ellipsometry

Maria Losurdo - Kurt Hingerl Editors .
Ellipsometry at the
" Nanoscale |

@ Springer

www.jawoollam.com

Spectroscopic n

Ellipsometry and
Reflectometry

A User’s Guide

Z

Harland G. Tompkins
William A. McGahan

NH PL
N :

ELLIPSOMETRY
) AND |
~ POLARIZED LIGHT




E.J A. Woollam Co., Inc.
Elipsometry Conference Proceedings

1. Spectroscopic Ellipsometry, (1993) A.C.Boccara, C.Pickering, J.Rivory, Editors, Elsevier Publishing.

Thin Solid Films Vol. 313-314 (1998). R.W.Collins, D.E.Aspnes, and E.A. Irene, Editors, Elsevier Science.

Thin Solid Films Vol. 455-456, (2004). M. Fried, K. Hingerl, and J. Humlicek, Editors, Elsevier Science.

A WO D

Phys. Stat. Sol. (c) 5, No. 5, (2008). M. Schubert, H. Arwin, U. Beck, Editors, Wiley-VCH.

5. Thin Solid Films Vol. 519, Issue 9, (2011). H. G. Tompkins, Editor, Elsevier Science.

El llipsometry " Proceedings Spectroscopi Ellpsometry (CSE-V)

! ‘\‘ 1 VOL. 455-456 1 thay 2004 1SSN 0040-6090 p

W e , o | . G : :

e Spectroscopic 3

: : { L | 5th International Conference
rew m

R. W. COLLINS

D. E. ASPNES 4th Intes nal Conference on

E.A. IRENE
Editors Internatioaat Jowrnal

= Editor:
el Harland G. Tompkins

ELSEVIER ELSEVIER

©2014 J.A. Woollam Co., . www.jawoollam.com



2 BK7_SE.dat, Append Transmission.

Step 1:
» Select Experimental Data Window.
» Open data file: 2 BK7_SE.dat.
» Append Data 2_BK7_T.dat

Step 2.
Select Graph Window
» Plot ¥ and A data.
» Plot Transmission data.
» What do they mean? (Describe polarization ellipse).
» What is each sensitive to? (Interpret the spectrum).

Learning Outcomes:
« Appending different types of data.
« Graphing different data types.
« Sensitivity of different data types to sample properties

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Example 2: Uncoated BK7 Glass Substrate

= 3 data types.

= Each sensitive to different sample
properties (iIndex, roughness, absorption).

Generated and Experimental Generated and Experimental Generated and Experimental
15 . ; . ; . ; . 180 — . — 1.0 . .
121
o F
d o
§’ 3 —— Model Fit
£ 61 ---—ExppT0°
9“ F
3L
0 . ! . ! . ! . 0 S , R B ——— 0.0 /\ ! . ! . ! .
200 400 600 800 1000 200 400 600 800 1000 200 400 600 800 1000
Wavelength (nm) Wavelength (nm) Wavelength (nm)
¥: index A: Roughness Transmission:

Absorption

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Spectral Features: Transparent Substrate

= Psi flat and smooth - follows shape of index
= Delta=0" or 180° - except for surface films

I/p—— T T T 180
o r b o
8 25 :' ': 150F \
ok 8 | 0.5nm roughness
o Q120
o |} ~— 5
o o [
c 15F S 9o —45°
— i f
9-‘ —— 45° E 3 _550
10F — 55 < 60} m—(5C
3 — 65° 1 i —750
5 — 30}
0 L 1 X 1 r 1 Y — | 0 [ 1 1 1 1 1
0 300 600 900 1200 1500 1800 0 300 600 000 1200 1500 1800
Wavelength (nm) Wavelength (nm)

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



l 3_nb.dat.

Step 1 (Type| .Style
» Select Experimental Data Window. o
> Open data file: 3_Nb.dat. R
Step 2: A
Select Graph Window e
Im(rho)
» Plot ¥ and A data. =
» Plot <n> & <k>. NOTE THE <> BRACKETS! Sin"Psi(Dete)
> “Pseudo”-values. What do they mean?
Learning Outcomes: .

« Study spectrum of opaque material.
* Introduction to “pseudo” <n> & <k>.
« Sample properties causing change in polarization state.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Opaqgue Sample: Metals
= Niobium: Psi and Delta

Experimental Data

Experimental Data

42 T T T T 160 T T T T T T
391  EpEe . 1401 .
| ---- Exp E 65° L
$ —— ExpE70° ~ ]
o 36| T T . $ 1201 .
o - )
g - g |
£ 331 - £ 1001 _
> | < | o ——Exp E60°
7 ---- Exp E 65°
30} . 80} d —— Exp E70° .
Ve
27 o1 ! . ! . ! . . 60 P N R ST BN R R
200 400 800 1000 1200 1400 1600 200 400 600 800 1000 1200 1400 1600

Wavelength (nm)

= Re-plofted as Pseudo <n>&<k>

Experimental Data

Wavelength (nm)

Experimental Data

2.00 T T T T T T T T 6.0 T T T T T T
1.90 - ’
L 5.0 _
—Exp E 60°
1.80 h - -----Exp E 65°
- ——-Exp E 70°
1.70 | 4.0 xp i
AN N
v i v o0
1.60 - 3.0 |
——Exp E 60° ] L
1.507 -----Exp E 65° 20
1.40 —— ExpE70 ] . -
1.30 L 1 . 1 . 1 . 1 . 1 . 1 . 1.0 . 1 . 1 . 1 . 1 . 1 . 1 .
200 400 600 800 1000 1200 1400 1600 200 400 600 800 1000 1200 1400 1600

Wavelength (nm)

Wavelength (nm)

= Opague Sample. All <n>&<k> angles the same.

©2014 J.A. Woollam Co., Inc.
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%EJ.A. Woollam Co., Inc.
Spectral Features: Opaqgue Metals

= Psistays near 45
= Delta away from 0° or 180°
= Pseudo <n>&<k>same at all angles.

46 r I r I r I r I T 180 T T T I r I r I .
- 150F / -
0
%) | 3 [ 1
=4 2 ! .
S { < 9of i
£ - S - ;
o g 6o o065
- [ &—a 75° l
30 B o—a 850 -
36 ) 1 . 1 ) i . 1 . 0 . . ] . 1 . 1 ) 1 . -
200 400 600 800 1000 1200 200 400 600 800 1000 1200
Wavelength (nm) Wavelength (nm)

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Substrate Identification

Transparent Absorbing
Psi =Flat =Shows features of n&k
=Approaches 0° at =Remains closer to 45° for all
Brewster’'s angle angles
Delta =Flat =Shows features of n&k
=Close to 0° or 180°. =Stays between 0° and 180°
<Pseudo =<n> has Cauchy shape =<n&k> follow actual n&k.
n&k> =<k> close to zero

Transparent Substrate Exceptions:
1. <n> separation for variable angle when backside reflections are present.
2. <k>non-zero and Delta away from 0,180° if surface layer (e.g. roughness).

<IjWhat about Semi-Absorbing’;:I>

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



4 S| wafer.dat

Step 1:
» Select Experimental Data Window.
» Open data file: 4 Si wafer.dat.

Experimental Data Experimental Data
40 , , , , , , 180

150

w
o
T T

120

Y in degrees
N
o

A in degrees
(e}
o

D
o
T T 7

=
o o
T T T T T

30
. I P Mt wteets st S NP R 0 . I . I . I . A S
0 300 600 900 1200 1500 1800 0 300 600 900 1200 1500 1800
Wavelength (nm) Wavelength (nm)

Learning Outcomes:
Study spectrum of crystalline material.
Note sharp structure below 450 nm. Why? Why so sharp?
Identify transparent and absorbing regions.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Substrate - Semiconductors

= Psj follows shape of absorption.
= Delta away from 0° or 180° when absorbing.
= Sharp features due to absorpftion.

a
o

Y in degrees
o &

! ) ! ) 200

T T T T T
— 55° - [
m— G5° ] 150F
m— 7 5° ] i

IN
o
—

A in degrees
H
o
(@)

| — 55°
_ . — 65°
10F - SOr —
0 el emmee—— 0 . 1 . 1 N L— |
200 400 600 800 1000 1200 200 400 600 800 1000 1200

Wavelength (nm) Wavelength (nm)

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Review: Substrate Types, Spectral Features.

[ ] [ ] (]
Transparent Semi-Absorbing Absorbing
30 25 39.0
25 20 Psi (70.00°) 38.0 Psi (65.00°)
Psi (55.00°) Psi (75.00° i (75.00°
\P 20 Psi (65.00°) 15 si( ) 370 Psi (75.00°)
515 : 5 0 5 360
10 35.0
5 5 34.0
0 0 33.0
300 600 900 1200 1500 1800 0 500 1000 1500 2000 2500 200 300 400 500 600 700 800 900
Wavelength (nm) Wavelength (nm) Wavelength (nm)
200 180 160
150 T .
A 150 f/ Delta (70.00°) 140
Delta (55.00°) 120 | Delta (75.00°)
g 100 Delta (65.00°) P o 120
K o 90 i K
0 50 o 60 0 100
Delta (65.00°)
of — 30 80 Delta (75.00°)
-50 0 60
300 600 900 1200 1500 1800 500 1000 1500 2000 2500 200 300 400 500 600 700 800 900
Wavelength (nm) Wavelength (nm) Wavelength (nm)

Describe unique features of each spectrum.

©2014 J.A. Woollam Co., Inc.
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Coated Samples!

Thin Film Identification
= Mulfiple Reflections at interfaces.
= Use to estimate film thickness and Index.
= Can be transparent, Absorbing, or Semi-Absorbing.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Coated Thin Film Examples

Transparent

Semi-Absorbing

Absorbing

Wavelength (nm)

Wavelength (nm)

100 30 42
Psi (55.00°) ESYEI
80 Psi (55.00°) 25 ‘ Psi (65.00°) a9 si ’
Psi (65.00%) Psi (65.00°%)
* 20
60 ‘ / 36
@ ‘@
a £ 15 o
40 L ~__ AN .
10 N
B \/\/- )
5 !
0 0 27 Vdl
200 400 600 800 1000 1200 1400 0 200 200 500 800 1000 200 400 600 800 1000 1200 1400 1600
Wavelength (nm) Wavelength (nm) Wavelength (nm)
300 300 160
3 Delta (55.00°)
/ Detta (55.00) Delta (65.00°)
200 // | | |Delta (85.00%) 200 | 140
/ 120 ! T ‘
£ s =
£ 10 3 100 8
100
0 | 0 Delta (60.00°)
J . Delta (65.00°)
-100 -100 60
200 400 600 800 1000 1200 1400 0 200 400 600 800 1000 200 400 600 800 1000 1200 1400 1600

Wavelength (nm)

Coatings add interference effects in transparent regions.

©2014 J.A. Woollam Co.,

Inc.
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5 SiIO2 on Si.dat

Transparent Film on Silicon

Step 1.
» Open data file: 5_SIiO2 on Si.dat. Experimental Data
Step 2: 7]
Select Graph Window [ I
> Plot ¥ and A data. -
» Note the interference effects. i
» What Causes these oscillations? I

Learning Outcomes:
« |dentify spectrum of a coated substrate with transparent film.
* Observe thin-film interference effects from transparent Film.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Thin Film on Substrate

= Multiple reflections in single film lead o an infinite
series of reflection:s.

Mot

\

—i2B .
2,14
lo to1t1o712€ tortioTioTip2e 4P

Phase from different
optical paths is fracked by
film phase thickness ()

d
[ = 27{1} N, cosé,

1-toT

_ 28 2 Y
Fot = Vo Tl pto€ ™" +1g 1, Tl € ™7+

©2014 J.A. Woollam Co., Inc.
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Thin-Film Interference Effects

m  SE measures
polarization change __
as light interacts with | .&5e
sample. |

angle of
incidence E
0

P

plane of
incidence

A\

m Inferference occurs as light
recombines after traveling
different paths through thin film.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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SE features — Transparent Films

= QOsclillation patterns in
ellipsometry data due 1o thin
film interference.

= Pattern affected by thickness
and index.

Spectroscopic Ellipsometric (SE) Data
80

Transparent -
J

o /\ /\ /\ /\\ oscillations
JUNN /N
\

0
600 800 1000 1200 1400 1600 1800
Wavelength (nm)

Psi
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Thickness Effects

100
4
~ /\ 500 nm oxide on Si
& 60 100
40— \\\ 80 l ’l\ /\
60
20 o
o )\\// \\ // \\ L —
20 V /
\/ 80
= e o | A A }“\
Thicker films have more e I \ \/\/ /\/ \
interference oscillations : AR
200 400 600 800 1000

100 nm oxide on

Si

Wavelength (nm)

1200

©2014 J.A. Woollam Co., Inc.
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6_Dielectric on Glass.dat

Very Thick Transparent Film on Glass

Step 1:
» Open data file: 6_Dielectric on Glass.dat.

Step 2 T
Select Graph Window .
> Plot ¥ and A data. § 1y RS
» Thick or thin film? R
» Why small amplitudes? oI NI T

400 600 800 1000 1200 1400 1600 1800
Wavelength (nm)

Learning Outcomes:
* |dentify spectrum of thick versus thin transparent film.
* Note small amplitude of oscillations. Why?
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Thin Film Identification
Transparent Absorbing
Psi =Oscillates =No oscillations.
=Size of oscillations signify index | =Shows features of n&k.
difference beftween substrate | «| ooks like opaque substrate.
and thin film
=Number of oscillations
indicate thickness
Delta =Oscillates =Shows features of n&k.
=Number of oscillations =Stays between 0° and 180°.
indicate thickness
<Pseudo =May separate for multi-angles. | =Overlapping at multi-angles.
n&k>

©2014 J.A. Woollam Co., Inc.

VERY THIN LAYER Exceptions:

1. Oscillations will not appear until about 25-50 nm thickness.
2. Psi may go above 45° for thin coatings.

What about Semi-Absorbing?

www.jawoollam.com
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Break!
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/_SINx on Si.dat

Semi-Absorbing Film on Silicon

Experimental Data
50 . :

Step 1. ol
» Open data file: 7_SiINx on Si.dat. It o

Step 2: : |
Select Graph Window .
» Plot ¥ and A data. e

> Note the interference effects.
» Discuss IR and UV behavior.

. | . | Rl .
200 400 600 800 1000
Wavelength (nm)

Learning Outcomes:
* |dentify spectrum of a UV absorbing film.
« Observe thin-film interference effects and absorption effects.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Semi-Absorbing Films

Spectral Identification: What to expect?

= |f light is absorbed before returning 1o surface, only top
reflection is ‘seen’ (Film appears as opaque substrate).

300 T T T T T T T T T T
250 - N M\ / j

@ 200 -

{1
1 |
| 1
|
o I 'l I
> 150 - AR
o B I 1
< 100 | 1 |
< 5o I" \ = ]
/

_50 L | L 1 L | L | L | L
120 150 180 210 240 270 300
Wavelength (nm)
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WVASE Model Window

Add layers. Define fit parameters.

g§ V.AS.E. for Windows [7a_sinx on si] —

File AddlLayer Recentlayers DeleteMod Superlattice

& Model:
= 1 513nd 150.000 nm
0 si_jaw 1 mm

-

©2014 J.A. Woollam Co., Inc.

e

Growth Select Options  Angles
Optical Constants: si3nd @
nm n k Cancel
216.283 Z2.4594 0.05%197 -
217.876 2.4479 0.050646 :l Save
219.47 Z2.4363 0.046095
221.063 2.4248 0.041544 Copy to Clipboard
222.657 2.4133 0.036991
224.251 24017 0.032438
225.845 Z2.3907 0.028345
227.44 Z2.3815 0.025672
229.034 2.3723 0.022998
230.629 2.3631 0.020324
232.22% Z2.35639 0.017649
233.82 2.3447 0.014974
235.416 Z2.3355 0.012299
237.011 2.3273 0.010576
Z238.607 2.3202 0.0097515
240.204 2.313 0.008927
241.8 Z2.3058 0.0081024
243.397 2.2987 0.007277¢8 -
244.993 2.2915 0.006453 =~ [ N min=2.005 max=2.4594
— k min=0 max=0.055197

Contains optical constants of each layer.
What are “Optical Constants”?

www.jawoollam.com




Step 1:

» Open data file: 7_SINx on Si.dat.

Select Model Window.
» Add Layer: Si_jaw.mat.
» Add Layer: Si3N4.mat.

Step 2.

» Add fit Parameter: Film Thickness.
» Show table of optical constants.

/_SINx on Si.dat

Build Model For Silicon Nitride on Silicon

1 si3n4 150.000 nm
0 si_jaw 1mm
[Layer =)
Layer Name: |Si3n4
Comment: |SILICON NITRIDE: PALIK Vol. 1, p.774
Spectral range of optical constants | 206.67 -1240 nm

Thickness: ||l nm W Fit

ical Constants >>
ok |
Opt Const Fit _
M n Cancel
Fk Replace Layer
Delete Layer

« Adding fit parameters.

Learning Outcomes:
« Building a model. Adding layers.

©2014 J.A. Woollam Co., Inc.
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Generate Data Window
Generates data from the Model

P VASE. foj \Gows [/ 28g:x on si] = g

File Rangd{ Generate Data JCopy to Exp _ Delete Data Window  Global

P S—— (= (@[] | & Bpermental Dated_sinmon ===

| Single-ayer dielectric on i, nom. 150nm, (1.3 -5.75 V)
@

Selected Type nm Angle Data
#E 21628 6500 104762009 116 34048
#E 21768 6500 10307:0 08 115 71+0 46
#E:21947 6500 1040840 08 117 0440 46
#E 27106 6500 10077:0 07 117 07+0 45
#E 22266 6500 1009740 07 117 14+0 45
#E: 22425 6500 1004540 07 11711043
#E 29585 6500 98947+0 06 117 2640 47
#E 22744 6500 99899:0 06 117 74<0 40
#E:22903 6500 9816140 06 118 6340 39
#E 23063 6500 98786+0 05 1187140 37
#E 23222 6500 975754005 118 930 37
#E:23382 6500 9675640 05 121.04+0 36
#E 23542 6500 95976+0 05 1212840 34
#E 23701 6500 9 5874£0 05 122 3540 34
#E°23861 6500 9450340 05 123 2640 33
#E 2002 65.00 944692005 125174032
#E 2418 6500 937424005 126 38+0 33
#E:2434 6500 918424005 127 340 33
#E:244.99 6500 5.9716:0.05 129.29:0.33 i
& Generated Data: "o B | &P ceph =@ ]=]
e o Ao Dot 5 Generated and Experimental

E 21625 6500 32 12 57538

é £ 217.88 65.00 30528 74395 100 . . . .
E. 219.47 66.00 29.857 88.084 I I l

E- 22106 6500 29835 10027
E:- 22266 6500 302 1117 -

[ 1siand 150.000 nm |
| 0sijaw 1Tmm

E:224.25 65.00 30771 12276 —— Model Fit 1
E 227t 600 3108 1aai 8oL -~ Exp E 65° N
E Sanes ae00 3168 1o22n i —— ExpEB7.5°
—— = = - - ExpET70° 4
- S — ExpET725°
F 601 — — ExpE75° ]
——Exp E77.5°

401

YV in degrees

200 400 600 800 1000
Wavelength (nm)

Graphs compare Model Generated and Experimental Data.
Thickness is close, so why not a perfect match?
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Optical Constants, Refractive Index, n

Light in Different Media:
Velocity and wavelength vary in different materials.

V:E\ speed of
n ‘ light I

Frequency (color) of wave remains the same! f = —

A

Energy of photon E(eV) —ho =~ 1,240
remains the same: A(n m)

Planck’s constant I

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



%EJ.A. e niCo! Inc.
Index of Refraction, n

= Index of Refraction (n)

= Describes How Light is affected by Materials:
reflection, refraction, phase velocity, absorption

L):—:i
~— A na

Frequency constant

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



%EJ.A. e niCo! Inc.
Refractive Index, n

= Determines Wave speed.
v=cC/n

= Determines Angle of Propagation.
— Snell’s Law of Refraction:

n,siNB, = N,siNB,

— Example: Pencil in glass of water appears
“Bent”, or “Broken”. Caused by refraction.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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% Refractive Index: Transparent Materials
= |[ndex decreases for longer wavelengths.
= Higher index for stronger UV absorption.

4
=== Si02
=== S|3N4 B 1T R
- Sj

3

c

X

(D)

@)

<

2 &—
—

0 500 1000 1500 2000
Wavelength in nm
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Absorption and Extinction
—aZ
— 4 7K
| =1_¢

Bulk Material Absorption:
Deeper propagation gives:
= more energy loss.
= complete extinction.

Absorbing films:
Increasing thickness gives:
= longer propagation path in film.
= wave spends longer time in film.
= more absorption by material.
= more extinction of wave.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



%EJ.A. Woollam Co., Inc.
Absorption: Beer-Lambert-Bouguer Law

= Absorption coefficient (a)
= Extinction coefficient (k) —_—>>

— Loss of wave energy to the l
material.

dl(z) - —dl(2) o 4K

dz

o

Pierre Bouguer
(1698-1758)

Johann Heinrich Lambert
(1728-1777)

©2014 J.A. Woollam Co., Inc. www.jawoollam.com


//upload.wikimedia.org/wikipedia/commons/9/9b/JHLambert.jpg
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%ﬁj A. Woollam Co., Inc.
Multiple types of opftical absorption
= Common absorption of EM waves:

Electronic

UV-visible-near IR frequencies

Vibrational
mid-IR freg

Free carriers
(conductivity)
mostly IR

Rotational
(microwave oven)

©2014 J.A. Woollam Co., Inc.
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%EJ.A. Woollam Co., Inc.
Metals: Free-carrier Absorption

= Metals have more electrons than needed for bonding
(covalent bonds = sharing electrons).

= Electric wave causes “free” electrons fo move.

= When electrons collide with nearby atoms wave energy
Is lost as heat.

B
o

8

e- c [ '7 W

- 3.5k 1/ =

e- s | 1 2

e- g 3.0} | Y

e- = r -5 >

© 25F 1 9

E—F 5 1¢ S

EE x 2.0 _'3 o

qJ —

§e) [ ] g

e- £ 15F 42 =

E 1 G o '] o [l o [l o [l o '] o ] 1 ~
8- 0 300 600 900 1200 1500 1800

Wavelength (nm)
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%EJ.A. e niCo! Inc.
Semiconductors: Electronic Transitions

= Electrons in energy bands.

Conduction
Band

= Gap between valence-conduction band.

= |f light (photon) provides enough energy ndiect Eneray.
electron may excite to higher state. W o\
Bandgap

6 4 Energy, eV
/ Rﬂ
4
/—\- Valence
. Band

Momentum, k

= Real materials have complicated energy bands.

Energy (eV)

=  See lots of sharp structures in optical constants.

S. Adachi, Optical properties of
crystalline and amorphous semiconductors,
Kluwer Academic Publishers, Boston (1999).

Wave Vector, k

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Infrared Absorption: Molecular Vibrations

= |nfrared light has low energy. Can vibrate molecules
(stretching, bending, twisting, rotating).

H H H H H
| | I I I Il
-N-C-C-C-C-C- f
] I I I
H H H H o
. CHo stretch & CHo stretch \&
(symmetric) (asymmetric)
N-H  CH, )
C=0
| N-H & C=0

Wavenumber (cm'1)

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Infrared Absorption: Crystal Lattice Vibrations

= Electric Field causes crystal lattice to vibrate.
— Longitudinal (LO) or Transverse (TO) Optical “Phonons”.

180

[ERN

N

(=}
I

A in degrees

60

TO+LA

M. Schubert, 2002

O 1 I 1 I 1 I 1 I
600 900 1200 1500 1800 2100

Wave Number (cm?)

T.E. Tiwald et al., Thin Solid Films, 313-314
(1998) 661.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Optical Constants

= Complex Refractive Index:

N(A) = N(x) + ik(x)

E(z,t) = Eyjexpli(wt — Kz + §)]
K= 27” (n — ik)

Describes what material does to light wave.
= Slows down, wavelength changes, refraction, extinction.

Alternatively...

= Complex Dielectric Function: D= F

e(h) =& (1) £ 1gy(2)

&E
8280(1-'_)()1 87'28_
0

Describes what wave does to material.
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l /_SINx on Si.dat

Graphing Optical Constants in WVASE.

Using Graph Window.
» Select Data: “Current Layer (Opt. Const.)”
» Note position of current layer arrow “>” next to layer.

» Select Global, then “Defaults”
» Change plot to “e1 & e2” vs eV.

. . . . (V.ASE. Defauits [
si3n4 Optical Constants si3n4 Optical Constants il
2.50 r r T r 0.060 X .
T T T ] 63 T T T T 0.30 Specify Thickness in: Specify Light in:
ool 10,050 &' 6 O’ ! Jloos g  Angstroms [A)  Angstroms [A)
£ J x 0T /] Q * Nanometers [nm) * Nanometers [nm]
IS ! g
§ [ -40.040 5 ‘@' [ /' 4020 @ " Microns [pm) " Microns [um)
3 2.30 J S S 55 g 4 3 " Photon Energy [e¥]
E) 3 400309 o | ' 4015 & Specify Optical Const. in: " Wavenumber [1fcm]
5 2200 1% §so g & o and c T
) r e = = " 'el1" and 'e2 " GHz
° 1 =3 Q El
£ 210} = < 45 =
40010 = g 0.05 =
F oo | & L S Memory Allocation |
2.00L . . n 0.000 4.0 . ! . Lt . 0.00 o -
200 400 600 800 1000 1.0 2.0 3.0 4.0 5.0 6.0 Cancel Material File Directories |
Wavelength (nm) Photon Energy (eV)

Learning Outcomes:
« Graphing layer optical constants in WVASE.
« Understand “Current layer”.
« Changing defaults settings.
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%ﬁj A. Woollam Co., Inc.
Dispersion: Wavelength Dependence

= Opfical Properties vary with wavelength.
= Transparent regions (normal dispersion).
= Absorbing regions (anomalous dispersion).

8 12

j r\ e2 [\ \‘ 8
1[N — I

N N 4
il A
_4..rt................"j-.. HEN 0

(@)]
e2

el

0 2 4 6 8
Wavelength (microns)
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The Dielectric Function g(w)

= The Dielectric Function g(E) or g(w), is the Dielectric
Polarization as a function of Energy (or Frequency).

Dielectric Function vs. eV

20 25

l

e1 Re{epsilon

15 i
: N e2 Im{epsilon} || 20
10 P H

5 ! 1
€ac T o |

: \f A 110
5
-10 — ;

el

A
v

Do transparent V
15 B v | K . 0
0 2 4 6 8 10
T eV T T
absorption absorption

= Regions of fransparency, and regions of absorption.
= Where do these features come from?
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%EJ.A. Woollam Co., Inc.
Kramers-Kronig Relation

= Real and imaginary parts depend on each other.

= QOptical constants must satisfy
KK-relation to be physical.

= “Bumps make wiggles”...the
shape of n & k curves are
related.

¢91(a)):1+g Pro a)'<292 (a)'z) do’
T Y0 @' —w

20 =& (w)-1.
52(0)):_7(0'3'[0 2,(20)_)0)2 o

Frequency (energy)

P means “principal part”

Integral equation relates area under ¢, to shape of ¢, and vice-versa.
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Absorbing Regions

Absorbing regions occur in different parts of the spectrum.
Absorptions have different shapes, depending on cause.

— Free-carriers Lattice Transparent ~ Electronic

. o V|b_rat|orlls — . Transitjons {,

— Electronic Transitions Visibld ;. UV ]

—Molecular Vibrations [ | et e 1 40
—_— 1 1 0N 3 T 21 o |0 |..... ] m
Latfice Vibrations Rufile TIO, e a0

UV to IR 120

[t

'58_03 . 0.1 . 0?3 . i | 3 . 1(9

Photon Energy (eV)
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%EJ.A. Woollam Co., Inc.
Dispersion Models: Practical Use.

= Equations used to describe the optical
functions versus wavelength.

= Transparent Materials:
— Cauchy, Sellmeier models.

= Absorbing Materials:
— Large variety of Oscillator Models:
— Lorentz, Drude, Gaussian, Tauc-Lorentz, etc.
— All available within Genosc.mat layer!

©2014 J.A. Woollam Co., Inc. www.jawoollam.com
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Transparent Materials: Cauchy Dispersion Equation

= Describes index (n) as a function of wavelength n().
= For transparent materials only (k=0 or very small).

Optical Constants of Cauchy Film

2.20 s ‘
A=1.8,B=0.01

2.10\ \V/_ ﬁ: 12 B=0.01, C=0.002

2.00\ (A)=A+B/ A%+ C/A*4

n +
] \ N )
\ k(A =0 Y

190 \ ~ ™ ‘
\________\__ ‘ Augustin-Louis Cauchy

1.80 (1789-1857)

1.70
300 600 900 1200 1500 1800
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/_SINx on Si.dat

Using Model For Silicon Nitride on Silicon

Select Model Window.
> Replace Si3N4 layer with Cauchy.mat o<
» Set An=2, Bn=0.01. [ |

Select Experimental Data Window.
» Range Select 400-1000 nm.

Select Experimental Data Range @
EHQIE: |'EI:I o |9I:| Band Edge.: ,4097 ] r E
wavelength:[400.00 1o [1000] lnm -

» Generate data.

Learning Outcomes:
* Replacing layers.
« Define Fit parameters. Cauchy model for index.
* Select Experimental data range.
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WVASE Fit Window

Used to optimize model by adjusting fit parameters
“‘Normal” oy
P —

. SIS | & Epermentsl Datet_siconi e
Single-tayer dislectric on Si. nom_ 150nm. (13 - 5.75 eV) -
| [EET R e s wes
o . | E E =
2| Osijaw Toom | E:217.88 6500 1030740 08 115714046
E- 21947 6500 10408:0 08 117 04+0 46
£ 22106 6500 1007740 07 117 074045
£ 22266 65.00 1009740 07 117 14045
£ 22425 6500 1004560 07 117 114043
E- 22585 6500 9894740 06 117 26042
| E 22744 6500 9.9893:0 06 117 74+040
[0 E 22903 6500 98161006 118 6340 39
£ 23063 6500 98786:0 05 118 7140 37
E- 23222 6500 9757560 05 119 9840 37
£ 23382 6500 96756:0 05 121040 36
£ 23542 65.00 95976£0 05 121 260
£ 23701 65.00 958740 05 122 350
£ 23861 6500 9450360 05 123 26:0 33
E- 2402 65.00 9445360 05 125 1740 32
£ 2418 6500 9374260 05 126 380 33
E- 2434 65.00 9 184260 05 127 360 33
E- 24499 6500 89716:0 05 129 2940 33

»

& Generated Date: (= [@][=] | & Greph ==
00 g Dt & Generated and Experimental

E- 40007 6500 42742 52499

E: 40167 6500 43928 47603 50

E: 40326 65.00 45.072 -42.308 T T T T T T l T I T

E:404.86 65.00 46.126 -36.6 :

E:406.46 65.00 47.035 -30.495 —— Model Fit 4

E:408.05 65.00 47.748 -24.045 ~

E:409.65 65.00 48213 -17.334 40 2

E:41125 65.00 48.395 -10.481 .

E:412.84 65.00 48.283 -3.6271 ; - EXp E 67.5°

E:414.44 6500 47883 3.0855 (N % N - - EXp E 70°

S e o — —ExpET725°

Final B o o
MSE 8274 I o 30 Exp E 75 .
150.131 £ 0.0664 - o

And 2.032:;000626 ' Normal Fit ’ Ctri+F [@)] EXp ET77.5

Bn.1 0.037149 £ 0.000117 % . '\ N W 1
Reset
Stats Ctrl+S. _E 20 (— —
Defaults 9_‘
Copyto Clipboard - u
File »
Normal Fits 3 1 0 — —
Reset
Edit Parms L i
Fit Studies »

I ] I ] I ] I ] I 1 I

0
- . 400 500 600 700 800 900 1000
Or nght-C“Ck Wavelength (nm)

Perform a “Normal Fit” to start.
What’s going on below 450 nm? Beyond 850 nm?
How to improve this fit?




%EJ.A. Woollam Co., Inc.
Dispersion Models: Practical Use.

= Equations used to describe the optical
functions versus wavelength.

= Transparent Materials:
— Cauchy, Sellmeier

= Absorbing Materials:
— Large variety of Oscillator Models:
— Lorentz, Drude, Gaussian, Tauc-Lorentz, etc.
— All available within Genosc.mat layer!
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/d_SINX on Si-genosc.env

Silicon Nitride on Silicon
Final Model Using Genosc.mat

» Select Global, then “Load New Environment”.

= X
Wind Global
F1

» Open 7d_Sinx on Si-genosc.env

» Examine Y and A data fits. Are the fits good?
» Click Genosc layer to open Window.

» Study oscillators and poles used for fit.

Learning Outcomes:
* Opening Environment Files.
e Study Genosc fit.

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



/d_SINX on Si-genosc.env
Silicon Nitride on Silicon

Generated and Experimental

1 50 . . . .
Final Results T T
[ ----Exp E 65° 1
401 —— BXpE675° A
- - BETO
L o 50 J
2 srough 1.877 nm 8 5ol ~ Eeere ]
1 genosc 151.734 nm g ]
.. £ 201 B
0 si_jaw 1 mm > | |
10+ i
General Oscillator Layer @ OV 1 1 1 1
Name; | genosc Comment: | Generalized Oscillator Layer 200 400 600 800 1000

Wavelength (nm)

Thickness: | 151.734 nm |« Fit .
- Generated and Experimental
Position (gV): Magnitude: 300 T T T T T T T
Pole #1: | 5.3385 [V 75.74 [ Delete Layer g
—— Model Fit
. 200 - ExpE65° ]
Pole #2: | n.001 [ i I Replace Laver " —— EXpE675°
. Opt Const Fit @ - - BoET0°
1 Offset: |1 I 1 O o Optical Constants == | % 7’335;@5
o 100 - 4
Egap: | 0 !e s —— EXpET75
Ik c - ExpE80°
Osgcillator Parameters: < 0 |
Active:  Type: Style: S I e =
= - Graphing and Fitting Opti —’;;5%/ ]
v |Gau: Gaussian j |.U: eV, A*Gauss(E,A En,Br) ﬂ raphing and riting Uptions 100 ‘ 1 ‘ 1 /‘/é/‘
Amp - = Ref. Material | Fitto Ref. | | 200 400 600 800 1000
| 1 ™ | 3 I | 0.2 u ez siand Wavelength (nm)
genosc Optical Constants
*1: C-L.0, Amp=31.608F, En=8.4768F, Br=8.7838F, Eg=3.4906F, Ep=1 , Et=0 , Eu=0.5 K -[s by |0.025 2.50 . ; . ; . . . 0.60
.. _ ) _ \
2: Gau.0, Amp=0.46499F, En=3.7443F, Br=1.0119F  Fite2 only 105
e¥  w| (& FitBoth = \ A ’ g
" Fitel only é -0.40 5
[ Restrict Parms to Graph Range § 1 (g_)
g : k3 40.30
@
What is the role of el and e2 sectigns;? 1*8
? 3 {020 2
Osc Down Add Oscillator g | g
= Jo.1o X
LS 4
2.00 L [ 1 L 1 L 0.00
200 400 600 800 1000

Wavelength (nm)
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Ellipsometry Data Analysis

= Rest of this course...3 days.
= How to analyze data.
* Infroduce some general concepts.
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Data Content vs Sample Unknowns

= Ensure data contains information to solve all unknowns.

Sample
Data Unknown
Content
‘ Over-Determined
Data Sample
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Why Analyze Datae

Ellipsometry measures two parameters: ¥ and A.

¥ and A are a function of film thicknesses and optical constants of
materials under study.

Desired information must be extracted through a model based
analysis using optical physics.

Inverse Problem:

— Result is known instead of Cause.

— Ellipsometry measures the “resulting” polarization change rather than
sample properties that are the “cause”.
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Generate Data From Model
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Data Fitting

= Software adjusts
“fit" parameters 1o
find best match
between model
and experiment.

= MSE is Difference.
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Data Fitting Algorithm
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= WVASE32 uses a Mean Squared Error (MSE) to quantify
the difference between experimental and calculated

model data.

= A smaller MSE implies a beftter fit.

= The MSE is weighted by the error bars on each
measured data point, so noisy points are weighted less

heavily.

©2014 J.A. Woollam Co., Inc.

www.jawoollam.com



%EJ.A. Woollam Co., Inc.
Minimizing the MSE

= Levenberg-Marquardt algorithm used o
quickly determine the minimum MSE (gives
best fit fo data).
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Quality of Data Fit

Use our Physical Intuition!

When fit is complete resulting fit parameters
must be evaluated for sensitivity and possible
correlation.

— Compare experimental data with generated data.

— How low is MSE? Can it be reduced further by
Increasing model complexity?

— Are fit parameters physical?
— How large are 90% confidence limits?

— Check Correlation matrix. Are parameters
correlated? Can some be turned off?

©2014 J.A. Woollam Co., Inc. www.jawoollam.com



%EJ.A. e niCo! Inc.
Correlation Matrix

= Example of Correlation Matrix

— matrix of two-parameter correlation coefficients
calculated from the covariance martrix

Correlation Matrix

« df | ThkUni  Thick.2  An.2 Bn.2 cn2 |~
Any oft diagona Jthkuni  1.000 0.065 -0.091 0.028 0022 |
elements near +/-1 [|Thick2  0.065 1.000 -0.680 0117 0.054

An.2 -0.091 -0.680 1.000 -0.530 0.515
are correlated. Bn.2 0.028 0417 -0.530 1.000 -0.965

cn.2 -0.022 0.054 0.515 -0.965 1.000

Correlated Parameters:
Cn.2 and Bn.2
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General Rules for Data Analysis

* Find the simplest optical model that fits
Experimental Data.

— User fewest fit parameters.

= Verify uniqueness of the model.

— Check correlation matrix, and error bars on parameters.

= Opftical 'constants' for materials are not always
constant, and quality of fit can only be as good as
the optical constants assumed in the model.
— May need to fit n & k.
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Data Analysis Flowchart
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Summary — Session #1

* Introduction to Spectroscopic Ellipsometry
— Polarized light, Ellipsometry experiment.
= Classification of Samples:
— Substrate, or coated,? Single-Layer, Multi-Layer?
— Absorbing, Transparent, Semi-Absorbing?
— Data Features: Spectral Interpretation.
= Optical constants.
— Refraction, absorption, n & k. Dispersion.
— Oscillator models, Cauchy, Lorentz, Gaussian, etc.
— WVASE Genosc layer.
* Fundamentals of WVASE.
— Basic software operation.
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Lunchl
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